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PREMIUM AND STANDARD PACKAGES

PolyWorks|Inspector is a powerful
industrial 3D metrology software

solution that uses noncontact point
cloud digitizers and single-point

contact-based probing devices to
acquire and control tool and part

dimensions, diagnose and prevent
manufacturing and assembly issues,

guide assembly building through real-
time measurements, and oversee the

quality of assembled products.
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GETTING STARTED
Introducing the Essentials

About
The Essentials guide is intended to be a companion for new users post-training and 
throughout their first year of using the PolyWorks Metrology Suite.

Approach
The Essentials content is presented following a workflow-based approach. The document is 
divided into sections according to specific workflow steps.

Each section is then organized using a tool-based approach, where each tool pertaining to the 
subject is documented following the established presentation layout (recipe).

Generally, the Essentials has been documented using the default configuration and visual 
layout with the exception of the background color of the 3D scene and the font size for certain 
annotations. Also, in most cases, only the basic parameters are described.

Document conventions

Navigation through the sections

• As mentioned previously, this document has been designed according to the inspection 
workflow recommended in the PolyWorks Metrology Suite (see The inspection workflow on 
page 31). The structure of the document is clearly identified in the header of each page 
using the icon and description corresponding to the workflow step.

• The Table of contents, as well as the first page of each section on measurement objects 
(data color maps, features, comparison points, cross-sections, and gauges), offer 
hyperlinks to the listed subjects.

A menu-based approach

• In the PolyWorks Metrology Suite, most of the functionalities offered on the menus are 
also available through toolbars. In this document, the menu paths are documented in the 
procedure. The corresponding toolbar buttons are shown to the right, as shown in the 
example below. 

Key parameters

• Key parameters, used for the creation of measurement objects, are explained in the 
introduction of the section pertaining to the object type, to avoid redundancy. For 
example, when creating a feature, it is specified to enter a maximum distance. For 
information on this parameter, see the introduction to features.

1. Choose Align > Feature-Based > Plane, Axis, 
Center Point.
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GETTING STARTED
Text formatting

The following text formatting conventions are used throughout the Essentials:

Objective and Required: 

For each procedure, the objective is stated and the requirements are listed. 

Sections:

Each procedure is organized using the following sections:

• Steps: Present the steps to follow for each tool.

• Results: Present the results in the Tree View (to the left) and the 3D scene (to the right). 
For simplification purposes, the in-tolerance status of measurement objects is only 
shown in Tree View images when relevant.

• Notes: Present useful additional information on the current tool.

• Tips: Present hints on how to use the current tool in a specific context.

Graphical user interface elements:

• Menu paths are presented in gray and italics, and chevrons are used to show the 
sequence. 

For example: Align > Best-Fit Data Objects > Data to Reference Objects

• Dialog boxes are capitalized. 

For example: The Best-Fit Data to Reference Objects dialog box opens.

• Parameters are presented in bold.

For example: In the Method list, click Fit to Reference Object Surfaces.
24



GETTING STARTED
Introducing the Workspace Manager

When starting the PolyWorks Metrology Suite, the Workspace Manager interface displays.

The Workspace Manager manages a PolyWorks process from beginning to end. This includes 
the following tasks:

• Adding software license keys.

• Managing all the incoming data files and the results produced by the PolyWorks 
Metrology Suite modules. As work progresses, files and projects are saved to a 
container called a “workspace”.

• Offering simple navigation between modules. 

Adding license keys

License keys are required to use the PolyWorks Metrology Suite. There are two 
types of licenses: node-locked or floating. Both types are managed through the 
PolyWorks Metrology Suite License Manager, which is available by choosing Tools > 
PolyWorks License Manager in the Workspace Manager.

For information on how to add license keys, choose Help > Reference Guides > License Keys.
25



GETTING STARTED
Introducing the workspace format

The Workspace Manager uses a workspace format which is designed to handle all the results 
of a point cloud processing project.

The .pwk file and associated _Files folder must remain in the same folder.

Starting the PolyWorks Metrology Suite modules

The Workspace Manager provides direct access to the PolyWorks Metrology Suite modules. 
The main modules are accessible through the Main Modules toolbar. Click a module button to 
launch the corresponding module. The present document covers the PolyWorks|Inspector 
module.

Note that the modules offered depend on the PolyWorks package used. All modules are 
described below.  

Here is a view of a workspace in the 
Workspace Manager. 

When a workspace is saved, it creates one 
XML file with the .pwk file and one folder with 
the _Files suffix. Both file and folder include 
the workspace name. The .pwk file is only an 
index – the folder contains all the data.

 

=

PolyWorks|Inspector

PolyWorks|Inspector

This module is a software tool that allows performing data alignments to 
Reference objects, measuring the deviations of Data point clouds and 
polygonal models to Reference surfaces, measuring the dimensions of 
specific features, and generating comparison and verification reports. Data 
acquisition can be performed in real time by probing and scanning the part.
26



GETTING STARTED
Utility modules
The complete list of modules is offered in Tools and in Tools > Utility Modules:

PolyWorks|Inspector Probing

Accessible through the down arrow of PolyWorks|Inspector, this module is a 
software tool that allows performing data alignments to Reference objects, 
measuring the dimensions of specific features, and generating comparison 
and verification reports. Data acquisition can be performed in real time by 
probing the part.

PolyWorks|Inspector for Modeler

Accessible through the down arrow of PolyWorks|Inspector, this module 
offers tools for data acquisition, data alignments, coordinate systems, and 
feature creation.

PolyWorks|Modeler 

PolyWorks|Modeler

This module offers a comprehensive set of advanced editing tools for 
polygonal models where NURBS patches can be created to conceive NURBS 
models or repair polygonal models. PolyWorks|Modeler also allows creating 
parametric sketches, which can be imported into CAD modeling software. 

PolyWorks|Modeler Light

This module is available with the PolyWorks|Inspector Premium package only. 
It offers editing tools for polygonal models, such as tools for reducing models, 
verifying their watertightness, or improving their appearance.

PolyWorks|Reviewer

This module allows viewing inspection projects and polygonal models.

IMAlign

This module is a software tool that accepts point clouds from all digitizers, 
and permits capturing point clouds in real time, and allows aligning these 
point clouds using the shape of the points clouds and, if desired, reference 
points.

IMMerge

This module allows automatically merging a set of aligned 3D scans of an 
object into a high-resolution polygonal model.
27



GETTING STARTED
Setting essential project options

Certain default values and parameters used in the PolyWorks Metrology Suite can be set in 
the Workspace Manager. The following procedure presents the options that are most 
frequently used. For information on the other options, see the PolyWorks Reference Guide 
available from the Help menu.

Objective: Set the units of length, the language, the plug-in(s) available in the module, and 
enable the Talisman functionality.

Required: The Workspace Manager is open.

Steps

To set project options, choose Tools > Options.

The Workspace Manager Options dialog box 
opens. 

Note that changes made to the options do not affect an open module; they apply the next time the 
module is launched.

Units of length

On the General page:

1. Select the units of length that will be used by 
default for the PolyWorks Metrology Suite 
modules.

2. Click Apply.

Regardless of what units of length are set in the 
Workspace Manager options, it is always possible 
to change the units within a module after opening 
it.

Language

On the Display page:

1. Select the language for the user interface.

2. Click Apply.
28



GETTING STARTED
Notes

If the Bonjour™ networking technology, a trademark of Apple Inc., is not installed on the 
workstation, the user will be prompted to install it.

Plug-ins

The PolyWorks Metrology Suite offers a wide choice of plug-ins that allow the capture of 3D 
coordinate points by way of line scanning and probing devices.

To use one or more plug-ins, the appropriate option must be selected. Only selected plug-ins 
will be loaded when PolyWorks|Inspector is launched. 

On the Plug-ins page:

1. Select one or more plug-ins.

2. Click Apply.

For information on a plug-in, see the custom document specific to this plug-in, which is available 
from the Help menu of the application.

Talisman functionality

PolyWorks|Talisman™ is a remote control application developed to allow controlling a 
probing/scanning session using a mobile device (such as Apple® iPod touch®, iPhone®, and 
iPad™ as well as Android mobile devices running Android 4.1 or higher).

To use the Talisman functionality, the appropriate option must be selected.

On the Talisman page:

1. Select PolyWorks server for Talisman.

2. The change applies to all open modules.

For information on PolyWorks|Talisman, see the 
Talisman Android or Apple Mobile Device User 
Guides and the Talisman Network Security and 
Setup Guide, which are available from the Help > 
Reference Guides > PolyWorks|Talisman menu 
of the application.

3. Click Apply. 
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PolyWorks|Inspector™
The PolyWorks|Inspector module is a

software tool that allows measuring
the deviations of Data objects to

Reference surfaces, measuring the
dimensions of specific features, and

generating comparison and
verification reports.

PolyWorks|Inspector offers an
object-oriented approach to

comparison and verification tasks. A
global object called the

PolyWorks|Inspector project
encloses all other objects. Inspection

projects describe the list of objects
imported and created within

PolyWorks|Inspector, and preserve
editing operations performed by

users. Within a
PolyWorks|Inspector project,
several categories of objects

can be generated.



GETTING STARTED
The inspection workflow

A basic inspection workflow is illustrated below. 

Import
Reference object

Report
measurement results

Align
Data object

to Reference object

Acquire
Data object 

Measure
dimensions and

 deviations
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GETTING STARTED
Understanding the workflow  

Import Reference object
Import the nominal information of the part 
(CAD model) into the inspection project.

Acquire Data object
Acquire or import the data of the actual part 
to inspect, as a point cloud or a polygonal 
model.

Align Data object to Reference 
object
Move the data close to the CAD model. This 
allows measuring deviations of the Data 
object to the Reference object, and to take 
advantage of powerful tools such as 
measurement extraction and visual 
guidance.

Measure dimensions and 
deviations
Perform the inspection of the part. Measure 
the deviations between the part and the 
nominal, in form, dimension, and position.

Report measurement results

Report the inspection measurement results 
using:

• Control views in the Control Reviewer;

• Tables and snapshots in formatted 
reports.
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GETTING STARTED
The probing workflow with a CAD model

Here is the basic inspection workflow when using only a probing device to perform the 
inspection and a CAD model of the inspected part is available. 

Report
measurement results

Align part
to Reference object

Import
Reference object

Measure
dimensions and

 deviations
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Understanding the workflow

Import Reference object
Import the nominal information of the part 
(CAD model) into the inspection project.

Align part to Reference object

Prealign part to Reference object

Prealign the part to the CAD model to take 
advantage of the visual guidance tools.

Refine part alignment to Reference 
object

Refine the part alignment to the CAD model 
using feature-based alignments, reference 
targets, or datum reference frames.

Measure dimensions and 
deviations
Perform the inspection of the part by 
probing point clouds and/or measurement 
objects such as features and comparison 
points.
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Report measurement results

Report the inspection measurement results 
using:

• Control views in the Control Reviewer;

• Tables and snapshots in formatted 
reports.
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GETTING STARTED
The probing workflow without a CAD model

Here is the basic inspection workflow when using only a probing device to perform the 
inspection and no CAD model of the inspected part is available.

 

Acquire 
part data

by probing

Position part

Report
measurement results

Measure
dimensions and

 deviations
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Understanding the workflow  

Acquire part data by probing
Acquire part data by probing point clouds 
and/or measurement objects such as 
features and comparison points on the 
actual part. 

Position part

Align part to standard axes

Align the probed data points to standard 
axes (X, Y, Z) to facilitate reporting. Note that 
this step is optional.

OR

Create coordinate systems

Create a coordinate system using the probed 
features to orient and locate the probed data 
points. This facilitates reporting. Note that 
this step is optional.

Measure dimensions and 
deviations
Complete the part measurement. Enter 
object control nominal values and 
tolerances, if they are known, into the 
Geometry Controls pane. 
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Report measurement results

Report the inspection measurement results 
using:

• Control views in the Control Reviewer;

• Tables and snapshots in formatted 
reports.
38



Fundamentals



40

FUNDAMENTALS

The graphical user interface

The user interface offers a menu bar, toolbars, a status bar, and several main dockable panes.

 

1 Menu bar: Access to all PolyWorks|Inspector functionalities.

2 Standard toolbar: Quick access to common operations (e.g., Open, Save, and 
Undo).

3 Main Objects toolbar: Quick access to the most common tools for an inspection.

4 Search box: Used to enter a query and search through Tree View objects or 
menu items. 

5 Multipiece Inspection 
toolbar: Quick access to the various multipiece tools.

6 Tree View: Pane where all the objects of the project are stored.

7 3D Scene: 3D rendering window where objects are displayed.

8 Status bar:
Provides information and allows changing project units, the 
active layer, the propagation status, and the automatic update 
status.

9 Selection toolbar: Used to select objects or elements in the project.

10 3D Scene toolbar: Used to navigate in the 3D scene, to change the view, and to 
control the visibility and display of objects.

1
2

3 4 5
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Specifying the required plug-ins

Measurement devices can be used for data acquisition in the PolyWorks Metrology Suite. To 
do so, the required plug-ins must be specified.

The plug-ins that will be made available in PolyWorks|Inspector depend on the settings in the 
Workspace Manager Options. These options are displayed the first time that the 
PolyWorks Metrology Suite is opened. They are also available at any time by following these 
steps: 

Connecting to devices

To use a scanning or a probing plug-in, a connection must first be established with the device. 
To do so, use the Devices toolbar, which is displayed in the lower left-hand corner of 
PolyWorks|Inspector. It offers the following standard functionalities:    

1. In the Workspace Manager, choose Tools > 
Options. The Workspace Manager Options 
dialog box opens.

2. On the Plug-ins page, select the plug-ins that 
correspond to the scanning or probing device 
that will be used. 

3. Click Apply. 

4. Start PolyWorks|Inspector. 

The options set on the Plug-ins page are automatically saved and are used at the next module 
startup.

Connect to/Disconnect from Device

Connects to or disconnects from the current probing device.

Scan

Opens the Scan dialog box.

Offline Simulation Mode

Activates or deactivates a simulation mode, where operations 
can be performed without having to be physically connected to a 
device.
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Particularities when scanning

An additional toolbar is offered when scanning. The first step consists in specifying the 
appropriate plug-in, then connecting to the device. 

Connecting to a scanning device

Proceed as follows to establish a connection with the device:

The plug-in dialog box opens and, once the scan operation is launched, a scanning toolbar 
appears in the 3D scene. The functions offered through this toolbar depend on the specified 
parameters (real-time quality meshing enabled or not) while scanning.  

It offers the following buttons:

1. Choose Tools > Plug-ins.

2. Choose a device.

Alternatively, click the arrow next to the Scan 
button on the Devices toolbar. Choose the device 
from the list, then click the Scan button.

Delete Last Scan Pass

Deletes the last scan passes of the current scanning session. Offered in both 
cases, for scanning using real-time quality meshing or not.

Feature Scanning Guidance

Activates or deactivates feature scanning guidance.

When a clipping plane has been defined, the following button becomes available:

Clipping Plane

Activates or deactivates the use of the clipping plane when surface scanning 
is performed.

The following buttons are only offered when real-time quality meshing is used:

Recover Last Deleted Elements

Recovers the last deleted elements of the current scanning session.
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For information about scanning plug-ins, including real-time quality meshing and quality 
metrics, see Scanning a part using a point cloud digitizer plug-in on page 91.

High Scanner-to-Surface-Normal Angle

Activates or deactivates the High Scanner-to-Surface-Normal Angle quality 
metric.

Low Scan Density for Mesh Curvature

Activates or deactivates the Low Scan Density for Mesh Curvature quality 
metric.

High Noise Level

Activates or deactivates the High Noise Level quality metric.

The following buttons are only offered when the scanning session is launched from a 
measurement sequence:

Start Scan

Starts or resumes the scanning session.

End Scan

Pauses or ends the scanning session, depending on whether scanning is 
performed with or without real-time quality meshing.
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The graphical user interface specific to probing

When probing, the user interface offers different probing toolbars, probing status 
information, and a Digital Readout.     

1 Probing Status: Displays the progression in capturing points.

2 Digital Readout: Displays real-time information about the position of the probe 
and information related to the object being probed.

3 Devices toolbar: Offers items to connect to the probing device.

4 Probing Device 
toolbar:

Offers quick access to set probing device properties.

5 Probing Device 
Control toolbar:

Available for specific probing devices, such as laser trackers, to 
control the device.

6 Probing Control 
toolbar:

Offers items to control the probing session that is being 
performed.

7 Device Positions 
toolbar:

Offers quick access to device-position-related operations such 
as defining targets, moving the device, and managing device 
positions and targets.

1

7

2

3 4 5 6
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Particularities when probing

Additional toolbars are offered when probing. The first step consists in specifying the 
appropriate plug-in, then connecting to the device. According to the selected device, one or 
more toolbars are added to the user interface.

Connecting to a probing device

To use a probing plug-in, proceed as follows:

Probing toolbars are displayed in the lower part of PolyWorks|Inspector. They contain tools 
and settings to facilitate the probing session. The tools and settings offered depend on the 
current device. In this section, only the most common functionalities are presented. For 
information on a functionality specific to a device, see the Plug-in Guide of this device which is 
located on the Help menu of the Workspace Manager or the PolyWorks|Inspector module.

Probing Device toolbar

For articulated arms, the Probing Device toolbar contains the following standard 
functionalities:    

1. On the Devices toolbar (located in the lower 
part of PolyWorks|Inspector), click the arrow 
next to the Connect to Device/Disconnect 
from Device button.

2. Choose the device from the drop-down list.

3. Click the Connect to Device/Disconnect from 
Device button.

The button changes, as shown to the right.

Device Properties

Opens the property sheet of the current probing device.

Tip Diameter

Displays the current probe tip diameter.

Probing Mode

Sets the probing mode for the current probing device.

6
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For laser trackers, the Probing Device toolbar offers the following standard functionalities:   

Probing Options

Provides quick access to options typically located on the Measurement 
Mode and Compensation Method pages of the PolyWorks|Inspector 
Options dialog box.

Device Properties

Opens the property sheet of the current probing device.

Reflector

Sets the reflector used by the current probing device.

Reflector Diameter

Displays the current reflector diameter or the Reflector 
Normal/Tangent offset.

Probing Mode

Sets the probing mode for the current probing device.

Probing Options

Provides quick access to options typically located on 
the Measurement Mode and Compensation Method 
pages of the PolyWorks|Inspector Options dialog box.

Temperature Stability Monitoring

Opens a dialog box used to control temperature 
stability monitoring.

38.1
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Probing Device Control toolbar

For laser trackers, the Probing Device Control toolbar offers items to control the probing 
device. The following standard functionalities are offered:   

Go Home

Orders the current probing device to move to, or to target, a location called 
"Home".

Go Front

Orders the current probing device to move to, or to target, its front.

Go to Object

Orders the current probing device to move to, or to target, the location of the 
selected object.

Go to XYZ

Orders the current probing device to move to, or to target, the specified XYZ 
coordinates.

Find Target

Orders the current probing device to find a nearby target.

Probing Device Utilities toolbar

Provides access to specific tracker functionalities.

Orient to Gravity

Measures the inclination of the current probing device in order to orient new 
measurements to gravity for the active device position.
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Probing Control toolbar

The Probing Control toolbar offers items to control the probing session that is being 
performed. It offers the following standard functionalities:  

Depending on the connected device, two additional functionalities are offered:

Undo Last Probed Point

Removes the last probed point of the current acquisition session.

Reprobe Object

Enables an interactive mode to reprobe the last probed object.

Start or Stop Measurement

Starts or stops a measurement session.

End Probing and Process Probed Data

Ends the current acquisition session and attempts to create a new object 
using the probed points.
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Interactive mode guidance

PolyWorks offers many interactive modes. Interactive modes are modes for operations where 
clicking in the 3D scene is required. Interactive mode guidance helps in quickly discovering, 
learning, and mastering these modes. The different parts of interactive mode guidance are 
described below. 

1 Interactive mode 
guidance toolbar:

Provides information on the current interactive mode as well 
as quick access to general operations. Information on how to 
perform the operation can also be accessed.

2 How To window: Provides more information on how to perform the operation, 
and in some cases offers diagrams.

3 Contextual toolbar: When applicable, offers quick access to operations that are 
specific to the current interactive mode.

1

2 3
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Interactive mode guidance toolbar

The interactive mode guidance toolbar, displayed at the top of the 3D scene while in the 
interactive mode, displays information regarding the current interactive mode as well as quick 
access to show or hide the How To window and to perform 3D scene manipulations. It can 
also be used to exit the current mode.

The N Point Pairs Alignment interactive mode is provided as an example.    

Notes

Information on the current interactive mode

Displays the name and, when applicable, the icon for the current inter-
active mode.

How To Window

Opens or closes the How To window.

3D Scene Manipulations (Spacebar)

Temporarily interrupts the mode to perform translations/rotations in 
the 3D scene.

Close/Back

The Close button is offered to exit the current mode. If the current 
mode was launched through another mode, the Back button is offered 
to exit the current mode and return to the previous mode.

Shortcut keys and mouse buttons, such as the SPACEBAR and the right-click, can also be used 
to perform operations such as to interrupt the mode to perform translations/rotations or to 
exit the mode.
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How To window

Contextual toolbar

The How To window is displayed in the Dialog 
Zone when the How To Window button is clicked. 

It offers detailed instructions and, when 
applicable, diagrams that guide the user in 
completing the operation while in the current 
interactive mode. 

In some cases, it also offers a Note and a 
Shortcuts section at the bottom to provide 
information to further assist the user.

In some cases, a contextual toolbar is displayed at 
the bottom of the 3D scene. It offers buttons that 
provide quick access to certain operations for the 
current interactive mode.
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Using the Search tool

PolyWorks|Inspector offers a Search tool, used to 
quickly find Tree View objects or menu items by entering 
text in the appropriate field. It is available in the upper-
right corner of the interface.

Steps

1. Enter text in the Search field (partial terms can 
also be entered).

The Search tool is not case-sensitive.

Results appear as soon as the first letter of the 
search string is entered. 

2. If needed, continue refining the search.

The list of results is displayed under the Search field. The results are organized within the 
Tree View and Menus sections which can be collapsed or expanded.

 

The number of hits for each section is displayed 
between parentheses. If a large number of 
results are found, they are not all displayed. To 
see them all, click Show all or the [...] symbol.
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Results

3. Click the appropriate object or item in the list of search results.

Note the following:

• Right-clicking an object in the Tree View section displays the shortcut menu for the 
object, making the operations related to that object easily accessible. 

• Hovering the mouse over an item in the Menu section displays a short description of 
the corresponding operation.

.

• When clicking a search result for a Tree View object, the object is also selected in the Tree 
View and, if applicable, it is centered in the 3D scene. 

• When clicking a search result for a menu item, the corresponding operation is launched.
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Quickly importing Reference and Data objects

It is possible to import Reference objects and/or Data objects by dragging the selected files 
from a Windows file browser and dropping them anywhere in an open PolyWorks Metrology 
Suite module, allowing users to quickly import more than one type of object at once (i.e., point 
clouds, CAD models, and polygonal models) . 

When dragging and dropping files, file formats are automatically detected. 

Objective: Quickly import Reference and/or Data objects using the drag and drop operation.

Required: A supported file format is available. A PolyWorks Metrology Suite module is open.

Steps

1. In Windows Explorer, locate the files to import.

2. Drag and drop the files in an open module.

3. Specify the import parameters as needed.
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Results

Notes

The files are imported and stored under the 
Reference branch or the Data object branch of 
the Tree View based on their respective 
formats.

The objects are shown in the 3D scene.

 

When importing JT file types, the Object Type to 
Import dialog box opens. Specify whether the 
selected objects are imported as CAD models or 
polygonal models. 
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Views in the 3D scene

The content of the 3D scene can be viewed using standard 
views (e.g., +X), custom user-saved views, and views based on 
the normal of an object.

Interactive view selector

The 3D scene offers a view selector that allows specifying orthogonal or isometric views 
interactively.

Objective: Set a view interactively using the view selector.

Required: An object is displayed in the 3D scene.

Steps

Results

1. To display the view selector, represented by a 
cube, place the mouse pointer in the lower-left 
corner of the 3D scene.

2. To specify an orthogonal view in the 3D scene, 
click a face of the cube or an axis.

3. To specify an isometric view, click a corner of 
the cube.

The 3D scene content is displayed according to 
the specified view clicked on the view selector. 
The axes are based on the active coordinate 
system.
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Standard views

Standard views (e.g., +X) based on the active coordinate system axes are offered. 

Objective: View the content of the 3D scene using a standard view.

Required: An object is displayed in the 3D scene.

Steps 

Results

1. Choose View > Standard Views > [choose view 
type].

Alternatively, click Standard Views on the 3D 
Scene toolbar.

2. Choose which standard view to display in the 
3D scene. This is based on the active coordinate 
system.

The 3D scene content is displayed according to 
the selected view based on the active 
coordinate system.
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Shortcuts through the interface

Shortcuts to different functionalities are offered when right-clicking elements or areas of the 
user interface.  
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Moving objects in the 3D scene

The position of objects can be modified in the 3D scene using the mouse. Rotations, 
translations, and zoom operations are each mapped to a specific mouse button.

Mouse-based operations:  

Rotation

To rotate about the X axis and the Y axis viewing axes, click and hold the left 
mouse button in the 3D scene. To constrain rotations to a vertical or a 
horizontal viewing axis, press and hold SHIFT before clicking.

Translation
To translate along the X axis and the Y axis, click and hold the middle mouse 
button. Translations along the X axis or the Y axis are performed by moving the 
mouse in the X or Y directions respectively, in the 3D scene.

Zoom
Translating along the Z axis is equivalent to a zoom operation. Click and hold 
the right mouse button, then move the mouse forward and backward. When 
the mouse is moved forward, a positive translation is performed on the 3D 
object, and the scene moves nearer to the user. When the mouse is moved 
backward, a negative translation is performed on the 3D object, and the scene 
moves farther away from the user.

Zoom box
Zoom on part of an object by delimiting a rectangular area:

1. Press and hold SHIFT.

2. Middle-click to create a first rectangle corner.

3. Drag the pointer to the opposite rectangle corner.

4. Release the middle mouse button.

Rotation about the viewing axis

To rotate about the viewing axis, press and hold SHIFT, click and hold the right 
mouse button, then move the mouse in the right or left direction. 

Mouse Button Behavior menu button
Note that the same operation can be assigned to all mouse 
buttons by selecting a corresponding button on the 
Mouse Button Behavior menu button, available on the 
3D Scene toolbar.



FUNDAMENTALS
An object-based approach

PolyWorks|Inspector offers an object-oriented approach to measurement and analysis tasks. 
Inspection projects describe the list of objects imported and created within 
PolyWorks|Inspector and they preserve editing operations performed by users. Several 
categories of objects can be generated within an inspection project. They are described in the 
subsections that follow.

Objects and their elements 

Objects are items found in the Tree View, such as Data and Reference objects. They are made 
up of elements, like data points in a point cloud, or surfaces in a CAD model. Both entire 
objects and specific elements can be considered for analysis during inspection.

Module Objects Elements

PolyWorks|Inspector

point cloud

polygonal model

CAD model

data points

vertices 

CAD surfaces

There are two interactive 
selection tools, one for 
objects and one for elements.

A point cloud contains data points.

A polygonal model contains triangle vertices.

A CAD model contains CAD surfaces.
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As shown below, the list of objects is available in the Tree View.       

Reference object 
Tools > Reference Objects

Data object 
Tools > Data Objects

Data alignment 
Align

Data color map 
Measure > Deviations of Data Objects

Feature 
Measure > Features

Cross-section 
Measure > Cross-Sections

Comparison point 
Measure > Comparison Points

Gauge 
Measure > Gauges

Custom measurements

Measure > Custom Measurements

Interactive measurements 
Measure > Interactive Measurements > 
Basic

Reference target 
Measure > Reference Targets

Coordinate system 
Tools > Coordinate Systems

Report 
Report
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Selecting objects

Objects can be selected in the Tree View or in the 3D scene by using 
the Select Objects Interactively tool. Object selection is needed in 
order to apply operations to specific objects.

Objective: Select an object interactively in the 3D scene.

Required: The project contains a Reference or a Data object.

Steps

Results 

1. Choose Select > Objects > Interactively.

Alternatively, press CTRL + SHIFT + SPACEBAR to 
enable the object selection mode.

2. Pick objects in the 3D scene.

3. Press and hold CTRL to select additional 
objects.

4. Press the Select Objects Interactively button 
to exit the object selection mode.

The selected object is highlighted in the 
Tree View. 

 

IMBlock.pqk
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Notes

Selecting elements

It is possible to select a single element or groups of elements, 
either on the nearest surface or volumetrically (through the 
dataset). Element selection is needed in order to apply 
operations to specific elements.

The Select Elements dialog box used to select elements is 
available through Select > Elements > Interactively.

• Hold CTRL + SHIFT + middle-click while 
dragging to create a rectangular selection 
zone. The objects within the zone are selected.

• The type of objects that can be selected can be 
specified. Click the arrow next to the Select 
Objects Interactively button, then enable or 
clear the objects in the menu.

• Additional object selection tools are available on the Select > Objects menu, including 
Select > Objects > All, Select > Objects > None, and Select > Objects > Invert. 
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Selection tools
In the Select Elements dialog box, five selection tools are available:  

Selection modes
In the Select Elements dialog box, three Selection Modes are available:

Multiple

Different selection tools can be accessed depending on the mouse button and the 
quick access key used:

• Brush: Left-click

• Freeform Contour: Middle-click + hold

• Polygonal Contour: Middle-click + CTRL key 

To select a single element: Left-click + CTRL key.

Brush 

Used to perform element selection in the 3D scene by dragging the mouse over the 
object. Elements within the area defined by the brush tip are selected once the 
mouse is released.

Freeform Contour 

Used to perform element selection in the 3D scene by dragging the mouse over the 
object and defining a free-form contour. Elements within the area defined by the 
contour are selected.

Polygonal Contour 

Used to perform element selection in the 3D scene by left-clicking to anchor a 
polygonal outline until a polygonal contour has been formed. The contour is closed 
by left-clicking near the end of the initial line or by simply right-clicking to add a 
final point. Elements within the area defined by the contour are selected.

Single Element

Used to perform single element selection in the 3D scene by left-clicking the 
element. The type of element selected depends on the object type.

Select 

Selects elements.

Deselect

Deselects elements. Hold the ALT key as a shortcut.
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Selection types
In the Select Elements dialog box, two Selection Types are available:

Selectable faces
In the Select Elements dialog box, three Selectable Faces can be used to control which 
elements are selected:

Global element selection
In the Select Elements dialog box, three buttons give quick access to the global element 
selection operations that are available: 

Toggle 

Inverts the element selection status. It can be used to select elements or deselect 
elements that have already been selected.

Surface 

Element selection is performed on the visible surfaces of the object.

Volumetric

Element selection continues through the object, including elements behind the 
visible surfaces.

Front

Selects only elements that are facing up in the 3D scene.

Back

Selects only elements that are facing down in the 3D scene.

Front and Back

Selects elements regardless of orientation.

All

Selects all elements.

Invert 

Inverts the selection of all elements.
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Notes

Element selection operations are also available through the Select > Elements menu.

None

Deselects all elements.
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Selecting elements using the Brush tool

Objective: Select multiple Reference or Data object elements with the brush tool.

Required: The project contains a Reference or Data object with selectable elements.

Steps  

1. Choose Select > Elements > Interactively, or press 
SPACEBAR to enable the interactive element 
selection mode.

The Select Elements dialog box opens.

2. Select the Brush selection tool.

3. In the 3D scene, hold the left mouse button 
while dragging the mouse over the object to 
select all elements within the brush stroke, such 
as:

• CAD model surfaces. 

• Polygonal model vertices.

• Point cloud data points.

It is possible to switch to the Deselect mode by 
holding the ALT key and performing the same 
action.

4. Press ESC or SPACEBAR to exit the selection 
mode and close the Select Elements dialog box.
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Results  

Notes

The selected elements are highlighted in red in 
the 3D scene.

Since the selection was performed using the 
Surface selection type, none of the elements 
behind the visible surfaces were selected.

Point clouds have no surface information, so the 
selection type automatically changes to 
Volumetric when it is detected that the selection 
is being performed on point clouds.

• The Volumetric selection type continues 
through the object, including elements 
behind the visible surfaces.

• In the More section, it is possible to change 
the shape of the brush tip to Square.

• The brush tip can be resized interactively in 
the 3D scene by scrolling the mouse wheel.
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Selecting elements using the Freeform Contour tool 

Objective: Select multiple Reference or Data object elements by defining a freeform contour.

Required: The project contains a Reference or Data object with selectable elements.

Steps  

Results  

1. Choose Select > Elements > Interactively, or press 
SPACEBAR to enable the interactive element 
selection mode.

The Select Elements dialog box opens.

2. Select the Freeform Contour selection tool.

3. In the 3D scene, hold the left mouse button 
while dragging the mouse over the object to 
select elements such as: 

• CAD surfaces.

• Polygonal model vertices.

• Point cloud data points.

It is possible to switch to the Deselect mode by 
holding the ALT key and performing the same 
action.

4. Press ESC or SPACEBAR to exit the selection 
mode and to close the Select Elements dialog 
box.

The selected elements are highlighted in red in 
the 3D scene.
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Notes

Since the selection was performed using the 
Surface selection type, none of the elements 
behind the visible surfaces were selected.

Point clouds have no surface information, so the 
selection type changes to Volumetric 
automatically when it is detected that the 
selection is being performed on point clouds.

• To perform a selection with a polygonal 
contour, select the Polygonal Contour 
selection tool. Left-click to anchor corners 
of the polygonal outline; to close the 
contour, left-click near the end of the initial 
line or simply right-click to add the last 
point.

• The Volumetric selection type continues 
through the object, including elements 
behind the visible surfaces.
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Selecting a single element

Objective: Select a single element on a Reference or Data object.

Required: The project contains a Reference or Data object.

Steps

Results

1. Choose Select > Elements > Interactively, or press 
SPACEBAR to enable the interactive element 
selection mode.

The Select Elements dialog box opens.

2. Select the Single Element selection tool.

3. In the 3D scene, left-click on:

• a CAD surface to select it.

• a polygonal model to select the nearest 
vertex.

• a point cloud to select the nearest data 
point.

4. Press ESC or SPACEBAR to exit the selection 
mode and to close the Select Elements dialog 
box.

The selected surface, vertex, or data point is 
highlighted in red in the 3D scene.
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IMPORTING REFERENCE OBJECTS
Introducing Reference objects

Reference objects are the nominal objects (typically a CAD model or a polygonal model) to 
which the Data objects are measured.

Categories of Reference objects

There are two categories of Reference objects. The following table presents each category: 

Once a Reference object is imported, it is displayed in the 
Tree View under the Reference branch.

Assigning tolerances

Tolerances are automatically assigned to Reference objects. A tolerance is useful for obtaining 
pass/fail inspection results. For example, when a data point is no farther from the surface 
than a given tolerance value, the point “passes” the tolerance test. If the data point is farther 
from the surface than the same tolerance value, the point “fails” the tolerance test. See 
Assigning tolerances to Reference objects on page 80.

Icon Type Description

CAD Reference objects All imported CAD formats.

Polygonal Reference 
objects

Polygonal models as well as IMAlign projects and 
planar grid/mesh point clouds that have been 
triangulated.
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Controlling CAD model display colors

The color used to display CAD models can be controlled through the properties of the 
CAD Reference object. 

Three color display modes are offered: Object, By CAD Layer, By CAD Surface.

Objective: Change the color display mode of the CAD model.

Required: The project contains a CAD model with embedded surface color information 
imported along with layers.

Steps

Results

1. Select the CAD model in the Tree View.

2. Choose Edit > Object Properties. 

3. On the Display tab, choose from the Color 
mode list one of the following options:

• Object

• By CAD Layer

• By CAD Surface

4. Click Apply.

Object

The CAD Reference object color is displayed using 
the defined color mode. The whole CAD Reference 
object is the same color.

The CAD Reference object color can be changed from 
its property sheet using the Color button.
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Notes

By CAD Layer

The CAD Reference object color is displayed using 
the defined CAD layer colors. 

If specific surfaces of the CAD Reference object are 
associated to specific CAD layers, each surface is 
colored depending on the color definition of its 
associated CAD layer.

By CAD Surface

The CAD Reference object color is displayed using 
the defined CAD surface colors. 

The surface color is defined in the CAD software and 
imported automatically in PolyWorks|Inspector.

The default color mode can be set in the 
PolyWorks|Inspector options and saved in the 
user configuration.

1. Choose Tools > Options to access the 
PolyWorks|Inspector options.

2. Open the Display > Reference/Data page.

3. Choose the Default CAD color mode.

4. Click Apply.

5. Choose Tools > Save User Configuration to save 
the user configuration.
75



IMPORTING REFERENCE OBJECTS
Using CAD models to describe nominal parts

It is common practice, in the industry, to design the shape of 
parts using 3D drawing software, commonly known as 
computer-aided design (CAD) software. CAD models greatly 
simplify the task of defining nominal geometries and 
dimensions, an essential step in the process of inspecting parts.

Importing a CAD model

Objective: Import a CAD model, into the inspection project, as a Reference object.

Required: A CAD file in a neutral format (IGES or STEP file) or a native format (such as CATIA, 
NX, Creo, SolidWorks, or Inventor).

Steps

Results 

1. Choose File > Import > CAD Models.

A file browser opens.

2. Browse for the CAD file and select it.

3. Click Open.

The CAD model is added to the Tree View, 
under the Reference branch.

The CAD model is displayed in the 3D scene.
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Importing Product and Manufacturing Information (PMI) with the 
CAD model

Some computer-assisted design platforms have the capability to add geometric dimensioning 
and tolerancing controls to the model in order to have this information embedded in the file. 
Depending on the CAD file format, the import options may include extracting features and 
their feature control frames to import the model with the GD&T control information. The 
import options are offered on the CAD Models page of the PolyWorks|Inspector Options.

Objective: Import a CAD model with embedded GD&T control information.

Required: CAD model with embedded GD&T controls in a format such as CATIA V5 and V6, 
Creo, JT, NX, SAT, or SolidWorks.

Steps

1. Choose Tools > Options.

The PolyWorks|Inspector Options dialog 
box opens.

2. Open the Objects > Reference/Data > 
CAD Models > [choose a file format] 
page.

3. For each required CAD file format, select 
Import features and controls.

4. Click OK.

5. Choose File > Import > CAD Models.

A file browser opens.

6. Browse for the CAD file and select it.

7. Click Open.
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Results

Notes

• A CAD translator is required to read the native CAD file formats.

• The Features and Controls Import Log is added to the Tree View, under the Reports branch. 
It provides information about the operations done by the PolyWorks Metrology Suite 
during the import process.

The CAD model is imported with the GD&T 
controls and the nominal feature compo-
nents are created automatically. 

The CAD model is displayed in the 3D scene, 
along with the features.
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Using polygonal models to describe nominal parts

Polygonal models are meshes composed of triangles and vertices 
that are the result of a merging process of the data points 
acquired by a scanning device. Polygonal models are generally 
imported as Data objects, but can also be imported as Reference 
objects. For example, the original model can be imported as a 
Reference object to monitor wear on a part over time.

Converting a polygonal Data object to a Reference object

Objective: Import a polygonal model as a Data object and convert it to a Reference object.

Required: A polygonal model file in a PolyWorks format (such as POL or PQK), or a neutral 
format (such as STL or OBJ).

Steps

Results 

1. Choose File > Import > Polygonal 
Models.

2. Browse for the file to import.

Common polygonal file formats include 
.pol, .pqk, .stl, .obj, and .ply.

3. In the Object Units list, select the 
native units of the file then click OK.

The polygonal model is imported as a 
Data object.

4. Select the polygonal model in the Tree 
View, then choose Tools > Data Objects > 
Convert to Reference Objects.

The polygonal model is now added to the 
Tree View, under the Reference branch.

The polygonal model is displayed in the 3D 
scene.
79



IMPORTING REFERENCE OBJECTS
Assigning tolerances to Reference objects

Tolerances, assigned to Reference objects, define upper and 
lower envelopes used by measurement tools to determine 
whether a measured value is within tolerance (pass) or out of 
tolerance (fail). Tolerances can be assigned to the entire 
Reference object at once, or to individual surfaces or areas.

The examples shown in the following subsections use a CAD 
model. Note that the procedure is applicable to any type of 
Reference object.

Assigning tolerances to the entire Reference object

Objective: Assign tolerances to all the surfaces of the CAD model.

Required: A CAD file, imported as a Reference object.

Steps 

1. Select the CAD model in the Tree View. 

2. Choose Tools > Reference Objects > 
Tolerances.

The Edit Reference/Primitive Tolerances 
dialog box opens.

By default, all the CAD surfaces are assigned a 
tolerance of +/- 0.5 mm, which is shown in 
purple. 

3. Enter a new value to modify the tolerance. 
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Assigning tolerances to specific surfaces

Objective: Assign tolerances to specific surfaces of the CAD model.

Required: A CAD file, imported as a Reference object.

Steps

1. Choose Select > Elements > Interactively to 
enable an interactive picking mode.

2. Left-click the CAD surfaces where a different 
tolerance must be assigned. 

3. Choose Tools > Reference Objects > 
Tolerances.

The Edit Reference/Primitive Tolerances 
dialog box opens.

4. In the dialog box, click Add to create a new 
tolerance.

5. Enter the values for the new tolerance. 

6. Click Assign to Selected CAD Surfaces.
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Results 

A new tolerance is added and is assigned to 
the selected CAD surfaces. 
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Introducing Data objects

In a typical inspection process, Data objects represent the objects that will be inspected. They 
can be imported from a standard format or created within PolyWorks|Inspector as a result of 
line scanning, probing physical objects, or using other operations (e.g., transferring).

Categories of Data objects

There are three types of Data objects covered in this guide. The following table presents each 
type:    

Data objects are displayed in the Tree View, under the Data 
branch. 

Icon Type Description

Surface Data objects 
(with normals)

Surface Data objects 
(without normals)

• Point Clouds (organized and unorganized1, line 
scans1, planar grid/meshes2, IMAlign projects2, 
and probed surface point clouds1). They are 
obtained by importing files, scanning, or 
probing.

• Polygonal Models2 obtained by importing files or 
by scanning.

1. With or without normal information.
2. Always have normal information.

Boundary Data objects 
(with normals)

Boundary Data objects 
(without normals)

Boundary point clouds obtained by importing 
unorganized point clouds1, scanning, or probing3.

3. Without normal information.

Probed Data objects 
(with normals)

Probed Data objects 
(without normals)

Data points obtained when:

• Probing measurement objects (i.e., features, 
comparison points, cross-sections, and gauges).

• Performing a surface point alignment.
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Introducing surface and boundary Data acquisition

PolyWorks|Inspector offers the capability to acquire data through the use of scanning and 
probing plug-ins. These plug-ins are only available if they have been selected from the list of 
plug-ins, which loads them during module startup such as when starting 
PolyWorks|Inspector. For more information, see Specifying the required plug-ins on page 41.

Data acquisition by scanning 

When scanning in PolyWorks|Inspector, it is possible to capture 
the surface of a part or the outer trim boundaries and the inner 
hole boundaries of thin parts. Data is acquired in the form of a 
polygonal model or a point cloud.

Scanning plug-ins are offered for various devices, including 
articulated arms, trackers, optical systems, photogrammetry-
based systems, robots, custom encoder-based translation and 
rotation systems, and so on.

Scan types

Three types of scanning are offered: 

Surface scanning  

Surface Scanning is the most common scanning 
technique. It gathers data points across all the 
material within the digitizer acquisition range. If 
using the real-time meshing technology, those 
data points are converted to a polygonal model.

See Scanning surfaces of a part to obtain a raw point 
cloud Data object on page 98.
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Surface and boundary scanning 

Sharp edge scanning  

Surface and Boundary Scanning combines the 
surface scanning behavior with the capability to 
delineate the boundaries of the part and of holes. 
Surface scanning captures data points across the 
part. Boundary scanning detects large gaps 
between surface points as part holes and saves 
the innermost data points as a boundary scan 
Data object. It also detects the end of scanned 
lines and saves the end points in the boundary 
scan Data object as well.

These boundary points can then be used for data 
color maps. This scanning method is commonly 
used when dealing with thin parts.

See Scanning surfaces and boundaries of thin parts 
on page 102.

Sharp Edge Scanning calculates the theoretical 
sharp edge of any hole or part boundary by 
extrapolating from laser readings on the part 
surface and sidewall.

See Scanning sharp edges of thin parts on page 105.
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Using a clipping plane

When scanning a part, oftentimes, a portion of the table on which the part lies is also 
scanned. In these situations, a clipping plane is useful to automatically delete points on the 
table while scanning.

This reduces the manual clean-up of the scanned data, which makes it easier to scan both 
sides of a part.

The data points are shown during the scan pass but are permanently deleted at the end of 
the pass.

The same clipping plane can be reused from one piece to another, and from one project to 
another, as it is saved in the user configuration. 

Objective: Define a clipping plane prior to scanning. 

Required: A line scanning device is ready to use. The required plug-in is loaded in 
PolyWorks|Inspector. 

Steps

1. From the Scan dialog box, enable Clipping 
plane.

2. Click Define Clipping Plane to define a 
clipping plane.

The Define Clipping Plane dialog box opens.

3. Choose a Method from the following choices.

Probe

This method is used to define the clipping plane by probing a plane.

1. In the Method list, select Probe.
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Results  

Notes

• A clipping plane defined using the Probe method does not appear in the Tree View nor is it 
displayed in the 3D scene.

• The data points filtered by the clipping plane while scanning are permanently deleted.

2. Click Probe.

A probing device must be selected in the 
probing plug-ins list. The device must be ready 
to use. 

It should be the same device that will be used to 
scan the part.

3. Probe the plane, which is typically the table on 
which the part is resting.

From Plane

This method is used to define the clipping plane from a plane feature that is already defined in 
the Tree View.

1. In the Method list, select From Plane.

Note that the selected plane must be aligned 
to the part that will be scanned.

2. Select a Plane from the list. 

Alternatively, click the Pick Plane button to the 
right of the list box to pick a plane primitive 
directly in the 3D scene.

3. Click Define.

The clipping plane is defined, and automati-
cally saved to the user configuration.
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Scanning parameters

Scanning profiles are offered in the plug-in dialog box. On choosing a profile, the value of 
scanning parameters changes accordingly, simplifying the setup of a new laser scanning 
session. Five predefined profiles are available, which are adapted to the size of the smallest 
details that will be captured:

• Coarse Resolution: for details greater than 2.0 mm in size

• Standard Resolution: for details greater than 1.0 mm in size

• Fine Resolution: for details greater than 0.5 mm in size

• Extra Fine Resolution: for details less than 0.5 mm in size

• Large Standoff: for scanners with a standoff distance over 500.0 mm

When the plug-in dialog box is opened, the latest active profile is loaded. If a laser scanning 
parameter is modified, the profile in the list box is set to (Custom). 
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A drop-down menu, to the right of the list box, allows saving the current scanning parameters 
to a user scanning profile or deleting the selected user scanning profile.

If not saved, (Custom) profiles are lost when another profile is selected.

Once the scan operation is launched, a scanning toolbar appears in the 3D scene. For 
information, see Connecting to a scanning device on page 42.

Data acquisition by probing

A probing device (such as a laser tracker or an articulated 
arm) can be used directly within the 
PolyWorks|Inspector user interface to digitize parts. 
Point clouds can be probed on the part surface, or along 
its boundaries (edges):

• When probing on the part surface: 

• If the probing device is aligned to the Reference 
object, the points can be compensated toward the 
closest surface. 

• If the probe tip has an orientation, that orientation can be used to assign point normals.

• When probing along the part edges, a boundary point cloud is created. This method can be 
used to measure the perimeter shape of a thin-walled part, such as a sheet metal part. 

For information on the user interface when probing, see Connecting to a probing device on 
page 45.
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Acquiring surface and boundary Data objects

Scanning a part using a point cloud digitizer plug-in

A point cloud digitizer plug-in is used to scan the surfaces and boundaries of a part and obtain 
a point cloud Data object or a polygonal Data object.

Meshing point cloud data in real time while scanning

The surfaces of a part can be meshed in real time while 
scanning. Creating a mesh while scanning can be done to 
obtain optimal surface data quality and highlight areas 
where data is missing.

Objective: Scan the surfaces of a part using a laser line 
scanner in PolyWorks|Inspector, automatically 
producing a polygonal model from scan passes 
in real time.

Required: A line scanning device is available and ready to use. The required plug-in is loaded 
in PolyWorks|Inspector.

Steps  

1. Choose Tools > Plug-ins > [device name].

The plug-in dialog box opens.

2. Select the Surface Scanning scan type.
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3. In the Surface list, select (Create New) to 
create a new Data object or specify an existing 
Data object to which data will be added. See 
Adding data to a scanned Data object on 
page 127.

4. Specify the Name of the new surface Data 
object.

5. Select Real-time quality meshing. 

6. Select Polygonal model as the final data type.

7. If desired, enable the Clipping plane.

8. Under Scanning options, select the 
appropriate Profile based on the size of the 
smallest details on the part.

9. In the plug-in dialog box, click Start Scan.

The scanning toolbar appears in the 3D scene, 
providing quick access to the quality metrics. See 
Analyzing the quality of the digitized polygonal 
model using metrics on page 93.

10. In the plug-in dialog box, click End Scan when 
scanning is completed.

11. Click Finalize Mesh to complete the polygonal 
model. 

Once scanning is completed, the mesh must be finalized. The seams that are left visible in the 
mesh that is under construction are automatically stitched to produce a high-quality mesh. 

Before finalization After finalization
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Results

Notes

Analyzing the quality of the digitized polygonal model using metrics

When using real-time quality meshing, the scan quality is monitored and low-quality areas are 
detected using four quality metrics: High scanner-to-surface-normal angle, Low scan density 
for mesh curvature, High noise level, Detect misaligned scan passes. 

The activation state and the parameters for each quality metric can be configured through the 
Surface Scan > Real-Time Quality Meshing > Quality Metrics page of the Line Scan Options 
dialog box. 

The scanning toolbar, displayed at the bottom of the 3D scene when the scanning mode is 
launched, provides quick access to the three quality metrics that are computed directly on the 
polygonal model as well as to their associated parameters. Click the arrow to the right of the 
buttons to modify the default values for each quality metric. All quality metrics can be enabled 
simultaneously.

The polygonal model is added to the Tree 
View, under the Data branch, as a surface 
Data object.

A polygonal model is displayed in the 
3D scene.

  

When specifying Point cloud from mesh as the final data type, the point cloud has the same 
quality and precision as the polygonal model output of the real-time quality meshing engine, 
without the extra computing time required by the mesh finalization phase. The mesh-based 
point cloud can be converted into a polygonal model at any time by selecting it in the Tree 
View and choosing Tools > Data Objects > Convert Mesh-Based Point Clouds to Polygonal Models.
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When a quality metric is activated in the scanning toolbar, areas of the scanned polygonal 
model that are identified as problematic are highlighted using a color specific to each metric. 
The four quality metrics are described in the following subsections:  

High scanner-to-surface-normal angle 
The High scanner-to-surface-normal angle 
quality metric controls the angle between the 
digitizing vector (direction along which the laser 
light is projected) and the normal vector of the 
scanned surface. This quality metric is enabled by 
default. 

The best quality data is acquired when the laser is 
normal to the scanned surface.

When the angle between the digitizing vector and 
the surface normal vector is greater than the 
specified value, the area is highlighted.

When new scan passes are added covering the 
same area with an acceptable angle, the 
highlighting is automatically removed.
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Low scan density for mesh curvature
The Low scan density for mesh curvature 
quality metric, enabled by default, identifies 
problematic areas where the local resolution of 
data points is insufficient to properly obtain a 
smooth curvature transition.

In low-curvature areas, a low density of scanned 
data points is acceptable while in high-curvature 
areas a higher density is required. Otherwise, the 
problematic area is highlighted.

  

To increase the density in areas of curvature, scan 
at a slower speed, keeping the laser line perpen-
dicular to any fillet or sharp edge, to ensure that 
the laser line wraps fillets or radii when possible.
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High noise level
The High noise level quality metric detects high 
noise levels on scanned data, often resulting from 
specular reflection (shiny material), dark 
materials (less reflected light), or textured 
surfaces (output from machining). 

Local areas where high deviations are detected 
compared to the surroundings are highlighted 
indicating the presence of a high noise level.

Note that this quality metric is deactivated by 
default because its computational time is more 
significant. It is recommended to activate this 
metric every few scan passes.

To enable this quality metric, click the High Noise 
Level button on the scanning toolbar. Click the 
arrow to the right of the button to modify the 
Standard deviation threshold value. 

Detect misaligned scan passes
The Detect misaligned scan passes quality 
metric, enabled by default, analyzes each scan 
pass as it is captured. 

Certain circumstances, such as incorrect arm 
calibrations, part displacements, or temperature 
changes can cause the misalignment of incoming 
scan passes, becoming unacceptable based on a 
specified Max average deviation.

If a scan pass is misaligned, a message appears. 
Based on the scanning accuracy requirements, 
choose to delete or to keep the scan pass.

In the Behavior when misaligned list, select 
Confirm Pass Deletion if a user confirmation is 
required prior to deleting misaligned scan passes.
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Enhancing the quality of the mesh

Once the issues have been identified using the quality metrics, the operator can rescan until 
the low-quality areas are no longer highlighted and the polygonal model meets the required 
quality criteria. This visual feedback ensures systematic high-quality measurements and 
reduces the variability of scanning results.

According to the identified issues, up to four corrective actions can be taken:

• Add new scans using a better technique

• Scanning at a moderate speed.

• Maintaining a good angle between the scanner and the surface.

• Keeping the laser line perpendicular to any fillets or sharp edges. 

• Delete scans and rescan

In the following example, a problematic area caused by specular reflection has been 
corrected by deleting the area and rescanning it. 

• Delete last scan pass  

If the last scan pass captured is of low quality, 
click the Delete Last Scan Pass button on the 
scanning toolbar to delete it and rescan.

• Reject misaligned scans

Reject misaligned scans even before they are 
integrated into the polygonal model that is under 
construction. Click Delete Pass in the message that 
appears.
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Scanning surfaces of a part to obtain a raw point cloud Data object

Surface scanning is the most common scanning technique. It 
gathers data points from all material within the digitizer 
acquisition range. As data is captured from different angles, point 
density increases in overlapping areas. Each data point location 
(x, y, z) is recorded and the point neighborhood is analyzed, 
allowing point normals (i, j, k) to be calculated.

Objective: Scan the surfaces of a part using a plug-in to obtain a raw point cloud directly in 
PolyWorks|Inspector.

Required: A line-scanning device is available and ready to use. The required plug-in is loaded 
in PolyWorks|Inspector.

Steps 

1. Choose Tools > Plug-ins > [device name].

The plug-in dialog box opens.

2. Select the Surface Scanning scan type.

3. In the Surface list, select (Create New) to 
create a new surface Data object or specify an 
existing surface Data object to which data will 
be added.

4. Specify the Name of the new surface Data 
object.

5. Clear Real-time quality meshing.

6. If desired, enable the Clipping plane.

7. Under Scanning options, select the 
appropriate Profile based on the size of the 
smallest details on the part.

8. If required, click Options to set the different 
options for the specific device.

9. In the plug-in dialog box, click Start Scan to 
scan the surfaces of the part.
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Typical scanning session

A scanning session involves scanning one or more 
passes with the same parameters. 

All scan passes are added to the same Data object 
in the Tree View (surface scan 1 in this example).

The number of acquired data points is displayed in 
the top left corner of the 3D scene.

Second scan pass.

After several scan passes.

Remove unwanted data

To remove unwanted data points at any time while 
scanning, use the interactive element selection 
mode (choose Select > Elements >  
Interactively), then press DELETE. This can be useful, 
for example, in removing data from a fixture 
holding the part. See Selecting elements on page 63.
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Results 

Best practices

Depending on the scanning device used, various settings and quality parameters may be 
available in the plug-in or in the manufacturer’s software. In general, follow the 
manufacturer’s recommendations to apply the optimal settings for the specific device and 
application. It is recommended, when available, to adjust the scanner intensity as necessary to 
capture high-quality measurements on a particular material.

When using a line scanner, the tips below also help maximize point cloud quality.

A surface Data object is added to the Tree 
View. All scan passes are added to one Data 
object. 

The point cloud is displayed in the 3D scene.

Scanner-to-surface angle
A surface is best captured when the viewpoint is 
normal to the surface.

Orientation of line scan
To best capture part details with a line scanner, 
orient each scan pass so that it runs along edges. 
Aim directly at the edge detail. This allows more 
points to be captured along the edge, capturing 
small features better.

Direction of 
scan pass
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Scan passes
Focus on one simple scan pass at a time. Rather 
than scanning around the part at multiple angles in 
one pass, stop each pass after a straight pass, 
change the position or angle, and begin a new scan 
pass. This facilitates point cloud organization and 
point normal calculations.

Filtering scan lines
Unnecessarily dense and noisy point clouds can be 
prevented by using the Filter scan lines point 
filtering option, activated by default, to remove 
data point outliers during scanning.

The example shown to the right represents the 
difference between unfiltered data points (a) and 
filtered data points (b).

The Filter scan lines option is found on the 
Surface Scan > Filtering page of the Line Scan 
Options dialog box.

(a)
(b)
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Scanning surfaces and boundaries of thin parts

Surface and Boundary scanning combines the surface 
scanning behavior with the capability to delineate the 
boundaries of a part and of holes. Surface scanning captures 
data points across the part. Boundary scanning detects large 
gaps between surface points as part holes and saves the 
innermost data points as a boundary scan Data object. It also 
detects the end of scanned lines and saves the end points in 
the boundary scan Data object as well. These boundary 
points can then be used for data color maps.  

Objective: Scan the surfaces of a part using a plug-in to obtain both a surface point cloud 
and a boundary point cloud, delineating internal and external boundaries.

Required: A line-scanning device is available and ready to use. The required plug-in is loaded 
in PolyWorks|Inspector.

Steps

1. Choose Tools > Plug-ins > [device name].

The plug-in dialog box opens.

2. Select the Surface and Boundary Scanning 
scan type.

3. In the Surface list, select (Create New) to create 
a new surface Data object, or specify an existing 
surface Data object to which data will be added.

4. Specify the Name of the new surface Data 
object.

5. In the Boundary list, select (Create New) to 
create a new Data object, or specify an existing 
boundary Data object to which data will be 
added.

6. Specify the Name of the new boundary Data 
object.

7. Select Real-time quality meshing. 

8. Select the Polygonal model as the final data 
type.

9. If desired, enable the Clipping plane.

10. Under Scanning options, select a Profile based 
on the size of the smallest details on the part.

11.  Click Start Scan.
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Typical scanning session 

Results 

A scanning session involves performing one or 
more scan passes with the same parameters. 

All scan passes are added to the same Data objects 
in the Tree View (surface scan 1 and boundary 
scan 1 in this example).

The number of acquired data points is displayed in 
the top left corner of the 3D scene.

    

Second scan pass.

   

After several scan passes.

 

A surface Data object and a boundary Data 
object are added to the Tree View, under the 
Data branch.

The polygonal model and point cloud are 
displayed in the 3D scene.

Direction of scan 
pass

Direction of scan 
pass
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Notes

The Surface and Boundary Scan page of the Line Scan Options dialog box offers:

• an option to control the minimum hole width.

• an option to turn the external boundary 
detection on or off. It is enabled by default.
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Scanning sharp edges of thin parts

The sharp edge scanning method is especially designed for 
sheet metal applications. It records data points by calculating 
the theoretical sharp edge of any hole or part boundary, 
which is obtained by extrapolating edge points from laser 
readings on the part surface and sidewall. Boundary data 
points can then be used, for example, for part boundary color 
maps. 

Objective: Scan the surfaces of a part using a plug-in to obtain a boundary point cloud, 
delineating holes and part edges.

Required: A line-scanning device is available and ready to use. The required plug-in is loaded 
in PolyWorks|Inspector.

Steps 

1. Choose Tools > Plug-ins > [device name].

The plug-in dialog box opens.

2. Select the Sharp Edge Scanning scan type.

3. In the Boundary list, select (Create New) to 
create a new boundary Data object, or specify 
an existing boundary Data object to which data 
will be added.

4. Specify the Name of the new boundary Data 
object.

5. Under Scanning options, select a Profile 
based on the size of the smallest details on the 
part.

Note that the Sharp Edge Scan page of the Line 
Scan Options dialog box offers an option to 
control the maximum point-to-point distance 
for points along a scan line as well as the 
maximum thickness of the part.

6. In the plug-in dialog box, click Start Scan.
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Typical scanning session

Since the data points are calculated by extrapolating between the part surface and sidewall, 
the scanner must be angled to adequately measure both surfaces.

A scanning session involves scanning one or more 
passes with the same parameters. 

All scan passes are added to the same Data object 
in the Tree View (boundary scan 1 in this example).

The number of acquired data points is displayed in 
the top left corner of the 3D scene.

After several scan passes.

The laser line should intersect the part edge at a 
45 degree angle in order to gather data both on the 
material surface and the sidewall.

The part must be thick enough, and the scanner 
resolution small enough, so that at least three 
points can be measured on the part surface and 
sidewall.

points for extrapolation

boundary point
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Results 

A boundary Data object is added to the Tree 
View. All scan passes are added to one Data 
object. 

The boundary point cloud is displayed in the 
3D scene.
107



ACQUIRING DATA OBJECTS
Guidance while scanning features

When scanning, sometimes there is not enough 
scanned data to extract quality features or to even 
extract features at all.

Using guidance when scanning features guides the 
operator to acquire enough data, based on the feature 
coverage, to perform the extraction of the features 
downstream in the inspection process.

Guidance is available for all features whose 
measurement method is set to Undefined or Extract. 
When set to Extract, the guidance takes the extraction parameters of each feature into 
account. When set to Undefined, the default extraction parameters are used. 

An inspection workflow, using feature scanning guidance to ensure the extraction of features, 
is illustrated below. 

1. Import Reference object

Import the nominal information of the part 
(CAD model) into the inspection project.

2. Create features

Create the nominal components of features 
and set their parameters before starting the 
inspection.

3. Align part to Reference object

Align the part to the CAD model to take 
advantage of the visual guidance tools.

4. Acquire Data object by scanning

Acquire point cloud or polygonal model data 
from the actual part needing inspection. Use 
the feature scanning guidance function to 
capture enough data and to ensure that the 
extraction of features is of the highest 
quality.
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Objective: Use the guidance function when scanning features.

Required: The required plug-in is loaded in PolyWorks|Inspector. A line-scanning device is 
available, ready to use, and prealigned to the CAD model. The project contains 
nominal features. 

Steps 

1. Choose Tools > Plug-ins > [device name].

The plug-in dialog box opens.

2. Select the Surface Scanning scan type.

3. In the Surface list, select (Create New) to 
create a new Data object, or specify an existing 
Data object to which data will be added.

4. Specify the Name of the new Data object.

5. Select Real-time quality meshing.

6. Select Polygonal model as the final data type.

7. If desired, enable the Clipping plane. 

8. Under Scanning options, select a Profile 
based on the size of the smallest details on the 
part.

9. Click Start Scan.

The scanning toolbar appears in the 3D scene, 
providing quick access to feature scanning 
guidance.

10. Scan the part, making sure that the data 
acquired around the features is sufficient to 
obtain the measured component.
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Results 

Notes 

Understanding the visual cues of the guidance function

In the 3D scene, pins and guidance zones are 
displayed for existing features based on their 
extraction parameters. The pins and guidance 
zones disappear as soon as the extraction require-
ments are met. 

A message in the 3D scene indicates the number of 
features left to scan.

• Guidance is offered for nominal features when 
the measurement method is set to Undefined 
or Extract.

• The line-scanning device can be aligned using 
the Surface Points Alignment.

• Orange pins indicate the location of features. 
Features are viewed from the front side (normal 
orientation).

• The orange highlight indicates where additional 
data is required in the form of a surface Data 
object (polygonal model or point cloud).

• The size and the location of the highlight are 
based on the extraction parameters set for 
each feature. If the measurement method is set 
to Undefined, the default extraction 
parameters are used.
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• A gray pin under an arrow indicates the location 
of a feature. However, these features are 
viewed from the back side.

• The white highlight indicates where additional 
data is required in the form of a boundary Data 
object.
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Probing a part using a probing device plug-in

PolyWorks|Inspector has the capability to use a probing 
device directly within its user interface to digitize parts. 
Probing devices include equipment such as laser trackers 
and articulated arms. Point clouds can be probed on the 
part surface, or along its boundaries. The point 
coordinates (x, y, z) and optionally, for arms, the normals 
(i, j, k) are stored in the current probing session in the Tree 
View, as either probed surface or probed boundary Data 
objects.

Using the probing device to collect surface points

A probing device can be used to collect a point cloud on the part. The data points are stored in 
the current probing session as a probed surface Data object containing the x, y, z point 
coordinates of each probed point. If the probing device is aligned to the Reference object, the 
points can be compensated toward the closest surface. If the probe tip has an orientation, 
that orientation can be used to assign point normals.

Objective: Probe the surfaces of a part using a plug-in to obtain a point cloud directly in 
PolyWorks|Inspector.

Required: A probing device is available and ready to use, and the required plug-in is loaded 
in PolyWorks|Inspector. A CAD model is loaded for point compensation, and the 
device is aligned to it.

Steps 

1. Choose Tools > Data Objects > Probe Surface 
Point Clouds.

The Probe Surface Point Clouds dialog box 
opens.

2. Select Compensation and specify the Use 
Reference Object method. 

The probed points are translated by the probe 
radius toward the nearest Reference surface.

3. If it is possible to keep the probe tip orthogonal 
to the part, and the tip has an orientation (is not 
only a reflector), point normals can be assigned 
by selecting Store normal vectors.

4. Click Probe and acquire data points on the part.
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Results 

Notes 

A probed Data object is added to the Tree 
View. All probed points are added to one 
Data object.

The point cloud is displayed in the 3D scene.

Many probing modes are available when probing, 
the most common being:

• The Single (or Stationary) mode collects one 
point each time the device is triggered. 

• The Continuous Time mode collects a series of 
points when the device is triggered, at equal 
time increments. 

• The Continuous Distance mode collects a 
series of points when the device is triggered, at 
equal distance increments.

• The increment values can be edited using the 
Probing Options button.
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Using the probing device to collect boundary points

A probing device can be used to collect a point cloud on the part edges only, creating a 
boundary point cloud. This method can be used to measure the perimeter shape of a piece of 
sheet metal or a thin-walled part. Either the probe tip or shank can be used.

Objective: Probe the surfaces of a part using a plug-in to obtain a point cloud directly in 
PolyWorks|Inspector.

Required: A probing device is available and ready to use, and the required plug-in is loaded 
in PolyWorks|Inspector. A CAD file is loaded for point compensation, and the 
device is aligned to it.

Steps 

Results 

1. Choose Tools > Data Objects > Probe Boundary 
Point Clouds.

The Probe Boundary Point Clouds dialog box 
opens.

2. In the Reference object list, select (Closest) to 
use the closest Reference object, or specify an 
existing Reference object.

3. Select the Project points using closest 
surface comparison point parameter to offset 
the probed boundary data points by the 
measured deviation along the normal of the 
closest surface comparison point. 

4. If the shank of the probing device is calibrated, 
the shank can be used for probing, rather than 
the probe tip, by selecting Use shank.

5. Click Probe.

A probed Data object is added to the Tree 
View. All probed points are added to one 
Data object. 

The probed boundary point cloud is 
displayed in the 3D scene. 
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Notes 

Many probing modes are available when probing, 
the most common being: 

• The Single (or Stationary) mode collects one 
point each time the device is triggered. 

• The Continuous Time mode collects a series of 
points when the device is triggered, at equal 
time increments. 

• The Continuous Distance mode collects a 
series of points when the device is triggered, at 
equal distance increments.

• The increment values can be edited using the 
Probing Options button.
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Importing surface and boundary point cloud Data 
objects

Data objects can be imported from point cloud or polygonal model files, or from other 
PolyWorks Metrology Suite projects such as another PolyWorks|Inspector project.

Importing surface Data objects

Surface Data object files contain a set of data points of the actual 
part, acquired by a digitizing device. Usually, the points cover the part 
surface but sometimes points are collected only around the hole and 
edge boundaries of the part. Most point cloud files can only be 
imported as Data objects. 

Importing IMAlign projects

Objective: Import the acquired data of an actual part as an IMAlign project.

Required: An IMAlign project.

Steps

Results

1. Choose File > Import > Point Clouds.

2. Browse for the IMAlign project that will be 
imported and click Open.

The IMAlign project is added to the Tree View, 
under the Data branch.

The Data object is displayed in the 3D scene.
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Meshing an IMAlign project

When the data cannot be acquired through a PolyWorks|Inspector digitizer plug-in, or when 
the data has previously been acquired through an IMAlign plug-in, it is possible to create a 
polygonal Data object from IMAlign projects.

Objective: Create a polygonal Data object from an IMAlign project.

Required: An open PolyWorks|Inspector project.

Steps  

Results 

1. Choose Tools > Data Objects > Create Polygonal 
Models.

The Create Polygonal Data Objects dialog box 
opens.

2. Specify the Name of the new polygonal Data 
object.

3. In the Method list, select From IMAlign 
Project.

4. Browse for the IMAlign project.

5. Specify a Sampling step.

The default value is set to Automatic, which 
means the sampling step is obtained from the 
IMAlign project.

If desired, specify a Custom sampling step.

6. Click Create.

A new polygonal Data object is added to the 
Tree View, under the Data branch.

The new polygonal Data object is displayed in 
the 3D scene. 
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Importing surface Data objects from files

Objective: Import the acquired data of the actual part in the form of a surface point cloud.

Required: A data file in a PolyWorks format (PSL or PIF files), a native format, or a neutral 
format (such as IGES or text files).

Steps

1. Choose File > Import > Point Clouds.

2. Browse for the file that will be imported.

To the right is an example of a text file 
containing x, y, and z coordinates for each data 
point.

The Import Parameters dialog box opens. 

3. Specify the required parameters.

The parameters offered depend on the format 
of the imported file and the options set in the 
PolyWorks|Inspector Options (available by 
choosing Tools > Options). For example, for 
a .txt file:

• In the Object units list, select the native 
units of the file.

• In the Data object type list, select Surface.

• Specify the decimal symbol and field 
delimiters of the file.

A preview of how the file is interpreted is 
shown in the form of a grid.

4. Click OK.
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Results

The point cloud is added to the Tree View, 
under the Data branch, as a surface Data 
object.

The object is displayed in the 3D scene.
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Importing boundary Data objects

Objective: Import the acquired data of the actual part edges in the form of a boundary point 
cloud.

Required: A data file in a neutral format (such as IGES or text files).

Steps 

1. Choose File > Import > Point Clouds.

2. Browse for the file that will be imported.

To the right is an example of a text file 
containing x, y, and z coordinates for each data 
point.

The Import Parameters dialog box opens. 

3. Specify the required parameters.

The parameters offered depend on the format 
of the imported file, and the options set in the 
PolyWorks|Inspector Options (available by 
choosing Tools > Options). For example, for 
a .txt file:

• In the Object units list, select the native 
units of the file.

• In the Data object type list, select 
Boundary.

• Specify the decimal symbol and field 
delimiters of the file.

A preview of how the file is interpreted is 
shown in the form of a grid.

4. Click OK.
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Results

The Data point cloud is added to the Tree 
View, under the Data branch, as a boundary 
Data object.

The object is displayed in the 3D scene.
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Importing polygonal models

A polygonal model is a mesh composed of triangles and vertices 
obtained from data points scanned on the actual part. Polygonal 
models are generally imported as Data objects, but can also be 
imported as Reference objects. 

Objective: Import the acquired data of the actual part in the form 
of a polygonal model.

Required: A polygonal model file in a PolyWorks format (such as 
POL or PQK), or a neutral format (such as STL or OBJ).

Steps 

Results

1. Choose File > Import > Polygonal Models.

2. Browse for the file that will be imported.

The Import Parameters dialog box opens.

3. In the Object units list, select the native units 
of the file.

By default, polygonal models are imported as 
Data objects. The default behavior can be 
changed in the PolyWorks|Inspector Options 
(Objects > Reference/Data > Polygonal 
Models page). The PolyWorks|Inspector 
Options are available by choosing Tools > 
Options.

4. Click OK.

The polygonal model is added to the Tree 
View, under the Data branch, as a surface 
Data object.

The polygonal model is displayed in the 
3D scene.
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Editing Data objects

It may sometimes be useful to clean up Data objects by removing unwanted data points or by 
dividing the dataset into multiple objects. For example, data points collected on a part fixture 
or inspection fixture can be removed from the overall dataset, or particular regions of a part 
can be split from the original Data object into a new Data object. Another common operation 
consists in adding more data to an existing scanned Data object.

Cleaning scan data

It is possible to select and delete individual data points 
from a Data object. This can be done interactively, in 
the 3D scene, or by using criteria such as the proximity 
to reference surfaces. Data points deleted in the 
project can always be recovered, if necessary.

Removing data points interactively

Objective: Remove data points from a Data object by manually selecting and deleting them.

Required: The project contains a Data object.

Steps

Results 

1. Choose Select > Elements > Interactively.

Alternatively, press SPACEBAR to enable the 
interactive element selection mode.

The selection mode is activated.

2. Use the interactive selection tool to select the 
data points that will be removed.

To select point cloud data points, see Selecting 
elements on page 63.

3. Press DELETE. 

Alternatively, choose Edit > Delete > Elements to 
delete the selected data points.

The selected points are removed from the 
Data object and are not used for analysis. 
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Removing data points using a CAD model

Objective: Remove selected data points from the Data object. The data points are selected 
using a Reference object (CAD model).

Required: A Reference object and a Data object are available in the project. In addition, the 
Data object is aligned to the Reference object.

Steps

1. Select the Reference object in the Tree View.

2. Choose Select > Data Points > Using Reference 
Object Surfaces.

The Select Data Points using Surfaces dialog 
box opens.

3. In the Direction list, select Shortest.

Since a Reference object has been preselected, 
Specific is displayed in the Reference objects 
list as well as the Reference object name. 

It is possible to change the Reference object for 
another one, or choose All in the Reference 
objects list to use all Reference objects.

4. Specify the Max distance that will be 
considered between data points and reference 
surfaces. 

5. Click the Select button to select the data points.

The selected data points are highlighted red in 
the 3D scene.

6. Select the Data object in the Tree View.

7. Right-click and choose Select > Elements > Invert 
to select only data points that do not meet the 
selection criteria above. New selected data 
points are highlighted red.

8. Choose Edit > Delete > Elements to delete the 
selected data points.

Alternatively, press DELETE. 
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Results  

Recovering deleted data points

When data points are deleted, they are not deleted permanently. It is possible to recover 
deleted data points at any time, which makes deleting and editing operations safer and 
reversible.

Objective: Recover deleted data points.

Required: The project contains a Data object. Data points have been deleted from that 
object.

Steps

Results 

Notes 

The selected points are removed from the 
Data object and are not used for analysis. 

 

1. Select the Data object in the Tree View. 

2. Choose Edit > Recover Deleted Elements.

Previously deleted data points will be added to the Data object. All deleted data points are 
recovered, not just the last data points deleted. 

Recovering deleted data points can be a long operation due to the automatic project update.
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Purging deleted data points

It is possible to purge deleted data points for surface Data objects of a piece in order to 
reduce RAM requirements and accelerate software operations, as well as to reduce project 
size on disk.

Objective: Purge deleted data points.

Required: The project contains a surface Data object. Data points have been deleted from 
that object.

Steps

Results 

Notes 

1. Choose Edit > Purge Deleted Elements.

Previously deleted data points are permanently deleted. 

• Only surface Data objects (polygonal models or point clouds) are supported by this tool. 
This tool does not support the following Data objects:

•    Using real-time quality meshing: polygonal models and point clouds from mesh

•    Boundary point clouds

•    Probed point clouds

• The Edit > Recover Deleted Elements command cannot be used to recover data points that 
have been purged.
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Adding data to a scanned Data object

A common editing operation for Data objects consists in adding more data to an existing 
scanned Data object.

Objective: Add data to an existing Data object acquired using a scanning plug-in.

Required: A Data object that was scanned directly in PolyWorks|Inspector and a scanning 
device is ready to use and is aligned to the Data object that will be modified.

Steps

Results  

1. Choose Tools > Plug-ins > [device name].

The plug-in dialog box opens.

2. In the Surface list, select the Data object to 
which data will be added.

3. Click Start Scan and scan the required areas.

4. Click End Scan to end the scanning session.

5. If meshing point cloud data in real time, click 
Finalize Mesh to complete the polygonal Data 
object.

The Data object before adding new data. The Data object after acquiring new data. 
Holes have been covered with new data.
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Splitting a Data object into two objects

Selected data points can be moved or copied from one Data 
object to a new object using the Split command. This is useful 
in separating scans containing multiple parts. Selection can be 
done interactively in the 3D scene, or using criteria such as the 
proximity to Reference surfaces. 

Objective: Move data points to a new Data object.

Required: The project contains a Data object.

Steps

Results 

1. Select data points, using one of these methods 
for example:

• The interactive element selection tool. See 
Selecting elements on page 63.

• Using a Reference object; choose Select > 
Data Points > Using Reference Object Surfaces.

2. Choose Edit > Split Objects > Move Elements to 
remove the selected data points from the 
current Data object and create a new Data 
object containing only those data points.

Choose Edit > Split Objects > Copy Elements to 
preserve the data points in the original Data 
object. 

A new Data object is added to the Tree View, 
under the Data branch, containing only the 
selected data points. 
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Introducing alignments

An alignment is an object transformation operation that changes the position and orientation 
of a Data object to bring it into the coordinate system of a Reference object.  

PolyWorks|Inspector offers a variety of alignment tools to meet a wide variety of scenarios. 
Each alignment is represented in the Tree View as a data alignment.

Alignments are available on the Align menu or on the Alignments toolbar. 

Alignment tools

Here is a list of common tools offered by PolyWorks|Inspector that are used to align Data 
objects to Reference objects:   

Surface Points
Match source points probed on 
physical objects to matching 
destination points picked on 
Reference objects or specified 
numerically.

Best-Fit Data to Reference 
Objects
Best-fit the surface of selected Data 
objects to the surface of available 
Reference objects.

Before alignment After alignment

Reference object
Data object
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Best-Fit Data to Data 
Objects
Aligns Data objects to fixed Data 
objects. This tool is useful when 
Data objects are acquired in 
multiple device positions that are 
not aligned to each other.

Best-Fit Measurement 
Objects

Align a Data object to a Reference 
object by matching the points of 
point-reducible measurement 
objects (features and comparison 
points) and surface features to the 
matched nominal component.

Plane, Axis, Center Point
and

Perpendicular Planes

Align Data objects to Reference 
objects using pairs of planar, 
direction-based, and center-point-
based features (Plane, Axis, Center 
Point), or by matching three plane 
features (Perpendicular Planes).
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Reference Targets
and

Reference Targets by 
Probing

Match components extracted from 
Data objects, or points obtained on 
Data objects, to reference targets 
created on Reference objects.

Datum Reference Frame
and

Datum Reference Frame by 
Probing
Align Data objects (using the 
measured components of datum 
features) to Reference objects 
(using the nominal components of 
datum features).
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Introducing data alignments

Each transformation of a Data object is automatically recorded in the Tree View as a data 
alignment. While the latest data alignment is usually the active data alignment, a previous 
data alignment can be activated manually. This may be useful in examining inspection results 
that use a variety of alignments.

Each data alignment is stored chronologically within an 
alignment group. When created, the data alignment is 
called original. Data alignments within an alignment group 
form an alignment history. The name of each data alignment 
states the type of alignment performed. 

The active data alignment, often the last one, is shown in 
bold. Any data alignment can be activated, and project 
contents are updated automatically. Unnecessary data 
alignments can be deleted.

Data objects with the same transformations can be contained within the same alignment 
group, whereas Data objects requiring different alignments are automatically placed in 
separate alignment groups. The latter case is common for assemblies of multiple Data 
objects. An alignment performed on any Data object applies to all the Data objects.

The creation of alignment groups and data alignments is automatically managed by 
PolyWorks|Inspector.

Activating a data alignment

An alignment group can contain multiple data alignments, such as a Best-Fit alignment 
followed by a Feature-Based alignment. It is possible to activate any alignment in an 
alignment group and results are automatically updated. 

Objective: Activate a previous data alignment in an alignment group.

Required: A Data object with at least two data alignments in an alignment group.

Steps

Here, there are two data alignments: 
original and best-fit to ref 1.

The best-fit to ref 1 alignment is currently 
the active alignment and is shown in bold.
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Results

Notes

When a data alignment is performed incorrectly, it is best to 
delete it immediately. First, activate the previous data 
alignment, then select the last data alignment in the alignment 
group, and choose Edit > Delete > Objects. Deleting an interme-
diate data alignment may have an effect on subsequent data 
alignments.

1. Select a data alignment in the Tree View 
and choose Align > Data Alignments > 
Activate.

Alternatively, right-click the selection and 
choose Activate.

Measurement objects and results are 
updated automatically.

The selected data alignment is activated and 
shown in bold in the Tree View.

The Data objects are transformed by the new 
active data alignment.
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Aligning using object surfaces

An alignment is the operation that brings a Data object into the 
coordinate system of a Reference object. The Best-Fit operation is a 
surface-based alignment tool that iteratively transforms the position 
and orientation of a Data object to minimize the deviations of the 
data points with respect to the surface of a Reference object. The 
Data object must first be prealigned to the Reference object.

Best-fitting Data objects to Reference objects using an 
automatic prealignment

For the Automatic prealignment function to work well, the Data object must cover most of 
the Reference object, and the Reference object must not have a symmetrical form.

Objective: Align a Data object to a Reference object using a Best-Fit alignment with an 
Automatic prealignment.

Required: The project contains a Data object and a Reference object.

Steps

1. Choose Align > Best-Fit Data Objects > Data to 
Reference Objects.

The Best-Fit Data to Reference Objects dialog 
box opens.

2. In the Method list, click Fit to Reference 
Object Surfaces.

3. The Prealignment parameter is enabled by 
default and set to Automatic.

4. In the Reference objects list, select All to 
consider all the Reference objects.

5. In the Data objects list, select Surface to 
consider all the surface Data objects.

Specific considers specific objects.

6. Specify the Max distance used to match data 
points to the surface of the Reference object.

If the Data object is highly deviated from the 
Reference object, increase the Max distance to 
match data points to the surface of the Reference 
object.
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Results 

Notes

7. In the Subsampling list, select 1/1 to refine the 
alignment, but with a longer computing time.

By default, the alignment operation uses one point 
out of every four points to speed up calculations.

8. Click Start.

As the alignment converges to a solution, statistics 
are displayed in the Statistics section.

The new data alignment is added to the Data 
alignment group of the Data object.

The Data object is aligned to the Reference 
object using an automatic prealignment 
and is then best-fitted using object 
surfaces.

  

It is possible to edit a data alignment using its 
property sheet. Select the object in the Tree View and 
choose Edit > Object Properties, and then change the 
parameters.

For example, edit the objects used, the Max distance, 
or the Subsampling factor to refine the alignment 
result. Then, click Apply and click Close.
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Best-fitting Data objects to Reference objects using a 
manual prealignment

If a part is partially scanned, or shaped differently from the Reference object, the automatic 
prealignment tool may not position the Data object in the optimal position for best-fitting. The 
Point Pairs manual prealignment tool (1 Point Pair and N Point Pairs methods) should be used 
instead.

Objective: Align a Data object to a Reference object using a Best-Fit alignment with a manual 
prealignment.

Required: The project contains a Data object and a Reference object.

Steps

If the alignment fails, a manual prealignment may be 
necessary. In the object properties, click the Set 
Prealignment button and choose Prealign using 
Point Pairs. Click Close. See the next section for 
instructions on using point pairs as a prealignment 
method.

1. Choose Align > Best-Fit Data Objects > Data to 
Reference Objects.

The Best-Fit Data to Reference Objects dialog 
box opens.
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2. In the Method list, click Fit to Reference 
Object Surfaces.

3. In the Prealignment list, select Point Pairs.

4. In the Reference objects list, select All to 
consider all the Reference objects.

5. In the Data objects list, select Surface to 
consider all the surface Data objects.

Specific considers specific objects.

6. Specify the Max distance used to match data 
points to the surface of the Reference object.

If the Data object is highly deviated from the 
Reference object, increase the Max distance to 
match data points to the surface of the Reference 
object.

7. In the Subsampling list, select 1/1 to refine the 
alignment, but with a longer computing time.

By default, the alignment operation uses one point 
out of every four points to speed up calculations.

8. Click Start.

The Prealign using Point Pairs dialog box opens. 

The Reference object and the Data object are 
displayed in separate viewports.

9. Move both the Reference object (left) and the 
Data object (right) to give them a similar 
orientation. This facilitates the picking of pairs 
of points in similar areas.

Just moving the objects does not operate any 
transformation of the objects. If the mode is exited 
before picking points and aligning, the objects are 
still in their original position.
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Results

Notes

In the Prealign using Point Pairs dialog box, another method is available: the 1 Point Pair 
method. This method requires picking only one pair of points. A Best-Fit alignment is 
automatically performed after a successful prealignment.

10. Click N Point Pairs.

11. Click Pick.

12. Anchor matching points on both objects, using 
the same order. A minimum of three pairs of 
points is required.

The points are displayed using the same color and 
the same number in subscript.

13. Click Align to confirm the alignment and exit 
the picking mode.

The Best-Fit alignment is automatically performed 
after the manual prealignment. As the alignment 
converges to a solution, statistics are displayed in 
the Statistics section.

The new data alignment is added to the data 
alignment group of the Data object.

The Data object is aligned to the Reference 
object using a manual prealignment and is 
then best-fitted using object surfaces.
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Aligning by probing surface points

The Surface Points alignment method is used to align probed points to the same locations on 
Reference objects. This prealignment tool greatly facilitates visualization and guidance for 
subsequent operations.

Objective: Align by probing surface points.

Required: A Reference object, a physical part, and a probing device.

Steps

1. Choose Align > Surface Points.

The Create Surface Points dialog box opens.

2. In the Method list, specify Anchor.

3. Click Anchor.

4. Anchor six points on the Reference object that 
will be used for the alignment.

All six degrees of freedom should be constrained 
using a 3-2-1 alignment method, where the 
alignment direction of three surface points is 
along one reference axis (X axis), the alignment 
direction of two other surface points is along a 
second reference axis (Y axis), and the alignment 
direction of the last surface point is along the 
remaining reference axis (Z axis). If all the degrees 
of freedom are not constrained, then only a final 
N Point Pairs alignment is performed.

The anchored points are listed in the Align Surface 
Points pane. A radial tolerance determines how 
closely the probed point must match the reference 
location.

5. If a probing device is connected, the probing 
dialog box opens automatically. Otherwise, 
click Probe Source Points in the pane.

6. On the physical part, probe the same six points 
using the same order.

As the points are probed, the probing device is 
more closely aligned to the Reference object 
providing a better visual context.
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Results

7. If the probed points are not precise enough to 
fall within the radial tolerance of the reference 
location, a message box offers the possibility of 
reprobing the points that are out of tolerance.

Visual and audio guidance are provided to 
remeasure those points. The points can be 
reprobed in any order.

The new data alignment is added to the 
alignment group of the Data object.

The probed data points are aligned to the 
same locations on the Reference object.
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Best-fitting measurement objects

The Best-Fit Measurement Objects alignment method is 
used to improve workflows in the aerospace and 
automotive industries. This method aligns the measured 
component of a measurement object to the corresponding 
nominal component. 

The following table indicates the possible alignment 
techniques based on the types of measurement objects 
used. 

 

Point-reducible features can also be paired. A number of combinations are possible. They can 
be paired with another point-reducible feature, a line feature, a cylinder axis, a cone axis, or a 
plane feature.

Measurement objects Alignment technique

Point-reducible features:

Circles, slots, ellipses, 
spheres, arcs duplicated 
in 3D, polygons, 
rectangles, points

Aligns objects by matching the center point of a measured 
component to the center point of the corresponding 
nominal component. 

Surface features

Plane features

Cylinder features

Cone features

Aligns objects by matching the measured data points to 
the corresponding nominal component.

Pattern features Adds all features of the pattern to the alignment pane and 
aligns the objects based on the children feature types.

Comparison points Aligns the data points to the nominal component along the 
surface normal (surface comparison points) or along the 
edge vector (trimmed edge or hemmed edge comparison 
points).
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Objective: Align a Data object to a Reference object using a Best-Fit Measurement Objects 
alignment.

Required: The Data object should be prealigned to the Reference object. The objects used 
for the alignment must contain nominal and measured components.

Steps

1. In the Tree View, select the objects that will be 
used for the alignment.

2. Choose Align > Best-Fit Measurement Objects.

The Best-Fit Measurement Objects dialog box 
opens, as well as the Best-Fit Measurement 
Objects - Setup and Results pane.

The selected objects are automatically added 
in the pane. 

3. In the pane, specify the alignment direction 
(X, Y, Z) for each object.

4. If necessary, click Add Objects and choose 
Add. 

An empty line is added, and the edit dialog 
opens automatically. 

5. In the Measurement object list, choose the 
object that will be added.

6. Click elsewhere in the interface.

Alternatively, drag and drop measured 
measurement objects from the Tree View into the 
pane to add them to the alignment.
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Results

In the Best-Fit Measurement Objects dialog box: 

The Automatic prealignment is enabled by 
default. It allows roughly aligning measured 
geometry to nominal geometry. The alignment will 
continue to refine the match until the Max 
number of iterations is reached, or when all 
objects move less than the Max displacement 
target between iterations.

7. Specify the Max number of iterations.

8. Specify the Max displacement target. 

9. Click Start.

As the alignment converges to a solution, 
statistics are displayed in the Statistics section.

As long as the dialog box is not closed, it is 
possible to make modifications to the alignment 
parameters and objects. The results are updated 
automatically. 

Once the dialog box is closed, the alignment can 
be edited by right-clicking the alignment in the 
Tree View, and choosing Edit Alignment (see 
Editing the alignment parameters on page 146). 

The new data alignment is added to the 
alignment group of the Data object.

The Data object is aligned to the Reference 
object using the specified measurement 
objects.
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Notes

• Surface features with non compensated points can be used in this alignment.

• Point-reducible cross-section features can be used in this alignment if they are duplicated 
in 3D.

• In the More section, the Scale to minimize 3D deviations parameter enables the scaling 
of all available Data objects and the measured components in order to minimize the 
3D deviations between the nominal components and the measured components used for 
alignment. This is useful in compensating for temperature variations when measuring 
Data objects that span over 10 meters.

Understanding the Best-Fit Measurement Objects - Setup 
and Results pane

The Best-Fit Measurement Objects pane is used to specify the objects that will be used for the 
alignment and to set the alignment parameters. It features a vertical toolbar and a table area 
to configure the alignment. 

Column header
Names of the different columns displayed in the pane.

Statistics for each object are displayed in the pane.

Table 
area

Column 
header Vertical 

toolbar
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Vertical toolbar

Table area
The table area presents the list of objects used for the alignment, their alignment directions 
and their statistics (once the alignment is created).

Note

It is possible to customize the pane. For example, it is possible to show more columns and to 
reorder them.

Editing the alignment parameters

Objective: Edit the Best-Fit Measurement Objects alignment.

Required: The project contains a Best-Fit Measurement Objects alignment.

Steps

Add Objects

Menu button that allows adding objects to the alignment or adding objects 
already selected in the Tree View to the alignment.

Edit Objects

Menu button that allows modifying the Use axes, Weight, and Use to 
compute scaling factor parameters of the selected objects.

Remove Objects

Removes the selected object from the alignment.

Automatic Update

The alignment automatically updates when a change is made in the pane. 
This menu button allows disabling the automatic update. It also allows 
manually launching the update of the alignment.

Report

Allows creating a report table of the alignment.

1. In the Tree View, select the data alignment.
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Results

Changing the objects used for the alignment

It is possible to change the objects used for the alignment. Objects can be deleted, added, or 
changed.

2. Right-click and choose Edit Alignment. 

The Best-Fit Measurement Objects dialog box 
and the Best-Fit Measurement Objects - Setup 
and Results pane open.

3. Make the necessary modifications, such as 
modifying the axes used for the alignment and 
the weight of an object.

4. Click Apply.

The results are updated automatically and displayed in the Best-Fit Measurement Objects -
Setup and Results pane. 

Before

After

In the Best-Fit Measurement Objects - Setup and 
Results pane:

• Select an object and remove it using the 
Remove Objects button.
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• Add an object using the Add Objects 
button. Alternatively, drag and drop 
measured objects from the Tree View into 
the pane.

• Replace an object by clicking the edit 
shortcut arrow that corresponds to the 
object to be modified.
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Changing the pairing of feature components

By default, this alignment method matches measured components to their nominal 
components. It is possible to customize the pairing and align a measured component to 
another measured component. This is especially useful for virtual assemblies of parts.

Steps

In the Best-Fit Measurement Objects - Setup and Results pane: 

1. Click the edit shortcut arrow adjacent to the 
object to be modified.

The contextual dialog box opens.

2. Select Pair of feature primitives.

3. In the Source list, specify the source 
component.

4. In the Destination list, specify the destination 
component. 

Source components are moved to destination 
components.
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Aligning with features

This approach consists in creating features whose nominal primitives are created on the 
Reference object, and whose measured primitives are created on the Data object. Then, the 
measured primitives are aligned to the nominal primitives, transforming the position and the 
in-space orientation of the Data object.

There are several feature-based alignment methods:   

Alternatively, the Plane, Axis, Center Point and the Perpendicular Planes methods can also 
align the Data object to standard axes. Measured primitives created on the Data object are 
aligned to standard planes, standard axes, and a coordinate along the axes.

Distinct characteristics of planar features, direction-based features, and center-point-based 
features allow using them for alignment methods:

• Planar features: planes, circles, arcs, ellipses, polygons, rectangles, slots, and slabs.

• Direction-based features: circles, arcs, cones, cylinders, ellipses, polygons, rectangles, 
slots, and lines, but not planes.

• Center-point-based features: circles, arcs, ellipses, points, polygons, rectangles, slots, 
and spheres. They are also called point-reducible features.

Plane, Axis, Center Point

Perpendicular Planes
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Aligning using a plane-axis-point approach

The Plane, Axis, Center Point alignment method is used to align Data objects to Reference 
objects using pairs of planar, direction-based, and center-point-based features. Generally, the 
measured component of a feature is assigned as the source object while its nominal 
component is assigned as the destination object.

Objective: Align a Data object to a Reference object using a Plane, Axis, Center Point 
alignment.

Required: The project contains a Data object and a Reference object, as well as a planar 
feature, a direction-based feature (except planes), and a center-point-based 
feature, each containing a nominal and a measured component.

Steps

1. Choose Align > Feature-Based > Plane, Axis, 
Center Point.

The Align Plane, Axis, Center Point dialog box 
opens.

2. In the Sequence list, select Plane, Axis, Center 
Point.

3. Specify a planar feature, a direction-based 
feature, and a center-point-based feature that 
will be used for the alignment.

The Source object is the measured feature 
component, while the Destination is the nominal 
feature component. The measured components 
are moved to the nominal locations.

Click the Pick button to the right of each list box 
to pick the source and destination objects directly 
in the 3D scene.

4. Click Confirm.
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Results

Notes

• If no nominal feature component has been defined, standard system planes, axes, and 
coordinates can be specified in the Destination list box.

• Sometimes, a partial alignment can be performed. If only one or two features are used for 
the alignment, the remaining parameters can be left blank. Make sure that the Sequence 
chosen begins with the type of feature used for the partial alignment.

The new data alignment is added to the 
alignment group of the Data object.

The Data object is aligned to the Reference 
object using the features.
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Aligning using perpendicular planes

The Perpendicular Planes alignment method aligns the Data 
object to the Reference object by matching three plane features. 
The planes must intersect each other in space.

Objective: Align a Data object to a Reference object using a 
Perpendicular Planes alignment.

Required: A Reference object, a Data object and three 
perpendicular plane features with nominal and 
measured components.

Steps

1. Choose Align > Feature-Based > Perpendicular 
Planes. 

The Align Perpendicular Planes dialog box 
opens.

2. In the lists, select the planes that will be used 
for the alignment. The measured components 
should be in the Source column.

When a measured component is selected in the 
Source column, the corresponding nominal 
component is automatically specified in the 
Destination list. The user can select another 
component in the Destination list, if desired.

The order in which planes are specified is 
important. The first plane is the primary plane 
and has precedence over the second and third 
planes when aligning.

3. Click Align, then click Done.
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Results

Notes 

The new data alignment is added to the 
alignment group of the Data object.

The Data object is aligned to the Reference 
object using three perpendicular planes.

 

When no Destination components exist, the 
alignment can be performed using planes 
obtained from standard axes and positions.
154



ALIGNING DATA OBJECTS TO REFERENCE OBJECTS
Aligning with reference targets

Reference targets are points, lines, or areas that 
can be used to constrain an alignment along a 
specified direction. They are commonly found in 
sheet metal part drawings as well as mold and die 
drawings, in which specific coordinates on the part 
are established and directions along the standard 
axes are defined to align the part. 

Typically, reference targets are created on the 
Reference object. Once they are in the desired 
position, measurements for the reference targets 
are obtained and a reference target alignment can 
be performed.

Introducing reference targets

There are three types of reference targets: points, lines, and areas.

Reference target points
They are positioned at precise 
coordinates, and align the Data 
object along the alignment 
directions.

Reference target lines
They are created from line 
features, and constrain the 
alignment along a pin or shank 
edge. 
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There are three subtypes of reference target points: surface, feature, and cross-section.

Reference target areas
They align the Data object 
according to the specified area on 
the Reference object. Two types 
can be created: circular and 
rectangular.

Surface reference target points 

They are positioned at precise 
coordinates on Reference object 
surfaces. When performing the 
alignment, the distance from the 
measured point on the Data 
object to the target is minimized 
according to the specified 
alignment directions. 

Feature reference target 
points 

They are created from precise 
coordinates of the Reference 
object, and are associated with 
individual features, such as a 
circle, a slot, or a plane. When 
performing the alignment, the 
distance to the feature is 
minimized according to the 
specified alignment directions. 
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Cross-section reference target 
points 

They are positioned at precise 
coordinates on Reference object 
surfaces, and are associated with 
cross-sections. When performing 
the alignment, the distance from 
a measured point on the cross-
section to the target is 
minimized.
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Creating reference target areas

Objective: Create reference target areas using specific coordinates on the part.

Required: A Data object, a Reference object, and coordinates for target locations.

Steps

1. Choose Measure > Reference Targets > Create > 
Areas.

The Create Reference Target Areas dialog box 
opens.

2. In the Method list, select Numerically to 
specify coordinates.

By default, the reference target area is circular. 
However, it is also possible to create a rectangular 
reference target area. 

3. Use the coordinates provided on the part 
drawing to define the Center of the reference 
target area.

The target can be projected onto the Reference 
object surface along an axis. Instead of entering 
the third coordinate, select Project and choose 
the projection axis.

4. Set the Axis orientation of the reference target 
area. If the Automatic option is enabled, the 
axis orientation of the area is calculated 
automatically by projecting the center point of 
the reference target area onto the Reference 
object at the nearest location. The normal of 
the Reference object is then used to determine 
the axis orientation.

5. Set the Diameter of the reference target area.

6. Set the Alignment direction of the target 
point. It can be set to:

• Automatic: The standard axis that is closest 
to the axis orientation of the reference target 
area is used to determine the alignment 
direction.

• Axis orientation: The axis orientation of the 
reference target area is used to determine 
the alignment direction.

• One of the standard axis: +X, -X, +Y, -Y, +Z or 
-Z.

7. Click Create.
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Results

The new reference target areas are added to 
the Tree View, under the Reference Targets 
branch.

The reference target areas are displayed in 
the 3D scene as lined plane areas.

 

target area 1 target area 2

target area 3
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Creating reference target points

Creating surface reference target points

Objective: Create surface reference target points using specific coordinates on the part.

Required: A Data object, a Reference object, and coordinates for target locations. 

Steps

1. Choose Measure > Reference Targets > Create > 
Surface Points.

The Create Surface Reference Target Points 
dialog box opens.

2. In the Method list, select Numerically to 
specify coordinates.

3. Use the coordinates provided on the part 
drawing to define the target Point location.

The target can be projected onto the Reference 
object surface along an axis. Instead of entering 
the third coordinate, select Project and choose 
the projection axis.

4. Set the Normal direction of the point. If the 
Automatic option is enabled, the normal 
direction of the surface point is calculated 
automatically from the surface normal of the 
Reference object.

5. Set the Alignment direction of the target 
point. It can be set to Automatic, Point 
Normal, +X, -X, +Y, -Y, +Z, -Z, or XYZ direction.

6. Click Create.
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Results

Notes

The surface reference targets can be set as datum targets and be used as part of a Datum 
Reference Frame of a GD&T control. For more information on datum targets, see Defining 
datum targets on page 511.

Creating feature reference target points

Objective: Create feature reference target points using features on the part.

Required: A Data object and a Reference object. The part must have measurable features.

Steps

The new surface reference targets are added 
to the Tree View, under the Reference Targets 
branch.

The reference targets are displayed in the 
3D scene.

 

1. Choose Measure > Reference Targets > Create > 
Feature Points.

The Create Feature Reference Target Points 
dialog box opens.

surf target pt 3 surf target pt 1

surf target pt 2
161



ALIGNING DATA OBJECTS TO REFERENCE OBJECTS
Result

2. In the Method list, select From Feature 
Creation to create a new feature for the 
reference target.

3. Choose a Feature type, such as a circle feature.

4. Specify the Alignment directions to be 
constrained by the feature. 

It can be any combination of X, Y, and Z.

5. Click Create.

The feature creation dialog box opens.

6. In the Method list, select a feature creation 
method such as Pick on CAD Model.

7. Click Pick.

8. In the 3D scene, pick the feature on the CAD 
model.

The new feature reference targets and their 
associated features are added to the Tree 
View.

The feature reference targets are displayed in 
the 3D scene.

 ftr target pt 2
ftr target pt 1
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Measuring reference targets

Reference targets can be extracted from scanned data. The Data object must be closely 
aligned to the Reference object for the reference target measurement to be successful.

Objective: Measure the reference targets by extracting them.

Required: The project contains a Data object, a Reference object, and reference targets 
(feature/surface reference target points or reference target areas). The Data 
object must be prealigned to the Reference object.

Steps

1. Select the reference targets in the Tree View.

2. Choose Measure > Extract Measured.

Note the following:

• Feature reference targets are measured by 
measuring their associated features. 

• Reference target areas and surface reference 
targets are measured, but they will also be 
remeasured throughout the alignment 
operation. See Aligning using reference targets 
on page 165.
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Results

Notes

• Feature reference targets can also be measured by probing the associated features.

• It is also possible to measure surface reference target points, reference target lines, and 
reference target areas using a scripted measurement method (see Scripted measurement 
methods on page 698). 

The reference targets are measured. For 
feature reference targets, the corresponding 
features are measured as well.

The reference targets show the current 
deviation between the Data object and the 
Reference object in the specified alignment 
directions.

 

164



ALIGNING DATA OBJECTS TO REFERENCE OBJECTS
Aligning using reference targets

Reference targets can be used in a reference target alignment. A combination of reference 
targets can be used for the alignment of Data objects.

Two alignment methods are available, which are explained below: 

• Align (for reference targets measured using the Extract measurement method);

• Align by Probing (for reference targets measured using the Probe measurement 
method). This method is not available for reference target lines and reference target areas.

Reference targets can be used as datum targets for use in Datum Reference Frame alignments 
(see Defining datum targets on page 511).

Align using reference targets

Objective: Align the Data object to the Reference object using reference targets.

Required: The project contains a Data object, a Reference object and reference targets. The 
Data object must be prealigned to the Reference object.

Steps

1. Select the reference targets in the Tree View.

2. Choose Align > Reference Targets > Align.

The Align Reference Targets dialog box opens.

3. The preselected reference targets are 
automatically selected in the Reference 
targets area.

4. Select or clear reference targets as desired.

Only selected reference targets are used for the 
alignment.

5. Click Start.

If there are unmeasured targets, they will be 
measured before the alignment starts. As for 
reference target areas and surface reference 
targets, they will be remeasured throughout the 
alignment operation.
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Align using surface and feature reference targets by probing 

Objective: Align the Data object to the Reference object by probing using reference targets.

Required: A Reference object, a physical part, surface or feature reference target points, and 
a probing device.

Steps

The new data alignment is added to the 
alignment group of the Data object. 

The Data object is aligned to the Reference 
object using the reference targets.

 

1. In the Tree View, select the reference target 
points.

2. Choose Align > Reference Targets > Align by 
Probing.

The Align Reference Targets by Probing pane 
opens.
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3. The selected reference target points are listed 
in the pane.

4. Click the Probe Measured button.

5. Probe the surface reference target points and 
features associated to the feature reference 
target points, as guided.

The new data alignment is added to the Tree 
View. The reference targets and the features 
associated to the feature reference targets 
are measured.

The Data object is aligned to the Reference 
object using reference target points.
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Notes

• For point features, a radial tolerance is used; it is possible to reprobe points that are out of 
the radial tolerance.

• The feature type can be specified in the Align Reference Targets by Probing pane if not 
already linked to a feature.
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Aligning with Datum Reference Frames

A Datum Reference Frame (DRF) is a reference that serves to 
orient and locate objects in space. A DRF can be composed of 
datum features with nominal and measured primitives. The 
DRF alignment aligns Data objects (using the measured 
primitives) to Reference objects (using the nominal 
primitives). It can also be composed of datum targets. A DRF 
used by a Geometric Dimensioning and Tolerancing (GD&T) 
control serves to orient and locate tolerance zones.

Align using a Datum Reference Frame

Objective: Align the Data object to the Reference object using a DRF.

Required: The PolyWorks|Inspector project contains a Data object and a Reference object, 
as well as datum features and/or datum targets, each containing a nominal and a 
measured component.

Steps

1. Choose Align > Datum Reference Frame > Align.

The Align Datum Reference Frame dialog box 
opens.

2. Choose an existing DRF from the list. 

DRFs used in any GD&T controls are listed 
automatically.

3. To add a new DRF, under Creation, select 
datum features using the lists.

4. Click Create.

The new DRF is added to the Datum reference 
frames list.

5. Select a DRF from the list, then click Align.

To be used in a DRF, a feature must have a datum 
feature label. The datum feature label can be 
specified on the Feature tab of a feature’s 
property sheet.
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Results

Notes

When datum features are specified in a GD&T control, the Datum Reference Frame alignment 
is applied virtually for the calculation – the Data object does not need to be actually aligned to 
the Reference object. However, the alignment used by a GD&T control can be visualized using 
the Feature Navigator tool.

To be used in a DRF, a reference target must have 
a datum target label. The datum target label can 
be specified on the Reference target tab of a 
reference target's property sheet.

The new data alignment is added to the 
alignment group of the Data object.

The Data object is aligned to the Reference 
object using the datum features.
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Align a Datum Reference Frame by probing

Objective: Align the Data object to the Reference object by probing the datum features and 
the datum targets linked to a Datum Reference Frame.

Required: The PolyWorks|Inspector project contains a Data object and a Reference object, 
as well as datum features and/or datum targets.

Steps

1. Choose Align > Datum Reference Frame > Align 
by Probing.

The Align Datum Reference Frame by Probing 
pane opens.

2. Choose an existing DRF from the drop-down 
list. 

DRFs used in any GD&T controls are listed 
automatically.

3. To add a new DRF, click on the Create Datum 
Reference Frame button located next to the 
drop-down list.

4. The involved datum features and datum targets 
are listed in the pane.

5. Click the Probe Measured button.

6. Probe the features and targets, as guided.

The order in which the datums are probed is 
based on their order in the Datum Reference 
Frame.
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Results

Notes

• For datum target points, a radial tolerance is used; it is possible to reprobe points that are 
out of the radial tolerance.

The new data alignment is added to the 
alignment group of the Data object. The 
datum features and datum targets are 
measured.

The Data object is aligned to the Reference 
object using the A B C Datum Reference 
Frame.
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Aligning surface Data objects to each other using 
surface information

When scanning a part, it is sometimes impossible to capture all 
the surfaces without moving the scanning device or changing the 
part position relative to the scanning device. This generates one 
surface Data object for each different setup used. If the device 
positions are not already aligned, it is possible to align these 
surface Data objects to one another. The alignment uses the areas 
that overlap with neighboring surface Data objects.

Align Data objects to Data objects one at a time

This method aligns one set of Data objects to a fixed set of Data objects. First, a prealignment 
is done by the user by picking matching points. Then, a best-fit alignment is performed using 
the surface shape in the overlying regions.

Objective: Align one set of surface Data objects to a fixed set of Data objects.

Required: Two or more surface Data objects with sufficient overlapping data to guarantee a 
proper alignment.

Steps

1. Choose Align > Best-Fit Data Objects > Data to 
Data Objects.

The Best-Fit Data to Data Objects dialog box 
opens.

2. Specify a Name for the data alignment.

3. Select the Align Data Objects method.

4. The Prealign using point pairs check box is 
selected by default.

5. In the Data objects to align list, select the Data 
objects that will be aligned.

6. In the Fixed data objects list, select Other 
Data Objects.

Fixed Data objects do not move for the alignment.

7. Specify a Max distance.

The maximum distance is used by the best-fit 
alignment to find overlapping areas.
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8. In the Subsampling list, select 1/1.

Here, all points are used to refine the best-fit 
alignment but with a longer computing time. The 
default value is 1/4.

9. Click Start. 

The Prealign using Point Pairs dialog box opens.

Fixed Data objects and the Data objects that will 
be aligned are displayed in separate viewports.

10. Move both the fixed Data object (left) and the 
Data object that will be aligned (right) to give 
them a similar orientation.

This facilitates the picking of pairs of points.

11. Choose the N Point Pairs prealignment 
method.

12. Click Pick to enable an interactive picking 
mode.

13. Anchor at least three matching points on both 
objects, using the same order. It is 
recommended to anchor four or five pairs of 
matching points. The matching points are 
displayed using the same color and the same 
number.

14. Click Align to confirm the alignment and exit 
the picking mode.

The best-fit alignment is automatically performed 
after the prealignment.

As the alignment converges to a solution, results 
are displayed in the Statistics section.

1 1

22

3 3
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Results

Notes

A new data alignment is added to the 
alignment group of the aligned Data objects.

The surface Data objects are aligned to each 
other in the 3D scene.

 

When there are three Data objects or more, and once they are aligned together using a best-fit 
Data to Data Objects alignment, it is possible to optimize the alignment between all the Data 
objects, using surface information, through the Globally Optimize Alignments method.
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Globally optimizing the alignments of all Data objects

When scanning parts in multiple device positions, a new scanned Data object is produced in 
each device position and then aligned to the Data objects from previous device positions using 
the best-fit Data to Data Objects functionality. When three or more Data objects from different 
device positions are present, the alignment of all Data objects can be optimized using the 
Globally Optimize Alignments method to ensure the best results in terms of alignment 
between the scanned Data objects. Typically, this method should be used in the last device 
position.

Objective: Optimize the alignment of all the Data objects.

Required: Three or more Data objects from different device positions are in the project and 
already aligned using the Best-Fit Data to Data Objects alignment.

Steps

1. Choose Align > Best-Fit Data Objects > Data to 
Data Objects.

The Best-Fit Data to Data Objects dialog box 
opens.

2. Specify the Globally Optimize Alignments 
method. 

3. Specify a Name for the data alignment.

4. In the Data objects to align list, select All.

5. Specify a Max distance.

The maximum distance is used by the best-fit 
alignment to find overlapping areas.

6. In the Subsampling list, select 1/1.

Here, all points are used to refine the best-fit 
alignment but with a longer computing time.

7. Click Start. 

As the alignment converges to a solution, results 
are displayed in the Statistics section.
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Results

A new data alignment is added to the 
alignment group of the aligned Data objects.

The surface Data objects are aligned in the 
3D scene, and their alignment is globally 
optimized.
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Introducing coordinate systems 

A coordinate system describes the origin and orientation of an inspection project.

Three types of coordinate systems are supported by PolyWorks|Inspector:

• Cartesian 

• Cylindrical

• Spherical

PolyWorks|Inspector projects come with a default coordinate system called “world”. It 
corresponds to the standard Cartesian coordinate system (x, y, z), whose origin is located at  
0, 0, 0.

Multiple coordinate systems are useful for users who need to work in a specific frame of 
reference for the purpose of visualizing and reporting information. New coordinate systems 
can be created. They appear under the Coordinate Systems branch of the Tree View, and are 
represented in the 3D scene as an origin and three axes. Only one coordinate system can be 
active at a time.

In the 3D scene

Using a new coordinate system

When a coordinate system is activated, the following occurs:

• All objects are represented in the new coordinate system, regardless of their status.

• All measurement results are transformed in order to be aligned in the new coordinate 
system. Measurement results remain valid.

• The numerical values of object properties related to location and orientation are 
expressed in the active coordinate system. Default values, for example in the object 
creation dialog boxes, do not change.

• Objects are exported in the active coordinate system.

• The bounding box of the 3D scene is recalculated. This can influence the creation of 
certain primitives, like a plane primitive created numerically, or certain dependent 
primitives that are created using the bounding box.

The active coordinate system is displayed using red, 
green, and blue for the X, Y, and Z axes respectively.

The world coordinate system is easily identifiable since 
it has a gray cube at its origin.

Coordinate systems that are not active are displayed in 
gray.
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Understanding the coordinates of a point

Cartesian coordinates of a point are represented by x, y 
and z values based on three mutually perpendicular X, 
Y, Z axes.

The cylindrical coordinates of a (x, y, z) point are 
represented by a trio of radius, azimuthal angle, and 
height values calculated according to the following 
convention:

The radius value (r) represents the distance from the 
origin along the X-Y plane.

The azimuthal angle value (a) represents the angle with 
respect to the positive X direction, calculated within the 
X-Y plane according to the right-hand rule. This angle 
ranges from 0 to 360 degrees.

The height value (h) represents the distance from the 
origin along the cylindrical axis (or Z axis).

The spherical coordinates of a (x, y, z) point are 
represented by a trio of radius, azimuthal angle, and 
inclination angle values calculated according to the 
following convention:

The radius value (ρ) represents the distance from the 
origin.

The azimuthal angle value (θ) represents the angle with 
respect to the positive direction, calculated within the 
X-Y plane according to the right-hand rule. This angle 
ranges from 0 to 360 degrees.

The inclination angle value (φ) represents the angle 
with respect to the vertical axis (or positive Z axis). This 
angle ranges from 0 to 180 degrees.
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Creating and activating coordinate systems 

PolyWorks|Inspector projects come with a default coordinate 
system called “world”. New coordinate systems can be created as 
well from feature primitives, from translations and rotations, or 
numerically. When a new coordinate system is created, it is 
automatically activated.

As shown to the right, the active coordinate system is displayed 
using red, green, and blue for the X, Y, and Z axes respectively.

Objective: Create a new coordinate system using feature primitives to define the origin and 
orientation.

Required: Features whose geometric properties (ex. center point, normal) can be used to 
describe the origin and orientation of the coordinate system.

Steps

1. Choose Tools > Coordinate Systems > Create 
Cartesian.

The Create Cartesian Coordinate Systems 
dialog box opens.

2. In the Method list, select From Primitives.

3. In the Primary, Secondary, and Tertiary lists, 
select the primitives that define the coordinate 
system.

Optionally, click the hand icon and pick the 
primitives in the 3D scene.

4. In the 3D scene, clicking the colored arrow on 
an axis rotates the other axes around it by 
90 degrees, thereby changing their direction.

5. In the Create Cartesian Coordinate Systems 
dialog box, click Create to confirm the new 
coordinate system.
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Tips

Results

All coordinate systems are listed as objects in 
the Tree View. The active coordinate system is 
displayed in bold in the Tree View, and in color 
in the 3D scene. To activate a coordinate 
system, right-click it in the Tree View and 
choose Activate.

The new coordinate system is added to the 
Tree View, under the Coordinate Systems 
branch. It is named csys by default.

The new coordinate system is displayed in 
the 3D scene.
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Notes

• When the creation method is set to 
Numerically, the exact origin and axis of 
the coordinate system can be specified. No 
Reference object or feature primitives are 
required.

• When the creation method is set to From 
Translation and Rotation, the origin and 
axes can be offset from the active 
coordinate system position by entering 
specific values. No Reference object or 
feature primitives are required.
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MEASURING DIMENSIONS AND DEVIATIONS
Introducing measurement objects in 
PolyWorks|Inspector

PolyWorks|Inspector is an object-oriented analysis and verification environment. All items 
imported or created in PolyWorks|Inspector are objects, and PolyWorks|Inspector preserves 
the relational correspondence of these objects throughout the inspection process.

Measurement objects

Measurements are done through the use of measurement objects: data color maps, features, 
cross-sections, comparison points, and gauges. These objects can be measured, remeasured, 
updated, and reported. Measurement objects obtain results by calculating the deviation 
between nominal components, derived from a Reference object, and measured components, 
derived from a Data object. The components of feature and cross-section measurement 
objects can be displayed by expanding the objects in the Tree View, while the components of 
comparison points and gauges are contained within the objects themselves. A measured 
status icon is displayed in the Tree View for objects that have been successfully measured. For 
color maps, the measured status icon indicates that the color map is valid.

Measured status icon

A ruler icon indicates the measured status of objects in the Tree View. The color of the icon 
specifies whether or not the controls associated with the object are within tolerance:

A simple feature has a nominal and a 
measured component.

The nominal and the measured component 
of a cross-section can be represented by 
several children, depending on the number 
of Reference and Data objects encountered 
by its slicing plane.

All controls are within tolerance.

At least one control is within the warning limit. 

At least one control is out-of-tolerance. This status has priority over the warning 
status.
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The Display > Tree View options page offers the Show in-tolerance status on 
measurement objects option, used to enable or disable the display of the in-tolerance 
status. When disabled, only the measured status is displayed (white ruler).

Automatic project update

The automatic project update is an option that keeps objects up-to-date by recalculating 
measured values as related objects are modified. By propagating changes throughout the 
inspection project, the coherence of the inspection project is always maintained. For more 
information, see Automatic project update on page 695.

The in-tolerance status is unknown for at least one control (for example, the 
measurement object is not controlled, or one of its controls is in error). This status 
has priority over all other statuses.
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Measuring deviations using data color maps

Data color maps are measurement tools to measure the 
deviation of Data objects from the surfaces or boundaries of 
Reference objects, or from primitives or other objects. A 
deviation is calculated for each data point, or for just 
selected data points, of the Data object. The deviations are 
displayed in the 3D scene using a color map and can also be 
presented in report form (table). Color map display options 
are available to configure the color scale and the color 
mapping to get a specific result, like a pass/fail 
representation.

Data color map types

Data color maps are available on the Measure menu or on the Data Color Maps toolbar: 

Data object deviations from 
Reference object surfaces

Data object deviations from 
Reference object boundaries

Data object deviations from 
feature primitives
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Understanding key parameters

Parameters are offered for the creation of data color maps. Possible values vary according to 
the type of data color map. Here are some key parameters:

Direction
Select a direction along which deviations are measured. Possible values are illustrated below. 
They vary according to the type of data color map.

Data object thickness

Data object clearance

Along the axis (X axis)

Shortest

Along the axis 
(Y axis)

Shortest to 
Boundary

Normal to 
Boundary

Tangent to Boundary
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Reference objects
Choose the Reference objects that are taken into 
consideration for the measurement. Possible values 
are:

• All: Considers all non-ignored Reference objects.

• Specific: Considers only specific Reference objects; specify them in the list box offered.

• Selected Elements: Considers only the selected elements of Reference objects.

Data objects
Choose which Data objects are taken into 
consideration for the measurement. Possible values 
are:

• Surface: Considers all surface Data objects, which 
includes point clouds and polygonal models.

• Boundary: Considers all boundary Data objects, such as boundary point clouds.

• All: Considers all non-ignored Data objects.

• Specific: Considers only specific Data objects; select them in the list box offered.

• Selected Elements: Considers only the selected elements of Data objects.

Max distance
To speed up calculations, a maximum search distance is 
considered to find the deviations of the Data object 
from the Reference object. The default value is 4 mm 
and no deviation larger than 4 mm is detected. If high deviations occur on a part, ensure that 
the Max distance is larger than the expected deviations so as to measure all deviations.

Max angle
In the Filtering section, the Max angle parameter is 
enabled by default. This parameter acts as a filter to 
ensure that the normal of each considered data 
element has a normal compatible with the reference 
surfaces or the feature from which the deviations are 
measured. The angular deviation between the two 
normals must be smaller than the specified Max 
angle.

If the part is highly deformed, it may be necessary to 
disable this parameter which allows data elements to 
be considered regardless of their normal direction.

Reference object

Data points
45° 
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Measuring deviations from surfaces

The deviations of Data objects from Reference object surfaces 
can be measured. The results are displayed in the 3D scene by 
means of a data color map, as shown to the right.

The procedure used to measure deviations is explained below. 
For information on the key parameters, see Understanding key 
parameters on page 189.

Objective: Obtain the deviations of a Data object from the 
surface of a Reference object.

Required: The project contains a Data object and a Reference object. The Data object must 
be aligned to the Reference object.

Steps

Results

1. Choose Measure > Deviations of Data Objects > 
From Reference Object Surfaces.

The Measure Deviations from Surfaces 
dialog box opens.

2. In the Direction list, select the measurement 
direction (Shortest, typically).

3. In the Reference objects and Data objects 
lists, select the objects that will be measured.

4. Specify a Max distance.

5. Click Measure.

The data color map is added to the Tree View, 
under the Data Color Maps branch. 

The color-mapped object is displayed in the 
3D scene. 
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Notes

• To hide the display of the active data color 
map, click Hide Color Map.

• To edit the color scale, choose View > Edit Color 
Scale. Conversion to colors, scale type, and 
range limits can be edited in the dialog box.

• Once created, it is possible to access and edit the color map creation parameters if needed 
using its property sheet. Select the object in the Tree View and choose Edit > Object 
Properties.
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Measuring deviations from boundaries

The perimeter of a Data object (usually boundary Data 
type point clouds) can be compared to the perimeter of a 
Reference object by measuring each data point to the 
open boundary edges of the Reference object. Deviations 
can be measured along the shortest, normal or tangent 
distance to the boundary. The results are displayed in the 
3D scene by means of a data color map, as shown to the 
right.

The procedure used to measure deviations is explained below. For information on the key 
parameters, see Understanding key parameters on page 189.

Objective: Measure the deviation of the measured data points from the open boundaries of 
the Reference object, generating a data color map.

Required: The project contains a Data object as well as a Reference object with open 
boundaries. The Data object must be aligned to the Reference object.

Steps

1. Choose Measure > Deviations of Data Objects > 
From Reference Object Boundaries.

The Measure Deviations from Boundaries 
dialog box opens.

2. In the Direction list, select a direction of 
measurement (Shortest to Boundary 
typically).

3. In the Reference objects and Data objects 
lists, select the objects that will be measured.

4. Specify the Max distance.

5. Click Measure.
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Results

Notes

The new data color map is added to the Tree 
View, under the Data Color Maps branch.

The color-mapped object is displayed in the 
3D scene.

• A Reference object with open boundaries implies the presence of surface discontinuities in 
which case the model does not define a closed volume. In the following examples, a 
Reference object is illustrated with both types of boundaries: open and closed.

Open boundaries Closed boundaries

• To hide the display of the active data color 
map, click Hide Color Map.

• To edit the color scale, choose View > Edit Color 
Scale. Conversion to colors, scale type, and 
range limits can be edited in the dialog box.

• Once created, it is possible to access and edit the color map creation parameters if needed 
using its property sheet. Select the object in the Tree View and choose Edit > Object 
Properties.
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Measuring deviations from feature primitives

The shape of a Data object can be compared to a geometric 
feature, such as a plane or a cylinder, by measuring each data 
point to a feature primitive. The results are displayed in the 3D 
scene by means of a data color map, as shown to the right.

The procedure used to measure deviations is explained below. 
For information on the key parameters, see Understanding key 
parameters on page 189.

Objective: Measure the deviations of the measured data points from feature primitives, 
which generates a data color map.

Required: The project contains a Data object and a feature primitive, which are aligned.

Steps

1. Choose Measure> Deviations of Data Objects > 
From Feature Primitives.

The Measure Deviations from Feature 
Primitives dialog box opens.

2. In the Direction list, select the measurement 
direction.

3. In the Primitives list, select the primitives that 
will be used.

4. In the Data objects list, select the Data objects 
that will be used.

5. Specify a Max distance.

6. Click Measure.
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Results

Notes

The data color map is added to the Tree View 
under the Data Color Maps branch. 

The color-mapped object is displayed in the 
3D scene.

 

• To hide the display of the active data color 
map, click Hide Color Map.

• To edit the color scale, choose View > Edit Color 
Scale. Conversion to colors, scale type, and 
range limits can be edited in the interface.

• Once created, it is possible to access and edit the color map creation parameters if needed 
using its property sheet. Select the object in the Tree View and choose Edit > Object 
Properties.
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Measuring the thickness of a part

The thickness of thin-walled parts can be measured by matching each data point to an 
opposing surface that has an opposite orientation. A data color map is generated on the Data 
object to illustrate the deviations. If the project contains a Reference object, it is also possible 
to measure the deviation between Data object thicknesses and Reference object thicknesses 
at similar locations. The Data object must be aligned to the Reference object.

The procedure used to measure the thickness of a part is explained below. For information on 
the key parameters, see Understanding key parameters on page 189.

Objective: Calculate the thickness of a Data object.

Required: The project contains a Data object.

Steps

Results

1. Choose Measure > Thickness of Data Objects.

The Measure Thickness of Data Objects dialog 
box opens.

2. In the Data objects list, select the Data objects.

3. Specify a Max distance.

The distance should be at least as large as the 
width of the thickest wall that will be measured.

4. If the Data object is a point cloud, select 
Sampling step which ensures smooth, 
continuous shading.

A smaller sampling step results in finer 
measurement details, while a larger sampling step 
speeds up the operation.

5. Click Measure.

The data color map is added to the Tree View, 
under the Data Color Maps branch.

The color-mapped Data object is displayed in 
the 3D scene.
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Notes

• Optionally, a Reference object can be used for thickness comparison purposes. In this 
case, the data color map displays either the measured thickness, the nominal thickness, or 
the deviation between the two thicknesses. In all cases, the data color map is displayed on 
the Data object.

• To hide the display of the active data color 
map, click Hide Color Map.

• To edit the color scale, choose View > Edit Color 
Scale. Conversion to colors, scale type, and 
range limits can be edited in the dialog box.

• Once created, it is possible to access and edit the color map creation parameters if needed 
using its property sheet. Select the object in the Tree View and choose Edit > Object 
Properties.

1. In the Measure Thickness of Data Objects 
dialog box, select Compute nominal and 
deviation.

2. Specify a value for the Reference objects, 
Max distance, and Max angle parameters.

3. Click the Object Display Options menu 
button on the 3D scene toolbar.

4. In the Thickness color mode list, under Data 
color maps, select Nominal, Measured, or 
Deviation.
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Measuring the clearance between parts

When two or more Data objects have been aligned to each other, 
the clearance between these objects can then be measured. The 
resulting data color map illustrates gaps or interference between 
the objects. This information can be used to adjust their position.

The procedure used to measure the clearance between parts is 
explained below. For information on the key parameters, see 
Understanding key parameters on page 189.

Objective: Measure the clearance between several Data objects.

Required: The project contains two or more Data objects that have been previously aligned 
to each other.

Steps 

1. Choose Measure > Clearance between Data 
Objects.

The Measure Clearance between Data Objects 
dialog box opens.

All nonignored polygonal Data objects are 
considered for the clearance operation.

2. Choose the measurement method, either for 
measuring objects between themselves or to 
master objects only.

If a master object is used, it becomes the focus of 
the measurement and all other Data objects are 
measured only to it.

3. When the thickness of a part is known and only 
one side of the part was scanned, specify a 
Thickness to take into account the other side 
of the part.

4. Specify a Max distance and a Max angle.

5. Click Measure.
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Results

Notes

The data color map is added to the Tree View, 
under the Data Color Maps branch. 

The color-mapped object is displayed in the 
3D scene.

 

• To hide the display of the active data color 
map, click Hide Color Map.

• To edit the color scale, choose View > Edit Color 
Scale. Conversion to colors, scale type, and 
range limits can be edited in the interface.

• Once created, it is possible to access and edit the color map creation parameters if needed 
using its property sheet. Select the object in the Tree View and choose Edit > Object 
Properties.

Interference

Clearance
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Changing the color map display

The color scale controls the way measured deviations are converted to colors in color maps. 
PolyWorks|Inspector provides many predefined color scales, and an interface that allows 
customizing them.

Objective: View a color map using different color scales.

Required: A project contains an active data color map.

Steps

1. Choose View > Edit Color Scale.

The Edit Color Scale dialog box opens.

2. In the Conversion to colors list, select a 
method. The following methods are available:

• Auto Range assigns a predefined range of 
colors to the range of color map values.

• Use Customized Scale assigns colors based 
on a specific range of values.

• Use Object Tolerances assigns colors based 
on the pass/fail status of data points.

3. In the Scale type list, select a predefined type.

4. To create a custom color scale, click Add to 
create a completely new color scale, or click 
Edit to modify an existing color scale.

5. Edit the Range limits parameters, if using the 
Auto Range conversion to colors, to display the 
desired range of deviation values.

6. Click Apply.
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Results 

Notes

If the Auto Range method is specified, the 
range of deviations is displayed as a 
continuous map, with minimum and 
maximum values defined in the Range 
limits.

If the Use Object Tolerances method is 
specified, the deviations are displayed as 
passing or failing the tolerance test, based on 
the tolerance associated with the Reference 
object.

• To hide the display of the active data color 
map, click Hide Color Map.

• Choose Tools > Options > Display > Color Maps 
for additional color map display settings, such 
as the use of deviation vectors and how color 
mapping can be applied to both Data and 
Reference objects.

• Minimum and maximum deviations can be 
displayed on a data color map. To view them, 
select Identify min and max values, available 
on the Display tab of the property sheet of the 
data color map.
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Displaying data point deviations on a data color map

The deviation value of any data point on a data color map can be displayed using an 
annotation. Annotations can be created interactively by clicking the model and then 
repositioning them for better viewing. Annotation values can also be reported in a table.

Objective: Place annotations on the data color map, showing individual data point 
deviations, and report them.

Required: The project contains a Data object aligned to a Reference object, and an active 
data color map.

Steps 

1. Choose Tools > Annotations > Create > Color 
Map Point Annotations.

An interactive picking mode is launched.

2. Hover the pointer over the color map in the 
3D scene to temporarily display the deviation of 
the closest data point.

3. Click the color map to create the annotation, 
which shows the deviation of the data point. 
Right-click to exit the mode.

4. For a clearer display, or for snapshot purposes, 
the annotations can be dragged. Choose Tools > 
Annotations > Position.

• Press Spacebar to temporarily exit the mode 
and perform rotations/translations.

• Press ESC to exit the mode.

5. Choose View > Hide > All Color Map Point 
Annotations to control the visibility of the 
annotations.

6. Choose Report > Create Tables > From All Color 
Map Point Annotations of Active Data Color 
Map to report the annotations.
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Results

Tip

Tools to delete, hide, and restore annotations are also 
accessible using the down arrow next to the Create 
Color Map Point Annotations button.

Individual data point deviations are displayed 
using annotations in the 3D scene.

Data point annotations are added to a table 
for reporting.
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Defining part geometry using features

Features define geometric characteristics of a part, such as holes and planar surfaces, and are 
typically used for part alignment and dimensional inspection purposes.

A feature typically contains a nominal and/or a measured component, also referred to as 
primitives. The nominal primitive represents the theoretical or ideal measurement, such as 
that found on a CAD model. The measured primitive is created from data points measured on 
the actual part being inspected. 

Features are available on the Measure > Features menu or on the Features toolbar. 

Feature types

Features can be categorized as follows: 

Individual features Features containing a nominal and/or a measured primitive. 
Individual features can be categorized by their geometrical 
properties. The most common categories are:

Surface-based: 

Features that have a 
surface.

Plane Cylinder Cone Sphere

Curve-based: 

Planar curves with a center 
point (x, y, z) and a direc-
tional vector (i, j, k). Circle Arc Slot Rectangle Polygon

Ellipse

Other:

Point Line Polyline

Slab*

*Feature composed of two existing parallel plane 
features with opposite orientations and 
containing a nominal and/or a measured 
primitive.
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Feature primitives

A feature typically contains a nominal and/or a measured primitive:

The feature creation methodology

A standard dialog box with common and contextual parameters is used for the creation of 
individual features and their primitives. Other features (surface, slab, angle, distance, and 
pattern) are created using their own creation dialog box, described respectively in each 
subsection.

The subsections that follow describe the feature creation methods and their parameters.

Composite features

Features composed of two or 
more existing features.

Distance Angle Pattern

Surface**

**Feature composed of CAD surfaces (nominal 
component) and data points (measured 
component).

Nominal primitives represent the theoretical or ideal 
measurement, such as that found on a CAD model.

Measured primitives are the geometrical entities 
found on the actual part being inspected.
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The feature creation dialog box

Key feature creation parameters

The feature creation dialog box offers the following parameters, depending on the feature 
type: 

Name
A default name is automatically entered in the 
Name text box. It can be edited, if desired.

The same name is assigned to the primitive with 
the -nom- (nominal) or the -meas- (measured) 
suffix according to the primitive status.

Datum feature label
A datum label can be specified for all individual 
features, except polylines, to create a Datum 
feature. Datum features are used in GD&T controls 
(Adding and encoding GD&T controls on page 508).

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose which type of feature to create.

3. In the Name text box, specify a name, if 
desired.

4. In the Datum feature label list, assign a 
datum label, if desired.

5. In the Method list, select a creation method.

6. In the Submethod list, select a creation 
submethod, if available.

7. Specify the required Parameters according to 
the creation method.

8. Click the appropriate button to launch the 
creation.
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Choose a datum letter in the Datum feature label combo box, or type in a customized 
datum label, consisting of one or more letters. Note that datum labels cannot contain the 
letters I, O, Q, X, Y, and Z. Once created, the feature is assigned the specified datum label.

Method
The creation methods available vary according to 
the type of feature selected. 

The Pick on CAD Model, Anchor, Numerically, 
Probe, and Fit creation methods follow standard 
creation processes which are described later, and 
result in a feature object with a nominal or a 
measured primitive.

Construction methods, such as From Objects, 
From Intersection, and From Projection, create 
features using existing objects.

The From Elements construction method creates points from selected elements.

The Empty Feature creation method allows creating an empty geometric feature of a 
specific type, to which a nominal and/or measured object can eventually be added.

Parameters
The parameters available in the dialog box vary according to the creation method 
specified in the Method list box.
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Creation methods explained

Pick on CAD model

Features (except arcs, points, polylines, and lines) can be created by picking the CAD geometry. 
For instance, a cylinder on the CAD model can be picked to create a nominal cylinder feature.

The Pick on CAD Model creation method offers two submethods for surface-based features:

• Single Surface: Creates a feature by picking a single CAD surface in the 3D scene.

• Multiple Surfaces: Creates a feature by picking multiple CAD surfaces in the 3D scene. 

To create different types of features without 
opening separate tools, choose Measure > 
Features > Create.

The Create Features dialog box opens.

Choose Multiple types from the feature type 
drop-down menu.

Most standard features can be picked using this 
interface. 

• To create curve-based features, such as circles 
and slots, two approaches can be used:

• Move the mouse cursor on a CAD model 
surface to select the closest curve-based 
feature and pick the one desired when it is 
highlighted.

• Move the mouse cursor in the void within a 
hole to select the first found primitive based 
on the current 3D scene view and pick.
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Anchor

Features can be created by anchoring their primitives on visible Data and Reference objects.

The Anchor creation method enables an interactive mode used to anchor primitives.

Each type of feature is created using a specific anchoring method. The How To Window 
button of the interactive mode guidance toolbar displays a diagram illustrating how to anchor 
points to create the specified feature type. 

When finished anchoring the required number of points, a primitive passing through the 
picked points is automatically created and added to the Tree View.

Numerically

Features can be created numerically using mathematical definitions.

The Numerically creation method offers parameters specific to the type of primitive being 
created.

Point, Center, Origin, or Apex coordinates can be provided by manually entering the (x, y, z) 
coordinates or by dragging a center-point-based primitive (arc, circle, ellipse, point, polygon, 
rectangle, slot, and sphere) and dropping it over the x, y, or z text box.

A Radius value can be provided manually or by dragging a primitive with a radius (arc, circle, 
polygon, rectangle, slot, cylinder, and sphere) and dropping it over the text box.

Orientation or Normal coordinates can be provided by manually entering the (i, j, k) 
coordinates or by dragging a direction-based primitive (arc, circle, cone, cylinder, ellipse, 
plane, polygon, rectangle, slot, and line) and dropping it over the i, j, or k text box.

Probe

Features can be created by probing a primitive directly using a measuring device.

The Probe method offers several parameters that allow users to customize the probing 
session.
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Thin material

Compensation method

Fixed number of points 

It is recommended to enable this parameter when 
probing curved-based features on an object made 
of a thin material like sheet metal. It takes the 
thickness of the material and the constraining 
plane into consideration to calculate the 
compensation correctly, even when the probe is in 
contact with the edge instead of the sidewall.

By default, the Compensation Method is 
generally set to From Device. This method uses 
the Compensation Method value of the probing 
device specified on the Probing Device > 
Compensation Method page of the 
PolyWorks|Inspector Options dialog box. The 
following values are available:

Compensation Point: using this method, a final 
probed point is used to identify the compensation 
direction. The probe is positioned away from the 
part material, and the probing session is ended. 

Probe Orientation: the probe orientation is used 
to identify the compensation direction. The first 
point must be gathered with the probe oriented 
normal to the contact surface.

In order to more strictly control the way each 
feature is probed, it is possible to set the number 
of probed points required to define it. When Fixed 
number of points is selected, any number of 
points greater than or equal to the mathematical 
minimum can be specified. The fixed number of 
points can also be set for constraining planes.
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Constraining planes
A constraining plane helps control the orientation of two-dimensional curve-based features 
like circles and slots. Since points probed around the feature perimeter may have different 
heights, the constraining plane prevents the feature from fitting at a tilt. 

Fit

When creating or extracting features from a point cloud or a polygonal model, the user can 
specify how the feature should be fit. Three items are available: Best-fit, Min, and Max. The 
method specified will determine where, within the data elements with the qualifying distance 
and angle, the feature primitive will be positioned. The Fit creation method allows creating 
features by fitting their primitives to selected Data or Reference object elements or to picked 
points.

When a curve-based feature, such as a circle, is 
probed, the exact height of each probed point 
will vary slightly. 

If a constraining plane is specified, the probed 
points will be projected onto that plane, 
removing the height variation.

While an unconstrained circle could be tipped 
compared to the part surface, a constrained 
circle will lie exactly on the surface plane.

Unconstrained Circle

Plane

Constrained Circle

Plane
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If the Best-fit fit type is selected, a standard best-fit algorithm is applied, using a pure least-
squares approach to generate a feature that is an average fit within the eligible data elements. 
Best-fit is the default fit type for many feature types, such as planes. It is a reasonable choice 
in regions where the point cloud is expected to generally define a smooth surface and any 
digitizer noise is equally distributed above and below the surface.

If the Min fit type is selected, the feature is fit such that no points are enclosed by the 
primitive. For a circular hole, the circle feature would fit to the innermost eligible data points, 
while for a planar surface, the plane would fit to the bottom eligible data points. It is a 
reasonable choice when defining a hole in the piece, because it describes the largest mating 
diameter possible without interference.

If the Max fit type is selected, the fitting algorithm applied creates the smallest primitive that 
encloses all considered data points. For a cylindrical pin, the cylinder would fit to the 
outermost eligible data points, while for a planar surface, the plane would fit to the top 
eligible points. The Max fit type is a reasonable choice when defining a physical pin or a 
diffuse surface like a honeycomb, because it describes the actual mating surface without 
interference.

 

A Best-fit, Min, and Max circle feature, fit to a 
selection of data points.

A Best-fit, Min, and Max plane, fit to a selection 
of data points.
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Constructing features

When creating features using construction methods, such as From objects or From 
Intersection, the creation method section of the creation dialog box offers a submethod 
selection list box. If the objects required for the construction are preselected in the Tree View, 
a corresponding construction submethod is automatically specified according to the type of 
objects selected.

When constructing features using existing features, the primitives of the selected features are 
divided into two separate groups, nominal and measured, and the desired construction 
operation is performed on each group. Note the following:

• If all the source features contain a nominal primitive, the resulting features also contain a 
nominal primitive.

• If all the source features contain a measured primitive, the resulting features also contain 
a measured primitive. 

• The nominal primitive and the measured primitive created using the same source feature 
belong to the same resulting feature.

If both the nominal and the measured primitives could not be created, and the Create 
dependencies check box was selected in the More subsection of the creation dialog box, 
corresponding empty features will be created. Otherwise, no feature is created.

Creating features from files

Commands on the Measure > Features > Create from Files submenu can be used to import 
same-type primitives from text files as well as to import one or more types of primitives from 
specific file types (for example, IGES files).

Each new primitive is assigned to a new feature of the primitive type. For example, importing a 
circle results in the creation of a circle feature that contains the circle primitive. The status of 
the new primitives (nominal or measured) can be specified when imported.

Feature dependencies

When a feature is constructed using existing objects in the project, for example, when using 
the From Objects method, the newly created features are dependent on the parent objects 
used to create them. This means that any changes made to the parent objects will result in the 
recalculation of the dependent features.

Dependent features can easily be identified in the 
Tree View, by a chain icon next to the feature icon. 

To remove the dependencies of a feature, select it in 
the Tree View and choose Measure > Features > 
Remove Dependencies.
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Creating features on cross-sections for 2D inspection

Inspecting in 2D along cross-sections is useful for parts that are too flexible or deformed, such 
as plastic parts and castings, or for measuring geometry types that are difficult to measure in 
3D, like fillet radius and wall thickness. Points, lines, circles, arcs, slots, angles, and distances 
can be directly created on nominal cross-section components and then extracted on 
measured cross-section components. A cross-section object must exist and be specified upon 
creation of these features. 

The following methods can be used to create features on cross-sections:

• Pick on CAD Model: Circles, arcs, slots, and lines can be created on cross-sections using 
this creation method. This method enables an interactive mode that has the same 
behavior as the existing mode for creating features. The only difference is that features are 
created by picking on the nominal cross-section components extracted from a CAD model. 
A preview of the feature that will be created is displayed.

• Anchor: Circles, arcs, slots, lines, and points can be created on cross-sections using this 
creation method. This method enables an interactive mode used to anchor primitives on 
nominal or measured cross-section components.

• Numerically: Circles, arcs, slots, lines, and points can be created on cross-sections using 
this creation method. Features that are created numerically are automatically projected 
onto the cross-section plane.

• From Objects, From Intersection, and From Projection: Circles, slots, lines, and points 
can be created on cross-sections using a construction method. Features created from 
other features are automatically projected onto the cross-section plane, while always 
preserving their form. For example, when creating a cross-section feature from the 
intersection of a plane and a cylinder, the circle resulting from the intersection is first 
computed in space. Then its center point is projected onto the cross-section plane and its 
axis orientation is forced to be the same as the cross-section normal vector while keeping 
the same radius.

• Empty Feature

 

To create features on cross-sections, the 
On cross-section parameter, located under 
the parameters section of the feature 
creation dialog box, must be selected and a 
cross-section must be specified.
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Duplicating cross-section features in 3D

Features created on a cross-section for 2D inspection can be duplicated in 3D for other 
purposes.

The resulting duplicated feature is dependent on its cross-section feature counterpart: the 
nominal primitive, on the one hand, is identical to the cross-section feature, except for arc 
features, which are duplicated as circles; the measured primitive, on the other hand, can 
deviate from the cross-section feature, since it is extracted in the active alignment instead of 
the alignment used to extract the cross-section.

Once the feature creation is launched, a 
special display mode is enabled. Only the 
specified cross-section is displayed in the 
3D scene. As the cross-section features are 
created, they are also highlighted in the 
3D scene.

A link associates the features with the 
specified cross-section by automatically 
placing them in a cross-section feature group 
named after the cross-section object and 
displaying them in the Tree View, under the 
Features branch.

 

To duplicate cross-section features in 3D, 
select the feature in the Tree View and 
choose Edit > Duplicate Cross-Sections Features 
in 3D.
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Duplicated features are created outside of 
the cross-section feature group but are 
associated to their corresponding cross-
section feature by a dependency link.
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Analyzing measured point deviations

Deviation information of measured points for a feature can be displayed in the 3D scene at 
any time, without having to create a data color map. This information is available when 
features are measured and the appropriate option is enabled.

Objective: Display the measured point deviations for a feature.

Required: The project contains a measured feature.

Steps

Results

1. Select a feature in the Tree View.

2. Choose View > Restore > Feature Deviations.

Alternatively, right-click the selected feature in 
the Tree View and choose View > Deviations > 
Restore.

The deviations are displayed according to predefined options (see Feature measured point 
deviation display options on page 221 for information). 

• Deviation display for features measured by 
extraction.
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Notes

• Deviation display for features measured by 
probing.

• The deviation display can also be enabled/
disabled from the property sheet of each 
feature. Select a feature, choose Edit > 
Object Properties, then click the Display tab.

• The Display tab also offers the Identify 
min and max deviations parameter. When 
selected, annotations are displayed in the 
3D scene to identify the minimum and 
maximum measured point deviations for 
the feature. In this example, the parameter 
has been enabled for a plane feature.
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Feature measured point deviation display options

A number of display options are available to modify the way measured point deviations are 
represented for features. 

1. Click the Object Display Options menu 
button on the 3D Scene toolbar.

The Features section contains the following 
options:

• Deviation type:

By default, Measured Points is selected, which 
means that the deviation of measured points is 
displayed with respect to the nominal or the 
measured primitive (see the Considered 
feature component option later on in this 
section).

• Deviation scaling factor:

Increases the length of deviation vectors for 
better viewing.

• Show deviation values when possible:

Deviation values can be displayed as 3D text by 
enabling this option.

The Feature measured point deviations 
section contains the following options:

• Considered feature component:

The deviations can be displayed from the 
Nominal component or the Measured 
component.
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Notes

• Deviation vectors:

It controls whether deviation vectors are 
displayed. The default value is set to 
Automatic, which lets the application decide 
whether the vectors are shown or not based 
on the number of point deviations that are 
displayed in the 3D scene. The deviation vector 
display can also be set to Show or Hide.

The measured point deviations are displayed 
as colored points, based on the active color 
scale.

Additional options are found on the Display > 
Features page of the PolyWorks|Inspector 
Options (available by choosing Tools > Options).
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Creating point features

Point features are typically created with a nominal primitive, using different creation methods. 
The measured primitive is subsequently added to the feature using specific methods. 

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal point primitives

Objective: Create a nominal point primitive interactively or using mathematical definitions.

Required: The project contains at least a Reference object, a Data object, a surface-based 
feature, a curve-based feature, or a cross-section-based object, or the information 
that defines the nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Point.

3. Choose one of the following methods.

Numerically

1. In the Method list, select Numerically.

2. Specify the Point coordinates to define the 
feature.

3. Click Create.
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Results  

Obtaining measured point primitives

To obtain the measured primitive of a point feature, the most typical method available is 
Probe. The method is explained in the following subsection.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Probe

Objective: Create the measured point primitive by probing it.

Required: The project contains a nominal point primitive. A probing device is ready to use.

Steps  

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. In the 3D scene, anchor a point at the desired 
location.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

3. Right-click to exit the anchoring mode.

The point feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The nominal primitive is displayed in the 3D 
scene.

 

1. In the Tree View, select the features that will be 
probed.
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Results  

Notes 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select 
Uncompensated.

5. Click Probe.

6. Probe the measured point primitive.

The probed measured primitive is added to 
the point feature, under the Features branch 
of the Tree View. 

The primitives are displayed in the 3D scene. 

To probe a measured primitive without a nominal 
primitive:

1. Choose Measure > Features > Create. 

2. Expand the feature type drop-down menu and 
choose Point.

3. In the Method list, select Probe.
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Constructing point features

Objective: Construct a point feature using existing objects.

Required: The project contains objects.

Steps  

1. In the Tree View, select the objects to use for 
the construction.

2. Choose Measure > Features > Create. 

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Point.

4. Select one of the following methods.

From Objects

1. In the Method list, select From Objects.

2. In the Submethod list, select a submethod.

A corresponding construction submethod is 
automatically specified according to the type of 
selected objects.

3. Specify the required parameters, if necessary.

4. Click Create.

Example 1: The Circle Centers submethod 
creates a point at the center point of each 
selected circle. This submethod is available for 
all curve-based features.
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Results  

Example 2: The Profile Gauges submethod 
creates characteristic points related to the 
profile gauge, such as tangency points. 

From Intersection

1. In the Method list, select From Intersection.

2. In the Submethod list, select a submethod.

A corresponding construction submethod is 
automatically specified according to the type of 
selected objects.

3. Specify the required parameters, if necessary.

4. Click Create.

Example: The Plane and Cylinders 
submethod creates a point at the intersection 
of the selected plane and the axis of each 
selected cylinder.

The constructed point feature is added to the 
Tree View, under the Features branch. A chain 
overlays the icon, indicating its dependent 
status.

The point feature is displayed in the 
3D scene.
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Notes

These methods generate dependent point features, which means that if something affects the 
source objects, it affects the dependent point feature as well. For example, if the source object 
becomes measured, the dependent point feature becomes measured as well.

Creating point features on cross-sections

Point features can be created on cross-sections for 2D inspection purposes. Nominal point 
primitives are created on nominal cross-section components. The measured primitives are 
subsequently extracted on measured cross-section components. A cross-section object must 
exist and be specified upon creation of these features. 

For more information, see Creating features on cross-sections for 2D inspection on page 216.

The creation procedures are explained in the following subsections. 

Creating nominal cross-section point primitives

Objective: Create a nominal cross-section circle primitive.

Required: The project contains a nominal cross-section component created on a CAD 
Reference object.

Steps  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Point.

3. Choose one of the following methods.
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Results  

Extracting measured cross-section point primitives

Objective: Extract the measured primitive of a cross-section circle using its nominal 
primitive.

Required: The project contains a cross-section point feature with a nominal primitive, and its 
linked cross-section is measured. For more information about obtaining cross-
section measured components, refer to Measuring the geometry on the part on 
page 390.

Numerically

1. In the Method list, select Numerically.

2. Enable the On cross-section parameter and 
choose a cross-section from the list.

3. Specify the Point coordinates to define the 
feature.

4. Click Create.

The point is automatically projected onto the 
cross-section.

Anchor

1. In the Method list, select Anchor.

2. Enable the On cross-section parameter and 
choose a cross-section from the list. 

3. The interactive anchoring mode is 
automatically activated. If not, click Anchor.

4. In the 3D scene, anchor a point on the cross-
section contour at the desired location to 
create a point.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a cross-section component.

5. Right-click to exit the anchoring mode.

The point feature created on a cross-section, 
and its nominal primitive, are added to the 
Tree View, under the Features branch, and 
also grouped in a cross-section feature 
group.
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Steps  

Results

Constructing cross-section point features

Objective: Construct a cross-section point feature using existing objects.

Required: The project contains objects.

Steps

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the 
cross-section point feature, under the 
Features branch.

1. In the Tree View, select the objects to use for 
construction.

2. Choose Measure > Features > Create. 

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Point.

4. Choose one of the following methods.
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Results

Notes

From Objects and From Intersection

1. In the Method list, select From Objects or 
From Intersection.

2. In the Submethod list, select a submethod.

3. Enable the On cross-section parameter and 
choose a cross-section from the list. 

4. Specify the required parameters, if necessary.

5. Click Create.

Cross-section point features created from other 
features are automatically projected onto the 
specified cross-section. In this example, point 1 
was constructed from the center of circle 1.

For more information, see Constructing point 
features on page 226.

The cross-section point feature is created and 
added to the Tree View, under the Features 
branch. A chain overlays the icon indicating 
its dependent status.

These methods generate dependent point features, which means that if something affects the 
source objects, it affects the dependent point feature as well. For example, if the source object 
becomes measured, the dependent point feature becomes measured as well.
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Creating line features

Line features are typically created with a nominal primitive using different creation methods. 
The measured primitive is subsequently added to the feature using specific methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal line primitives

Objective: Create a nominal line primitive interactively or using mathematical definitions.

Required: The project contains at least a Reference object, a Data object, a surface-based 
feature, a curve-based feature, a cross-section-based object, or the information 
that defines the nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Line.

3. Choose one of the following methods.

Numerically

1. In the Method list, select Numerically.

2. In the Submethod list, select Origin and 
Orientation.

3. Specify the required values to define the 
feature Origin, Orientation, and Length.

4. Click Create.
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Results  

Anchor

1. In the Method list, select Anchor.

2. In the Submethod list, select Pick 2.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

3. In the 3D scene, anchor two points at the 
desired location.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a cross-section component.

4. Right-click to exit the anchoring mode.

The line feature and its nominal primitive are 
added to the Tree View, under the Features 
branch.

The nominal primitive is displayed in the 
3D scene.
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Obtaining measured line primitives

To obtain the measured primitive of a line feature, the most typical method available is Probe. 

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Probe

Objective: Create the measured line primitive by probing it.

Required: The project contains a nominal line primitive. A probing device is ready to use.

Steps  

1. In the Tree View, select the line features to 
probe.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Constrain the feature to a plane.

• Select Use Plane Feature to use an existing 
plane in the Tree View, or to probe a new 
one that will appear in the Tree View. This 
method is useful when the constraining 
plane will be used for several objects, for 
example, thick objects. 

• Select Probe Local Plane to probe a new 
plane. Note that this plane is probed near 
the feature. It is stored within the feature 
and does not appear in the Tree View. This 
method is useful, for example, when 
probing thin material, such as sheet metal, 
that could have a significant deviation from 
a feature to another.

6. Click Probe.

7. Probe the constraining plane, if (Probe New) 
or Probe Local Plane is specified.

8. Probe the measured line primitive.
234



MEASURING DIMENSIONS AND DEVIATIONS
Tips

Results  

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the line. 

The probed measured primitive is added to 
the line feature, under the Features branch of 
the Tree View. 

The primitives are displayed in the 3D scene. 
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Notes  

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Line.

• In the Method list, select Probe.

When probing, probed points are collected 
at the center of the probe tip.

Compensation is necessary to offset the 
measured points to the point of contact.

When using Compensation point as the 
compensation method, the line is compen-
sated by moving the probe slightly off the 
surface and ending the probing.
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Constructing line features

Objective: Construct a line feature using existing objects.

Required: The project contains existing objects.

Steps  

1. In the Tree View, select the objects to use for 
the construction.

2. Choose Measure > Features > Create. 

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Line.

4. Choose one of the following methods.

From Objects

1. In the Method list, select From Objects.

2. In the Submethod list, select a submethod.

A corresponding construction submethod is 
automatically specified according to the type of 
selected objects.

3. Specify the required parameters, if necessary.

4. Click Create.

Example: The Cylinder Axes submethod 
creates a line using the axis of each selected 
cylinder.
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Results  

Notes  

From Intersection

1. In the Method list, select From Intersection.

2. In the Submethod list, select a submethod.

A corresponding construction submethod is 
automatically specified according to the type of 
selected objects.

3. Specify the required parameters, if necessary.

4. Click Create.

Example: The 2 Planes submethod creates a 
line at the intersection of two selected planes.

The constructed line feature is added to the 
Tree View, under the Features branch. A chain 
overlays the icon indicating its dependent 
status.

The line feature is displayed in the 3D scene.

 

These methods generate dependent line features, which means that if something affects the 
source objects, it affects the dependent line feature as well. For example, if the source object 
becomes measured, the dependent line feature becomes measured as well. 

To make the line features independent, choose Measure > Features > Remove Dependencies.
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Creating line features on cross-sections

Line features can be created on cross-sections for 2D inspection purposes. Nominal line 
primitives are created on nominal cross-section components. The measured primitives are 
subsequently extracted on measured cross-section components. A cross-section object must 
exist and be specified upon creation of these features. 

For more information, see Creating features on cross-sections for 2D inspection on page 216.

The creation procedures are explained in the following subsections. 

Creating nominal cross-section line primitives

Objective: Create a nominal cross-section line primitive.

Required: The project contains a nominal cross-section component created on a CAD 
Reference object.

Steps  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Line.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. In the Cross-section list, select a cross-section.

3. Click Pick to launch the interactive picking 
mode.
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4. In the 3D scene, move the mouse cursor over 
the cross-section to select the closest line 
feature and pick the one desired when it is 
highlighted.

Numerically

1. In the Method list, select Numerically.

2. In the Submethod list, select a submethod.

3. Enable the On cross-section parameter and 
choose a cross-section from the list. 

4. Specify the required parameters, if necessary.

5. Click Create.

The line is automatically projected onto the cross-
section.

Anchor

1. In the Method list, select Anchor.

2. In the Submethod list, select Pick 2.

3. Enable the On cross-section parameter and 
choose a cross-section from the list. 

4. The interactive anchoring mode is 
automatically activated. If not, click Anchor.

5. In the 3D scene, anchor two points on the 
cross-section contour at the desired location to 
create a line

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

6. Right-click to exit the anchoring mode.
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Results  

Extracting measured cross-section line primitives

Objective: Extract the measured primitive of a cross-section line using its nominal primitive.

Required: The project contains a cross-section line feature with a nominal primitive, and its 
linked cross-section is measured. For more information about obtaining cross-
section measured components, refer to Measuring the geometry on the part on 
page 390.

Steps  

Results

The line features created on cross-sections, 
and their nominal primitives, are added to 
the Tree View, under the Features branch, 
and also grouped in a cross-section feature 
group.

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the 
cross-section line feature, under the Features 
branch.
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Constructing cross-section line features

Objective: Construct a cross-section line feature using existing objects.

Required: The project contains existing objects.

Steps

1. In the Tree View, select the objects to use for 
the construction.

2. Choose Measure > Features > Create. 

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Line.

4. Choose one of the following methods.

From Objects and From Intersection

1. In the Method list, select From Objects or 
From Intersection.

2. In the Submethod list, select a submethod.

3. Enable the On cross-section parameter and 
choose a cross-section from the list. 

4. Specify the required parameters, if necessary.

5. Click Create.

Cross-section line features created from other 
features are automatically projected onto the 
specified cross-section, while always preserving 
their form. In this example, line 1 was 
constructed from the center points of circle 1 and 
circle 2.

For more information, see Constructing line 
features on page 237.
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Results

Notes

The constructed line feature is added to the 
Tree View, under the Features branch, and 
grouped in the cross-section feature group. A 
chain overlays the icon indicating its 
dependent status.

These methods generate dependent line features, which means that if something affects the 
source objects, it affects the dependent line feature as well. For example, if the source object 
becomes measured, the dependent line feature becomes measured as well.
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Creating plane features

Plane features are typically created with a nominal primitive using different creation methods. 
The measured primitive is subsequently added to the feature using specific methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal plane primitives

Objective: Create a nominal plane primitive interactively using Reference object elements or 
a mathematical definition.

Required: The project contains a Reference object or the information that defines the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Plane.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. Click Pick to launch the interactive picking 
mode.

3. In the 3D scene, pick a CAD surface to create 
the plane.

4. Right-click to exit the picking mode.
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Results  

Numerically

1. In the Method list, select Numerically.

2. In the Submethod list, select Point and 
Normal.

3. Specify the required values to define the 
feature Point and Normal.

4. Click Create.

Anchor

1. In the Method list, select Anchor.

2. In the Submethod list, select Pick 3.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

3. In the 3D scene, anchor three points on the 
surface to create a plane.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

The plane feature, and its nominal primitive, 
are added to the Tree View under the 
Features branch.

The nominal primitive is displayed in the 
3D scene.
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Obtaining measured plane primitives

To obtain the measured primitive of a plane feature, the most common methods used are 
Extract, Probe, Extract from Polygonal Models, and Fit. Each method is explained in the 
following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured plane primitive using the nominal primitive.

Required: The project contains a feature with a nominal primitive and an aligned Data 
object.

Steps  

Results  

1. In the Tree View, select the plane feature that 
will be extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the plane 
feature in the Tree View, under the Features 
branch.

The primitives are displayed in the 3D scene.
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Probe

Objective: Create the measured plane primitive by probing it.

Required: The project contains a nominal plane primitive. A probing device is ready to use.

Steps  

1. In the Tree View, select the plane feature that 
will be probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Click Probe.

6. Probe the measured plane primitive.

Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the plane. 
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Results  

Notes  

The probed measured primitive is added to 
the plane feature, under the Features branch 
of the Tree View. 

The primitives are displayed in the 3D scene. 

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Plane.

• In the Method list, select Probe.

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model option.
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Fit 

Objective: Create measured plane primitives interactively using data elements.

Required: The project contains a Data object.

Steps

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.

When using Compensation point as the 
compensation method, a plane is compen-
sated by lifting the probe slightly off the 
surface and ending the probing.

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Plane.

3. In the Method list, select Fit.

4. In the Submethod list, select Pick, then Fit.

5. Specify the Max distance.

6. Select a Fit type.

7. Click Pick to launch the interactive picking 
mode.
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Results

Extract from Polygonal Models

Objective: Create measured plane primitives interactively using a polygonal model.

Required: The project contains a polygonal model.

Steps

8. In the 3D scene, anchor three points.

A preview plane is shown as points are 
anchored. If the preview plane does not look 
oriented as desired, restart the picking session 
by pressing ESC to cancel the current picking 
session and click Pick to start a new picking 
session.

9. After picking the third point, a plane is fitted to 
the Data object using the anchored plane as an 
initial guess to start the fitting process.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.

The measured primitive is added to the plane 
feature, under the Features branch of the 
Tree View.

The primitive is displayed in the 3D scene.

  

1. Choose Measure > Features > Extract from 
Polygonal Models. 

The Extract Primitives from Polygonal Models 
dialog box opens.
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Results

Notes 

The Extract from Polygonal Models method can also be used to create nominal primitives 
when using a polygonal model as the Reference object. 

2. Specify the feature Type.

The Automatic type is specified by default, 
which automatically determines the feature 
type that adjusts better to the area selected.

3. Specify the Method.

The Single Detection Zone method is selected 
by default. The Multiple Detection Zones 
method is useful when all areas that can be 
used to extract the feature primitive are not 
contiguous.

4. In the 3D scene, using the circular detection 
zone around the mouse pointer, click an area 
on the polygonal model that is part of the 
desired feature.

It is possible to increase or decrease the size of 
the detection zone at any time in the Parameters 
subsection, or using the mouse wheel.

5. Click Confirm.

The plane feature, and its measured 
primitive, are added to the Tree View under 
the Features branch.

The primitive is displayed in the 3D scene.

  
251



MEASURING DIMENSIONS AND DEVIATIONS
Constructing plane features

Objective: Construct a plane feature using existing objects.

Required: The project contains existing objects.

Steps  

1. In the Tree View, select the objects required for 
the construction.

2. Choose Measure > Features > Create.

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Plane.

4. Choose one of the following methods.

From Objects

1. In the Method list, select From Objects.

2. In the Submethod list, select a submethod.

A corresponding construction submethod is 
automatically specified according to the type of 
selected objects.

3. Specify the required parameters, if necessary.

4. Click Create.

Example: The Average of Planes submethod 
creates a plane by averaging the selected 
planes.
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Results  

The constructed plane feature is added to the 
Tree View, under the Features branch. A chain 
overlays the icon indicating its dependent 
status.

The plane feature is displayed in the 
3D scene.
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Creating circle features

Circle features are typically created with a nominal primitive using different creation methods. 
The measured primitive is subsequently added to the feature using specific methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal circle primitives

Objective: Create a nominal circle primitive interactively using Reference object elements or 
a mathematical definition.

Required: The project contains a Reference object, or the information that describes the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Circle.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick. 

3. In the 3D scene, pick a circle. Two approaches 
can be used:

• Move the mouse cursor on the CAD model 
surface to select the closest circle feature 
and pick the one desired when it is 
highlighted.

• Move the mouse cursor in the void within 
the hole to select the first found circle based 
on the current 3D scene view, then pick.
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Results  

Numerically

1. In the Method list, select Numerically.

2. Specify the required values to define the 
feature Center, Orientation, and Radius.

3. Click Create.

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. In the 3D scene, anchor three points on a hole 
boundary to create a circle.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

The circle feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The nominal primitive is displayed in the 
3D scene.
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Obtaining measured circle primitives

To obtain the measured primitive of a circle feature, the most common methods used are 
Extract, Probe, and Fit. Each method is explained in the following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured circle primitive using the nominal primitive.

Required: The project contains a circle feature with a nominal primitive and an aligned Data 
object.

Steps  

Results  

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the circle 
feature, under the Features branch of the 
Tree View.

The primitives are displayed in the 3D scene.

 

256



MEASURING DIMENSIONS AND DEVIATIONS
Probe

Objective: Create the measured circle primitive by probing it, along with its constraining 
plane, if required.

Required: The project contains a nominal circle primitive. A probing device is ready to use.

Steps  

1. In the Tree View, select the features that will be 
probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured. The 
Define Measured Feature Components dialog 
box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Specify a constraining plane.

• Select Use Plane Feature to use an existing 
plane in the Tree View, or to probe a new 
one that will appear in the Tree View.

• Select Probe Local Plane to probe a new 
plane. Note that this plane is probed near 
the feature. It is stored within the feature 
and does not appear in the Tree View.

6. Click Probe.

7. Probe the constraining plane, if (Probe New) 
or Probe Local Plane is specified.

8. Probe the measured circle primitive.

Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.
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Results  

Notes  

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the circle. 

The probed measured primitive is added to 
the circle feature, under the Features branch 
of the Tree View. 

The primitives are displayed in the 3D scene. 

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Circle.

• In the Method list, select Probe.

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model item.
258



MEASURING DIMENSIONS AND DEVIATIONS
Fit

Objective: Create measured circle primitives interactively using data elements.

Required: The project contains a Data object.

Steps

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.

When using Compensation point as the 
compensation method, a plane is compen-
sated by lifting the probe slightly off the 
surface and ending the probing.

When using Compensation point as the 
compensation method, a circle is compen-
sated by moving the probe inward (hole) or 
outward (pin) from the feature boundary, 
then ending the probing.

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Circle.
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3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.

It is recommended to set the Fit type to Min for a 
hole and Max for a pin.

6. Under Constraints, select Plane, then select a 
constraining plane, if required.

It is recommended to use a constraining plane to 
create a feature that is correctly oriented in 
space. The plane should be created prior to the 
fitting.

7. Under Filtering, adjust the filters based on the 
element selection.

It is recommended to remove the Max angle 
filter if no data is selected on the walls of the 
hole.

8. Choose Select > Elements > Interactively. 

9. In the 3D scene, select the elements that will 
be used to fit the circle.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

10. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.
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Results

Constructing circle features

Objective: Construct a circle feature using existing objects.

Required: The project contains existing objects.

Steps  

The measured primitive is added to the circle 
feature, under the Features branch of the 
Tree View. 

The primitive is displayed in the 3D scene. 

1. In the Tree View, select the objects to use for 
the construction.

2. Choose Measure > Features > Create.

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Circle.

4. Choose one of the following methods.
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From Objects

1. In the Method list, select From Objects

2. In the Submethod list, select a submethod.

A corresponding construction submethod is 
automatically specified according to the type of 
selected objects.

3. Specify the required parameters, if necessary.

4. Click Create.

Example: The Cylinders submethod creates a 
circle at each end of the selected cylinder, 
having the orientation of the cylinder.

From Intersection

1. In the Method list, select From Intersection.

2. In the Submethod list, select a submethod.

A corresponding construction submethod is 
automatically specified according to the type of 
selected objects.

3. Specify the required parameters, if necessary.

4. Click Create.

Example: The Plane and Cylinders 
submethod creates a circle centered at the 
intersection of a selected plane and the axis of 
each selected cylinder, oriented using the 
normal of the plane and with a radius equal to 
the radius of the cylinder.
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Results  

Notes  

The constructed circle features are added to 
the Tree View, under the Features branch. A 
chain overlays the icon, indicating its 
dependent status.

The circle features are displayed in the 
3D scene.

 

These methods generate dependent circle features, which means that if something affects the 
source objects, it affects the dependent circle feature as well. For example, if the source object 
becomes measured, the dependent circle feature becomes measured as well.

To make the circle features independent, choose Measure > Features > Remove Dependencies.
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Creating circle features on cross-sections

Circle features can be created on cross-sections for 2D inspection purposes. Nominal circle 
primitives are created on nominal cross-section components. The measured primitives are 
subsequently extracted on measured cross-section components. A cross-section object must 
exist and be specified upon creation of these features. 

For more information, see Creating features on cross-sections for 2D inspection on page 216.

The creation procedures are explained in the following subsections. 

Creating nominal cross-section circle primitives

Objective: Create a nominal cross-section circle primitive.

Required: The project contains a nominal cross-section component created on a CAD 
Reference object.

Steps  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Circle.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. Enable the On cross-section parameter and 
choose from the list of cross-sections. 

3. The interactive picking mode is automatically 
activated. If not, click Pick.

4. In the 3D scene, move the mouse cursor over 
the cross-section to select the closest circle 
feature and pick the one desired when it is 
highlighted.
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Results  

Numerically

1. In the Method list, select Numerically.

2. Enable the On cross-section parameter and 
choose from the list of cross-sections. 

3. Specify the required values to define the 
feature Center and Radius.

4. Click Create.

The circle is automatically projected onto the 
cross-section.

Anchor

1. In the Method list, select Anchor.

2. Enable the On cross-section parameter and 
choose from the list of cross-sections. 

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

3. In the 3D scene, anchor three points on the 
cross-section contour at the desired location to 
create a circle.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a cross-section component. 

4. Right-click to exit the anchoring mode.

The circle feature created on a cross-section, 
and its nominal primitive, are added to the 
Tree View under the Features branch, and 
also grouped in a cross-section feature 
group.
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Extracting measured cross-section circle primitives

Objective: Extract the measured primitive of a cross-section circle using its nominal 
primitive.

Required: The project contains a cross-section circle feature with a nominal primitive, and its 
linked cross-section is measured. For more information about obtaining cross-
section measured components, refer to Measuring the geometry on the part on 
page 390.

Steps  

Results

Constructing cross-section circle features

Objective: Construct a cross-section circle feature using existing objects.

Required: The project contains objects.

Steps

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the 
cross-section circle feature, under the 
Features branch.

1. In the Tree View, select the objects to use for 
the construction.

2. Choose Measure > Features > Create.

The Create Features dialog box opens.
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Results

3. Expand the feature type drop-down menu and 
choose Circle.

4. Choose one of the following methods.

From Objects and From Intersection

1. In the Method list, select From Objects or 
From Intersection.

2. In the Submethod list, select a submethod.

3. Enable the On cross-section parameter and 
choose a cross-section from the list. 

4. Specify the required parameters, if necessary.

5. Click Create.

Cross-section circle features created from other 
features are automatically projected onto the 
specified cross-section, while always preserving 
their form. In this example, circle 6 was 
constructed from the average of circle 1 to 
circle 5.

For more information, see Constructing circle 
features on page 261.

The constructed cross-section circle is added 
to the Tree View, under the Features branch, 
in the cross-section feature group. A chain 
overlays the icon, indicating its dependent 
status.
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Notes

These methods generate dependent circle features, which means that if something affects the 
source objects, it affects the dependent circle feature as well. For example, if the source object 
becomes measured, the dependent circle feature becomes measured as well. 
268



MEASURING DIMENSIONS AND DEVIATIONS
Creating arc features

An arc consists of a subsection of a circle. Arc features can only be created on cross-sections, 
typically with a nominal primitive, using different creation methods. The measured primitive is 
subsequently added to the feature using specific methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal arc primitives

Objective: Create a nominal arc primitive interactively using a Reference object or a 
mathematical definition.

Required: The project contains a cross-section, a Reference object, or the information that 
describes the nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Arc.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. In the Cross-section list, select a cross-section.

3. The interactive picking mode is automatically 
activated. If not, click Pick. 

4. In the 3D scene, move the mouse pointer over 
the cross-section contour, close to the area 
that defines an arc, and pick when it is 
highlighted.

5. Right-click to exit the picking mode.
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Numerically

1. In the Method list, select Numerically.

2. In the Cross-section list, select a cross-section.

3. Specify the required values to define the 
feature Center, Radius, Angle reference axis, 
Start angle, and End angle.

4. Click Create.

Anchor

1. In the Method list, select Anchor.

2. In the Cross-section list, select a cross-section.

3. The interactive anchoring mode is 
automatically activated. If not, click Anchor.

4. In the 3D scene, anchor three points on the 
cross-section contour, at the desired location, 
to create an arc.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a cross-section component.

5. Right-click to exit the anchoring mode.
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Results  

Notes  

The arc feature and its nominal primitive are 
added to the Tree View, under the Features 
branch.

The nominal primitive is displayed in the 
3D scene.

 

Creating arcs numerically requires the following information:

• Angle reference axis: Axis used as a reference for specifying the start and end angles of 
the arc. This axis is projected onto the cross-section plane.

• Start angle: Start angle of the arc, measured counterclockwise from the angle reference 
axis.

• End angle: End angle of the arc, measured counterclockwise from the angle reference 
axis.
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Obtaining measured arc primitives

To obtain the measured primitive of an arc feature, the method used is Extract from Cross-
Section. The measured primitive of the arc is extracted from the vertices of the measured 
components of its linked cross-section.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Objective: Extract the measured arc primitive using the nominal primitive.

Required: The project contains an arc feature with a nominal primitive and its linked cross-
section is measured.

Steps  

Results  

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the arc 
feature, under the Features branch of the Tree 
View.

The primitives are displayed in the 3D 
scene.
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Creating slot features

Slot features are typically created with a nominal primitive using different creation methods. 
The measured primitive is subsequently added to the feature using specific methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal slot primitives

Objective: Create a nominal slot primitive interactively using Reference object elements or a 
mathematical definition.

Required: The project contains a Reference object, or the information that defines the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Slot.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick.

3. In the 3D scene, pick a slot. Two approaches 
can be used:

• Move the mouse cursor on the CAD model 
surface to select the closest slot feature and 
pick the one desired when it is highlighted.

• Move the mouse cursor in the void within 
the hole to select the first found slot based 
on the current 3D scene view, then pick.
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Numerically

1. In the Method list, select Numerically.

2. Specify the values to define the feature Center, 
Axis orientation, Length orientation, 
Length, and Width.

3. Click Create.

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. In the 3D scene, anchor three points on one arc 
boundary and two points on the other arc 
boundary.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

The slot feature and its nominal primitive are 
added to the Tree View, under the Features 
branch.

The nominal primitive is displayed in the 
3D scene.
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Obtaining measured slot primitives

To obtain the measured primitive of a slot feature, the most common methods used are 
Extract, Probe, and Fit. Each method is explained in the following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured slot primitive using the nominal primitive.

Required: The project contains a slot feature with a nominal primitive and an aligned Data 
object.

Steps  

Results  

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the slot 
feature in the Tree View, under the Features 
branch.

The primitives are displayed in the 3D scene.
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Probe

Objective: Create the measured slot primitive by probing it, along with its constraining plane 
if required.

Required: The project contains a nominal slot primitive. A probing device is ready to use.

Steps  

1. In the Tree View, select the slot feature that will 
be probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select Arcs Only.

5. Specify a constraining plane.

• Select Use Plane Feature to use an existing 
plane in the Tree View, or to probe a new 
one that will appear in the Tree View.

• Select Probe Local Plane to probe a new 
plane. Note that this plane is probed near 
the feature. It is stored within the feature 
and does not appear in the Tree View.

6. Click Probe.

7. Probe the constraining plane, if (Probe New) 
or Probe Local Plane is specified.

8. Probe the measured slot primitive.
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Results  

Notes  

Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
for each arc to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the slot. 

The probed measured slot primitive and its 
constraining plane are added to the Tree 
View, under the Features branch. 

The probed slot feature components are 
displayed in the 3D scene. 

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive: 
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Fit

Objective: Create measured slot primitives interactively using data elements.

Required: The project contains a Data object.

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Slot.

• In the Method list, select Probe.

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model item. 

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.

When using Compensation point as the 
compensation method, a plane is compen-
sated by lifting the probe slightly off the 
surface and ending the probing.

When using Compensation point as the 
compensation method, a slot is compen-
sated by moving the probe inward (hole) or 
outward (pin) from the feature boundary, 
then ending the probing.
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Steps

1. Choose Measure > Features > Create. 

The Create Features dialog box opens. 

2. Expand the feature type drop-down menu and 
choose Slot.

3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.

It is recommended to set the Fit type to Min for a 
hole and Max for a pin.

6. Under Constraints, select Plane, then select a 
constraining plane from the list.

It is recommended to use a constraining plane to 
create the feature so that it is correctly oriented in 
space. The plane should be created prior to the 
fitting.

7. Under Filtering, adjust the filters based on the 
element selection.

It is recommended to remove the Max angle 
filter if no data is selected on the walls of the 
hole.

8. Choose Select > Elements > Interactively. 
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9. In the 3D scene, select the elements that will 
be used to fit the slot.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

10. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.

The measured primitive is added to the slot 
feature, under the Features branch of the Tree 
View.

The primitive is displayed in the 3D scene. 
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Creating slot features on cross-sections

Slot features can be created on cross-sections for 2D inspection purposes. Nominal slot 
primitives are created on nominal cross-section components. The measured primitives are 
subsequently extracted on measured cross-section components. A cross-section object must 
exist and be specified upon creation of these features. 

For more information, see Creating features on cross-sections for 2D inspection on page 216.

The creation procedures are explained in the following subsections.

Creating nominal cross-section slot primitives

Objective: Create a nominal cross-section slot primitive.

Required: The project contains a nominal cross-section component created on a CAD 
Reference object.

Steps  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Slot.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. Enable the On cross-section parameter and 
choose a cross-section from the list. 

3. The interactive picking mode is automatically 
activated. If not, click Pick.

4. In the 3D scene, move the mouse cursor over 
the cross-section to select the closest slot 
feature and pick the one desired when it is 
highlighted.

5. Right-click to exit the picking mode.
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Numerically

1. In the Method list, select Numerically.

2. Enable the On cross-section parameter and 
choose a cross-section from the list. 

3. Specify the values to define the feature Center, 
Length orientation, Length, and Width.

4. Click Create.

The slot is automatically projected onto the cross-
section.

Anchor

1. In the Method list, select Anchor.

2. Enable the On cross-section parameter and 
choose a cross-section from the list. 

3. The interactive anchoring mode is 
automatically activated. If not, click Anchor.

4. In the 3D scene, anchor three points on the 
cross-section contour at the desired location to 
define the first arc, then two points to define 
the second arc to create a slot.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a cross-section component.

5. Right-click to exit the anchoring mode. 

The slot feature created on a cross-section 
and its nominal primitive are added to the 
Tree View, under the Features branch, and is 
also grouped in a cross-section feature 
group.
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Extracting measured cross-section slot primitives

Objective: Extract the measured primitive of a cross-section slot using its nominal primitive.

Required: The project contains a cross-section slot feature with a nominal primitive, and its 
linked cross-section is measured. For more information about obtaining cross-
section measured components, refer to Measuring the geometry on the part on 
page 390.

Steps  

Results

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the 
cross-section slot feature, under the Features 
branch.
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Creating rectangle features

Rectangle features are typically created with a nominal primitive using different creation 
methods. The measured primitive is subsequently added to the feature using specific 
methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal rectangle primitives

Objective: Create a nominal rectangle primitive interactively using Reference object 
elements or a mathematical definition.

Required: The project contains a Reference object, or the information that describes the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Rectangle.

3. Choose one of the following methods.
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Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick.

3. In the 3D scene, pick a rectangle. Two 
approaches can be used:

• Move the mouse cursor on the CAD model 
surface to select the closest rectangle 
feature and pick the one desired when it is 
highlighted.

• Move the mouse cursor in the void within 
the hole to select the first found rectangle 
based on the current 3D scene view, then 
pick.

Numerically

1. In the Method list, select Numerically.

2. Specify the required values to define the 
feature Center, Axis orientation, Length 
orientation, Length, Width, and Corner 
radius.

To create a rectangle with sharp corners, set the 
Corner radius to zero.

3. Click Create.
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Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. Enable the Rounded corners parameters, if 
required.

3. In the 3D scene, anchor the required number 
of points on a rectangle boundary to create a 
rectangle.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model. 

The rectangle feature and its nominal 
primitive are added to the Tree View, under 
the Features branch.

The nominal primitive is displayed in the 
3D scene.

 

Rectangle with 
sharp corners

Rectangle with 
rounder corners
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Obtaining measured rectangle primitives

To obtain the measured primitive of a rectangle feature, the most common methods used are 
Extract, Probe, and Fit. Each method is explained in the following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured rectangle primitive using the nominal primitive.

Required: The project contains a rectangle feature with a nominal primitive and an aligned 
Data object.

Steps  

Results  

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the 
rectangle feature in the Tree View, under the 
Features branch.

The primitives are displayed in the 3D scene.
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Probe

Objective: Create the measured rectangle primitive by probing it, along with its constraining 
plane if required.

Required: The project contains a nominal rectangle primitive. A probing device is ready to 
use.

Steps  

1. In the Tree View, select the features that will be 
probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Specify a constraining plane:

• Select Use Plane Feature to use an existing 
plane in the Tree View, or to probe a new 
one that will appear in the Tree View. 

• Select Probe Local Plane to probe a new 
plane. Note that this plane is probed near 
the feature. It is stored within the feature 
and does not appear in the Tree View.

6. Click Probe.

7. Probe the constraining plane, if (Probe New) 
or Probe Local Plane is specified.

8. Probe the measured rectangle primitive.
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Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
for each side to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the rectangle. 

The probed measured primitive and the 
constraining plane are added to the Tree 
View, under the Features branch. 

The probed feature components are 
displayed in the 3D scene. 
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Notes  

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create.

 

• Expand the feature type drop-down menu 
and choose Rectangle.

• In the Method list, select Probe.

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model item. 

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.

 

When using Compensation point as the 
compensation method, a plane is compen-
sated by lifting the probe slightly off the 
surface and ending the probing.

When using Compensation point as the 
compensation method, a rectangle is 
compensated by moving the probe inward 
(hole) or outward (rectangular shaped pin) 
from the feature boundary, then ending the 
probing.
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Fit

Objective: Create measured rectangle primitives interactively using data elements.

Required: The project contains a Data object.

Steps

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Rectangle.

3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.

It is recommended to set the Fit type to Min for a 
hole and Max for a rectangular shaped pin.

6. Under Constraints, select Plane, then select a 
constraining plane from the list.

It is recommended to use a constraining plane to 
create the feature so that it is correctly oriented in 
space. The plane should be created prior to the 
fitting.

7. Under Filtering, adjust the filters based on the 
element selection.

It is recommended to remove the Max angle 
filter if no data is selected on the walls of the 
hole.

8. Choose Select > Elements > Interactively. 
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9. In the 3D scene, select the elements that will 
be used to fit the rectangle.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

10. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.

The measured primitive is added to the 
rectangle feature, under the Features branch 
of the Tree View. 

The primitive is displayed in the 3D scene.
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Creating polygon features

Polygon features are typically created with a nominal primitive using different creation 
methods. The measured primitive is subsequently added to the feature using specific 
methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal polygon primitives

Objective: Create a nominal polygon primitive interactively using Reference object elements 
or a mathematical definition.

Required: The project contains a Reference object, or the information that describes the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Polygon.

3. Choose one of the following methods.
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Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick.

3. In the 3D scene, pick a polygon. Two 
approaches can be used:

• Move the mouse cursor on the CAD model 
surface to select the closest polygon feature 
and pick the one desired when it is 
highlighted.

• Move the mouse cursor in the void within 
the hole to select the first found polygon 
based on the current 3D scene view, then 
pick.

Numerically

1. In the Method list, select Numerically.

2. Specify the required values to define the 
feature Center, Axis orientation, Vertex 
direction, Diameter, and Number of sides.

3. Click Create.

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. Specify the Number of sides for the polygon. 

3. In the 3D scene, anchor three points at the 
corners of the hole to create a polygon.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.
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Obtaining measured polygon primitives

To obtain the measured primitive of a polygon feature, the most common methods used are 
Extract, Probe, and Fit. Each method is explained in the following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured polygon primitive using the nominal primitive.

Required: The project contains a polygon feature with a nominal primitive and an aligned 
Data object.

Steps  

The polygon feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The nominal primitive is displayed in the 
3D scene.

 

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.
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Probe

Objective: Create the measured polygon primitive by probing it, along with its constraining 
plane if required.

Required: The project contains a nominal polygon primitive. A probing device is ready to 
use.

Steps  

The measured primitive is added to the 
polygon feature in the Tree View, under the 
Features branch.

The primitives are displayed in the 3D scene.

 

1. In the Tree View, select the feature that will be 
probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.
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3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Specify a constraining plane:

• Select Use Plane Feature to use an existing 
plane in the Tree View, or to probe a new 
one that will appear in the Tree View.

• Select Probe Local Plane to probe a new 
plane. Note that this plane is probed near 
the feature. It is stored within the feature 
and does not appear in the Tree View.

6. Specify the Number of sides for the polygon.

7. Click Probe.

8. Probe the constraining plane, if (Probe New) 
or Probe Local Plane is specified.

9. Probe the required number of sides for the 
measured polygon primitive.

Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
for each side to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the polygon. 
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Results  

Notes  

The probed measured primitive and 
constraining plane are added to the Tree 
View, under the Features branch. 

The primitives are displayed in the 3D scene. 

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive: 

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Polygon.

• In the Method list, select Probe. 

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model option. 

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.
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When using Compensation point as the 
compensation method, a plane is compen-
sated by lifting the probe slightly off the 
surface and ending the probing.

When using Compensation point as the 
compensation method, a polygon is 
compensated by moving the probe inward 
(hole) or outward (polygonal shaped pin) 
from the feature boundary, then ending the 
probing.
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Fit

Objective: Create measured polygon primitives interactively using data elements.

Required: The project contains a Data object.

Steps

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Polygon.

3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.

It is recommended to set the Fit type to Min for a 
hole and Max for a polygonal shaped pin.

6. Under Constraints, select Plane, then select a 
constraining plane, if required.

It is recommended to use a constraining plane to 
create the feature so that it is correctly oriented in 
space. The plane should be created prior to the 
fitting.

7. Under Filtering, adjust the filters based on the 
element selection.

It is recommended to remove the Max angle 
filter if no data is selected on the walls of the 
hole.

    

8. Choose Select > Elements > Interactively. 
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9. In the 3D scene, select the elements that will 
be used to fit the polygon.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

10. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.

The measured primitive is added to the 
polygon feature, under the Features branch 
of the Tree View.

The primitive is displayed in the 3D scene.
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Creating ellipse features

Ellipse features are typically created with a nominal primitive using different creation 
methods. The measured primitive is subsequently added to the feature using specific 
methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal ellipse primitives

Objective: Create a nominal ellipse primitive interactively using Reference object elements 
or a mathematical definition.

Required: The project contains a Reference object, or the information that describes the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Ellipse.

3. Choose one of the following methods.
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Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick.

3. In the 3D scene, pick an ellipse. Two 
approaches can be used:

• Move the mouse cursor on the CAD model 
surface to select the closest ellipse feature 
and pick the one desired when it is 
highlighted.

• Move the mouse cursor in the void within 
the hole to select the first found ellipse 
based on the current 3D scene view, then 
pick.

Numerically

1. In the Method list, select Numerically.

2. Specify the required values to define the 
feature Center, Axis orientation, Major 
orientation, Major diameter, and Minor 
diameter.

3. Click Create.

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. In the 3D scene, anchor five points on a hole 
boundary to create an ellipse.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model. 
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Obtaining measured ellipse primitives

To obtain the measured primitive of an ellipse feature, the most common methods used are 
Extract, Probe, and Fit. Each method is explained in the following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured ellipse primitive using the nominal primitive.

Required: An ellipse feature with a nominal primitive and an aligned Data object.

Steps  

The ellipse feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The nominal primitive is displayed in the 
3D scene.

 

1. In the Tree View, select the feature that will be 
extracted.

2. Choose Measure > Extract Measured.
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Probe

Objective: Create the measured ellipse primitive by probing it, along with its constraining 
plane, if required.

Required: The project contains a nominal ellipse primitive. A probing device is ready to use.

Steps  

The measured primitive is added to the 
ellipse feature in the Tree View, under the 
Features branch.

The primitives are displayed in the 3D scene.

 

1. In the Tree View, select the feature that will be 
probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.
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3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Specify a constraining plane:

• Select Use Plane Feature to use an existing 
plane in the Tree View, or to probe a new 
one that will appear in the Tree View.

• Select Probe Local Plane to probe a new 
plane. Note that this plane is probed near 
the feature. It is stored within the feature 
and does not appear in the Tree View.

6. Click Probe.

7. Probe the constraining plane, if (Probe New) 
or Probe Local Plane is specified.

8. Probe the measured ellipse primitive.

Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the ellipse. 
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Results  

Notes  

The probed measured primitive is added to 
the ellipse feature, under the Features 
branch in the Tree View. 

The primitives are displayed in the 3D scene. 

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Ellipse.

• In the Method list, select Probe. 

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model item. 
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Fit

Objective: Create measured ellipse primitives interactively using data elements.

Required: The project contains a Data object.

Steps

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.

When using Compensation point as the 
compensation method, a plane is compen-
sated by lifting the probe slightly off the 
surface and ending the probing.

When using Compensation point as the 
compensation method, an ellipse is 
compensated by moving the probe inward 
(hole) or outward (pin) from the feature 
boundary, then ending the probing.

1. Choose Measure > Features > Create. 

The Create Features dialog box opens. 

2. Expand the feature type drop-down menu and 
choose Ellipse.
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3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.

It is recommended to set the Fit type to Min for a 
hole and Max for a pin.

6. Under Constraints, select Plane, then select a 
constraining plane, if required.

It is recommended to use a constraining plane to 
create the feature so that it is correctly oriented in 
space. The plane should be created prior to the 
fitting.

7. Under Filtering, adjust the filters based on the 
element selection.

It is recommended to remove the Max angle 
filter if no data is selected on the walls of the 
hole.

8. Choose Select > Elements > Interactively. 

9. In the 3D scene, select the elements that will 
be used to fit the ellipse.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

10. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.
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Results

The measured primitive is added to the 
ellipse feature, under the Features branch of 
the Tree View. 

The primitive is displayed in the 3D scene.
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Creating cylinder features

Cylinder features are typically created with a nominal primitive using different creation 
methods. The measured primitive is subsequently added to the feature using specific 
methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal cylinder primitives

Objective: Create a nominal cylinder primitive interactively using Reference object elements 
or a mathematical definition.

Required: A Reference object or the information that defines the nominal primitive is 
available.

Steps  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Cylinder.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick.

3. In the 3D scene, move the mouse cursor on 
the CAD model surface to select the closest 
cylinder feature and pick the one desired when 
it is highlighted.

4. Right-click to exit the picking mode.
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Results  

Numerically

1. In the Method list, select Numerically.

2. Specify the required parameter values to 
define the feature Origin, Orientation, 
Radius, and Height.

3. Click Create.

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. In the 3D scene, anchor four points on the 
surface to create a cylinder.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

The cylinder feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The nominal primitive is displayed in the 
3D scene.
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Obtaining measured cylinder primitives

To obtain the measured primitive of a cylinder feature, the most common methods used are 
Extract, Probe, Extract from Polygonal Models and Fit. Each method is explained in the 
following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured cylinder primitive using the nominal primitive.

Required: The project contains a feature with a nominal primitive and an aligned Data 
object.

Steps  

Results  

1. In the Tree View, select the feature that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the 
cylinder feature in the Tree View, under the 
Features branch.

The primitives are displayed in the 3D scene.
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Probe

Objective: Create the measured cylinder primitive by probing it.

Required: The project contains a nominal cylinder primitive. A probing device is ready to use.

Steps  

1. In the Tree View, select the feature that will be 
probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Click Probe.

6. Probe the measured cylinder primitive.

Tips

• If a feature contains a nominal primitive, it will 
be highlighted and centered in the 3D scene 
for guidance.

• A minimum number of points must be probed 
to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the cylinder. 
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Results  

Notes  

The probed measured primitive is added to 
the cylinder feature, under the Features 
branch of the Tree View. 

The primitives are displayed in the 3D scene. 

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Cylinder.

• In the Method list, select Probe.

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model option.

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.
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Fit 

Objective: Create measured cylinder primitives interactively using data elements.

Required: The project contains a Data object.

Steps

When using Compensation point as the 
compensation method, a cylinder is 
compensated by moving the probe inward 
(hole) or outward (pin) from the feature 
boundary, then ending the probing.

1. Choose Measure > Features > Create.

The Create Features dialog box opens. 

2. Expand the feature type drop-down menu and 
choose Cylinder.

3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.
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Results

6. Choose Select > Elements > Interactively. 

7. In the 3D scene, select the elements that will 
be used to fit the cylinder.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

8. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.

The measured primitive is added to the 
cylinder feature, under the Features branch of 
the Tree View. 

The primitive is displayed in the 3D scene. 
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Extract from polygonal models

Objective: Create measured cylinder feature components interactively using a polygonal 
model.

Required: A polygonal model is available in the project.

Steps

Results

1. Choose Measure > Features > Extract from 
Polygonal Models. 

2. Specify the feature Type.

The Automatic type is specified by default, 
which automatically determines the feature 
type that adjusts best to the area selected.

3. Specify the Method.

The Single Detection Zone method is selected 
by default. The Multiple Detection Zones 
method is useful when all areas that can be 
used to extract the feature primitive are not 
contiguous.

4. In the 3D scene, using the circular detection 
zone around the mouse pointer, click an area 
on the polygonal model that is part of the 
desired feature.

It is possible to increase or decrease the size of 
the detection radius at any time in the 
Parameters subsection, or by using the mouse 
wheel.

5. Click Confirm. 

The measured cylinder feature primitive is 
added to the Tree View, under the Features 
branch. 

The measured feature primitive is displayed 
in the 3D scene.
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Notes 

The Extract from Polygonal Models method can also be used to create nominal primitives 
when using a polygonal model as the Reference object. 
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Creating cone features

Cone features are typically created with a nominal primitive using different creation methods. 
The measured primitive is subsequently added to the feature using specific methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal cone primitives

Objective: Create a nominal cone primitive interactively using Reference object elements or 
a mathematical definition.

Required: The project contains a Reference object, or the information that defines the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens. 

2. Expand the feature type drop-down menu and 
choose Cone.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick.

3. In the 3D scene, move the mouse cursor on 
the CAD model surface to select the closest 
cone feature and pick the one desired when it 
is highlighted.

4. Right-click to exit the picking mode.
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Results  

Numerically

1. In the Method list, select Numerically.

2. Specify the required values to define the 
feature Apex, Orientation, Slope (degrees), 
Distance from apex, and Height.

3. Click Create.

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. In the 3D scene, anchor four points on the 
surface to create a cone.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

3. Right-click to exit the anchoring mode.

The cone feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The nominal primitive is displayed in the 
3D scene.
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Obtaining measured cone primitives

To obtain the measured primitive of a cone feature, the most common methods used are 
Extract, Probe, Extract from Polygonal Models, and Fit. Each method is explained in the 
following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured cone primitive using the nominal primitive.

Required: The project contains a feature with a nominal primitive and an aligned Data 
object.

Steps  

Results  

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the cone 
feature in the Tree View, under the Features 
branch.

The primitives are displayed in the 3D scene.
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Probe

Objective: Create the measured cone primitive by probing it.

Required: The project contains a nominal cone feature. A probing device is ready to use.

Steps  

1. In the Tree View, select the feature that will be 
probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. In the Submethod list, select Standard.

5. Click Probe.

6. Probe the measured cone primitive.

Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the cone. 
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Results  

Notes  

The probed measured primitive is added to 
the cone feature, under the Features branch 
of the Tree View.

The primitives are displayed in the 3D scene.

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create. 

• Expand the feature type drop-down menu 
and choose Cone.

• In the Method list, select Probe.

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model item.

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.
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Fit 

Objective: Create measured cone primitives interactively using data elements.

Required: The project contains a Data object.

Steps

When using Compensation point as the 
compensation method, a cone is compen-
sated by moving the probe inward (hole) or 
outward (pin) from the feature boundary, 
then ending the probing.

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Cone.

3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.

6. Choose Select > Elements > Interactively. 
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Results

Extract from polygonal model

Objective: Create a measured cone primitive interactively using a polygonal model.

Required: The project contains a polygonal model.

Steps

7. In the 3D scene, select the elements that will 
be used to fit the cone.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

8. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.

The measured primitive is added to the cone 
feature, under the Features branch of the 
Tree View.

The primitive is displayed in the 3D scene.

  

1. Choose Measure > Features > Extract from 
Polygonal Models. 
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Results

Notes 

The Extract from Polygonal Models method can also be used to create nominal primitives 
when using a polygonal model as the Reference object. 

2. Specify the feature Type.

The Automatic method is specified by default, 
which automatically determines the feature 
type that adjusts best to the area selected.

3. Specify the Method.

The Single Detection Zone method is selected 
by default. The Multiple Detection Zones 
method is useful when all areas that can be 
used to extract the feature primitive are not 
contiguous.

4. In the 3D scene, using the circular detection 
zone around the mouse pointer, click an area 
on the polygonal model that is part of the 
desired feature.

It is possible to increase or decrease the size of 
the detection radius at any time in the 
Parameters subsection, or by using the mouse 
wheel.

5. Click Confirm.

The measured primitive is added to the cone 
feature, under the Features branch. 

The measured primitive is displayed in the 
3D scene. 
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Creating sphere features

Sphere features are typically created with a nominal primitive using different creation 
methods. The measured primitive is subsequently added to the feature using specific 
methods.

The creation procedures are explained in the following subsections. For information on the 
creation methods and their key parameters, see The feature creation methodology on page 207.

Creating nominal sphere primitives

Objective: Create a nominal sphere primitive interactively using Reference object elements 
or a mathematical definition.

Required: The project contains a Reference object, or the information that defines the 
nominal primitive is available.

Steps  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Sphere.

3. Choose one of the following methods.

Pick on CAD Model

1. In the Method list, select Pick on CAD Model.

2. The interactive picking mode is automatically 
activated. If not, click Pick.

3. In the 3D scene, move the mouse cursor on 
the CAD model surface to select the closest 
sphere feature and pick the one desired when 
it is highlighted.

4. Right-click to exit the picking mode.
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Results  

Numerically

1. In the Method list, select Numerically.

2. Specify the required values to define the 
feature Center and Radius.

3. Click Create.

Anchor

1. In the Method list, select Anchor.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.

2. In the 3D scene, anchor four points on the 
surface to create a sphere.

Press and hold SHIFT when anchoring to pick the 
closest vertex on a polygonal model.

3. Right-click to exit the anchoring mode.

The sphere feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The nominal primitive is displayed in the 
3D scene.
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Obtaining measured sphere primitives

To obtain the measured primitive of a sphere feature, the most common methods used are 
Extract, Probe, Extract from Polygonal Models, and Fit. Each method is explained in the 
following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured sphere primitive using the nominal primitive.

Required: The project contains a feature with a nominal primitive and an aligned Data 
object.

Steps  

Results  

1. In the Tree View, select the features that will be 
extracted.

2. Choose Measure > Extract Measured.

The measured primitive is added to the 
sphere feature in the Tree View, under the 
Features branch.

The primitives are displayed in the 3D scene.
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Probe

Objective: Create the measured sphere primitive by probing it.

Required: The project contains a nominal sphere primitive. A probing device is ready to use.

Steps  

1. In the Tree View, select the features that will be 
probed.

 

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected features in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. Click Probe.

5. Probe the measured sphere primitive.

Tips

• If a feature contains a nominal primitive, it is 
highlighted and centered in the 3D scene for 
guidance.

• A minimum number of points must be probed 
to fit a valid primitive.

• The probed primitive is compensated 
according to the specified compensation 
method set in the More section.

• Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the sphere. 
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Results  

Notes  

The probed measured primitive is added to 
the sphere feature, under the Features 
branch of the Tree View. 

The primitives are displayed in the 3D scene. 

A nominal primitive offers guidance when probing the measured primitive, but is not 
necessary. To probe a measured primitive without a nominal primitive:

• Choose Measure > Features > Create.

• Expand the feature type drop-down menu 
and choose Sphere.

• In the Method list, select the Probe creation 
method.

If the probing device is already aligned to a 
CAD model, the nominal primitive can be 
extracted at the same time by activating the 
Extract nominal primitive from CAD 
model item. 

When probing, probed points are collected 
at the center of the probe tip. Compen-
sation is necessary to offset the measured 
points to the point of contact.
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Fit 

Objective: Create measured sphere primitives interactively using data elements.

Required: The project contains a Data object.

Steps

When using Compensation point as the 
compensation method, a sphere is compen-
sated by moving the probe inward (concave 
surface) or outward (convex surface) from 
the feature boundary, then ending the 
probing.

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Sphere.

3. In the Method list, select Fit.

4. In the Submethod list, select Fit to Elements.

5. Select the Fit type.

6. Choose Select > Elements > Interactively. 
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Results

7. In the 3D scene, select the elements that will 
be used to fit the sphere.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

8. Click Create to fit a primitive to the selected 
elements.

Tips

To use the Fit method to define the measured primitive of an existing feature, select the 
feature in the Tree View and choose Measure > Features > Define Measured.

The measured primitive is added to the 
sphere feature, under the Features branch of 
the Tree View.

The primitive is displayed in the 3D scene. 
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Extract from Polygonal Models

Objective: Create measured sphere primitives interactively using a polygonal model.

Required: The project contains a polygonal model.

Steps

Results

1. Choose Measure > Features > Extract from 
Polygonal Models.

2. Specify the feature Type.

The Automatic method is specified by default, 
which automatically determines the feature 
type that adjusts best to the area selected.

3. Specify the Method.

The Single Detection Zone method is selected 
by default. The Multiple Detection Zones 
method is useful when all areas that can be 
used to extract the feature primitive are not 
contiguous.

4. In the 3D scene, using the circular detection 
zone around the mouse pointer, click an area 
on the polygonal model that is part of the 
desired feature.

It is possible to increase or decrease the size of 
the detection zone at any time in the Parameters 
subsection, or by using the mouse wheel.

5. Click Confirm.

The measured sphere feature primitive is 
added to the Tree View, under the Features 
branch.

The measured feature primitive is displayed 
in the 3D scene.
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Notes 

The Extract from Polygonal Models method can also be used to create nominal primitives 
when using a polygonal model as the Reference object. 
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Creating surface features

Surface features are created with a nominal component using different creation methods. The 
measured component is subsequently added to the feature using specific methods described 
in the following subsections.

Creating the nominal component of surface features

Objective: Create the nominal component of a surface feature interactively using Reference 
object elements.

Required: The project contains a Reference object in the form of a CAD model.

Steps  

1. Choose Select > Elements > Interactively.

2. In the 3D scene, select the CAD surfaces used 
to create the nominal component of the 
surface feature.

3. Choose Measure > Features > Create.

The Create Features dialog box opens.

4. Expand the feature type drop-down menu and 
choose Surface.

5. In the Method list, choose From Reference 
Elements.

6. Click Create. 
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Results  

Obtaining the measured component of a surface feature

To obtain the measured component of a surface feature, the most common methods used 
are Extract, Probe, and From Data Points. Each method is explained in the following 
subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract

Objective: Extract the measured surface component by detecting it near the nominal 
component.

Required: The project contains a feature with a nominal component and an aligned Data 
object.

Steps  

The surface feature is added to the Tree View, 
under the Features branch.

The feature is displayed in the 3D scene.

 

1. In the Tree View, select the features to extract.

2. Choose Measure > Extract Measured.
338



MEASURING DIMENSIONS AND DEVIATIONS
Results  

Probe – when aligned to a CAD model

Objective: Create the measured surface component by probing data points and 
compensating them.

Required: The project contains nominal surface components. A probing device is ready to 
use and is aligned to a CAD model. 

Steps

The measured component is extracted and a 
measured status icon is added to the surface 
feature icon in the Tree View, under the 
Features branch.

The feature is displayed in the 3D scene.

 

1. In the Tree View, select the surface feature that 
will be probed.

2. Choose Measure > Features > Define Measured.

Alternatively, right-click the selected feature in 
the Tree View and choose Probe Measured.

The Define Measured Feature Components 
dialog box opens.

3. In the Method list, select Probe.

4. Select Compensate when probing ends to 
compensate the probed data points using the 
normal orientation of the surface.

5. Click Probe.

6. Probe the measured surface feature.
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Results 

Probe – without being aligned to a CAD model

Sometimes, large parts need to be measured in a short period of time for reasons as diverse 
as part availability, safety reasons, or temperature variations. The measured component of 
the surface feature can be probed without having a nominal component and without the 
need to be aligned to a CAD model. The data points of the measured surface feature can later 
be compensated using the nominal components of surface features. 

The procedure involves the following steps, which are detailed hereafter:

The measured component is probed and a 
measured status icon is added to the surface 
feature in the Tree View, under the Features 
branch.

The feature is displayed in the 3D scene.

 

1. Probe the surface feature

Probe the surface feature on the 
part. The probed data points are 
stored in a “probed surface” Data 
object. 

2. Import the CAD model

Import the CAD model into the 
inspection project.
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Probe the surface feature
Objective: Measure a surface feature by probing it.

Required: A probing device is ready to be used.

Steps 

3. Align the probed data to the CAD 
model

Align the probed data to the CAD 
model using one of the available 
methods, including the Best-Fit Data 
to Reference Objects alignment or 
the Best-Fit Measurement Objects 
alignment.

4. Define the nominal component 
of the surface feature

Define the nominal component of 
the surface feature. It will be used to 
compensate the probed data points 
and subsequently used to calculate 
the deviations.

5. Compensate the data points

Compensate the probed data points 
to obtain the measured component 
of the surface feature. Once the data 
points are compensated, the 
deviations of the measured 
component to the nominal 
component are obtained.

1. Choose Measure > Features > Create.

The Create Features dialog box opens.
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Results

Define the nominal component of surface features
Once the CAD model is imported and the probed data points are aligned to the CAD model, 
define the nominal component of the surface feature.

When uncompensated probed data points are available and are aligned to the CAD model, 
Reference elements can be found automatically using the measured component of the 
surface feature. An option is available to quickly select Reference elements.

For information on how to import CAD models and proceed with an alignment, see Importing 
a CAD model on page 76 and Introducing alignments on page 130. 

Objective: Define the nominal component of a surface feature.

Required: The measured component is probed (uncompensated data points), and the 
probed points are aligned to the CAD model. 

Steps  

2. Expand the feature type drop-down menu and 
choose Surface.

3. Set the Method to Probe.

4. Click Probe.

5. Probe the surface feature.

The surface feature is created and measured, but not yet compensated. It is added to the Tree 
View, under the Features branch. A warning icon indicates that the probed points are not yet 
compensated.

1. In the Tree View, select the surface feature.
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Results  

Compensate data points
Once the probed data points are aligned to the CAD model, it is possible to compensate them 
to obtain the correct measured values of the surface feature.

Objective: Compensate a measured surface feature.

Required: The nominal component of the surface feature has been defined.

2. Choose Measure > Features > Define Nominal.

The Define Nominal Feature Components 
dialog box opens.

3. In the Method list, select From Reference 
Elements.

4. Click the Preselect reference elements from 
data points button to select Reference 
elements matching the data points of the 
measured components.

If desired, modify the selection of elements 
using the interactive selection mode.

5. Click Create.

The nominal component of the surface 
feature is created.

The feature is displayed in the 3D scene.
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Steps

Results  

Notes

1. Select the surface feature in the Tree View.

2. Right-click and choose Compensate Probed 
Data Points.

The surface feature is now correctly 
measured. A measured status icon confirms 
the measured status of the surface feature.

The probed data points are compensated 
using the normal orientation of the nominal 
component of the surface feature. The 
surface feature annotation shows the 
measured values for controls.

 

• The data alignment context in which a surface 
is compensated is saved to the Measurement 
tab of its property sheet. 

To view the data alignment context, choose 
Edit > Object Properties, then click the 
Measurement tab.
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Probe existing surface comparison points

Surface features also support Probe Surface Comparison Points as a measurement method 
for probing. This method consists in probing surface comparison points linked to the surface 
feature in order to measure the surface feature. In this context, the same guidance 
mechanism offered when probing surface comparison points provides guidance when 
measuring the surface feature.

Objective: Measure a surface feature by probing existing surface comparison points linked 
to the surface feature.

Required: The project contains a Reference object and a surface feature, and the probing 
device must be aligned to the Reference object.

Steps

• It is possible to change the data alignment 
used for compensation. When it is changed, 
select the surface feature in the Tree View, 
right-click, then choose Compensate Probed 
Data Points.

1. In the Tree View, select a surface feature. 

2. Choose Measure > Comparison Points > Create > 
Surface Points.

The Create Surface Comparison Points dialog 
box opens.
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3. In the Method list, select Sample using Grid.

4. Specify the Sampling step.

Here, the value is specific to the part.

5. Specify the Projection axis. 

6. Specify the Radius.

7. In the Link to object list, select Surface 
Feature.

8. Click Create.

The surface comparison points are created on 
the surface feature and added to the Tree View 
in a group named according to the surface 
feature. 

Each surface comparison point is automatically 
linked to the surface feature upon creation.

9. In the Tree View, select the surface feature to 
measure.

10. Right-click and choose Probe Measured 
Comparison Points.

The Probe Measured Comparison Point 
Components dialog box opens.
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Results 

Probe new surface comparison points

Objective: Measure a surface feature by probing new surface comparison points in real time.

Required: The project must contain a Reference object and a surface feature, and the 
probing device must be aligned to the Reference object.

Steps 

11. Click Probe to probe the surface comparison 
points following the guidance.

The surface feature and the surface comparison points are displayed as measured in the Tree 
View and in the 3D scene.

1. In the Tree View, select a surface feature.

2. Right-click and choose Probe New Comparison 
Points.
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Results

The Create Surface Comparison Points dialog 
box opens. The Method is set to Probe and the 
Link to object information is automatically set.

3. Specify the Radius.

4. Click Probe.

5. Probe new surface comparison points on the 
corresponding surface.

The surface feature is automatically highlighted 
in the 3D scene to guide the probing of the 
surface comparison points.

The surface feature is measured. The surface comparison points are created, measured, 
linked to the surface feature and added to the Tree View in a group named according the 
surface feature.
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From data points 

Objective: Create measured surface components interactively using data elements.

Required: The project contains a Data object.

Steps

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Surface.

3. In the Method list, select From Data Points.

4. Choose Select > Elements > Interactively. 

5. In the 3D scene, select the elements that will 
be used to fit the surface.

See Selecting elements on page 63 for 
information on how to select elements 
interactively.

6. Click Create to create the feature using the 
selected elements.

Tips

To define the measured component of an existing feature, select the feature in the Tree View 
and choose Measure > Features > Define Measured.
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Results

The surface feature is added to the Tree View, 
under the Features branch. Surface features 
created from data points have no display in the 
3D scene.
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Creating slab features

Use slab features to obtain measurements on grooves or keyways with parallel sides.

Objective: Create a slab between two parallel planes.

Required: The project contains two parallel plane features having opposite orientations.

Steps  

1. Choose Measure > Features > Create. 

The Create Slab Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Slab.

3. Specify a Name and assign a Datum feature 
label, if needed.

4. Choose a 1st plane and a 2nd plane, between 
which the slab will be created.

If two features are selected prior to accessing 
the creation dialog box, the fields are 
automatically populated.

The nominal planes must be parallel and have 
opposite orientations.

5. Click Create.
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Results  

Notes

The slab feature is dependent on the two source features. If, for any reason, they are 
modified, the slab feature is automatically updated.

If the source features contain only nominal components, the slab feature therefore only 
contains a nominal component. If both source features contain measured components, the 
slab feature therefore contains a measured component.

The slab feature is added to the Tree View, 
under the Features branch.

The slab feature is displayed in the 
3D scene. 
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Creating polyline features

Polyline features are typically created using existing objects or by data acquisition and they 
generally contain a measured primitive. The nominal primitive is rarely used for the 
measurement operations.

Creating nominal polyline primitives

Objective: Create a nominal polyline primitive interactively using a Reference object or a 
Data object.

Required: The project contains a Reference object, a Data object, or a plane feature.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Polyline.

3. In the Method list, select Anchor.

4. Specify whether the Polyline type is Open or 
Closed.

5. If required, select Constraining plane and 
specify a standard plane or an existing plane 
primitive to constrain the anchored points to a 
plane.

The interactive anchoring mode is automati-
cally activated. If not, click Anchor.
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Results  

Left-click to anchor a point, middle-click to delete 
the last anchored point, and right-click to end the 
interactive picking mode.

The polyline feature and its nominal primitive 
are added to the Tree View, under the 
Features branch.

The primitive is displayed in the 3D scene.
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Obtaining measured polyline primitives

To obtain the measured primitive of a polyline feature, the most common methods used are  
Probe, From Data Error Contours, and From Tracking. Each method is explained in the 
following subsections.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Probe

Objective: Create the measured polyline primitive by probing it.

Required: A probing device is ready to use.

Steps  

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Polyline.

3. In the Method list, select Probe.

4. Specify whether the Polyline type is Open or 
Closed.

5. Click Probe to probe the measured polyline 
primitive.

Click the How To Window button of the 
interactive mode guidance toolbar to view the 
different steps required to probe the polyline. 
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Results  

Notes  

From Data Error Contours

Objective: Create the measured polyline primitive from data error contours.

Required: The project contains an active data color map on a polygonal model colored using 
the Enhanced coloring option with a color scale that has 25 colors or less.

Steps

The probed measured primitive is added to the 
Tree View, under the Features branch.

The polyline is displayed in the 3D scene. 

• When probing, probed points are collected 
at the center of the probe tip. It is not 
possible to compensate as the polyline is 
being probed. 

• It is possible to project the polyline onto a 
plane or offset it to apply a compensation 
on 2D polylines.

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Polyline.
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Results  

From Tracking

Objective: Create the measured polyline primitive from tracking.

Required: The project contains a Data object.

Steps

3. In the Method list, select From Data Error 
Contours.

4. Click Create.

The measured polyline primitives are added to 
the Tree View and are automatically grouped, 
under the Features branch.

The polylines are displayed in the 3D scene. 

1. Choose Measure > Features > Create.

The Create Features dialog box opens.

2. Expand the feature type drop-down menu and 
choose Polyline.
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Results  

3. In the Method list, select From Tracking.

4. In the Submethod list, select a submethod.

5. In the 3D scene, pick three points on the Data 
object to define the tracking start point, search 
direction, and search radius. 

The measured polyline primitive is added to 
the Tree View, under the Features branch.

The polyline feature is displayed in the 
3D scene.
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Constructing polyline features

Objective: Construct a polyline feature using existing objects.

Required: The project contains existing objects required by the specified submethod.

Steps  

1. In the Tree View, select the objects required for 
the construction.

2. Choose Measure > Features > Create.

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Polyline.

4. In the Method list, select From Objects.

5. In the Submethod list, select a submethod.

6. Click Create.

Example: The Cross-Sections submethod 
creates a polyline for each segment of the 
selected nominal and measured cross-section.
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Results  

The constructed polyline features are added 
to the Tree View, under the Features branch. 
If the objects used have nominal and 
measured components, the corresponding 
polylines are created separately.

The polyline features are displayed in the 
3D scene.
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Creating pattern features

Patterns are created by grouping together features of the same type. The pattern is necessary 
when a GD&T control is assigned to a group of features, such as it is often the case on a 
Position control for holes.

Objective: Create a pattern of holes.

Required: The project contains at least two features of the same type.

Steps  

1. In the Tree View, select the features that will be 
used.

2. Choose Measure > Features > Create. 

The Create Features dialog box opens.

3. Expand the feature type drop-down menu and 
choose Pattern.

4. Specify a Name and assign a Datum feature 
label, if required.

5. Click Create.
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Results  

The pattern feature is added to the Tree View, 
under the Features branch. The features are 
grouped under the pattern feature.

The pattern feature is displayed in the 
3D scene and the annotation is attached to 
one of its features. 
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Creating distance features

Use distance features to measure the distance between two existing features. 

Objective: Create a distance dimension between two features.

Required: The project contains two valid features.

  

Results  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Select Distance.

3. Choose a Reference feature and a Feature 
between which the distance will be measured.

Click the hand symbol adjacent to the list boxes 
to pick features in the 3D scene. If two features 
are selected prior to accessing the creation dialog 
box, the fields are automatically populated. 
When necessary, the Reference feature is 
considered to be extended to infinity. 

4. Click Create.

The distance feature is added to the Tree 
View, under the Features branch.

The distance feature is displayed in the 
3D scene. 
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Notes

Creating distance features on cross-sections

Distance features can be created on cross-sections for 2D inspection purposes. A cross-
section object must exist and be specified upon creation of these features. 

For more information, see Creating features on cross-sections for 2D inspection on page 216.

Objective: Create a cross-section distance feature.

Required: The project contains a valid cross-section and two valid features.

Steps

• When the pick tool (hand symbol) or the list boxes are used to specify the features to use, 
a third left-click is possible to position the distance annotation in the 3D scene. 

Depending on the position of the pointer with respect to the features used, different 
controls are activated.

Once the third left-click is performed, the distance is automatically created. 

• The controls shown in the 3D scene are the ones activated in the Geometry Controls pane 
for the distance feature that was created.

• The distance feature is dependent on the source features and is automatically updated if 
the source features are modified. 

• If the source features have a nominal component, the resulting distance feature also has a 
nominal component. If all the source features have a measured component, the resulting 
distance feature also has a measured component.

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Select Distance.
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Results

Notes

3. Enable the On cross-section parameter and 
choose from the list of cross-sections. 

4. Choose a Reference feature and a Feature 
between which the distance will be measured.

Click the hand symbol adjacent to the list boxes 
to pick features in the 3D scene. If two features 
are selected prior to accessing the creation dialog 
box, the fields are automatically populated. 
When necessary, the Reference feature is 
considered to be extended to infinity. 

5. Click Create.

The distance feature is added to the Tree 
View, under the Features branch, and is also 
grouped in a cross-section feature group.

The distance feature is displayed in the 
3D scene. 

 

• When the pick tool is used (hand symbol) to specify the features to use, a third left-click is 
required to position the distance annotation in the 3D scene. 

Depending on the position of the pointer with respect to the features used, different 
controls are activated.
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Once the third left-click is performed, the distance is automatically created. 

• The controls shown in the 3D scene are the ones activated in the Geometry Controls pane 
for the distance feature that was created.
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Creating angle features

Use angle features to measure the angle between two existing features.

Objective: Create an angle dimension between two features.

Required: The project contains two features.

Steps  

Results  

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.

2. Select Angle.

3. Choose a Reference feature and a Feature, 
between which the angle will be measured. 

Click the hand symbol adjacent to the list boxes 
to pick features in the 3D scene. If two features 
are selected prior to accessing the creation dialog 
box, the fields are automatically populated. 
When necessary, the Reference feature is 
considered to be extended to infinity. The 
measurement is calculated from the Reference 
feature to the Feature.

4. Click Create.

The angle feature is added to the Tree View, 
under the Features branch.

The angle feature is displayed in the 3D 
scene. 
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Notes 

Creating angle features on cross-sections

Angle features can be created on cross-sections for 2D inspection purposes. A cross-section 
object must exist and be specified upon creation of these features. 

For more information, see Creating features on cross-sections for 2D inspection on page 216.

Objective: Create a cross-section angle feature.

Required: The project contains a valid cross-section and two valid features.

Steps

• When the pick tool (hand symbol) or the list boxes are used to specify which features to 
use, a third left-click is possible to position the angle annotation in the 3D scene. 

Depending on the position of the pointer with respect to the features used, different 
controls are activated.

Once the third left-click is performed, the angle is automatically created. 

• The controls shown in the 3D scene are the ones activated in the Geometry Controls pane 
for the angle feature that was created.

• The angle feature is dependent on the source features and is automatically updated if the 
source features are modified. 

• If the source features have a nominal component, the resulting angle feature also has a 
nominal component. If all the source features have a measured component, the resulting 
angle feature also has a measured component.

1. Choose Measure > Features > Create. 

The Create Features dialog box opens.
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Results

2. Select Angle.

3. Enable the On cross-section parameter and 
choose a cross-section from the list. 

4. Choose a Reference feature and a Feature, 
between which the angle will be measured.

Click the hand symbol adjacent to the list boxes 
to pick features in the 3D scene. If two features 
are selected prior to accessing the creation dialog 
box, the fields are automatically populated. 
When necessary, the Reference feature is 
considered to be extended to infinity. The 
measurement is calculated from the Reference 
feature to the Feature.

5. Click Create.

The angle feature is added to the Tree View, 
under the Features branch, and is also 
grouped in a cross-section feature group.

The angle feature is displayed in the 
3D scene. 
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Notes

• When the pick tool is used (hand symbol) to specify which features to use, a third left-click 
is required to position the angle annotation in the 3D scene. 

Depending on the position of the pointer with respect to the features used, different 
controls are activated.

Once the third left-click is performed, the angle is automatically created. 

• The controls shown in the 3D scene are the ones activated in the Geometry Controls pane 
for the angle feature that was created.
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Editing feature primitives

Once a measured primitive has been extracted or probed, it 
can be reviewed and edited to refine the measured value. For 
example, it is possible to select the measured data points used 
to create the primitive, edit the measured data points to see 
the coordinates and fitting errors of each point, add probed 
data points to an existing primitive or set measured primitive 
boundaries using the nominal primitive. 

Note that other feature editing tools are available on the Measure > Feature Primitives menu. A 
feature can also be edited by adjusting parameters on the Measurement tab of its properties.

Selecting data points of measured primitives

It is useful to highlight the data points used in calculating a 
measured primitive or its local constraining plane. The 
selection shows whether unwanted data points have been 
included. This allows making adjustments and recalculating 
the measured primitive. 

Objective: View the points used to fit the measured feature component.

Required: The project contains a Data object and a measured feature.

Steps

1. Select a feature in the Tree View and choose 
Select > Data Points > Measured Data Points.

2. To view the points used for the local 
constraining plane of a curve-based feature, 
choose Select > Data Points > Measured Data 
Points of Local Planes.
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Results

Editing the measured points of extracted feature primitives

Using the Edit Measured Points interface, the exact fitting statistics of each data point used in 
the extracted measured primitive can be reviewed. If necessary, individual points can be 
removed from the solution to improve the overall result.

Objective: Review measured feature point fitting statistics and remove unwanted data 
points.

Required: The project contains a Data object, and an extracted measured feature 
component.

Steps

The data points used to calculate the 
measured primitive are selected in the 3D 
scene.

If specified, the data points used to calculate 
the local constraining plane of the measured 
primitive are selected in the 3D scene. 

 

1. Select a feature in the Tree View and choose 
Measure > Features > Edit Measured Points.

Circle 1 Circle 1 local constraining plane
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Results

Notes

Each point used in the measured feature 
component fit is listed, with its coordinates and 
deviation. They can be sorted by column value 
by clicking on the column header.

2. Under Fit statistics, a summary of current and 
initial fitting values is displayed.

3. In the Fit parameters section, the fitting 
parameters specified during the feature 
extraction are shown.

4. To remove points from the fitting solution, 
clear them from the list or right-click and 
choose Ignore. The current fit statistics will 
update.

5. Click Apply.

The Fit statistics are updated to display the 
current fitting summary, and the measured 
feature component is updated.

For surface features, statistics report the 
deviation between the measured points and 
the nominal component, as no fitting is 
performed.
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Editing the measured points of probed feature primitives

The Edit Measured Points interface can be used to review the 
exact fitting statistics of each point probed for the measured 
feature component. If necessary, individual points can be 
removed from the solution to improve the overall result. 
Additionally, the interface allows for the review and correction 
of probing compensation and constraints.

Objective: Review probed feature point fitting statistics, remove unwanted points, and 
correct compensation errors.

Required: The project contains a Data object and a probed measured feature component.

Steps

1. Select a feature in the Tree View and choose 
Measure > Features > Edit Measured Points.

Points tab:

2. Each point used in the probed feature 
component fit is listed, with its coordinates and 
deviation. Points can be sorted by column 
value, by clicking on the column header.

3. Under Fit statistics, a summary of current and 
initial fitting values is displayed.

4. In the Fit parameters section, the fitting 
parameters used for probing are shown.

5. To remove points from the fitting solution, 
clear them from the list or right-click and 
choose Ignore. The current fit statistics will be 
updated.

6. Click Apply.
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Results

Notes

Probing parameters tab:

7. The Probe tip diameter can be adjusted if 
incorrect.

8. The Constraining plane parameter, and the 
plane used for curve-based features, can be 
redefined.

9. The Compensation, if incorrectly performed, 
can be reversed.

10.  Click Apply.

The Fit statistics are updated to display the 
current fitting summary. 

The probed feature component is updated.

For surface features, statistics report the 
deviation between the measured points and 
the nominal component, as no fitting is 
performed.
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Adding points to a probed feature

If a probed feature contains too few points for the desired 
inspection, more points can be added and incorporated into 
the probed feature fitting solution. Adding probed points is 
useful in creating a more robust feature fit, or to continue 
defining a very large feature from a later device position.

Objective: Add additional probed points to a measured feature component.

Required: The project contains a Data object, and a probed feature.

Steps

Results  

1. Select the feature in the Tree View and choose 
Measure > Feature Primitives > Add Probed Data 
Points.

2. Specify the required Point acquisition 
parameters.

3. Click Probe.

The probed feature component is updated to 
include the newly-probed points. 
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Setting measured feature boundaries using the nominal component

In some cases, a measured feature component cannot have 
the same extent as the nominal component. For instance, a 
pin is used to define a nominal hole, so the measured 
component is above the nominal hole boundary. It is then 
useful to adjust the measured feature component to fit within 
the nominal component boundaries. This functionality is 
available for surface-based features. 

Objective: Set the measured feature extent to match the nominal feature component extent.

Required: A Data object; a surface feature with a nominal and measured component.

Steps

Results

1. Select a feature in the Tree View and choose 
Measure > Features > Set Measured Boundaries 
using Nominal.

Alternatively, right-click the feature in the Tree 
View and choose Edit > Set Measured Boundaries 
using Nominal.

The measured feature originally had the 
extent of the probed data points.

After processing, it is extended to the 
boundaries of the nominal feature 
component.

  

Nominal

Measured

Nominal

Measured
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Exporting feature primitives

Most nominal and measured primitives can be exported for 
use outside of the PolyWorks Metrology Suite. All features, 
except for angles, distances, surfaces, and slabs, can be 
exported as an IGES file. Points, lines, planes, circles, and 
polylines can also be exported in text format. 

Objective: Export primitives as an IGES file.

Required: The project contains features.

Steps

Results

1. In the Tree View, select the features that will be 
exported and choose File > Export > Features.

2. Click Options.

3. Specify which feature primitives to export, 
either Nominal, Measured, or both.

4. Click OK.

5. Navigate to the desired file-saving location. 

6. Name the file.

7. Click Save.

The selected primitives are saved to an IGES 
file and can be opened in another software 
package. 
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Cross-sections  

Standard cross-sections

Offset cross-sections
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Inspecting 2D part profiles with cross-sections

Cross-sections are measurement tools used for 2D inspection 
of surfaces. They allow calculating deviations along profiles 
obtained from slicing planes.

Introducing cross-sections

Cross-sections are used to inspect a profile of a part along a 
cross-sectional plane using the nominal geometry and the geometry of the part in order to 
produce results determined by geometry controls. The nominal geometry and the part 
geometry are captured by intersecting aligned Reference and Data objects with a slicing plane. 

Cross-sections can be created along an axis, around an axis (radially), along a curve, or using 
several other methods.

Cross-sections are available on the Measure > Cross-Sections menu or on the Cross-
Sections toolbar.

Types of cross-sections

There are two types of cross-sections:

Standard cross-sections
A standard cross-section is created by 
intersecting aligned Reference and 
Data objects with a slicing plane 
delimited by a measurement zone.

Offset cross-sections
An offset cross-section is created by 
intersecting aligned Reference and 
Data objects with parallel slicing 
planes to produce a single multistep 
cross-section. Offset cross-sections 
are useful in controlling 2D dimen-
sions defined between features 
situated on different slicing planes.
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Measurement zone

The measurement zone defines the 3D limits of the slicing 
process, delimiting a slicing plane. As shown to the right, it 
is represented by a blue rectangle with red corners. The 
dimensions of the measurement zone are defined during 
cross-section creation, and can be edited by dragging 
rectangle sides.

Measurement methods

There are two main measurement methods used to obtain the part geometry. Extract obtains 
the part geometry by slicing an aligned Data object, while Probe involves probing the part 
geometry on the part that is within the measurement zone.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698). 

Display options

A number of display options are available to visualize cross-sections with captured nominal 
and part geometry.

They are offered in the Object Display Options.

Under Cross-sections, several display options are 
offered. They are only available when Color map is 
selected.

• Color map

Displays the deviation of the measured 
geometry to the nominal geometry. Note that 
the color map display can be customized. For 
information, see Changing the color map display 
on page 201.

• Tolerance curves

Displays the cross-section with respect to the 
tolerances of the Reference object, allowing a 
pass/fail representation.

Tolerance +

Tolerance -
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• Deviation vectors

Displays the direction and amplitude of the 
deviations.

Increasing the Scaling factor increases the 
length of the deviation vectors for better 
visibility.
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Creating standard cross-sections

A cross-section is a measurement object. It is created to obtain 
the deviation along a cross-sectional plane. The geometry of 
the part can be obtained by extracting it from an aligned Data 
object, or by probing the geometry on the part.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Start inspecting a part along a 2D profile by creating a cross-section to capture the 
nominal component.

Required: The project contains a Reference object. If the project also contains a Data object, 
the Data object must be aligned to the Reference object.

Steps

1. Choose Measure > Cross-Sections > Create > 
Standard Cross-Sections.

The Create Cross-Sections dialog box opens.

2. Choose a creation Method.

The creation of cross-sections using the most 
frequently used methods follows.

All of the possible creation methods are shown 
to the right.
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Along Standard Axis

This method allows creating a cross-section perpendicular to a standard system axis, such as 
the X axis. It is recommended to have a properly oriented coordinate system to obtain the 
anticipated results.

1. In the Method list, select Along Standard 
Axis.

2. Under Axis, select X, Y, or Z.

The cross-section will be positioned along and 
perpendicular to the axis.

3. Under Mode, select Individual to create a 
single cross-section.

The Multiple mode allows creating evenly 
spaced cross-sections at a specified step either 
within a range or by slicing whole objects.

4. Under Position, specify a position along the 
axis using one of these methods:

• Numerically, by typing a value.

• Manually, by clicking Anchor Point, then 
picking a location on an object in the 3D 
scene.

5. Click Preview.

A preview of the measurement zone of the 
cross-section is displayed in the 3D scene.

The preview is displayed automatically when 
anchoring a point. 

Right-click to exit the anchoring mode.

6. To resize the measurement zone to include 
only the area of interest, drag the blue 
borders.

7. Click Create.
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Along Curve

This method allows creating a cross-section perpendicular to a curve. It involves specifying the 
type of curve to use, and then specifying the location of the cross-section along the curve.

1. In the Method list, select Along Curve.

2. Under Curve, select From reference object 
curves.

The cross-section will be positioned along and 
perpendicular to a curve on the Reference 
object.

From polyline allows cross-sections to be 
located either along an existing polyline feature, 
or by interactively anchoring a polyline.

3. Under Mode, select Individual to create a 
single cross-section.

The Multiple mode allows creating evenly 
spaced cross-sections at a specified step either 
within a range or by slicing whole objects.

4. Under Position, click Anchor Point.

An interactive anchoring mode is launched.

5. Anchor a point along the curve by picking a 
point on the Reference object in the 3D 
scene. Right-click to exit the anchoring mode.

If At intersection with plane is selected, only 
the location of the intersection of the curve and 
the chosen standard plane can be picked.

A measurement zone is displayed.

6. To resize the measurement zone to include 
only the area of interest, drag the blue 
borders.

7. Click Create.
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Tips 

Cross-sections can be created along a whole curve or just using a portion of the curve. When 
the Mode is set to Multiple, two anchoring modes become available:

• Whole curve: Cross-sections are created along the entire length of the curve.

• Partial curve: Cross-sections are created between the specified start and end point on the 
curve. Click a first point on the curve to indicate the start point and click a second point to 
indicate the end point.
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Radial

This method allows creating a cross-section that radiates from an axial primitive, such as a 
cylinder or cone.

1. In the Method list, select Radial.

2. Under Rotation axis, select in the Axial 
primitive list a feature with an axis, such as a 
cone or a cylinder.

The cross-section will be positioned radially, 
originating from the selected axis.

3. Set the mode to Individual to create a single 
cross-section.

The Multiple mode allows creating evenly 
spaced cross-sections at a specified angular 
step either within a range or by slicing whole 
objects.

4. Under Position, specify a position using one 
of these methods:

• Numerically, by typing a value.

• Manually, by clicking Anchor Point, then 
picking a location on an object in the 3D 
scene.

5. Click Preview.

A preview of the measurement zone of the 
cross-section is displayed in the 3D scene.

The preview is displayed automatically when 
anchoring a point. 

Right-click to exit the anchoring mode.

6. To resize the measurement zone to include 
only the area of interest, drag the blue 
borders.

7. Click Create.
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Results

Notes

• If a Data object is available and aligned when the cross-section 
is created, then the measured component is extracted.

Anchor

This method allows creating a cross-section by anchoring a line in the 3D scene.

1. In the Method list, select Anchor.

2. Under Mode, select Individual to create a 
single cross-section.

The Multiple mode allows creating evenly 
spaced cross-sections at a specified step either 
within a range or by slicing whole objects.

3. Under Position, click Anchor Line and click 
two locations in the 3D scene. Right-click to 
exit the anchoring mode.

A measurement zone is displayed in the 3D 
scene.

4. To resize the measurement zone to include 
only the area of interest, drag the blue 
borders.

5. Click Confirm.

The new cross-section, with a nominal 
component, is added to the Tree View under 
the Cross-Sections branch.

The cross-section is displayed in the 3D scene 
along with a color scale showing the 
deviations (requires both the nominal and 
the measured component to obtain results).
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• The measurement zone of a cross-section can be edited post creation by following these 
steps: 

1. Select the cross-section in the Tree View.

2.  Choose Measure > Cross-Sections > Edit 
Measurement Zones.

3. The measurement zone is displayed in the 
3D scene and can be edited by dragging the 
borders. 

4. Press ESC to exit the editing mode.
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Measuring the geometry on the part

For an existing cross-section, the corresponding geometry on the part can be obtained by 
extraction on an aligned Data object or by probing a physical part. If proceeding by probing, 
the digitizing device must be aligned to the Reference object. In PolyWorks|Inspector, the 
geometry obtained on the part is called the measured component of the measurement object.

Extract the geometry

When there is a Data object available in the project at cross-section creation, the measured 
component is extracted automatically. Otherwise, when the Data object becomes available 
and is aligned, a manual extraction operation must be performed using the cross-section.

Objective: Finish inspecting the profile for an existing cross-section by extracting the 
corresponding profile geometry on the part to obtain the measured component 
of the cross-section.

Required: The project contains a Reference object, an aligned Data object, and a cross-
section with a nominal component.

Steps

Results

1. Select a cross-section in the Tree View.

2. Choose Measure > Extract Measured.

The measured component is added to the 
cross-section. The measured status icon 
indicates its measured status.

Deviations are calculated using the nominal 
and the measured components and are 
displayed in the 3D scene using a color scale.

 

 

390



MEASURING DIMENSIONS AND DEVIATIONS
Notes

The extraction parameters of a cross-section are saved to the Measurement tab of its 
property sheet. They can be edited post creation by selecting the cross-section in the Tree 
View, choosing Edit >Object Properties, opening the tab, and making other specifications.

Probe the geometry

The geometry for a profile on the part can be obtained by probing the measured component 
of a cross-section. The probed points are projected onto the plane defined by the 
measurement zone of the cross-section. Subsequently, the projected points are joined by a 
polyline to define the measured component of the cross-section.

Objective: Finish inspecting the profile for an existing cross-section by probing the 
corresponding part geometry to obtain the measured component of the cross-
section.

Required: The project contains a Reference object and a cross-section with a nominal 
component. The probing device is aligned to the Reference object.

Steps

1. In the Tree View, select the cross-section.

2. Choose Measure > Cross-Sections > Probe 
Measured.
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Results

The Probe Measured Cross-Section 
Component dialog box opens.

3. Under Sectioning plane, click Use and 
choose a cross-section from the list.

By default, the probe Compensation is 
calculated using the closest Reference object.

4. Under Probing method, select Projection.

All points acquired within the specified 
projection Distance of the plane are used to 
create the measured cross-section component.

The Max point-to-point distance determines 
how close the probed points must be spaced to 
be used to generate the measured cross-section.

5. Click Probe.

Use the visual and audio guidance to move the 
probe to the cross-section location. Once within 
the cross-section projection distance, probing is 
allowed.

Tip

Use the Continuous Time or Continuous 
Distance probing mode to facilitate the probing.

The measured component is added to the 
cross-section. The measured status icon 
indicates its measured status.

The cross-section is displayed in the 3D scene 
along with a color scale showing the 
deviations.
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Notes

• Probing can also be done without an existing cross-section by using the Probe 2 points 
method to define the location of the sectioning plane.

• The Zig-zag probing method is another way to probe the geometry of the part. 

Each probed point must be captured on alternating sides of the sectioning plane. The 
plane changes color from blue to orange to indicate which side of the plane the probe is 
currently on. The intersection of the sectioning plane with the line connecting the currently 
probed point and the last probed point determines the acquired point.

• Additional probed points can be added to the probed measured 
component of a cross-section to better capture the part 
geometry. Select the cross-section in the Tree View and choose 
Measure > Cross-Sections > Add Probed Data Points.
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Creating offset cross-sections

Occasionally, a profile must be inspected along offset parallel 
segments along the part. An offset cross-section is a 
measurement object that is useful for measuring deviations 
from the nominal contour located on different parallel slicing 
planes. The contour of the part can be obtained by extracting 
it from an aligned Data object.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Start inspecting the form of a part along discontinuous cutting planes by creating 
an offset cross-section, thereby obtaining its nominal component.

Required: The project contains a Reference object. In the example presented below, two 
circle primitives are in the project to position each segment of the offset cross-
section.

If the project contains a Data object, it should be aligned to the Reference object.

Steps

1. Choose Measure > Cross-Sections > Create > 
Offset Cross-Sections.

The Create Offset Cross-Sections dialog box 
opens.

2. Choose a creation Method.

The creation of cross-sections using the most 
frequently used methods follows.

All of the possible creation methods are shown to 
the right.
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Along Standard Axis

This method allows creating an offset cross-section as discontinuous cross-section segments 
perpendicular to a standard system axis, such as the X axis. It is recommended to have a 
properly oriented coordinate system to obtain the anticipated results.

1. In the Method list, select Along Standard Axis.

2. Under Axis, select X, Y, or Z.

The cross-section segments will be positioned 
along and perpendicular to the axis.

3. Under Position, click Pick Primitives.

An interactive picking mode is launched.

Two circle primitives are already in the project. 

4. In the 3D scene, click the primitive by which the 
first segment of the cross-section will pass.

The cross-section offset passes by the center of 
the picked primitive.

5. In the 3D scene, click the second primitive by 
which the second segment passes.

The new cross-section segment is parallel to the 
other segments and does not overlap another 
segment.

Repeat as many times as necessary.

6. Right-click to exit the mode.

7. To resize the measurement zone to include 
only the area of interest, drag the blue borders 
of the desired measurement zone.

The other measurement zones resize themselves 
to avoid any overlap of segments.

8. If other segments are needed, click Add Step.

The measurement zone of the preceding segment 
is displayed.

9. Click Confirm to create the offset cross-section.
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Anchor

This method allows creating an offset cross-section by anchoring discontinuous cross-section 
segments in the 3D scene.

1. In the Method list, select Anchor.

2. Under Position, click Anchor Lines.

An interactive anchoring mode is launched.

3. In the 3D scene, click a start and end point for 
the first segment of the cross-section.

4. Click again to define the end point for the 
second segment of the cross-section.

The new cross-section segment is parallel to the 
other segments and does not overlap another 
segment.

The measurement zone of the preceding segment 
is displayed.

Repeat as many times as necessary.

5. Right-click to finish.

6. To resize the measurement zone to include 
only the area of interest, drag the blue borders 
of the desired measurement zone.

The measurement zones of other segments resize 
themselves as consecutive segments never 
overlap.

7. Click Confirm.
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Results

Notes

The new offset cross-section, with a nominal 
component, is added to the Tree View under 
the Cross-Sections branch.

The offset cross-section is displayed in the 
3D scene.

To adjust the measurement zones of an offset cross-section post creation:

1. Select the cross-section in the Tree View.

2.  Choose Measure > Cross-Sections > Edit 
Measurement Zones.

3. The cross-section extent of each segment is 
displayed in the 3D scene and can be edited by 
dragging the borders. 

The size of the measurement zone of neighboring 
segments is automatically adjusted to avoid 
segment overlap.

4. Press ESC to exit the editing mode.
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Extracting the geometry on the part

When there is a Data object available in the project at cross-section creation, the measured 
component is extracted automatically. Otherwise, when the Data object becomes available 
and is aligned, a manual extraction operation must be performed using the offset cross-
section.

Objective: Finish inspecting the profile for an existing offset cross-section by extracting the 
corresponding profile geometry on the part to obtain the measured component 
of the cross-section.

Required: The project contains a Reference object, an aligned Data object, and an offset 
cross-section with a nominal component.

Steps

Results

Notes

The extraction parameters of a cross-section are saved to the Measurement tab of its 
property sheet. They can be edited post creation by selecting the cross-section in the Tree 
View, choosing Edit > Object Properties, opening the tab, and making other specifications.

1. Select an offset cross-section in the Tree View.

2. Choose Measure > Extract Measured.

The measured component is added to the 
offset cross-section. The measured status 
icon indicates its measured status.

The offset cross-section is displayed in the 
3D scene along with a color scale showing 
nominal-to-measured deviations.
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Surface comparison points

Trimmed edge comparison points

Hemmed edge comparison points
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Measuring specific locations on a part using 
comparison points

A comparison point contains an exact coordinate, usually located on a CAD object, at which 
the data deviation is to be measured. These coordinates can be entered numerically, or 
generated by anchoring, sampling the CAD object, imported from a text file, or created by way 
of several other methods. Comparison points can be positioned on a part surface or curve, or 
along cross-sections. Surface comparison points are the most common.

Introducing comparison points

There are five types of comparison points, each one tailored to calculate deviations in a 
specific context. The following sections explain the types of comparison points that are most 
frequently used.

Comparison points are available on the Measure > Comparison Points menu or on the 
Comparison Points toolbar.

Types of comparison points

Each type of comparison point is identified by a specific icon.

Surface comparison points

Trimmed edge comparison 
points

Hemmed edge comparison 
points
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Comparison point creation and measurement methods

A comparison point is a measurement object that contains nominal and measured 
information in order to obtain results.

• The nominal component contains the exact coordinate at which the deviation is measured. 
It is created using different creation methods. The sections that follow explain the most 
frequently used methods.

• The measured component is created by measuring the part, either by extracting the 
measured value using predefined parameters, or by probing. By default, the measured 
component of a comparison point is extracted from available Data objects. If not 
automatically extracted, comparison points can be measured later. The Extract and Probe 
measurement methods are presented in the sections that follow.

Understanding key parameters

Radius
Each comparison point has a measurement zone, cylindrical by default, within which 
measurements will be collected. The measurement zone has a radius, which is the radius of 
the cylinder, and a maximum distance, which is the height of the cylinder.    

Note that the measurement zone is different for trimmed edge comparison points. In this 
case, the radius of the measurement zone is the height of the cylinder, while the maximum 
distance is the radius of the cylinder.

Cross-section comparison 
points

The radius is specified during comparison 
point creation, and can be edited in the 
properties for that object. The Max 
distance, 4 mm by default, can also be 
edited in the object properties, along with 
other filtering criteria and tolerances.

Radius

Max 
Distance
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Display options

A number of display options are available to modify the way comparison points are 
represented.

They are offered in the Object Display Options.

Under Comparison points, several display options 
are offered. 

• Select Color map, then Color measured data 
points to display the deviation values of every 
data point used to calculate the measured 
comparison point. Note that the color map 
display can be customized. For information, see 
Changing the color map display on page 201.

• By default, Disc or line is selected to allow 
specifying the size of the displayed reference 
disc or line. If cleared, only the center 
coordinate is displayed.

• Select Deviation vector to view the direction of 
deviation. Increasing the Scaling factor 
increases the length of the deviation vector for 
better visibility.

In the PolyWorks|Inspector Options dialog box 
(choose Tools > Options, click Display, then 
Comparison Points):

Disc

Line
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• Select Measurement zone to display in 3D the 
measurement zone.
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Creating surface comparison points to inspect the surface 
of a part

A surface comparison point is a measurement object. It is created 
to obtain the deviation on a surface, at specific coordinates. The 
geometry of the surface can be obtained by extracting it from an 
aligned Data object, or by probing the measured component of 
the surface comparison point.

If creating by probing, the nominal component is automatically 
extracted on the closest Reference object. The digitizing device 
must be aligned to the Reference object.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Create surface comparison points to capture the nominal component.

Required: The project contains a Reference object. If the project also contains a Data object, 
the Data object must be aligned to the Reference object.

Steps

1. Choose Measure > Comparison Points > Create > 
Surface Points.

The Create Surface Comparison Points dialog 
box opens.

2. Choose a Method among the following.

The creation of surface comparison points using 
the most common methods follows.

All creation methods are shown to the right.
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Anchor

This method allows creating surface comparison points by anchoring on surfaces.

1. In the Method list, select Anchor.

2. Enter the Radius of the measurement zone for 
each comparison point. See Understanding key 
parameters on page 401.

3. If required, select Link to object to bind 
surface comparison points to a Reference 
object or a surface feature. Then, specify 
whether the comparison points are linked to 
the closest object/feature or to a specific one.

4. Click Anchor.

5. In the 3D scene, click a location on the model to 
place the comparison point.

6. Right-click to exit the anchor mode.

Numerically

This method allows creating surface comparison points by entering values for certain 
geometrical properties.

1. In the Method list, select Numerically.

2. Under Point, enter the coordinates of the point 
to create.

If one coordinate is missing, select the Project 
option to get the missing coordinate. The 
coordinate is calculated by projecting the point 
onto the Reference surface along the axis corre-
sponding to the missing coordinate.

3. Specify the Surface normal information of the 
point.

By default, Automatic is selected. It extracts 
the normal information from the closest point 
on the surface of the reference object. To 
specify values manually, the option must be 
disabled.

4. Enter the Radius of the measurement zone for 
each comparison point. See Understanding key 
parameters on page 401.

5. If required, select Link to object to bind 
surface comparison points to a Reference 
object or a surface feature. Then, specify 
whether the comparison points are linked to 
the closest object/feature or to a specific one.

6. Click Create.
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Sample using Grid

This method allows creating uniformly spaced surface comparison points by sampling a virtual 
grid that covers the selected or visible surfaces of Reference objects.

1. In the Method list, select Sample using Grid.

2. Specify the Sampling step that determines the 
comparison point spacing.

3. Specify the Projection axis, which means the 
direction in which the comparison points will be 
projected on the model.

4. Enter the Radius of the measurement zone for 
each comparison point. See Understanding key 
parameters on page 401.

5. Under Link to object, specify whether surface 
comparison points will be bound to a Reference 
object or a surface feature. Then, specify 
whether the comparison points are linked to 
the closest object/feature or to a specific one.

6. Under Considered reference surfaces, select 
whether the grid is to be sampled on all of the 
visible surfaces of the Reference object or on 
the selected surfaces only.

7. Click Preview. 

A preview of the comparison point layout is 
presented in the 3D scene.

8. Click Confirm.

From Text File

This method allows creating surface comparison points from values contained in text files. If 
the new comparison points are not located on a Reference object, they can be projected onto 
the nearest linked Reference object.

1. In the Method list, select From Text File.

2. Enter the Radius of the measurement zone for 
each comparison point. See Understanding key 
parameters on page 401.

3. If required, select Link to object to bind 
surface comparison points to a Reference 
object or a surface feature. Then, specify 
whether the comparison points are linked to 
the closest object/feature or to a specific one.

4. Click Browse.
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Results

5. Navigate to a text file containing the x, y, z 
coordinates of the desired measurement 
locations.

The Import Parameters dialog box opens.

6. In the file browser, select a Template that 
corresponds to the file structure. A preview of 
the file is presented giving feedback if the 
chosen template is incorrect.

7. Click OK.

The new comparison points, with a nominal 
component, are added to the Tree View 
under the Comparison Points branch.

The comparison points are displayed in the 
3D scene.
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Measuring the geometry on the part

For an existing surface comparison point, the corresponding geometry on the part can be 
obtained by extraction on an aligned Data object or by probing a physical part. If proceeding 
by probing, the digitizing device should be aligned to the Reference object. In 
PolyWorks|Inspector, the geometry obtained on the part is called the measured component of 
the measurement object.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract the geometry

When creating a surface comparison point and a Data object is available in the project, the 
measured component is extracted automatically. Otherwise, when the Data object becomes 
available and is aligned, a manual extraction operation must be performed using the surface 
comparison point.

Objective: Extract the corresponding geometry on the part to obtain the measured 
component of the comparison point.

Required: The project contains a Reference object, an aligned Data object, and a surface 
comparison point with a nominal component.

Steps

1. Select the surface comparison point in the 
Tree View.

2. Choose Measure > Extract Measured.
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Results

Probe the geometry

The geometry of the surface on the part can be obtained by probing the measured 
component of a surface comparison point. 

Objective: Probe the corresponding geometry on the part to obtain the measured 
component of the comparison point.

Required: The project contains a Reference object and a surface comparison point with a 
nominal component. A probing device is available and ready to use. The probing 
device is aligned to the Reference object.

Steps

A measured status icon indicates the 
measured status of the surface comparison 
points.

The surface comparison points are displayed 
in the 3D scene with a solid measurement 
zone. The color of the comparison points 
corresponds to the defined color scale. 

1. Select the surface comparison points to 
probe in the Tree View.

2. Choose Measure > Comparison Points > Define 
Measured.

The Define Measured Comparison Point 
Components dialog box opens.
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Results

3. Specify the probing mode: 

• Specific: Allows probing the selected 
comparison points following the Tree View 
order.

• Auto-detect: Allows probing the 
comparison point closest to the probing 
device. Only the selected comparison 
points will be detected.

4. Click Probe. 

Tips

When probing comparison points, visual and audio feedback are provided. If the probe is out 
of the measurement zone, the display color of the comparison point disc is red and the 
farther the probe is from the comparison point the slower the sound is. Moving towards the 
comparison point will accelerate the sound. Once the measurement zone is reached, the 
display color of the comparison point disc will change to green and the sound will change to a 
higher pitch which eventually stops indicating the location of the probing device is good 
enough to acquire data.

A probing session Data object is added to the 
Tree View and a measured status icon 
indicates the measured status of the surface 
comparison points.

The surface comparison points are displayed 
in the 3D scene with a solid measurement 
zone. The color of the comparison points 
corresponds to the defined color scale.
410



MEASURING DIMENSIONS AND DEVIATIONS
Creating trimmed edge comparison points to inspect 
sharp edges of a part

A trimmed edge comparison point is a 
measurement object. It is created to obtain the 
deviation on an edge, at specific coordinates. 
The geometry of the part can be obtained by 
extracting it from an aligned Data object, or by 
probing the measured component of the 
trimmed edge comparison point.

If creating by probing, the nominal component is automatically extracted on the closest 
Reference object. The digitizing device must be aligned to the Reference object.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Create trimmed edge comparison points to capture the nominal component.

Required: The project contains a Reference object. If the project also contains a Data object, 
the Data object must be aligned to the Reference object.

Steps  

1. Choose Measure > Comparison Points > Create > 
Trimmed Edge Points. 

The Create Trimmed Edge Comparison Points 
dialog box opens.

2. Choose a Method among the following.

The creation of trimmed edge comparison points 
using the most common methods follows.

All creation methods are shown to the right.
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Anchor

This method allows creating trimmed edge comparison points by anchoring on a Reference 
object curve.

1. In the Method list, select Anchor.

2. Specify the Radius of the measurement zone 
for each comparison point. See Understanding 
key parameters on page 401.

3. Click Anchor.

4. In the 3D scene, click an edge curve to anchor 
the trimmed edge comparison points. 

5. Right-click to exit the anchor mode.
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Sample Reference Curve

This method allows creating uniformly spaced trimmed edge comparison points by sampling 
curves of Reference objects using a step.

1. In the Method list, select Sample Reference 
Curve. 

2. Specify the Sampling step. This parameter sets 
the distance between comparison points along 
the reference curve.

3. Specify the Radius of the measurement zone 
for each comparison point. See Understanding 
key parameters on page 401.

4. Select the Range:

• Whole Curve: This option, selected by 
default, enables creating comparison points 
along the whole curve.

• Partial Curve: This option enables creating 
comparison points along a portion of the 
curve.

5. In the 3D scene, click the reference curve to 
select it. A preview is displayed to show where 
the comparison points will be located.

If the Partial Curve range option is selected, 
two clicks are required: the start and the end 
point of the range. 

6. Click Confirm.
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Results

Notes

The new comparison points, with a nominal 
component, are added to the Tree View 
under the Comparison Points branch.

The comparison points are displayed in the 
3D scene. 

 

By default, when creating trimmed edge 
comparison points, a back point is created. 
The back point is a surface comparison point 
offset from the part edge.

The back point locates the actual part surface 
before measuring the edge, ensuring that 
deformation of the actual part shape does 
not prevent edge inspection. 

If back points are not desired, the option can 
be disabled under the More section of the 
creation dialog box. 

Reference object

Measurement 
zoneActual

part
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Measuring the geometry on the part

For an existing trimmed edge comparison point, the corresponding geometry on the part can 
be obtained by extraction on an aligned Data object or by probing a physical part. If 
proceeding by probing, the digitizing device should be aligned to the Reference object. In 
PolyWorks|Inspector, the geometry obtained on the part is called the measured component of 
the measurement object.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract the geometry

When there is a Data object available in the project at trimmed edge comparison point 
creation, the measured component is extracted automatically. Otherwise, when the Data 
object becomes available and is aligned, a manual extraction operation must be performed 
using the trimmed edge comparison point.

Note that when a trimmed edge comparison point is extracted, the corresponding back point 
is also automatically extracted.

Objective: Extract the corresponding geometry on the part to obtain the measured 
component of the comparison point. 

Required: The project contains a Reference object, an aligned Data object, and a trimmed 
edge comparison point with a nominal component. 

Steps

1. Select the trimmed edge comparison point in 
the Tree View. 

2. Choose Measure > Extract Measured.

Tips

If a trimmed edge comparison point cannot be extracted, make sure that there is enough data 
to perform the extraction. Also, modifying the extraction parameters could make a difference. 
In the Tree View, select the trimmed edge comparison point, choose Edit > Object Properties, 
then click the Measurement tab to access the extraction parameters.
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Results

Probe the geometry

The geometry of the sharp edge on the part can be obtained by probing the measured 
component of a trimmed edge comparison point.

Objective: Probe the corresponding geometry on the part to obtain the measured 
component of the comparison point.

Required: The project contains a Reference object as well as a trimmed edge comparison 
point with a nominal component and its back point. The probing device is aligned 
to the Reference object.

A measured status icon indicates the 
measured status of the trimmed edge 
comparison points and their corresponding 
back points.

The trimmed edge comparison points and 
their back points are displayed in the 3D 
scene with a solid measurement zone. The 
color of the comparison points corresponds 
to the defined color scale.
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Steps

1. Select the trimmed edge comparison points 
to probe in the Tree View.

2. Choose Measure > Comparison Points > Define 
Measured.

Alternatively, right-click the selected 
comparison points in the Tree View and 
choose Probe Measured.

The Defined Measured Comparison Point 
Components dialog box opens.

3. Specify the probing mode: 

• Specific: Allows probing the selected 
comparison points following the Tree View 
order.

• Auto-detect: Allows probing the 
comparison point closest to the probing 
device. Only the selected comparison 
points will be detected.

Regardless of the probing mode, you will always 
be prompted to probe the back point first and 
then the trimmed edge comparison point. 

4. In the Method list, select Probe.
417



MEASURING DIMENSIONS AND DEVIATIONS
5. Click Probe.

Two points must be probed: first probe the 
back point, then the corresponding trimmed 
edge comparison point.

Tips

When probing comparison points, visual and audio feedback are provided. If the probe is out 
of the measurement zone, the display color of the comparison point disc is red and the 
farther the probe is from the comparison point, the slower the sound is. Moving towards the 
comparison point will accelerate the sound. Once the measurement zone is reached, the 
display color of the comparison point disc will change to green and the sound will change to a 
higher pitch which eventually stops, indicating the location of the probing device is good 
enough to acquire data.
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Results 

A probing session Data object is added to the 
Tree View and a measured status icon 
indicates the measured status of the 
trimmed edge comparison points and their 
corresponding back points. 

The trimmed edge comparison points and 
their backpoints are displayed in the 3D 
scene with a solid measurement zone. The 
color of the comparison points corresponds 
to the defined color scale. 
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Creating hemmed edge comparison points to inspect the 
hemmed edges of a sheet metal part

A hemmed edge is typically found in sheet metal parts as 
the result of a hemming process which consists in folding 
an edge until it is flush to itself. A hemmed edge 
comparison point is a measurement object. It is created to 
obtain the deviation on a hemmed edge, at specific 
coordinates. The geometry of the part can be obtained by 
extracting it from an aligned Data object, or by probing the 
measured component of the hemmed edge comparison 
point. 

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Create hemmed edge comparison points to capture the nominal component.

Required: The project contains a Reference object. If the project also contains a Data object, 
the Data object must be aligned to the Reference object.

Steps  

1. Choose Measure > Comparison Points > Create > 
Hemmed Edge Points.

The Create Hemmed Edge Comparison Points 
dialog box opens.

2. Choose a Method among the following.

The creation of hemmed edge comparison points 
using the most common methods follows.

All creation methods are shown to the right.
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Anchor

This method allows creating hemmed edge comparison points by anchoring on a Reference 
object curve.

1. In the Method list, select Anchor.

2. Specify the Radius of the measurement zone 
for each comparison point. See Understanding 
key parameters on page 401.

3. Specify how the Hemmed edge radius is 
measured, either by extracting the radius from 
the Reference object, or by manually entering it 
in the Custom field.

4. Click Anchor.

5. In the 3D scene, click the tangency curves of the 
hemmed edge to anchor the hemmed edge 
comparison points.

6. Right-click to exit the anchor mode.
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Sample Reference Curve

This method allows creating uniformly spaced hemmed edge comparison points by sampling 
curves of Reference objects using a step.

1. In the Method list, select Sample Reference 
Curve.

2. Specify the Sampling step. This parameter sets 
the distance between comparison points along 
the reference curve. 

3. Specify the Radius of the measurement zone 
for each comparison point. See Understanding 
key parameters on page 401.

4. Specify how the Hemmed edge radius is 
measured, either by extracting the radius from 
the Reference object, or by manually entering it 
in the Custom field.

5. Select the Range:

• Whole Curve: this option, selected by 
default, enables creating comparison points 
along the whole curve.

• Partial Curve: this option enables creating 
comparison points along a portion of the 
curve.

6. In the 3D scene, click the reference curve to 
select it. A preview is displayed to show where 
the comparison points will be located.

If the Partial Curve range option is selected, 
two clicks are required: the start and the end 
point of the range. 

7. Click Confirm.
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Results

Notes

The new comparison points, with a nominal 
component, are added to the Tree View 
under the Comparison Points branch.

The comparison points are displayed in the 
3D scene.

 

By default, when creating hemmed edge 
comparison points, a back point is created. The 
back point is a surface comparison point offset 
from the part edge.

The back point locates the actual part surface 
before extracting the edge measurement, ensuring 
that deformation of the actual part shape does not 
prevent edge inspection.

If back points are not desired, the option can be 
disabled under the More section of the creation 
dialog box.
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Measuring the geometry on the part

For an existing hemmed edge comparison point, the corresponding geometry on the part can 
be obtained by extraction on an aligned Data object or by probing a physical part. If 
proceeding by probing, the digitizing device should be aligned to the Reference object. In 
PolyWorks|Inspector, the geometry obtained on the part is called the measured component of 
the measurement object.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract the geometry

When there is a Data object available in the project at hemmed edge comparison point 
creation, the measured component is extracted automatically. Otherwise, when the Data 
object becomes available and is aligned, a manual extraction operation must be performed 
using the hemmed edge comparison point.

Note that when a hemmed edge comparison point is extracted, the corresponding back point 
is also automatically extracted.

Objective: Extract the corresponding geometry on the part to obtain the measured 
component of the comparison point. 

Required: The project contains a Reference object, an aligned Data object, and a hemmed 
edge comparison point with a nominal component.

Steps

1. Select the hemmed edge comparison points 
in the Tree View.

2. Choose Measure > Extract Measured.

Tips

If a hemmed edge comparison point cannot be extracted, make sure that there is enough 
data to perform the extraction. Also, modifying the extraction parameters could make a 
difference. In the Tree View, select the hemmed edge comparison point and choose Edit > 
Object Properties, then click the Measurement tab to access the extraction parameters.
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Results

Probe the geometry

The geometry of the hemmed edges on the sheet metal part can be obtained by probing the 
measured component of a hemmed edge comparison point. 

Objective: Probe the corresponding geometry on the part to obtain the measured 
component of the comparison point.

Required: The project contains a Reference object as well as a hemmed edge comparison 
point with a nominal component and its back point. The probing device is aligned 
to the Reference object.

Steps

A measured status icon indicates the 
measured status of the hemmed edge 
comparison points and their corresponding 
back points.

The hemmed edge comparison points and 
their back points are displayed in the 3D 
scene with a solid measurement zone. The 
color of the comparison points corresponds 
to the defined color scale. 

1. Select the hemmed edge comparison points 
in the Tree View.
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2. Choose Measure > Comparison Points > Define 
Measured.

Alternatively, right-click the selected 
comparison points in the Tree View and 
choose Probe Measured.

The Defined Measured Comparison Point 
Components dialog box opens.

3. Specify the probing mode: 

• Specific: Allows probing the selected 
comparison points following the Tree View 
order.

• Auto-detect: Allows probing the 
comparison point closest to the probing 
device. Only the selected comparison 
points will be detected.

Regardless of the probing mode, you will always 
be prompted to probe the back point first and 
then the hemmed edge comparison point. 

4. Click Probe.

Two points must be probed: first probe the 
back point, then the corresponding hemmed 
edge comparison point.

Tips

When probing comparison points, visual and audio feedback are provided. If the probe is out 
of the measurement zone, the display color of the comparison point disc is red and the 
farther the probe is from the comparison point the slower the sound is. Moving towards the 
comparison point will accelerate the sound. Once the measurement zone is reached, the 
display color of the comparison point disc will change to green and the sound will change to a 
higher pitch, which eventually stops indicating the location of the probing device is good 
enough to acquire data.
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Results

A probing session Data object is added to the 
Tree View and a measured status icon 
indicates the measured status of the 
hemmed edge comparison points and their 
corresponding back points.

The hemmed edge comparison points, and 
their backpoints, are displayed in the 3D 
scene with a solid measurement zone. The 
color of the comparison points corresponds 
to the defined color scale.
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Gauges  

Calipers

Profile gauges

Flush & gap gauges

Airfoil gauges
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Measuring part dimensions with gauges

In PolyWorks|Inspector, common physical measurement tools such as calipers, radius 
gauges, and step gauges are simulated using Gauge objects. Gauges are used to measure the 
deviations of the part geometry with respect to the nominal geometry. 

There are four types of gauges:         

Gauges, except for calipers, are measured on linked cross-sections which are automatically 
created on gauge creation. Calipers calculate distances either on a 3D surface or at locations 
on a cross-section.

Caliper
A gauge that is similar to a physical 
caliper used to measure distances.

Profile gauge
Profile gauges are used to measure 
the radii, distances, or heights on the 
fillets or rounds of a part on a cross-
sectional plane.

Flush & gap gauge
Flush & gap gauges are used to 
measure the flush and gap between 
parts of an assembly on a cross-
sectional plane.

Airfoil gauge
Airfoil gauges are used to measure 
airfoil profiles on a cross-sectional 
plane.
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Display options

There are display options for the visualization of the results.

1. Click Object Display Options.

2. Under Gauges:

• Select Color map to display the deviation of 
the measured geometry to the nominal 
geometry. Note that the color map display 
can be customized. For information, see 
Changing the color map display on page 201.

• Select the component that will be displayed: 
Nominal or Measured.
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Measuring object dimensions with calipers

A caliper is a measurement instrument widely used in the manufacturing industry to measure 
the distance between two opposite sides of an object by adjusting its tips to fit the points to 
be measured. The gap between the tips reports the distance between the sides directly, if the 
caliper has a built-in scale, or indirectly, if another measurement instrument must be used to 
measure the gap.

Introducing calipers

In PolyWorks|Inspector, the caliper tool is a software simulation of a physical caliper. It has 
similar behavior and applications. For example, it has two customizable tips.

Calipers are used to inspect distances using the nominal geometry and the geometry of the 
part in order to produce results determined by geometry controls. The nominal geometry and 
the part geometry are captured by intersecting the surface of aligned Reference and Data 
objects with the caliper tips.

Calipers are available on the Measure > Gauges menu or on the Gauges toolbar.

Caliper types

There are two types of calipers:

Standard caliper
Calculates distances on a 
3D surface.

Cross-section caliper
Calculates distances on cross-
sections.
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Axis types

There are two axis types for both types of calipers:

Caliper tip directions

Calipers can have one or both tips facing inward along the direction of measurement, 
outward along the direction of measurement, or be anchored.

• Single axis

Allows creating calipers using one single 
axis for both endpoints.

• Offset axes

Allows creating calipers using one axis for 
each endpoint.

• Inward

An inward tip points towards the other tip.

• Outward

An outward tip points away from the other 
tip.

• Anchored

An anchored tip is fixed and it does not 
move from where it is created.
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Display options

There are display options for the visualization of the results.

Creation methodology

A standard dialog box with common and contextual parameters is used for the creation of 
calipers.

1. Click Object Display Options.

2. Under Gauges:

• Select Color map to display the deviation of 
the measured geometry to the nominal 
geometry. Note that the color map display 
can be customized. For information, see 
Changing the color map display on page 201.

• Select the component that will be displayed: 
Nominal or Measured.

1. Choose Measure > Gauges > Create > [any 
caliper type].

A creation dialog box opens.

2. Specify a Name, if desired.

3. In the Axis type list, click Single Axis or Offset 
Axes.

4. In the Method list, select a creation method.

5. In the Submethod list, select a creation 
submethod.

This list is not offered for some methods.

6. In the Parameters section, configure the 
caliper creation.

7. Click the appropriate button to launch the 
creation.
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Creating standard calipers to measure distances on 
objects

it is possible to measure distances between surfaces 
using the standard caliper tool, which simulates a 
physical caliper. While standard calipers created 
using default settings may meet many needs, they 
are fully configurable in the creation dialog box or 
post creation using their property sheet.

A caliper is a measurement object. It is created to 
obtain a) the nominal geometry of the Reference 
object, and b) the geometry of the part by extracting 
it from an aligned Data object using an existing 
caliper. When both geometries have been obtained, 
geometry controls are applied to produce the desired results.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Start inspecting a distance on a part by creating a standard caliper to capture the 
nominal component.

Required: The project contains a Reference object.

Steps

1. Choose Measure > Gauges > Create > Standard 
Calipers.

The Create Calipers dialog box opens.

2. Select the Axis type:

• Single Axis allows creating calipers that use 
one single axis for both endpoints.

• Offset Axes allows creating calipers using 
one axis for each endpoint.

3. Choose a Method from those that follow.

The creation of calipers using the most frequently 
used methods follows.

All of the possible creation methods are shown to 
the right.
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Anchor

This method allows anchoring caliper endpoints interactively.

1. In the Method list, select Anchor.

2. In the Submethod list, select Two Endpoints.

This allows creating a caliper by specifying the 
two endpoints.

If using offset axes, this is the only submethod.

3. Select a Tip direction:

• Automatic specifies the tip direction to 
automatically point toward the surface 
where the endpoints are located.

• Custom allows configuring the tip direction 
to face inward, outward, or be anchored in 
space.

4. Specify the Axis orientation.

The caliper axis can be normal to the surface, 
follow a system axis, a custom vector, or be 
defined by the endpoints.

5. Click Anchor.

An interactive anchoring mode is launched:

• Press the SPACEBAR to interrupt the mode 
and rotate the model.

• Pick the endpoints of the caliper on the 
Reference object.

• Repeat if desired.

• Right-click to exit the mode.
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Numerically

This method allows entering numerical values for the coordinates of the caliper endpoints.

1. In the Method list, select Numerically.

2. In the Submethod list, select Two Endpoints.

This allows creating a caliper by specifying the two 
endpoints. If using offset axes, this is the only 
submethod.

3. Select a Tip direction:

• Automatic specifies the tip direction to 
automatically point toward the surface 
where the endpoints are located.

• Custom allows configuring the tip direction 
to face inward, outward, or be anchored in 
space.

4. Under 1st endpoint and 2nd endpoint, enter 
the (x, y, z) coordinates of the endpoints.

5. If using offset axes, specify the Axis 
orientation.

The caliper axis can be normal to the surface, 
follow a system axis, a custom vector, or be 
defined by the endpoints.

6. Click Create. 
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From Text File

This method allows creating calipers by importing information from a text file. While the file 
must contain the coordinates of one or both endpoints, other information such as vectors, 
nominal lengths, radii, and names can also be imported.

1. In the Method list, select From Text File.

2. In the Submethod list, select Two Endpoints.

This allows creating a caliper by specifying the two 
endpoints. If using offset axes, this is the only 
submethod.

3. Select a Tip direction:

• Automatic specifies the tip direction to 
automatically point toward the surface 
where the endpoints are located.

• Custom allows configuring the tip direction 
to face inward, outward, or be anchored in 
space.

4. If offset axes are used, specify the Axis 
orientation.

The caliper axis can be normal to the surface, 
follow a system axis or a custom vector, or be 
defined by the endpoints.

5. Click Browse.

A file browser opens.

6. Navigate to a text file containing the (x, y, z) 
coordinates of the endpoints.

7. In the import dialog box, under Text files, 
select a Template that corresponds to the file 
structure.

A preview of the file is presented to verify that the 
chosen template is correct.

8. Click OK.
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Results

Notes

The new calipers, with a nominal component, 
are added to the Tree View under the 
Gauges > Calipers branch.

A caliper with a single axis and one with 
offset axes are displayed in the 3D scene.

 

 

• By default, if a Data object is available and aligned when the caliper is created, the 
measured component is extracted automatically.

• The One Endpoint submethod allows 
creating calipers by specifying only the 
first endpoint. The second endpoint is 
automatically computed using the 
specifications in the Parameters section.

The parameters are slightly different than 
the ones for the Two Endpoints 
submethod, but the creation workflow is 
the same.
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Extracting the geometry of the part

For an existing caliper, the corresponding geometry of the part can be obtained by extraction 
on an aligned Data object. In PolyWorks|Inspector, the geometry obtained on the part is 
called the measured component of the measurement object.

When there is a Data object available in the project at caliper creation, the measured 
component is extracted automatically. Otherwise, when the Data object becomes available 
and is aligned, a manual extraction operation must be performed using the caliper.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Objective: Finish inspecting the surface location for an existing caliper by extracting the 
corresponding geometry of the part to obtain the measured component of the 
caliper.

Required: The project contains a Reference object, an aligned Data object, and a caliper with 
a nominal component.

Steps

Results

1. In the Tree View, select the calipers.

2. Choose Measure > Extract Measured.

A measured status icon indicates the 
measured status of the calipers.

A caliper with a single axis and one with 
offset axes are displayed in the 3D scene. The 
color of the calipers corresponds to the 
defined color scale and it reflects, by default, 
the deviation of the measured component 
from the nominal component.
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Notes

• The extraction parameters of a caliper are saved to the Measurement tab of its property 
sheet. They can be edited post creation by selecting the caliper in the Tree View, choosing 
Edit > Object Properties, opening the tab, and making other specifications.

• Caliper endpoints can be moved inward or outward after creation. 
To do so, select the caliper in the Tree View and choose Measure > 
Gauges > Drag Caliper Endpoints.
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Creating cross-section calipers to measure distances on 
cross-sections

Cross-sections allow the 2D analysis of a part at 
specific locations. A cross-section caliper allows 
further 2D analysis by measuring distances using 
only the contours of cross-sections.

A cross-section caliper is a measurement object. It is 
created to obtain a) the nominal geometry of the 
Reference object, and b) the geometry of the part by 
extracting it from an aligned Data object. When both 
geometries have been obtained, geometry controls 
are applied to produce the desired results.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Start inspecting a distance on a cross-section by creating a cross-section caliper to 
capture the nominal component.

Required: The project contains a Reference object and a cross-section with a nominal 
component.

Steps

1. In the Tree View, select the cross-section and 
choose View > Object Navigator > Cross-Sections.

The Cross-Section Navigator dialog box opens, 
and the selected cross-section is displayed in 
2D in the 3D scene.

2. Choose Measure > Gauges > Create > Cross-
Section Calipers.

The Create Cross-Section Calipers dialog box 
opens.

3. Select an Axis type:

• Single Axis allows creating calipers using 
one single axis for both endpoints.

• Offset Axes allows creating calipers using 
one axis for each endpoint.

4. Choose a Method from those that follow.

The creation of cross-section calipers using the 
most frequently used methods follows. All of the 
possible creation methods are shown to the right.
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Anchor

This method allows anchoring cross-section caliper endpoints interactively.

1. In the Method list, select Anchor.

2. In the Submethod list, select Two Endpoints.

This allows creating a caliper by specifying the 
two endpoints. If using offset axes, this is the only 
submethod.

3. Select a Tip direction:

• Automatic specifies the tip direction to 
automatically point toward the surface 
where the endpoints are located.

• Custom allows configuring the tip direction 
to face inward, outward, or to be anchored in 
space.

4. Specify the Axis orientation.

The caliper axis can be normal to the surface, 
follow a standard axis, a custom vector or be 
defined by the endpoints.

5. Click Anchor.

An interactive anchoring mode is launched:

• Pick the endpoints of the caliper on the 
nominal component of the cross-section.

• Repeat if desired.

• Right-click to end the anchoring operation.
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Numerically

This method allows entering numerical values for the coordinates of the cross-section caliper 
endpoints.

1. In the Method list, select Numerically.

2. In the Submethod list, select Two Endpoints.

This allows creating a caliper by specifying the two 
endpoints. If using offset axes, this is the only 
submethod.

3. Select a Tip direction:

• Automatic specifies the tip direction to point 
automatically toward the surface where the 
endpoints are located.

• Custom allows configuring the tip direction 
to face inward, outward, or to be anchored in 
space.

4. Under 1st endpoint and 2nd endpoint, enter 
the (x, y, z) coordinates of the endpoints.

5. If using offset axes, specify the Axis 
orientation.

The caliper axis can be normal to the surface, 
follow a system axis, a custom vector or be 
defined by the endpoints.

6. Click Create.
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From Text File

This method allows creating calipers by importing information from a text file. While the file 
must contain the coordinates of one or both endpoints, other information such as vectors, 
nominal lengths, radii, and names can also be imported.

1. In the Method list, select From Text File.

2. In the Submethod list, select Two Endpoints.

This allows creating a caliper by specifying the two 
endpoints. If using offset axes, this is the only 
submethod.

3. Select a Tip direction:

• Automatic specifies the tip direction to point 
automatically toward the surface where the 
endpoints are located.

• Custom allows configuring the tip direction 
to face inward, outward, or to be anchored in 
space.

4. If using offset axes, specify the Axis 
orientation.

The caliper axis can be normal to the surface, 
follow a system axis, a custom vector or be 
defined by the endpoints.

5. Click Browse.

A file browser opens.

6. Navigate to a text file containing the (x, y, z) 
coordinates of the endpoints.

7. In the import dialog box, under Text files, 
select a Template that corresponds to the file 
structure.

A preview of the file is presented, which allows 
verifying that the chosen template is correct.

8. Click OK.
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Results

Notes

The new cross-section calipers, with a 
nominal component, are added to the Tree 
View under the Gauges > Calipers branch.

Single axis and offset axis cross-section 
calipers are displayed in the 3D scene.

 

 

• By default, if the cross-section has a measured component when the cross-section caliper 
is created, the measured component of the caliper is extracted automatically.

• The One Endpoint Submethod allows 
creating cross-section calipers by only 
specifying the first endpoint. The second 
endpoint is automatically computed 
using specifications in the Parameters 
section.

The parameters are slightly different than 
the ones for the Two Endpoints 
submethod, but the creation workflow is 
the same.
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Extracting the geometry of the part

For an existing cross-section caliper, the corresponding geometry of the part can be obtained 
by extraction on an aligned Data object. In PolyWorks|Inspector, the geometry obtained on 
the part is called the measured component of the measurement object.

When there is a Data object available in the project at caliper creation, the measured 
component is extracted automatically. Otherwise, when the Data object becomes available 
and is aligned, a manual extraction operation must be performed using the cross-section 
caliper.

Objective: Finish inspecting the distance for an existing cross-section caliper by extracting 
the corresponding geometry of the part to obtain the measured component of 
the caliper.

Required: The project contains a cross-section caliper with a nominal component and its 
linked cross-section, and an aligned Data object.

Steps

Results

1. Select a cross-section caliper in the Tree View.

2. Choose Measure > Extract Measured.

Extracting the cross-section calipers triggers 
the extraction of measured component of 
their linked cross-section.

A measured status icon indicates the 
measured status of the cross-section calipers 
and the linked cross-section.

Single axis and offset axis cross-section 
calipers are displayed in the 3D scene. The 
color of the calipers corresponds to the 
defined color scale and reflects, by default, 
the deviation of the measured component 
from the nominal component.
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Notes

• The extraction parameters of a caliper are saved to the Measurement tab of its property 
sheet. They can be edited post creation by selecting the caliper in the Tree View, choosing 
Edit > Object Properties, opening the tab, and making other specifications.

• A caliper’s endpoints can be moved inward or outward after 
creation. To do so, select the caliper in the Tree View and choose 
Measure > Gauges > Drag Caliper Endpoints.
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Measuring object radii with profile gauges

The profile gauge is a useful tool to inspect radii on a part on 
a cross-sectional plane.

Introducing profile gauges

The profile gauge is used to inspect a profile along a cross-
sectional plane using the nominal geometry and the 
geometry of the part in order to produce results determined 
by geometry controls.

Several profile gauge types are available that allow inspecting one radius at a profile, or two 
radii and the distance between them.

Profile gauges are available on the Measure > Gauges menu or on the Gauges 
toolbar.

Profile gauge families

There are three families of profile gauges. 

One radius
This family type computes measurements 
only for one radius.

Two radii
This family type computes measurements for 
two radii.

Design lines
This family type detects one variable radius 
representing a feature line. Feature lines are 
characteristic lines creased into the side of a 
car to give it visual distinction.
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Profile gauge types

There are several types of profile gauges offered for each family, and certain types obtain 
more accurate results in certain applications. To help choose the correct type of profile gauge, 
the Visualize type usage section in the creation dialog box offers an interactive display of the 
different scenarios where the selected type works.

The selection of gauges for each family meets the needs of most users. In addition, users can 
program their own gauges using special creation tools; this advanced subject is not presented 
in this document.

Visualizing type usage

Creation methods

Profile gauge measurements are calculated on a 
linked standard cross-section, which is created at 
the same time as the profile gauge. This is why 
profile gauges share the same creation methods 
as standard cross-sections. The methods most 
frequently used are presented in this document. 

1. In the creation dialog box, expand the 
Visualize type usage area.

2. A display of the current gauge type is shown.

3. Use the vertical scroll bar to interactively 
change the display, showing the possible 
scenarios supported by the selected gauge 
type. If the two radii families are selected, two 
scroll bars are available, one for each radius.
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Creation methodology

Display options

Display options are available for the visualization of the results.

PolyWorks|Inspector also offers a visualization mode called Profile Gauge Navigator that 
displays a single profile gauge in 2D mode, making it easier to understand the results. See 
Reviewing profile gauge measurement results on page 563.

1. Choose Measure > Gauges > Create > Profile 
Gauges.

The Create Profile Gauge dialog box opens.

2. Specify an object Name, if desired.

3. Specify the gauge Family and Name.

Use the Visualize type usage to display the 
possible scenarios supported by the selected 
profile gauge type.

4. In the Method list, select a creation method.

5. Specify the required parameters according to 
the creation method.

Method-specific parameters may include 
browsing for a text file or entering point 
coordinates manually.

6. Click Preview to view the measurement zone 
of the profile gauge.

7. Click the appropriate button to launch or 
confirm the creation of the gauges.

1. Click Object Display Options.

2. Under Gauges, in the Component list, choose 
Nominal or Measured.
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Creating profile gauges

A profile gauge is a measurement object. It is created to obtain, along a cross-sectional plane, 
a) the nominal geometry on the Reference object, and b) the geometry of the part, by 
extracting it from an aligned Data object, or by probing the geometry on the part. When both 
geometries have been obtained, geometry controls are applied to produce the desired results.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Start inspecting a profile along a cross-sectional plane by creating a profile gauge 
to capture the nominal component.

Required: A Reference object. If there is a Data object in the project, it must be aligned to the 
corresponding Reference object.

Steps

1. Choose Measure > Gauges > Create > Profile 
Gauges.

The Create Profile Gauges dialog box opens.

2. Choose a gauge Family type and Name.

To better understand how to choose the type, the 
Visualize type usage section can be expanded. 
In this section, all operations that the selected 
type can perform are illustrated. This is for 
visualization purposes only, and does not affect 
the creation process.

3. Choose a Method from those that follow.

The creation of profile gauges, using the most 
frequently used methods, follows.

All of the creation methods are shown to the 
right.
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Along Curve

This method allows creating profile gauges perpendicular to a curve. It involves specifying 
the type of curve to use, and then specifying the location of the gauge along the curve.

1. In the Method list, select Along Curve.

2. Under Curve, select From reference object 
curves to use the curves of a Reference 
object.

3. Under Mode, select Individual.

If multiple profile gauges are needed, the 
Multiple mode allows gauges to be spaced 
evenly at a specified step along the curve.

4. Under Position, click Anchor Point.

An interactive anchoring mode is launched.

5. Anchor a point along the curve by picking a 
point in the 3D scene. Right-click to exit the 
anchoring mode.

If At intersection with plane is selected, only 
the location of the intersection of the curve and 
the chosen standard plane can be picked.

The measurement zone is displayed.

6. To resize the measurement zone to include 
only the area of interest, drag the blue 
borders.

7. Click Confirm.

Tips

Profile gauges can be created along a whole curve or just using a portion of the curve. When 
the Mode is set to Multiple, two anchoring modes become available:

• Whole curve: Profile gauges are created along the entire length of the curve.

• Partial curve: Profile gauges are created between the specified start and end point on 
the curve. Click a first point on the curve to indicate the start point and click a second 
point to indicate the end point.
452



MEASURING DIMENSIONS AND DEVIATIONS
Along Standard Axis

This method allows creating profile gauges perpendicular to a standard system axis, such as 
the X axis. It is recommended to have a properly oriented coordinate system to obtain the 
anticipated results.

1. In the Method list, select Along Standard 
Axis.

2. Under Axis, select X, Y, or Z.

3. Under Mode, select Individual.

If multiple profile gauges are needed, the 
Multiple mode creates gauges evenly spaced at 
a specified step, either within a range or by 
slicing whole objects.

4. Under Position, specify the coordinate of a 
point on the selected standard axis.

The value can be entered in the text box or by 
clicking Anchor Point, which allows picking a 
point on the Reference object in the 3D scene.

5. Click Preview.

A preview of the measurement zone of the 
profile gauge is displayed in the 3D scene.

The preview is automatically displayed when 
anchoring a point. 

Right-click to exit the anchoring mode.

6. To resize the measurement zone to include 
only the area of interest, drag the blue 
borders.

7. Click Confirm.
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Results

Notes

• By default, if a Data object is available and aligned when the 
profile gauge is created, the measured component is extracted 
automatically.

• Since a profile gauge is a 2D analysis, a linked cross-section is 
automatically extracted on profile gauge creation to compute 
measurements.

• The measurement zone of a profile gauge can be edited post creation by following these 
steps:
 

The new profile gauge, with a nominal 
component, is added to the Tree View under 
the Gauges > Profile branch.

The profile gauge is displayed in the 
3D scene.

 

1. Select the profile gauge in the Tree View.

2.  Choose Measure > Gauges > Edit 
Measurement Zones.

The measurement zone is displayed in the 
3D scene and can be edited by dragging the 
borders. 

3. Press ESC to exit the editing mode.
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Measuring the geometry on the part

For an existing profile gauge, the corresponding geometry on the part can be obtained by 
extraction on an aligned Data object or by probing a physical part. If proceeding by probing, 
the digitizing device should be aligned to the Reference object. In PolyWorks|Inspector, the 
geometry obtained on the part is called the measured component of the measurement object.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract the geometry

When there is an aligned Data object available in the project at profile gauge creation, the 
measured component is extracted by default. Otherwise, when the Data object becomes 
available and is aligned, a manual extraction operation must be performed using the profile 
gauge.

Objective: Finish inspecting the profile for an existing profile gauge by extracting the gauge’s 
measured component.

Required: A profile gauge and an aligned Data object.

Steps 

Results

Notes

• If the profile gauge is created using the wrong family or name, it is possible to change 
these parameters as well as other gauge creation parameters. Select the gauge and 
choose Edit > Object Properties. The object’s property sheet opens. Open the Profile tab 
and make the desired specifications.

1. In the Tree View, select the profile gauge.

2. Choose Measure > Extract Measured.

A measured status icon indicates the 
measured status of the profile gauge as well 
as its linked cross-section.

The profile gauge is displayed in the 
3D scene.
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• It is possible to view in 2D mode the selected profile gauges using the Profile Gauge 
Navigator. To access the navigator, choose View > Object Navigator > Profile Gauges. See 
Reviewing profile gauge measurement results on page 563.

Probe the geometry

The geometry for a profile on the part can be obtained by probing the measured component 
of a profile gauge. The probed points are projected onto the plane defined by the 
measurement zone of the gauge. Subsequently, the projected points are joined by a polyline 
to define the measured component of the linked cross-section.

Objective: Finish inspecting the profile for an existing profile gauge by probing the 
corresponding part geometry.

Required: A Reference object, a profile gauge, a probing device aligned with the Reference 
object, and the part.

Steps

1. In the Tree View, select the profile gauges to 
probe.

2. Choose Measure > Gauges > Probe Measured 
Profile.

The Probe Measured Profile Gauge Compo-
nents dialog box opens.

3. In the Measurement zone area, select Use.

The selected profile gauges are available in the 
adjacent list.

4. Specify a Projection distance.

Probed points within this distance from the 
measurement zone are considered as valid 
points to compute the measured component.

5. Specify a Max point-to-point distance.

Specifies the maximum distance between points 
to be joined together by the polyline.

6. Click Probe.

Use the visual and audio guidance to move the 
probe to the desired location. Once within the 
profile projection distance, probing is allowed.
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Results

Notes

• Measured profile gauges can also be probed without having an existing profile gauge by 
using the Probe 2 points method. In this case, a measurement zone must first be defined. 
As well, no alignment is necessary for the probing device since no Reference object is 
required.

A measured status icon indicates the 
measured status of the profile gauge as well 
as its linked cross-section. 

The profile gauge is displayed in the 
3D scene.
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Measuring flush and gap with flush & gap gauges

In manufacturing, when performing an assembly, it 
can be necessary to measure the flush and the gap 
existing between the assembled parts to assure the 
assembly meets the design requirements.

Introducing flush & gap gauges

The flush & gap gauge is used to inspect the assembly on a cross-sectional plane using the 
nominal geometry and the geometry of the part in order to produce results determined by 
geometry controls.

Flush & gap gauges are available on the Measure > Gauges menu or on the Gauges 
toolbar.

Flush & gap gauges are organized by family, and each family can have several types 
of flush & gap gauges. This selection of gauges meets the needs of most users. Users can 
program their own gauges using special creation tools; this advanced subject is not covered in 
this document.

Flush & gap gauge families

There are four families of flush & gap gauges: Side B is a line, Side B is made of points, Side 
A and B are fillets, and Universal.

The Universal family is the most versatile one, enclosing almost every possible scenario 
where both sides are fillets. Since it offers more flexibility, it is the only family that is 
addressed in detail. While the types offered in the Universal family have wider applications, 
the ones offered for the Side A and B are fillets family have more specific applications.

Flush & gap gauge types

The Universal family offers three standard flush and gap gauge types:

• AutoDirections Universal

This type of flush and gap gauge computes 
both the gap and the flush whenever A and 
B side are fillets.

• AutoDirections Universal Flush Only

This type of flush and gap gauge computes 
only the flush whenever A and B side are 
fillets.

• AutoDirections Universal Gap Only

This type of flush and gap gauge computes 
only the gap whenever A and B side are 
fillets.
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Visualizing type usage

Each flush & gap gauge family and combination of types address specific needs of 
measurement. To help choose the correct family and type, the Visualize type usage section 
in the creation dialog box offers an interactive display of the different scenarios where the 
selected type works. 

Creation methods

Flush & gap gauge measurements are calculated along a linked 
standard cross-section, which is created at the same time as the 
flush & gap gauge. This is why flush & gap gauges use the same 
creation methods as standard cross-sections. The methods most 
frequently used are presented in this document.

1. In the creation dialog box, expand the 
Visualize type usage area.

2. A display of the current gauge type is shown.

3. Use the vertical scroll bar on each side to 
interactively change the display, showing the 
possible scenarios supported by the selected 
gauge type.
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Creation methodology

Display options

Display options are available for the visualization of the results.

1. Choose Measure > Gauges > Create > Flush & 
Gap Gauges.

The Create Flush & Gap Gauges dialog box 
opens.

2. Specify an object Name, if desired.

3. Specify the gauge Family and Name.

Use the Visualize type usage to display the 
possible scenarios supported by the selected 
flush & gap gauge type.

4. Specify a creation Method.

5. Specify the required parameters according to 
the creation method.

Method-specific parameters may include 
browsing for a text file or entering point 
coordinates manually.

6. Click Preview to view the measurement zone 
of the flush and gap gauge.

7. Click the appropriate button to launch the 
gauge creation.

1. Click Object Display Options.

2. Under Gauges, in the Component list, choose 
Nominal or Measured.
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PolyWorks|Inspector also offers a visualization mode called Flush & Gap Gauge Navigator that 
displays a flush & gap gauge in 2D mode, making it easier to read the results. See Reviewing 
flush & gap gauge measurement results on page 565.

Typical flush and gap analysis

The figure below illustrates the flush and the gap measured on the part.

Side A
(definition side)

Measured gap

Side B

Reference
Data

Measured 
flush
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Creating flush & gap gauges

A flush & gap gauge is a measurement object. It is created to obtain, along a cross-sectional 
plane, a) the nominal geometry on the Reference object, and b) the geometry of the part, by 
extracting it from an aligned Data object, or by probing the geometry of the part. When both 
geometries have been obtained, geometry controls are applied to produce the desired results.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Start inspecting the flush & gap on an assembly by creating a flush & gap gauge to 
capture the nominal component.

Required: A Reference object assembly, or separate Reference objects properly aligned to 
each other.
If there are Data objects in the project, they must be aligned to the corresponding 
Reference objects.

Steps

1. Choose Measure > Gauges > Create > Flush & Gap 
Gauges.

The Create Flush & Gap Gauges dialog box 
opens.

2. Choose the Family type and the name.

Use the Visualize type usage section to better 
understand how to choose the type. The 
operations that the selected type performs are 
illustrated. This is only for visualization purposes 
and does not affect the creation process.

3. Choose the creation Method from the 
methods that follow.

The creation of flush & gap gauges, using the 
methods most often used, follows.

All of the creation methods are shown to the right.
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Along Curve

This method allows creating flush & gap gauges perpendicular to a curve. It involves specifying 
the type of curve to use, and then specifying the location of the gauge along the curve.

1. In the Method list, select Along Curve.

2. Under Curve, select From reference object 
curves to use the curves of a Reference object.

3. Under Mode, select Individual.

The Multiple mode allows creating evenly spaced 
flush & gap gauges at a specified step either 
within a range or by slicing whole objects.

4. Under Position, click Anchor Point.

An interactive anchoring mode is launched.

5. Anchor a point along the curve by picking a 
point on the Reference object in the 3D scene. 
Right-click to exit the anchoring mode.

If At intersection with plane is selected, only the 
point where the curve and the specified standard 
plane intersect can be picked.

The measurement zone is displayed.

6. To resize the measurement zone to include 
only the area of interest, drag the blue borders.

7. Click Confirm.
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Tips

Flush & gap gauges can be created along a whole curve or just using a portion of the curve. 
When the Mode is set to Multiple, two anchoring modes become available:

• Whole Curve:

Flush & gap gauges are created along the entire 
length of the curve.

• Partial Curve:

Flush & gap gauges are created between the 
specified start and end points on the curve.

Click a first point to indicate the start point, and 
click a second point to indicate the end point 
on the curve.

Along Standard Axis

This method allows creating flush & gap gauges perpendicular to a standard axis. It is recom-
mended to have a properly oriented coordinate system to obtain the anticipated results.

1. In the Method list, select Along Standard Axis.

2. Under Axis, select X, Y, or Z.

3. Under Mode, select Individual.

The Multiple mode allows creating evenly spaced 
flush & gap gauges at a specified step either 
within a range or by slicing whole objects.

4. Under Position, specify the coordinate of a 
point on the selected standard axis.

The value can be entered in the text box or by 
clicking Anchor Point, which allows picking a 
point on the Reference object in the 3D scene.

5. Click Preview.
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A preview of the measurement zone of the 
flush & gap gauge is displayed in the 3D scene.

The preview is automatically displayed when 
anchoring a point. 

Right-click to exit the anchoring mode.

6. To resize the measurement zone to include 
only the area of interest, drag the blue borders.

7. Click Confirm.

From Text File

It is possible to create the flush & gap gauges from predefined points by importing them from 
a text file.

1. In the Method list, select From Text File.

2. Specify the File contents:

• Ordered Points: the file contains a list of 
ordered consecutive points.

• Points & Gap Vectors: the file contains a set 
of points and gap vectors, and optionally 
flush vectors.
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Results

3. Under Position, specify the path of the text file 
to be used. If the file content has been set to 
Ordered Points, additional information must 
be specified:

• Number of gauges per curve segment: 
specifies the number of gauges to create 
along each curve segment (line joining two 
consecutive points).

• Distance between gauges: specifies the 
spacing between gauges along the curve.

4. Click Preview.

A preview of the measurement zone of the 
flush & gap gauge is presented in the 3D scene.

5. To resize the measurement zone to include 
only the area of interest, drag the blue borders.

6. Click Confirm.

The new flush & gap gauge, with a nominal 
component, is added to the Tree View under 
the Gauges > Flush & Gap branch.

The flush & gap gauge is displayed in the 
3D scene.
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Notes

• By default, if Data objects are available and aligned when the flush & gap gauge is created, 
the measured component is extracted automatically.

• Since a flush & gap gauge is a 2D analysis, a linked cross-section 
is automatically extracted on flush & gap gauge creation to 
compute measurements.

• The measurement zone of a flush & gap gauge can be edited post creation by following 
these steps: 

Measuring the geometry on the part

For an existing flush & gap gauge, the corresponding geometry of the part can be obtained by 
extraction on an aligned Data object or by probing a physical part. If proceeding by probing, 
the digitizing device must be aligned to the Reference object. In PolyWorks|Inspector, the 
geometry obtained on the part is called the measured component of the measurement object.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Extract the geometry

When there is an aligned Data object available in the project at flush & gap gauge creation, the 
measured component can be extracted automatically. Otherwise, when the Data object 
becomes available and is aligned, a manual extraction operation must be performed using the 
flush & gap gauge.

Objective: Finish inspecting the flush and gap on a part assembly for an existing flush & gap 
gauge by extracting the gauge’s measured component.

Required: A flush & gap gauge, and properly aligned Data objects.

1. Select the flush & gap gauge in the Tree 
View.

2.  Choose Measure > Gauges > Edit 
Measurement Zones.

3. The measurement zone is displayed in the 
3D scene and can be edited by dragging the 
borders. 

4. Press ESC to exit the editing mode.
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Steps

Results

Notes

• If the flush & gap gauge is created using the wrong family or name, it is possible to change 
these parameters and other gauge creation parameters. Select the gauge and choose Edit 
> Object Properties. The object’s property sheet opens. Open the Flush & gap tab and make 
the desired specifications.

• It is possible to view in 2D mode the selected flush & gap gauges using the Flush & Gap 
Gauge Navigator. To access the navigator, choose View > Object Navigator > Flush & Gap 
Gauges. See Reviewing flush & gap gauge measurement results on page 565.

Probe the geometry

The geometry for a flush and gap on the part can be obtained by probing the measured 
component of a flush & gap gauge. The probed points are projected onto the plane defined by 
the measurement zone of the gauge. Subsequently, the projected points are joined by 
polylines to define the measured component of the linked cross-section.

Objective: Obtain the gauge’s measured component by probing the corresponding part 
geometry.

Required: A Reference object, a flush & gap gauge, a probing device aligned with the 
Reference object, and the part.

1. In the Tree View, select the flush & gap gauge.

2. Choose Measure > Extract Measured.

A measured status icon indicates the 
measured status of the flush & gap gauge.

The flush & gap gauge is displayed in the 
3D scene.
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Steps

1. In the Tree View, select the flush & gap 
gauges to probe.

2. Choose Measure > Gauges > Probe Measured 
Flush & Gap.

The Probe Measured Flush & Gap Gauge 
Components dialog box opens.

3. In the Measurement zone area, select Use.

The selected flush & gap gauges are available in 
the adjacent list.

4. Specify a Projection distance.

Probed points within this distance from the 
measurement zone are considered as valid 
points to compute the measured component.

5. Specify a Max point-to-point distance.

Specifies the maximum distance between points 
to be joined together by the polyline.

6. Click Probe.

Use the visual and audio guidance to move the 
probe to the desired location. Once within the 
projection distance, probing is allowed.

Measuring the flush and gap requires probing 
two sides and each side is probed in a separate 
step.
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Results

Notes

• Measured flush & gap gauges can also be probed without having an existing flush & gap 
gauge by using the Probe 2 points method. In this case, a measurement zone must first 
be defined. Moreover, no alignment is necessary for the probing device since no Reference 
object is required.

A measured status icon indicates the 
measured status of the flush & gap gauge as 
well as its linked cross-section. 

The flush & gap gauge is displayed in the 
3D scene.
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Measuring airfoil geometry with airfoil gauges

From domestic fans to turbines, blades play an important role 
in the manufacturing field. They make it possible to use fluid 
and gas dynamic principles to either absorb energy from fluids 
and gases, or produce energy. As a result, the design of their 
cross-sectional shape, called airfoil, must be accurately 
calculated and inspected.

Introducing airfoil gauges

The airfoil gauge is used to inspect standard airfoil 
characteristics on a cross-sectional plane using the nominal 
geometry and the geometry of the part in order to produce 
results determined by geometry controls.

Airfoil gauges are available on the Measure > Gauges menu or on the Gauges toolbar.

Airfoil gauges can measure the chord, the camber line, the leading and trailing edge radii and 
the maximum thickness, and more.

Airfoil gauge families

There are two families of airfoil gauges.

For both families, only the Classic name is available, which results in Aerodynamic - Classic 
or Tangential - Classic, depending upon the family chosen.

• Aerodynamic

Measurements are based on the aerodynamic 
chord that is defined as the vector that joins 
the limits of the camber line.

• Tangential

Measurements are based on the tangential 
chord that is defined as the vector that joins 
the two tangential points.
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Airfoil edges

Analyzing airfoils implies analyzing their edges, called leading edge (LE) and trailing edge (TE).

An airfoil typically has both edges. However, some sections can only present the leading edge 
or the trailing edge. PolyWorks|Inspector allows analyzing the edges simultaneously, or 
individually, depending on the scenario. The shape of the edges can be either circular or 
cutback.

Creation methods

Airfoil gauge measurements are calculated on a linked standard 
cross-section, which is created at the same time as the airfoil 
gauge. This is why airfoil gauges share most of the same creation 
methods as standard cross-sections. The methods most 
frequently used are presented in this document.

• Leading edge

Defined by the area of maximum curvature at 
the front of the airfoil.

• Trailing edge

Defined by the area of maximum curvature at 
the rear of the airfoil.
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Creation methodology

Display options

Display options are available for the visualization of the results.

PolyWorks|Inspector also offers a visualization mode called Airfoil Gauge Navigator which 
displays the airfoil gauge in 2D mode, making it easier to read the results. See Reviewing airfoil 
gauge measurement results on page 567.

1. Choose Measure > Gauges > Create > Airfoil 
Gauges.

The Create Airfoil Gauges dialog box opens.

2. Specify a Name, if desired.

3. Specify the family Type.

4. Specify the Edges to analyze on the airfoil 
profile.

5. Specify the Edges shapes.

6. Specify the creation Method.

7. Specify the required parameters according to 
the creation method.

8. Click Preview to view the measurement zone 
of the airfoil gauge.

9. Click the appropriate button to launch the 
gauge creation.

1. Click Object Display Options.

2. Under Gauges, in the Component list, choose 
either Nominal or Measured.
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Typical airfoil analysis

This figure shows an example of airfoil geometry captured by an airfoil gauge and the 
standard airfoil characteristics that can be calculated and reported. 

Camber line

Chord

Stagger

Maximum 
width

Maximum thickness

Trailing edge (TE)

                 LE tangent point TE point

Leading edge (LE)

LE radius and center
TE radius and center

LE thickness

TE thickness

LE point TE tangent point

Datum direction

Maximum 
thickness point

Centroid

Smallest enclosing
circle
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Creating airfoil gauges

An airfoil gauge is a measurement object. It is created to obtain, on a cross-sectional plane, a) 
the nominal geometry of the Reference object, and b) the geometry of the part by extracting it 
from an aligned Data object. When both geometries have been obtained, geometry controls 
are applied to produce the desired results.

Getting the nominal geometry

In PolyWorks|Inspector, the nominal geometry of a measurement object is called its nominal 
component, and the geometry obtained from the part is called its measured component.

Objective: Start inspecting the standard characteristics of an airfoil by creating an airfoil 
gauge to capture the nominal component.

Required: A Reference object that represents an airfoil.

Steps

1. Choose Measure > Gauges > Create > Airfoil 
Gauges.

The Create Airfoil Gauges dialog box opens.

2. Choose the Family type:

• Aerodynamic: measurements are based on 
the aerodynamic chord.

• Tangential: measurements are based on the 
tangential chord.

The Name offered for both families is Classic.

3. Specify the Edges to analyze:

• LE and TE: leading edge and trailing edge.

• LE: leading edge only.

• TE: trailing edge only.

4. Set the Edge shapes of the edges to analyze:

• Circular

• Cutback
5. Choose a creation Method from the ones that 

follow.

The creation of airfoil gauges using the most 
frequently used methods follows. To the right, all 
of the possible creation methods are shown.
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Along Standard Axis

This method allows creating airfoil gauges perpendicular to a standard axis. It is recom-
mended to have a properly oriented coordinate system to obtain the anticipated results.

1. In the Method list, select Along Standard Axis.

2. Under Axis, select X, Y, or Z.

3. Under Mode, select Individual.

The Multiple mode allows creating evenly spaced 
airfoil gauges at a specified step either within a 
range or by slicing whole objects.

4. Under Position, specify the coordinate of a 
point on the selected standard axis.

The value can be entered in the text box or by 
clicking Anchor Point, which allows picking a 
point on the Reference object in the 3D scene.

5. Click Preview.

A preview of the measurement zone of the 
airfoil gauge is displayed in the 3D scene.

The preview is automatically displayed when 
anchoring a point. 

Right-click to exit the anchoring mode.

6. Drag the blue borders to resize the 
measurement zone in order to include only the 
area of interest.

7. Click Confirm.
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From Planes

This method allows creating airfoil gauges at the position of existing plane primitives.

1. In the Tree View, select the plane(s) to use. 

2. In the Method list, select From Planes.

3. Specify the Primitives to use.

By default, both of the primitive types, Nominal 
and Measured, are selected. If a selected plane 
has a nominal and a measured primitive, an 
airfoil gauge is created at the location of each 
primitive.

4. Click Preview.

A preview of the measurement zone of the airfoil 
gauge is displayed in the 3D scene.

5. Drag the blue borders to resize the 
measurement zone in order to include only the 
area of interest.

6. Click Confirm.
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Results

Notes

• If a Data object is available and aligned when the airfoil gauge is 
created, then the measured component is extracted.

• An airfoil gauge uses a cross-section to compute the measurements 
since it is a 2D analysis. Because of this, a linked cross-section is 
created automatically on airfoil gauge creation.

• The measurement zone of an airfoil gauge can be edited post creation by following these 
steps: 

The new airfoil gauge, with a nominal 
component, is added to the Tree View under 
the Gauges > Airfoils branch. 

The airfoil gauge is displayed in the 3D scene.

 

 

1. Select the airfoil gauge in the Tree View.

 Choose Measure > Gauges > Edit Measurement 
Zones.
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2. The measurement zone is displayed in the 
3D scene and can be edited by dragging the 
borders. 

3. Press ESC to exit the editing mode.
479



MEASURING DIMENSIONS AND DEVIATIONS
Extracting the geometry of the part

For an existing airfoil gauge, the corresponding geometry of the part can be obtained by 
extraction on an aligned Data object. In PolyWorks|Inspector, the geometry obtained on the 
part is called the measured component of the measurement object.

The measured component of an airfoil gauge can be automatically extracted at creation when 
there is an aligned Data object available in the project. Otherwise, a manual extraction can be 
performed later when the Data object is acquired and properly aligned.

Note that it is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).

Objective: Finish inspecting the airfoil for an existing airfoil gauge by extracting the gauge’s 
measured component.

Required: An airfoil gauge and a properly aligned Data object representing an airfoil part.

Steps

Results

1. In the Tree View, select the airfoil gauge.

2. Choose Measure > Extract Measured.

Tip

It is possible to view in 2D mode the selected airfoil gauges using the Airfoil Gauge Navigator. 
To do so, choose View > Object Navigator > Airfoil Gauges. For more information, see Reviewing 
airfoil gauge measurement results on page 567.

A measured status icon indicates the 
measured status of the airfoil gauge.

The airfoil gauge is displayed in the 3D scene.
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Notes

If the airfoil gauge is created using the wrong family or if the information related to the edges 
to analyze was specified incorrectly, it is possible to change these parameters and other gauge 
creation parameters. Select the gauge and choose Edit > Object Properties. The object’s 
property sheet opens. Open the Airfoil tab and make the desired specifications.
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Additional tools  

Build/Inspect

Basic measurements

PolyWorks|Talisman™

Creating Level Planes
Orient to Gravity
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Measuring displacement during real-time 
assembly

When moving a physical part, it is very useful to track its 
deviation to stable CAD surfaces or feature(s) to get the 
part into the closest possible position.

The Build/Inspect mode offers visual and audio guidance 
for tasks such as lining up to a hole or axis, leveling a part, 
or securing it in a fixture. Deviations can be measured, in 
real time, to a center point, axis, or surface. It is possible 
to measure the probe position to one or to many features 
simultaneously, using set tolerances for each feature. If 
necessary, the deviation can be recorded for later 
reference.

Objective: Move a part into position over a fixed assembly hole using real-time guidance.

Required: A CAD model or feature(s), and a probing device aligned to the Reference object.

Steps

1. In the Tree View, select a destination feature.

2. Choose Measure > Build/Inspect.

The Build/Inspect dialog box and the Build/
Inspect Objects pane open.

3. In the Method list, select Single Distance to 
show guidance to just one feature.

4. Under Object selection, select Specific to 
choose which feature to be guided to.

Distance arrows, digital readout values, and audio 
feedback in the 3D scene indicate the current 
distance of the probe from the destination 
feature.

5. Adjust the part, using the guidance, to bring it 
closer to the destination.

Build/Inspect feedback is displayed in red and 
green, based on positional tolerances.
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Results

Notes

6. Specify the Distance Type, Compensation, 
and Tolerance values in the Build/Inspect 
Objects pane.

The Inverted compensation method can be useful 
when building or inspecting a fixture and only the 
CAD model of the part is available.

7. If desired, acquire a point to record the final 
position.

If a point is collected, it is added to the Tree 
View, under the Features branch. A measured 
status icon indicates the measured status.

The physical part location is optimized (a 
representation of the part is shown in blue), 
and if a point was collected, it is displayed in 
the 3D scene.

 

 

It is possible to measure several features 
simultaneously by selecting the Multiple 
Distances method.

Each feature can be assigned an individual 
Digital Readout that allows the user to track 
the probe position with regards to more than 
one destination.
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Taking basic measurements interactively

To quickly measure simple dimensions on a model, 
cross-section, or feature, use the Basic Measurements tool. 
Basic measurements include various distances, radii, curve 
lengths, and angles. Calculations are performed by simply 
anchoring on the object in the 3D scene. Basic measurements 
are not updatable, but offer a quick and easy way to get a 
measurement.

Objective: Measure an angle interactively. 

Required: The project contains a Reference and/or Data object.

Steps

1. Choose Measure > Interactive Measurements > 
Basic.

The Create Basic Measurements dialog box 
opens.

2. Specify the Angle measurement type to 
measure a basic angle on the part.

3. If the part is aligned to a coordinate system, 
select Project onto plane and choose a system 
plane or plane feature to constrain the angle 
measurement.

4. In the 3D scene, define one side of the angle by 
anchoring two or more points on the model.

Press and hold SHIFT to pick the closest vertex.

5. Right-click to confirm the first side.

1 2
485



MEASURING DIMENSIONS AND DEVIATIONS
Results 

Notes

6. Define the second side of the angle by 
anchoring two or more points on the model. 

Press and hold SHIFT to pick the closest vertex.

7. Right-click to end the measurement.

The angle measurement is added to the 
Tree View under the Interactive 
Measurements branch.

The angle measurement is displayed in the 
3D scene.

  

It is possible to perform basic measurements 
on cross-sections and features as well. This 
can make anchoring more accurate.

3
4
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Adding quantitative or visual checks

Inspection processes may require at some point 
quantitative checks using conventional metrology tools 
such as thread gauges, or visual checks such as the quality 
or presence of weld spots.

Quantitative checks imply physical measurements and are 
typically reported in terms of numerical values, while visual 
checks imply a qualitative test and are typically reported in 
terms of pass/fail values.

These checks can be added to the inspection project using the custom measurement objects.

Creating custom measurement objects

Objective: Create custom measurement objects to add quantitative or visual checks to the 
inspection project. 

Required: The project contains a Reference and/or Data object.

Steps

1. Choose Measure > Custom Measurements > 
Create.

The Create Custom Measurements dialog box 
opens.

2. Specify the Type:

• Numerical: Quantitative checks reported in 
terms of numerical values.

• Qualitative: Visual checks reported in terms 
of pass/fail values.

3. Choose one of the following creation methods:

Anchor

This method allows anchoring a point interactively at a representative location of the 
measurement. 

1. In the Method list, select Anchor.

2. Click Anchor.

The interactive anchoring mode is launched.
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Results 

Notes 

3. In the 3D scene, anchor a point at a 
representative location.

Press and hold SHIFT when anchoring to pick the 
closest vertex.

4. Right-click to exit the anchoring mode.

Numerically

This method allows defining the representative location of the point using specific 
coordinates.

1. In the Method list, select Numerically.

2. Specify the Position coordinates to define the 
location.

3. Click Create.

The custom measurement object is added to 
the Tree View, under the Custom 
Measurements branch.

The custom measurement object is displayed 
in the 3D scene.

  

The position and orientation (if any) of the custom measurement object are used during Play 
Inspection sequences to position and orient the 3D scene. 

The next step consists in defining the nominal and measured components for the Numerical 
type, or only the measured component for the Qualitative type.
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Defining the nominal component for the numerical type

Objective: Define the nominal component of a numerical type custom measurement object.

Required: The project contains a numerical custom measurement object.

Steps

Results 

Defining the measured component

Objective: Define the measured component of custom measurement objects.

Required: The project contains a custom measurement object.

Steps

1. In the Tree View, select the numerical custom 
measurement object for which to define the 
nominal component.

2. Choose Measure > Custom Measurements > 
Define Nominal.

Alternatively, right-click the selected object in the 
Tree View and choose Define Nominal.

The Define Nominal Custom Measurement 
Components dialog box opens.

3. Enter the value that defines the nominal 
component of the custom measurement 
object.

4. Click Create.

The nominal component of the numerical 
type custom measurement object is defined.

1. In the Tree View, select the custom 
measurement objects to measure.
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Results 

2. Choose Measure > Custom Measurements > 
Define Measured.

Alternatively, right-click the selected objects in the 
Tree View and choose Define Measured.

The Define Measured Custom Measurement 
Components dialog box opens. It is contextual 
to the type of custom measurement object:

Numerical type

1. Enter the Measured numerical value that 
defines the measurement. 

2. Click Create.

Qualitative type

1. In the Test list, select the qualitative value that 
defines the measurement. The following values 
are offered:

• Pass

• Warning

• Fail 

2. Click Create.

The measured component of custom 
measurement objects is defined.
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Notes 

• Tolerances can be adjusted using the Geometry Controls pane. See Editing control 
tolerances on page 501.

• In the PolyWorks Metrology Suite, the nominal and measured components of custom 
measurements are independent from the units set for the project. This means that if the 
project units are modified, custom measurement values are not converted. 

• It is also possible to measure an object using a scripted measurement method (see 
Scripted measurement methods on page 698).
491



MEASURING DIMENSIONS AND DEVIATIONS
Measuring when away from the workstation

When performing probing operations away from the computer, which is common for laser 
tracker applications, it may be helpful to have access to functions and operations, like 
capturing a point or changing the type of feature that will be probed, without having to go 
back to the computer. It is possible to perform these operations by using Talisman, which is 
the PolyWorks Metrology Suite mobile application.

Connecting to Talisman

Talisman gives remote control of the PolyWorks Metrology Suite such as: accessing the 
PolyWorks|Inspector 3D scene and performing 3D transformations; connecting to a probing 
or laser-scanning measurement device; configuring measurement modes and parameters; 
and data acquisition.

The Talisman application runs on mobile devices and communicates with the PolyWorks 
Metrology Suite via a Wi-Fi connection.

Objective: Have remote access to a PolyWorks|Inspector project using Talisman.

Required: The workstation and the mobile device must be connected to the same network 
and a PolyWorks|Inspector project must be open on the workstation.

Steps

1. In the Workspace Manager, choose Tools > 
Options.

2. In the Workspace Manager Options dialog box, 
open the Talisman page.

3. Select the PolyWorks server for Talisman 
parameter.

This enables communication between Talisman 
and the PolyWorks Metrology Suite. Unless the 
user configuration is reset, this only needs to be 
done once.

4. Click OK.

5. Start the Talisman application on the mobile 
device.

6. Within the Talisman application, select the 
project in order to view and perform desired 
operations.
492



MEASURING DIMENSIONS AND DEVIATIONS
Creating level planes

Some laser trackers have an electronic level that calculates the inclination of the tracker with 
respect to the axis of gravity. PolyWorks|Inspector allows the user to obtain the necessary 
information from the tracker's level to create a measured plane primitive. The plane is 
oriented with respect to gravity, which results in a plane that is perfectly horizontal.

Objective: Create a level plane.

Required: A laser tracker with an electronic level.

Steps  

Results  

Notes

Once the plane is created, a new coordinate system can be defined using this level plane by 
choosing Tools > Coordinate Systems > Create Cartesian.

1. Connect to the laser tracker in 
PolyWorks|Inspector.

2. Make sure that the laser tracker is initialized.

3. On the Probing Device Control toolbar, click 
the arrow next to the Orient to Gravity 
button.

4. Choose Create Level Plane.

The laser tracker performs a series of 
movements from which it will output a plane 
feature that is level.

The plane is added to the Tree View, under 
the Features branch.
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Orienting to gravity

When laser trackers have an electronic level, it is possible to orient them to gravity. The level 
inside the tracker computes the inclination of the tracker with respect to the axis of gravity so 
that acquired points are compensated by taking into account the computed inclination.

Objective: Orient the laser tracker to gravity.

Required: A laser tracker with an electronic level.

Steps  

Results  

1. Connect to the laser tracker in 
PolyWorks|Inspector.

2. Make sure that the laser tracker is initialized.

3. On the Probing Device Control toolbar, click 
the Orient to Gravity button.

The laser tracker performs a series of 
movements from which it measures its 
inclination angles.

A plumb bob icon appears to the left of the active 
device position to indicate that the laser tracker is 
oriented to gravity.
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Geometry controls 

Dimensional and GD&T controls
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Controlling measurements using geometry 
controls

When inspecting using measurement objects, namely features, cross-sections, comparison 
points, and gauges, the main purpose is to control whether the geometric characteristics of 
the objects are within the specified tolerance. This is done by adding controls on the 
geometric characteristics of measurement objects. These geometry controls can be of two 
types.

Dimensional controls – All measurement objects can have dimensional controls. These 
controls are used to control, using a tolerance, various geometric characteristics of 
measurement objects, like the diameter of a circle, the 3D distance of a comparison point, or 
the flush value of a flush & gap gauge. Each dimensional control reports a measured value 
and a deviation, is toleranced, and can report a nominal value. 

GD&T controls (features only) – Only feature objects can have GD&T controls. These special 
controls are used to control precise geometrical dimensions, as specified by the 
ASME Y14.5 and ISO standards. 

PolyWorks|Inspector offers the Geometry Controls pane that is the unique access through 
which the controls of all measurement objects are managed.

The Geometry Controls pane allows doing the following for a measurement object:

• View all dimensions and review the nominal, measured, and deviation values; note that 
distance controls and most GD&T controls typically only have a measured value, which is 
also the deviation.

• Choose the dimensions to tolerance (become dimensional controls).

• Create GD&T controls for features, as defined by the specified GD&T standard.

• Edit the tolerance for the controls.

By default, new controls are displayed in the annotation of features in the 3D scene, and are 
included in report tables created from all measurement objects.

To review and analyze the results of the geometry controls, it is recommended that the 
Control Reviewer tool is used. For information, see Reviewing measurement results using the 
Control Reviewer on page 533.
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The Geometry Controls pane

To open the Geometry Controls pane:

The Geometry Controls pane is displayed.  

It offers the list of controls for the selected measurement object, a contextual toolbar, column 
headers, and a measurement context header.

If no measurement object is selected in the Tree View, the list of controls appears empty and 
the buttons in the contextual toolbar are grayed out. 

1. Choose Measure > Geometry Controls.

Alternatively, click the Geometry Controls button 
on the Main Objects toolbar.

Column headers

Identify the values contained in the list of controls. It is possible to show/hide columns by 
right-clicking the column header and selecting the appropriate item. Columns can also be 
reordered by dragging them to a new location.

List of controls

Displays controls for the selected measurement object in the Tree View. 

Column headers

List of controls Contextual toolbar

Measurement context
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The contextual toolbar

Different functions are offered, depending on the context:  

Measurement context

Displayed when the selected object in the Tree View is a cross-section or a cross-section 
feature. Two uneditable text boxes are displayed, offering the following content:

• Data Alignment: displays the name of the data alignment to which the cross-section is 
bound (or the linked cross-section in the case of cross-section features).

• Best-Fit Activation State: displays the state of the best-fit alignment for the selected cross-
section (or the linked cross-section in the case of cross-section features).

Contextual toolbar 

It offers creation and editing functionalities. The toolbar varies depending on the 
measurement objects selected in the Tree View, as buttons can be missing or disabled. Some 
buttons display a dialog box, while others display a shortcut menu. Refer to the following 
section for more information.

Add/Remove Dimensional Controls

Available for all measurement objects. It allows activating or deactivating 
the mode for adding/removing dimensional controls.

Add GD&T Control

Available only when the selected measurement object is a feature. It 
displays the list of GD&T tools that can be added to the selected feature, 
according to the specified GD&T standard, along with their respective 
symbols. 

Set Controls using Template

It displays a shortcut menu that provides a list of the available control 
templates for the selected measurement object in the Tree View. By 
default, existing GD&T controls are preserved. 

Edit Controls

It either displays the Edit Controls dialog box, when selecting a dimensional 
control, or the editing window, when selecting a GD&T control. A multiple 
selection can be performed.

Remove Controls

It removes the selected controls. A multiple selection can be performed.
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Set as Default

It saves the current dimensional control specifications as a control 
template and sets it as the default template for the selected measurement 
object type. 

Save as Control Template

It saves the current dimensional control specifications as a control 
template for the selected measurement object type.
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Using the Geometry Controls

Adding and removing controls

The Geometry Controls pane allows viewing all dimensions (for example, radius, diameter, or 
X, Y, Z coordinates) and choosing which one will be used as a control. Check boxes and a 
different background color indicate whether each dimension is effectively controlled or not.

Objective: Specify dimensions to control for a measurement object.

Required: A measurement object.

Steps

Results

1. In the Tree View, select a measurement object.

Use a multiple selection to specify controls for 
same-type measurement objects simultaneously.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the feature type.

4. Select the desired controls in the expanded list.

Their current results are displayed in the pane.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.

The added controls, and their current results, are displayed in the Geometry Controls pane.  
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Notes

For features and gauges, if the nominal component is missing, its value can be entered directly 
in the cell under the Nominal column. The same applies for the Length, Perimeter, and Area 
dimensions of cross-sections.

The Geometry Controls pane is also used to add and encode Geometric Dimensioning and 
Tolerancing (GD&T) controls. See Adding and encoding GD&T controls on page 508 for more 
information.

Editing control tolerances

A tolerance, consisting of upper and lower tolerance limits, is assigned to each individual 
control. Values can be edited manually, or be changed by assigning a tolerance template that 
contains predefined tolerance limits.

Standard tolerance templates are provided. However, new tolerance templates can be 
created on the Objects > Tolerances page of the PolyWorks|Inspector Options dialog box. 
Choose Tools > Options to open the options dialog box.

Objective: Edit the tolerance of a geometry control.

Required: A measurement object.

Steps

1. In the Tree View, select a measurement 
object.

Use a multiple selection to specify tolerances 
for same-type measurement objects 
simultaneously.

2. Click the arrow in the Tolerance field.

3. Edit the tolerance limits using one of the 
following methods:

• Manually: Enter tolerance limit values in 
the dialog box displayed.

• Using a template: Click the Assign 
Tolerance button in the dialog box 
displayed and select a tolerance 
template.  
501



MEASURING DIMENSIONS AND DEVIATIONS
Results

Notes

Using control templates

When a measurement object is created, its controls and their tolerance are specified by the 
object’s default control template. In the Geometry Controls pane, new controls can be added 
and different tolerances can be specified for a measurement object. It is possible to save the 
current specifications as a new user control template for that type of object, which can then 
be used to set the controls of other objects of the same type. It can also be designated as the 
default control template for the particular type of object.

Control templates provided with the PolyWorks Metrology Suite are called standard templates 
and have the STD prefix in template lists, while control templates created by users have the 
USR prefix. Standard templates cannot be deleted.

Saving a control template

Objective: Save a control template from the current controls of a measurement object.

Required: A measurement object.

Steps

The new tolerance values are displayed in the 
pane.

Tolerances can be edited for multiple controls 
simultaneously by selecting the controls in 
the pane and clicking Edit Controls.

1. In the Tree View, select a measurement object.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, modify the controls if required. 
See Adding and removing controls on page 500 
and Editing control tolerances on page 501. 
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Results

Setting controls using a template

Objective: Set controls for a measurement object using a control template.

Required: A measurement object.

Steps

Results

4. Click Save as Control Template.

To save as the default control template for the 
type of measurement object, click Set as Default.

5. Specify the name of the new control template 
and click Save.

A user control template is saved for the type of 
measurement object. It can be used to set the 
contents of other measurement objects of the 
same type. The default template is in bold.

1. In the Tree View, select a measurement object.

Use a multiple selection to set the controls for 
same-type measurement objects simultaneously.

2. In the Geometry Controls pane, click Set 
Controls using Template.

3. Choose the template.

The control template is used to set the controls of the selected measurement object.
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Managing control templates

The template editor allows personalizing control templates, either to create a new control 
template, set a control template as the default for a measurement object type, edit the 
contents of a user control template (USR) or delete it from the list of templates.

Managing existing templates

Objective: For a type of measurement object, delete a user template from the list of 
templates and change the default control template.

Required: More than two control templates for the measurement object type.

Steps

Results

1. Choose Tools > Edit Templates.

The Edit Templates dialog box opens.

2. In the Type list, select Control.

3. Browse for the desired object type.

4. Select the control template to designate as the 
default control template.

The control template Dia+X+Y is selected as an 
example.

 

5. To make the selected template the default 
template, click Set as default.

6. To delete an existing user template (USR), 
select it and click Delete.

The new default control template is indicated 
in bold.

New circles will use the new default control 
template.
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Creating and editing a user control template

Objective: For a type of measurement object, create a new user template and edit its 
contents.

Required: PolyWorks|Inspector is open.

Steps

1. Choose Tools > Edit Templates.

The Edit Templates dialog box opens.

2. In the Type list, select Control.

3. Browse for the desired object type.

4. To create a new user template, click Create.

The Create User Template dialog box opens.
 

5. Specify the Name of the new user template.

6. Specify the Base Template for the new user 
template.

If a template is selected upon creation, it will be 
preselected as the base template by default. 

7. Click Create.

The newly created user template can be set as 
default by selecting the Set as default 
parameter.

 

8. Edit the content of the newly created control 
template, directly in the pane to the right, by 
selecting the desired controls and changing the 
tolerance values for the controls.

9. Click Apply.
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Notes

Controlling features

When inspecting using features, the geometric characteristics of the objects can be controlled 
with two types of controls: dimensional and GD&T.

• Dimensional controls: They allow controlling, using tolerances, all characteristics of a 
feature relating to size, location, and orientation, such as radius, origin, length, and angle. 
When nominal and measured values are present for a dimensional control, a deviation is 
calculated, and using the specified tolerance, a Pass/Fail status can be determined.

• GD&T controls: These controls are used to control precise geometrical dimensions, as 
specified by the ASME Y14.5 and ISO standards. The measurement envelope, datum 
constraints, measured results, and Pass/Fail statuses are displayed for each encoded 
control.

Adding dimensional controls

Objective: Add dimensional controls to a feature.

Required: A feature measurement object.

Steps

The new user control template is added to the 
list of templates.

It can now be assigned to measurement 
objects.

 

Edit the content of a user control template at any time by selecting it in the list, making the 
required modifications in the pane, then clicking Apply. 

1. In the Tree View, select a feature.

Use a multiple selection to modify same-type 
features simultaneously.
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Notes

If a nominal feature component exists, the nominal values are displayed in the Nominal 
column. If the component is missing, its nominal values can be entered directly in the fields.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the feature type.

4. Select each desired control in the expanded 
list.

Their current results are displayed in the pane.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.

The added controls and their current results are displayed in the Geometry Controls pane. 
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Adding and encoding GD&T controls

Objective: Add and encode a GD&T control.

Required: A feature measurement object.

Steps

1. In the Tree View, select a feature.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add GD&T Control.

4. In the list, select the desired GD&T control.

Only GD&T controls appropriate for the selected 
feature type, and the specified standard, are 
displayed. In this example, the ASME Y14.5 GD&T 
standard is specified.  

The GD&T standard can be specified on the 
Objects > Features > GD&T page of the 
PolyWorks|Inspector options.  

5. Enter the required information to define the 
GD&T control. The items offered depend on 
the specified GD&T tool and standard.

Datum Features must be defined before using 
them for encoding.

6. Press the ENTER key to confirm.
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Notes

When a GD&T control contains information (for example, an error or a warning), feedback is 
provided with different symbols in the Control column. Hovering the mouse over the symbol 
displays information about an invalid or incomplete GD&T encoding.    

The GD&T control is displayed in the Geometry Controls pane. If the feature contains a 
nominal and a measured component, the deviation is automatically calculated.  
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Defining datum features

Objective: Define a feature as a datum for use in GD&T controls.

Required: A feature.

Steps

Results

Notes

1. In the Tree View, select a feature.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

The property sheet of a feature can also be 
accessed by double-clicking on it.

3. Click the Feature tab.

4. Select a datum label in the Datum feature 
label list.

Labels that are already used are not available in 
the list. Custom datum labels can be created by 
entering them manually.

5. Click Apply.

The datum label is added to the feature, and 
the feature is renamed by default.

Datum labels can also be assigned to 
features during feature creation. While in the 
feature creation interface, select a datum 
label in the Datum feature label list.
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Defining datum targets

Objective: Define reference targets as a datum target for use in GD&T controls.

Required: A reference target point, line or area.

Steps

Results

Notes

When used in the Datum Reference Frame of a GD&T control, all index numbers of the 
specified datum are used. For example, if reference targets A1, A2, and A3 exist, and Datum A 
is specified in the Datum Reference Frame, all three reference targets are used.

1. In the Tree View, select a reference target.

Surface reference target points, reference target 
lines and reference target areas can be used as 
datum targets.

2. Choose Edit > Object Properties.

Alternatively, right-click the selected reference 
target in the Tree View and choose Properties.

The Properties dialog box opens.

3. On the Reference target tab, select a datum 
label in the Datum target label list.

Labels that are already used are not available in 
the list. Custom datum labels can be created by 
entering them manually.

4. A default index value, starting at 1, is 
automatically populated in the index field to 
the right. If desired, manually enter a custom 
index number.

5. Click Apply.

The datum label is added to the reference 
target and is renamed by default.

Datum labels can also be assigned to reference 
targets on creation. While in the creation 
interface, select a datum label in the Datum 
target label list.
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Defining composite datums

Objective: Create a composite datum from two or more datum features for use in GD&T 
controls.

Required: Two or more datums of the same feature type.

Steps

Results

1. Choose Measure > Features > Composite Datum 
Features.

The Composite Datum Features dialog box 
opens. 

In the Creation section:

2. Select the first datum feature in the first list.

3. Select a second datum feature of the same 
feature type in the second list, which appears 
after specifying the first one.

Only usable datum features, such as datum 
features of the same feature type, are displayed 
in the list.

4. Continue until the composite datum contains 
all the desired datum features.

5. Click Create.

The composite datum feature appears in the 
Composite datum features list.  

The composite datum feature is now 
available for use in GD&T controls.
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Creating features from measurement envelopes

Objective: Create features representing the GD&T measurement envelope.

Required: A valid and measured GD&T control.

Steps

Results

Notes

1. In the Tree View, select a feature.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, select a GD&T control.

4. Right-click in any field and choose Create 
Features > From Measured Envelope. 

A new feature is added to the Tree View that 
represents the shape and size of the 
measurement envelope.

The measured envelope is displayed in the 
3D scene at the location of the measured slot 
with respect to the DRF alignment.

  

The measurement envelope feature describes the measured value of the GD&T control, the 
envelope shape, and the measured location of the feature as constrained by the Datum 
Reference Frame.
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Controlling cross-sections

The Geometry Controls pane can be used to specify toleranced dimensional controls for a 
cross-section. Dimensional controls allow controlling, using tolerances, the characteristics of a 
cross-section relating to size, form, and deviation such as Min and Max deviations, line profile, 
length, and area. Results can be obtained when the nominal and measured components are 
present. For a control, typically the nominal and measured values are used to obtain a 
deviation and, using the tolerance and deviation, a Pass/Fail status is determined.

Objective: Specify controls for a cross-section.

Required: A cross-section.

Steps

1. In the Tree View, select a cross-section.

Use a multiple selection to modify cross-sections 
simultaneously.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the object type.

4. Select the desired controls in the 
expanded list.

Current values are displayed in the pane.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.
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Controlling comparison points

The Geometry Controls pane can be used to specify toleranced dimensional controls for a 
comparison point. Dimensional controls allow controlling, using tolerances, the 
characteristics of a comparison point that relate to its location in space. When the nominal 
and measured components are present, results can be obtained. For a control, typically the 
nominal and measured values are used to obtain a deviation and, using the tolerance and 
deviation, a Pass/Fail status is determined.

Objective: Specify controls for a comparison point.

Required: A comparison point.

Steps

The added controls and their current results are displayed in the Geometry Controls pane.  

1. In the Tree View, select a comparison point.

Use a multiple selection to modify comparison 
points simultaneously.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the object type.
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Controlling calipers

The Geometry Controls pane can be used to specify toleranced dimensional controls for a 
caliper. Dimensional controls allow controlling, using tolerances, the characteristics of a 
caliper that relate to its length and location in space. When the nominal and measured 
components are present, results can be obtained. For a control, typically the nominal and 
measured values are used to obtain a deviation and, using the tolerance and deviation, a 
Pass/Fail status is determined.

Objective: Specify controls for a caliper.

Required: A caliper.

Steps

4. Select the desired controls in the 
expanded list.

Current values are displayed in the pane for the 
new controls.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.

The added controls, and their current results, are displayed in the Geometry Controls pane.  

1. In the Tree View, select a caliper.

Use a multiple selection to modify calipers 
simultaneously.
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Controlling profile gauges

The Geometry Controls pane can be used to specify toleranced dimensional controls for a 
profile gauge. Dimensional controls allow controlling, using tolerances, the characteristics of a 
profile gauge that relate to its size and deviation from the nominal component. The exact 
controls available depend on the profile family type. For a control, typically the nominal and 
measured values are used to obtain a deviation and, using the tolerance and deviation, a 
Pass/Fail status is determined.

Objective: Specify controls for a profile gauge.

Required: A profile gauge.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the object type.

4. Select the desired controls in the 
expanded list.

Current values are displayed in the pane for the 
new controls.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.

The added controls, and their current results, are displayed in the Geometry Controls pane.  
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1. In the Tree View, select a profile gauge.

Use a multiple selection to modify profile gauges 
simultaneously.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the object type.

4. Select the desired controls in the 
expanded list.

Current values are displayed in the pane for the 
new controls.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.

The added controls, and their current results, are displayed in the Geometry Controls pane.  
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Controlling flush & gap gauges

The Geometry Controls pane can be used to specify toleranced dimensional controls for a 
flush & gap gauge. Dimensional controls allow controlling, using tolerances, the 
characteristics of a flush & gap gauge that relate to its size and deviation from the nominal 
component. The exact controls available depend on the flush & gap family and name. For a 
control, typically the nominal and measured values are used to obtain a deviation and, using 
the tolerance and deviation, a Pass/Fail status is determined.

Objective: Specify controls for a flush & gap gauge.

Required: A flush & gap gauge.

Steps

1. In the Tree View, select a flush & gap gauge.

Use a multiple selection to modify flush & gap 
gauges simultaneously.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the object type.

4. Select the desired controls in the 
expanded list.

Current values are displayed in the pane for the 
new controls.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.
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Controlling airfoil gauges

The Geometry Controls pane can be used to specify toleranced dimensional controls for an 
airfoil gauge. Dimensional controls allow controlling, using tolerances, the characteristics of 
an airfoil gauge that relate to its size, form, and deviation from the nominal component. The 
exact controls available depend on the airfoil family. For a control, typically the nominal and 
measured values are used to obtain a deviation and, using the tolerance and deviation, a 
Pass/Fail status is determined.

Objective: Specify controls for an airfoil gauge.

Required: An airfoil gauge.

Steps

The added controls, and their current results, are displayed in the Geometry Controls pane.  

1. In the Tree View, select an airfoil gauge.

Use a multiple selection to modify airfoil gauges 
simultaneously.

2. Choose Measure > Geometry Controls.

The Geometry Controls pane opens.

3. In the pane, click Add/Remove Dimensional 
Controls to display all available dimensional 
controls for the object type.
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4. Select the desired controls from the expanded 
list.

Current values are displayed in the pane for the 
new controls.

5. Click Add/Remove Dimensional Controls 
again to show only the effective controls.

The added controls and their current results are displayed in the Geometry Controls pane. 
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Annotations

Annotations are graphical notes displayed in the 
3D scene in order to identify objects and provide 
information about them. By default, each object 
shown in the 3D scene has an annotation attached 
to it. 

Annotations differ slightly from one type of object 
to another.

Annotation overview

Annotations are typically in a table format. Here is a typical example of an annotation:

1 Annotation mini 
toolbar

A toolbar displayed when hovering the mouse over an 
annotation. For more information, see The Annotation mini 
toolbar on page 525.

2 Header
Displays the object name, preceded by an icon that represents 
the object type and the measurement status of the object 
(measured or unmeasured).

3 Lines List all the object controls, one per line.

4 Columns Present attributes of the controls, such as the nominal, 
measured and deviation values, as well as the pass/fail test. 

5 Attachment line A line that links the annotation to the corresponding object.

6 Attachment point The location where the annotation is attached to the object.

2

4

3

5

1

6
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The Annotation mini toolbar

The annotation mini toolbar is displayed when hovering the mouse over an annotation. It 
offers the following buttons:    

Position Annotations

Enables or disables the interactive mode that allows repositioning 
annotations in the 3D scene. For more information, see Repositioning annota-
tions in the 3D scene on page 526.

Lock/Unlock Annotation Position

Locks or unlocks the position of the current annotation. When the annotation 
is locked, its position remains unchanged with respect to the object. Its 
repositioning is only possible using the Position Annotations tool. 

Edit Annotation

Opens a dialog box that allows specifying the type of information that will be 
displayed in the current annotation or modifying the appearance of this 
annotation. For more information, see Editing an object annotation on 
page 530.

Hide Annotation

Hides the current annotation. Hover the mouse over the attachment point of 
the annotation to display a button that allows displaying the annotation.
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Repositioning annotations in the 3D scene

To maximize the clarity of report snapshots, it is possible to reposition annotations in the 
3D scene prior to taking a snapshot. This operation can be made for a specific annotation or 
for all annotations simultaneously.

Objective: Reposition object annotations in the 3D scene.

Required: The project contains an object with a visible annotation.

Steps  

1. Choose Tools > Annotations > Position.

Alternatively, mouse over the annotation and 
click the Position Annotation button on the 
Annotation mini toolbar.

The positioning annotation mode is activated.

The Annotation Display Options toolbar is 
displayed in the lower part of the 3D scene. 
See The Annotation Display Options toolbar on 
page 528.

2. Reposition the annotations using one of the 
following methods.

Interactively

This method allows repositioning annotations individually in the 3D scene by dragging them 
to the desired location.

1. Left-click an annotation. 

The annotation is displayed in red, and a hand 
symbol is displayed when hovering the mouse 
over the annotation.

2. Hold the left mouse button and drag to the 
desired location.

• Press Spacebar to temporarily exit the mode 
and perform rotations/translations.

• Press ESC to exit the mode or click the first 
button on the mini toolbar.
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Automatically

This method allows repositioning annotations simultaneously in the 3D scene based on the 
automatic repositioning modes available.

1. On the Annotation Display Options toolbar, 
click the arrow next to the annotation 
positioning button.

2. Choose a positioning mode from the drop-
down list to position all annotations either:

• Close to object: annotations are 
automatically positioned as close as 
possible to their related object.

• Close to border: annotations are 
automatically positioned along the top, 
bottom, left, and right boundaries of the 3D 
Scene pane in a way that minimizes 
annotation overlap and the intersection of 
annotation attachment lines. 

The annotations are now repositioned in the 3D scene. When they have been repositioned 
automatically, two choices are offered and the difference between both is shown below:

• Close to border
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The Annotation Display Options toolbar

• Close to object

• The View menu offers tools used to hide, hide interactively, and restore annotations.

• When an annotation is repositioned by the user, it is automatically locked, which means 
that the length and the orientation of the attachment line will not change, even when 
performing a transformation in the 3D scene (for example, zoom, rotation, and 
translation). The annotation can be unlocked using the appropriate button on the mini 
toolbar, or by right-clicking the object in the Tree View, and choosing Annotation > Unlock 
Position.

Sets the annotation positioning mode to close to object/border

Menu button that allows positioning the annotations close to the object or 
along the boundaries of the 3D Scene pane. In both cases, the annotation 
overlap and the intersection of annotation attachment lines are 
minimized.

Options related to annotation positioning mode

Offers options that allow controlling the display and positioning of 
annotations. It also allows specifying the minimal length of the attachment 
line, in pixels.
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Locks/unlocks the position of all annotations

Menu button that allows locking or unlocking the position of all 
annotations.

Hides or restores all annotations

Displays or hides all annotations. 
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Editing an object annotation

On creation, the information of object annotations is determined using a default annotation 
template. The content of an annotation can be changed by applying another template, or by 
adding and removing items manually. It is also possible to modify the appearance of 
annotations.

Setting object annotation content

Annotations are configurable. It is possible to add or remove information items displayed on 
creation, as well as to modify the order in which the items appear. 

Objective: Edit the content of an object annotation.

Required: The project contains an object.

Steps

1. Choose Tools > Annotations > Edit, then left-click 
an object annotation in the 3D scene.

Alternatively, mouse over the annotation, and 
click the Edit Annotation button on the 
Annotation mini toolbar.

The annotation editor opens, displaying the 
object annotation.

2. Set the object annotation content using one of 
the following methods.

From a Template

1. On the annotation editor toolbar, click Set 
Contents using Template.

2. On the menu, select the annotation template 
to apply. 
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Results

The annotation content is set as specified.

Manually

1. On the annotation editor toolbar, click Edit 
Contents.

2. On the menu, select the section of the 
annotation to modify.

In this example, Columns is selected. The Edit 
Columns dialog box opens.

Alternatively, right-click in an empty area of the 
annotation editor and click Edit Header, Edit 
Columns or Edit Lines to access the dialog box 
that allows editing the appropriate content.

The changes made can be applied to all same-type 
objects by clicking the check box at the bottom of 
the Edit Annotation dialog box.
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Modifying the appearance of annotations

It is also possible to modify the appearance of annotations.

Objective: Edit the appearance of an annotation.

Required: The project contains an object with an annotation.

Steps

Results

The annotation appearance is set as specified.

1. Choose Tools > Annotations > Edit, then left-click 
an object annotation in the 3D scene.

Alternatively, mouse over the annotation, and 
click the Edit Annotation button on the 
annotation mini toolbar.

The annotation editor opens, displaying the 
object annotation.

2. On the annotation editor toolbar, click Edit 
Format.

The Display > Annotations > Formatting 
page of the PolyWorks|Inspector Options 
dialog box opens.

3. Edit the formatting options of annotations.

4. Click Apply.

The formatting is applied to all annotations 
that appear in the 3D scene.
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Reviewing measurement results using the 
Control Reviewer

The Control Reviewer offers a condensed view of the most important information of an 
inspection project: geometry controls. It displays a table of the controls, and it offers 
operations to filter, sort, and group them in views. Its content is also synchronized with the 
3D scene. Unlike 2D formatted reports, the 3D scene can be manipulated to better view the 
information.

The Control Reviewer can be used to:

• Review metrology results in an effective way

• Structure inspection projects

• Enhance the reporting workflow

The Control Reviewer pane

To open the Control Reviewer pane:

The Control Reviewer pane is displayed. It offers the Controls list box, a contextual toolbar, 
column headers, the list of controls, and statistics.     

1. Choose Report > Control Reviewer.

Alternatively, click the Control Reviewer button 
on the Main Objects toolbar.

Column headers

List of controls

Controls list box

Contextual 
toolbar

Statistics

Menu bar
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Menu bar

Provides access to all Control Reviewer functionalities. 

Controls list box

Specifies the controls that will be listed in the pane. 

An asterisk is displayed next to the control view name when there are new changes to the 
specified control view that have not been applied. 

Contextual toolbar 

Offers quick access to common operations. The operations offered on this toolbar change 
according to the selected item in the Controls list box.

Column headers

Used to filter and sort controls. It is also possible to show/hide column headers as well as 
reorder them.

List of controls

Displays controls according to the item selected in the Controls list box. Filters can also be 
applied to reduce the number of controls displayed.

Statistics

Displays statistics on the controls listed in the pane:

• Total number of controls;

• Number of measured controls;

• Number of controls that are out-of-tolerance (Fail) or for which a warning is issued.
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The contextual toolbar

Different tools are offered, depending on the context:    

Create Control View

Enters a creation mode based on all the controls listed in the pane, and 
opens the Create Control View dialog box.

Create Control View from Selected Controls

Enters a creation mode based on the controls selected in the pane, and 
opens the Create Control View dialog box.

Apply Changes to Control View

Applies the pertinent changes to the control view that is specified in the 
Controls list box. 

Clear Filters

Removes all applied filters.

Edit Context

Opens the Edit Context dialog box, which is used to edit the coordinate 
system and the data alignment used to display the controls currently 
selected.

Center on All Controls

Positions the 3D scene to show all the controls currently listed in the pane 
as much as possible, as well as their annotations.

Center on Selected Controls

Positions the 3D scene to show the controls currently selected as much as 
possible, as well as their annotations.

Restore Project View

Restores the 3D scene project view of the current control view.

Create Snapshot and Table

Creates a report snapshot and a report table for the current control view.
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Create Table

Creates a report table for the current control view.

Create Snapshot

Creates a report snapshot for the current control view.
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Using the Control Reviewer

Reviewing controls

By default, all active controls of all measurement objects in the project are listed in the 
Control Reviewer pane, offering an overview of the results without having any report items or 
formatted reports created. These controls can be filtered and sorted.

Filtering controls using the Controls list

Steps  

Results 

1. In the Control Reviewer pane, open the 
Controls list box.

2. Choose one of the following options:

• (All Controls): Displays all active controls of 
all measurement objects in the inspection 
project.

• (From Selected Objects): Displays all active 
controls of the selected measurement 
objects. Objects can be selected in the 
3D scene as well as in the Tree View.

• Control Views: User-defined control views 
are listed under this item. Displays the 
controls associated with the selected control 
view.

Controls are listed in the pane according to the selection made in the Controls list box.
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Filtering controls using filters

Steps  

1. In the Control Reviewer pane, identify the 
columns that have a filter icon.

Column headers with a filter icon indicate that 
controls in that column can be filtered.

2. Click the filter icon of a column header.

A contextual dialog box is displayed.

3. Enable the Activate filter parameter.

Depending on the column, controls can be 
filtered using a string-based filter, or a multiple 
selection from a predefined list of filters.

String-based filter

1. In the list, choose a filtering method:

• Is Equal To: Search for strings that are equal 
to the specified string.

• Contains: Search for strings that contain the 
specified string.

2. Type the string that will be used to filter the 
controls.

Multiple-selection based filter

1. In the list, choose a filtering method:

• Is Equal To: Search for results that are equal 
to the selection.

• Is Different From: Search for results that 
are different from the selection.

2. Select the desired expressions used to filter 
controls.
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Notes

Sorting controls

Steps

The list of controls is filtered, and only the relevant controls are displayed.

• When a column is filtered, its header is displayed in italics and the filter icon is colored.

• When filtering controls within a control view, 
an asterisk is added next to the name of the 
control view indicating that the changes have 
not been applied. Click Apply Changes to 
Control View.

Alternatively, choose Control View > Apply 
Changes from the Control Reviewer menu bar.

1. In the Control Reviewer pane, move the mouse 
pointer over the desired column header.

2. Click a column header to sort controls. 

All column headers can be sorted by increasing/
decreasing values. A third click on a column 
header removes the sorting.
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The list of controls is sorted.

Notes

When sorting controls within a control view, an 
asterisk is added next to the name of the control 
view indicating that the changes have not been 
applied. Click Apply Changes to Control View.

Alternatively, choose Control View > Apply Changes 
from the Control Reviewer menu bar.
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Introducing control views

Historically, engineering drawings have been conceived in terms of views: top, side, front, and 
auxiliary views present the dimensions and measurements of a part. CAD software capable of 
adding PMI to 3D models also use the concept of views.

Control views can be used to review measurement results in an effective and structured 
manner, offering an enhanced inspection workflow. Several methods can be used to create 
control views. Two of them are explained in the following subsections.

Creating control views from objects in the 3D scene

A control view can be easily created from objects in the 3D scene. If desired, a report snapshot 
and a report table are created at the same time. By default, they are added to the active 
formatted report.

Objective: Create a control view that will include controls for objects in the 3D scene.

Required: The project must have measurement objects with controls.

Steps

1. Position the 3D scene to show all objects that 
will be part of the control view, adjust their 
orientation, and position their annotation.

The control view will include controls for all 
objects in the 3D scene whose annotations are 
displayed, as well as controls for objects whose 
control labels are displayed.

2. On the main toolbar, click Create Control 
View from Objects in the 3D Scene.

The Create Control View from 3D Scene dialog 
box opens. 

3. Specify a name for the control view.

By default, report items (snapshot and report 
table) are created from this control view.

4. Click Create.
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Creating control views from selected controls

A control view can be created from a selection of controls in the Control Reviewer pane.

Objective: Create a control view based on a selection of controls.

Required: The project must have measurement objects with controls.

Steps

1. In the list of controls, select the controls that 
will be included in the control view.

Use CTRL or SHIFT when left-clicking to select 
multiple controls.

If desired, controls can be filtered and sorted 
to list only specific controls in the pane. 

2. In the Control Reviewer pane, click Center on 
Selected Controls. 

This positions the 3D scene to show, as much 
as possible, the associated objects and their 
annotations.

3. In the Control Reviewer pane, click Create 
Control View from Selected Controls.

The Create Control View dialog box opens.
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4. In the 3D scene, adjust the orientation of the objects and position of the annotations.

While in the creation mode, a toolbar that offers quick access to annotation display options is 
available. See The Annotation Display Options toolbar on page 528 for detailed information. 

5. In the Create Control View dialog box, specify a 
name for the control view.

By default, report items (snapshot and report 
table) are created from this control view.

6. Click Create.
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Results 

• Report items linked to the control view are created and automatically included in the active 
formatted report. 

 

• The control view is saved and added to the Control Views section of the Controls list box.
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• The control view can now be selected in the Controls list box. When selected, its controls 
are listed in the pane, and the associated 3D scene view is displayed.
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Managing control views  

Control views can be deleted, reordered, and renamed.

Steps

1. In the Control Reviewer pane, choose Control 
View > Manage Control Views.

The Manage Control Views dialog box opens.  

2. Select the desired control views in the control 
view list area.

The CTRL and SHIFT keys can be used to perform 
a multiple selection.

The vertical toolbar is made available.

• Click Delete to delete the selected control 
views.

Alternatively, select the control view from the 
controls list box. Choose Control View > Delete.

• Click the Move Up and Move Down buttons 
to move the selected control views within 
the list.

By default, control views are listed in creation 
order.
546



REPORTING MEASUREMENT RESULTS
Alternatively, drag and drop control views in the 
control view list area to place them in the desired 
order. 

• Click the text box to rename the control 
view.

Alternatively, choose Control View > Properties to 
rename a selected control view.

3. Changes are automatically applied to the list of 
control views as soon as they are made. Click 
Close.
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Results  

The changes made to the selected control 
views in the Manage Control Views dialog box 
are automatically applied.

 

Notes

Object visibility options can be specified for each control view:

• Select a control view.

• Choose Control View > Properties.
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Editing control views 

Steps

1. In the Control Reviewer pane, select a control 
view in the Controls list box.

2. Select the controls to edit. Choose Edit from 
the menu bar. Choose one of the following: 

• Edit color scale limits.

• Modify the context of the selected controls 
or the controls themselves.

• Clear filters for selected controls.

• Add selected controls to another control 
view.

• Remove the selected controls or the 
corresponding objects from the control 
view.

• Select the corresponding objects in the Tree 
View for the selected controls.

• Display the properties for the corresponding 
object of a selected control. 

3. An asterisk is added next to the name of the 
control view in the Controls list box when 
changes are made in the 3D scene, to the 
objects, or to the controls of the current 
control view but the changes have not yet 
been applied.

Click Apply Changes to Control View to apply 
the changes. 

Alternatively, choose Control View > Apply 
Changes from the Control Reviewer menu bar.
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Results  

The control view now contains all the 
changes that were made. 
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Displaying controls in the 3D scene

Controls and their associated measurement objects can be displayed in the 3D scene based 
on the project view embedded in a control view, or based on the content of Control Reviewer 
pane.

From a control view

Steps

Results  

1. In the Control Reviewer pane, choose a control 
view from the Controls list box.

The project view associated with the control view is shown in the 3D scene and the reviewing 
control view mode is launched.  
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Notes 

• A project view contains the list of displayed objects, elements, and annotations and their 
position in the 3D scene. 

• The 3D scene project view can be adjusted while in the reviewing control view mode. 

• If the project view associated with the control view is adjusted but not saved, an asterisk 
is displayed next to the name of the control view indicating that the changes have not 
been applied.  

Click Apply Changes to Control View on the 
Control Reviewer toolbar to apply changes.

• Click Restore Project View to restore the 
saved project view, which corresponds to 
last time any changes were applied to that 
control view. 
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From the list of controls 

Steps

Center on All Controls
1. If desired, filter and sort controls to display 

only specific controls in the list of controls.

2. Click Center on All Controls.

Center on Selected Controls
1. In the list of controls, select the controls that 

will be displayed in the 3D scene.

Use SHIFT or CTRL when left-clicking to select 
multiple controls.

2. Click Center on Selected Controls.
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Results 

The 3D scene displays the controls based on the selection that was previously made.
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Generating snapshots and report tables from control 
views

Reports can also be used to analyze and communicate inspection measurements. Typically, a 
report consists of report tables and snapshots, complete with observations, comments, and 
conclusions – all formatted into a printable document.

Reporting using control views allows generating snapshots and report tables that are 
synchronized and linked to control views. In other words, snapshots display the project view 
of the control view they are associated with, and report tables display the controls of the 
control view they are associated with.

Steps

1. In the Controls list box of the Control Reviewer 
pane, select the control view that will be in the 
report. 

2. Click the arrow next to Create Snapshot and 
Table, and choose one of the following:

• Create Table: Creates a report table linked 
to the current control view.

• Create Snapshot: Creates a snapshot 
linked to the current control view.

• Create Snapshot and Table: Creates a 
snapshot and a report table linked to the 
current control view.
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Results  

Notes

Report items linked to the control view are created and automatically included in the active 
formatted report. 

 

• When creating a control view, it is possible to 
create both the control view and the 
corresponding report items.

• Report items of all control views can also be 
automatically generated by choosing Report > 
Create Snapshots and Tables > From All Control 
Views.
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Viewing measurement results using the object 
navigator

Object navigators are specialized tools that 
allow viewing objects one by one. In 
addition, they display the dimensional and 
GD&T controls of features, and the 
measurement results of gauges. 

Such visualization of the measurements 
provides information about deviation 
sources and direction, which can be useful 
when troubleshooting.

Object navigators are available for:

• Features

• Cross-sections

• Airfoil gauges

• Flush & gap gauges

• Profile gauges

To access the object navigators, choose one from the View > Object Navigator submenu.
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Reviewing feature measurement results

The Feature Navigator is useful to review feature results, 
in order to view the dimensional and the GD&T 
measurements for each feature individually. This 
visualization of the measurements provides information 
about the deviation. Note that when features are 
created on cross-sections, features are shown on their 
cross-section.

Feature dimension results

Objective: Display the result of a dimensional measurement on the model.

Required: The PolyWorks|Inspector project must have measured features with a 
dimensional control.

Steps

Results

1. In the Tree View, select the features to 
visualize.

2. Choose View > Object Navigator > Features or 
right-click and choose View > Feature Navigator. 

The Feature Navigator dialog box opens.

3. In the Feature list, select the feature to display.

4. In the Control list, select the dimensional 
control to display.

5. To display the nominal and/or measured 
feature, select Show nominal components 
and/or Show measured components.

The feature dimensions for the selected 
feature are displayed in the 3D scene.
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Feature GD&T controls

Objective: Display the result of a GD&T measurement on the model, showing the datum 
reference frame, alignment, and calculated features.

Required: The PolyWorks|Inspector project must have a measured feature with a GD&T 
control.

Steps

1. In the Tree View, select the feature to visualize.

2. Choose View > Object Navigator > Features or 
right-click and choose View > Feature Navigator.

The Feature Navigator dialog box opens.

3. In the Control list, select the GD&T control to 
display.

4. To display the nominal and/or measured 
feature, select Show nominal components 
and/or Show measured components.

5. A color map can be displayed on GD&T 
controls that are measured using data points 
(for example, Surface Profile) by selecting 
Show GD&T control color map.

6. If Show datum reference frame alignment is 
selected, it displays the dataset and measured 
features in position, as defined by the datums 
in the datum reference frame.

7. Display the datum reference frame 
components by selecting the items under 
Datum features.
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Results

The model, datums used in the datum 
reference frame, and feature itself are 
displayed in the 3D scene. The measured 
features are aligned using the datum 
reference frame.

The nominal feature and the aligned and 
constrained measured feature are displayed, 
using Pass/Fail colors.

  

Measured Nominal
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Reviewing cross-section measurement results 

It is useful to review cross-section results, using the Cross-
Section Navigator, in order to visualize each cross-section 
individually. Such visualization of the cross-sections 
provides information about deviation, which can be useful 
when troubleshooting. 

Objective: Display the results of a cross-section, showing the nominal and measured 
sections and deviations.

Required: The PolyWorks|Inspector project must have measured cross-sections.

Steps

1. In the Tree View, select the cross-sections to 
visualize.

2. Choose View > Object Navigator > Cross-
Sections or right-click and choose View > Cross-
Section Navigator.

The Cross-Section Navigator dialog box opens.

3. In the Cross-section list, select the cross-
section to display.

4. Select Show nominal component and/or 
Show measured component to display the 
nominal and/or measured cross-section 
components. 

5. To manually modify the cross-sections by 
extending, adjusting, or cutting them, click the 
Extend, the Pick and Place Vertices, or the 
Cut Segments button.
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Results

Notes 

The cross-sections and deviations are 
displayed in 2D in the 3D scene.

 

By default, measured cross-sections are 
displayed along with a deviation color map 
and deviation vectors. To hide the color map 
and show only the cross-section profiles, click 
Hide Color Map.
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Reviewing profile gauge measurement results 

It is useful to review profile gauge results, using the Profile Gauge 
Navigator, in order to see how the results were obtained. Such 
visualization provides information about deviation, which can be 
useful when troubleshooting. 

Objective: Display the result of a profile gauge, showing the 
measurement zone, cross-sections, and gauge dimensions.

Required: The PolyWorks|Inspector project must have measured profile gauges.

Steps

1. In the Tree View, select the profile gauges to 
visualize.

2. Choose View > Object Navigator > Profile 
Gauges or right-click and choose View > Profile 
Gauge Navigator.

The Profile Gauge Navigator dialog box opens.

3. In the Profile gauge list, select the gauge to 
display.

4. In the Component list, select a component to 
display the Nominal or Measured 
component. 

5. To show the components of the cross-sections 
used to calculate the profile gauge, select 
Show nominal component and/or Show 
measured component.
563



REPORTING MEASUREMENT RESULTS
Results

Notes

To view both the nominal and measured profile gauge results simultaneously, select Split 
view. The nominal cross-sections and profile gauge dimensions are displayed on the left. The 
measured cross-sections and profile gauge dimensions are displayed on the right.

The profile gauge dimensions and linked 
cross-sections are displayed in 2D in the 
3D scene.

 

Nominal Measured
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Reviewing flush & gap gauge measurement results 

It is useful to review flush & gap gauge results, using the Flush & 
Gap Gauge Navigator, in order to see how the results were 
determined. Such visualization provides information about 
deviation, which can be useful when troubleshooting.

Objective: Display the result of a flush & gap gauge, showing 
the measurement zone, cross-sections, and gauge dimensions.

Required: The PolyWorks|Inspector project must have measured flush & gap gauges.

Steps

1. In the Tree View, select the flush & gap gauges 
to visualize.

2. Choose View > Object Navigator > Flush & Gap 
Gauges or right-click and choose View > Flush & 
Gap Gauge Navigator.

The Flush & Gap Gauge Navigator dialog box 
opens.

3. In the Flush & gap gauge list, select the gauge 
to display.

4. In the Component list, select a component to 
display the Nominal or Measured 
component. 

5. Select the Show variable annotations to 
display the coordinates of the gauge contact 
points and other gauge key points.

6. To show the components of the cross-sections 
used to calculate the flush & gap gauge, select 
Show nominal component and/or Show 
measured component.
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Results

Notes

To view both the nominal and measured flush & gap gauge results simultaneously, select Split 
view. The nominal cross-sections and flush & gap gauge dimensions are displayed on the left. 
The measured cross-sections and flush & gap gauge dimensions are displayed on the right.

The flush & gap gauge dimensions and linked 
cross-sections are displayed in 2D in the 
3D scene.

 

Nominal Measured
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Reviewing airfoil gauge measurement results 

It is useful to review airfoil gauge results, using the Airfoil Gauge 
Navigator, in order to examine each individual cross-section. 
Such visualization provides information about deviation, which 
can be useful when troubleshooting.

Objective: Display the result of an airfoil gauge, showing the measurement zone, cross-
sections, and gauge dimensions.

Required: The PolyWorks|Inspector project must have measured airfoil gauges.

Steps

1. In the Tree View, select the airfoil gauges to 
visualize.

2. Choose View > Object Navigator > Airfoil 
Gauges or right-click and choose View > Airfoil 
Gauge Navigator.

The Airfoil Gauge Navigator opens.

3. In the Airfoil gauge list, select the gauge to 
display.

4. In the Component list, select a component to 
display the Nominal or Measured 
component. 

5. To show the components of the cross-sections 
used to calculate the airfoil gauge, select Show 
nominal component and/or Show measured 
component.
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Results

Notes

To view both the nominal and measured gauge results simultaneously, select Split view. The 
nominal cross-sections and gauge dimensions are displayed on the left. The measured cross-
sections and gauge dimensions are displayed on the right.

The airfoil gauge dimensions and linked 
cross-sections are displayed in 2D in the 
3D scene.

 

Nominal Measured
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Reporting

Producing reports is key to analyzing and communicating inspection measurements. Typically, 
a report consists of report tables and report snapshots, completed by observations, 
comments, and conclusions, all formatted into a printable document.

PolyWorks|Inspector offers tools to generate and edit such reports.

Here is the typical workflow for reporting: 

1. Create report tables.

Create report tables from 
measurement objects in the Tree 
View. 

They are automatically added to the 
active formatted report

2. Create 3D scene snapshots.

Create snapshots of the 3D scene to 
show inspection results.

They are automatically added to the 
active formatted report.

3. Prepare the formatted report.

Using the Report Editor tool, format 
the report to include project and 
piece information, comments on the 
results, and shapes to emphasize 
content. 

4. Export.

Export the formatted report into 
different formats, such as PDF.

The individual report items can be 
exported as well. An example is to 
export to Microsoft Excel.
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Working with report tables

A report table is a listing of the desired information of any measurement object, such as 
nominal and measured values, tolerances, deviations, and pass/fail status. Tables are a very 
useful way to summarize inspection results.

Typically, a measurement object report table 
includes a title, a header area, the name of each 
object, and the following information for each 
of its controls: 

• Nominal and measured values

Note that certain dimensional controls (for example, distance controls), and GD&T controls 
(except size controls), do not have nominal values.

• Tolerance limits

• A deviation

• A pass/fail test result

• Out-of-tolerance value

Since objects are updated by the Automatic Project Update mechanism, table results are 
automatically updated as well. Table contents and formatting can be edited to suit different 
reporting needs. Table reports can be incorporated into a formatted report or exported for 
use in applications like Microsoft Excel.

Creating report tables

Objective: Create a report table containing the current results of a measurement object.

Required: The project contains a measurement object.

Steps

1. In the Tree View, select the measurement object 
for which to report measurements.

2. Choose Report > Create Tables > From Objects.
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Results

Notes

If two or more types of object are selected, a report table will be generated for each type. In 
the example shown below, all selected features are included in one report table, and selected 
comparison points are included in a second report table.

The report table is added to the active 
formatted report, shown at the bottom of the 
Tree View.

The report table is automatically positioned 
on a page in the report, and can be viewed 
by double-clicking the report name in the 
Tree View.
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Setting report table contents using a template

When a report table is created from a measurement object, its contents are specified by the 
object’s default table template. The report table can then be edited as required, by adding and 
removing information and changing the formatting. A new user table template can be created 
from the setup of the current report table, and can then be used to set the contents and 
formatting for other reports of the same type. It can also be designated as the default table 
template for the particular type of report table.

Table templates provided with the PolyWorks Metrology Suite are called standard templates 
and have the STD prefix in template lists, while table templates created by users have the USR 
prefix. Standard templates cannot be deleted.

Objective: Set the contents of a report table by applying a table template.

Required: The project contains a report table.

Steps

Results

The report table has the contents and formatting defined by the table template.

1. In the Tree View, double-click a report name to 
open the Report Editor.

2. In the Report Editor, select a report table.

3. Choose Edit > Table.

The table editor opens displaying the report 
table.

4. On the table editor toolbar, click Set Contents 
using Template.

5. On the menu, select the table template to 
apply.
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Editing report table contents manually

Objective: Edit the contents of a report table manually.

Required: The project contains a report table.

Steps

1. In the Tree View, double-click a report name to 
open the Report Editor.

2. In the Report Editor, select the report table to 
edit.

3. Choose Edit > Table.

The table editor opens displaying the report 
table.

4. On the table editor toolbar, click Edit Contents 
to edit the contents.

5. On the menu, select the section of the table to 
modify.

In this example, Columns is selected. The Edit 
Columns dialog box opens.
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Results

6. To add columns, select them in the Available 
columns list, and click the Add arrow to 
transfer them to the Displayed columns list.

7. To remove displayed columns, select them in 
the Displayed columns list, and click the 
Remove arrow to transfer them to the 
Available columns list.

8. Reorder the displayed columns using the Move 
Up and Move Down arrows located on the right 
side.

9. Click Apply to view the changes in the table.

10. Click OK to close the editor.

11. Repeat steps 3 through 9 to edit other sections 
of the table.

A similar dialog box is available when editing the 
other sections, such as Title and Table Header. 
However, when editing Lines, the dialog box 
features a list box that specifies if a table shows All 
Controls for the measurement objects, or allows 
selecting Specific lines (specific controls and 
dimensions) – Specific must be selected.

The report table now contains the desired information.
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Notes

Edit more quickly using the shortcut menus available by right-clicking in the different sections 
of the table editor:

• Click Edit Title, Edit Table Header, Edit Object Header, Edit Columns, and Edit Lines for 
the dialog boxes like those described previously.

• Add and remove items for each section by clicking them on the section’s shortcut menu.
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Saving a table template

Objective: Save a table template from a modified report table.

Required: The project contains a report table.

Steps

Results

1. In the Tree View, double-click a report name to 
open the Report Editor.

2. In the Report Editor, select a report table.

3. Choose Edit > Table.

The table editor opens displaying the report 
table.

4. On the table editor toolbar, click Save as 
Template to save the current report table 
configuration as a user table template.

The Save as Template dialog box opens.

5. Specify the name of the new table template 
and click Save.

The new user table template (USR) is saved. It 
can be applied to other report tables of the 
same type.
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Managing table templates

The template editor allows personalizing table templates, either to create a new table 
template, to set a table template as the default one, edit the contents of a user table template 
or delete it from the list of table templates.

Managing existing templates
Objective: For an object type, set a default table template, or delete a user template from the 

list of table templates.

Required: More than two table templates for the object type.

Steps

1. Choose Tools > Edit templates.

The Edit Templates dialog box opens.

2. In the Type list, select Table.

3. Browse for the desired table type.

4. Select the table template to define as the 
default one.

The feature table template SavedTemplate is 
selected as an example.

5. To make the selected template the default 
template, click Set as Default.

6. To delete an existing user template (USR), 
select it and click Delete.
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Results

Creating and editing a user table template
Objective: Create a new user template for an object type and edit its contents.

Required: PolyWorks|Inspector is open.

Steps

The new default table template is indicated in 
bold.

New feature report tables will be created using 
the new default table template.

1. Choose Tools > Edit Templates.

The Edit Templates dialog box opens.

2. In the Type list, select Table.

3. Browse for the desired table type. 

4. To create a new user template, click Create.

The Create User Template dialog box opens.
 

5. Specify the Name of the new user template.

6. Specify the Base template for the new user 
template.

If a template is selected upon creation, it is 
preselected as the base template by default. 

7. Click Create.

The newly created user template can be set as 
default by selecting the Set as default option.
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Results

Notes

8. Edit the content of the newly created table 
template directly on the right pane.

For more information, see Editing report table 
contents manually on page 573. 

9. Click Apply.

 

The new user table template is added to the list 
of table templates.

It can now be to assigned to report tables.

 

Edit the content of a user table template at any time by selecting it on the template list, 
making the required modifications on the right pane, then clicking Apply.
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Editing the report table format

Objective: Edit the font and font size of a report table.

Required: The project contains a report table.

Steps

Edit the format of a single report table

1. In the Tree View, double-click a report name to 
open the Report Editor.

2. In the Report Editor, select a report table.

3. Choose Edit > Table from the Report Editor 
menu bar.

The table editor opens displaying the report 
table

4. On the table editor toolbar, click Edit Format

The Edit Table Format dialog box opens.

5. Set the appropriate options.

To set the table format as the default one for all 
new tables, select Set as default in the Edit Table 
Format dialog box. The present settings are 
transferred to the Objects > Reports > Tables > 
Formatting page of the PolyWorks|Inspector 
options.

6. Click Apply.

The formatting is applied to the report table.

Specify the formatting options of all new report tables

1. Choose Tools > Options.

The PolyWorks|Inspector Options dialog box 
opens.

2. Choose Objects > Reports > Tables > Formatting.

3. Set the appropriate options.

4. Click Apply.

The formatting is applied to all subsequent 
new report tables.
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Working with report snapshots

Report snapshots are images captured from the 3D scene to report the 
model and measurement results in full detail.

Since objects are updated through the Automatic Project Update, the 
report snapshot will automatically be updated. The snapshot contents 
can also be edited to modify the part orientation or the objects shown 
at any time. Report snapshots can be incorporated into a formatted 
report, or exported for use in applications like Microsoft Excel.

Creating report snapshots

Objective: Create a report snapshot showing the contents of the 3D scene.

Required: The project contains a visible measurement object or model.

Steps

1. Prepare the 3D scene by giving the model a 
suitable orientation and zoom level, and 
displaying only the desired measurement 
objects.

2. The annotations can be repositioned. Choose 
Tools > Annotations > Position. 

• Using the ALT key as a shortcut to drag 
annotations. 

• When an annotation is repositioned, it is 
automatically locked. In this case, its position 
remains unchanged when performing a 
transformation in the 3D scene (for example, 
zoom, rotation and translation). 

3. Choose Report > Create Snapshots > Capture 
3D Scene.
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Results

The snapshot is added to the active formatted 
report, shown at the bottom of the Tree View.

The snapshot is automatically positioned 
on a page in the report, and can be viewed 
by double-clicking the report name.
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Editing a report snapshot

Objective: Edit a report snapshot to change its orientation or contents.

Required: The project contains a report snapshot.

Steps

Report snapshots are stored by default in the active formatted report, listed at the bottom of 
the Tree View.

1. In the Tree View, double-click a report name to 
open the Report Editor.

2. In the Report Editor, select a report snapshot.

3. Choose Edit > Snapshot.

4. In the 3D scene, modify the zoom level, 
orientation, or objects displayed. The snapshot 
extent is displayed as a dotted boundary line.

The extent of the 3D Scene region and the 
Snapshot size can also be edited using the fields 
in the Edit Snapshot dialog box.

5. Click Recapture.
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Results

Notes

If a color map simply needs to be updated, do not edit the report snapshot. Rather, select the 
snapshots for which the color map needs to be updated, and choose Edit > Assign Current 
Color Scale to Snapshots > Selected, or right-click and choose Assign Current Color Scale. 

The report snapshot is updated in the 
formatted report.
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Working with formatted reports

Reports are a good, organized way to present or share 
inspection results. Formatted reports normally contain 
report snapshots, report tables, text, and graphics and can 
be edited and prepared as needed using the Report Editor 
tool. While formatted reports are automatically generated 
when report snapshots or report tables are created, they 
can also be created manually. After a report is completed, 
it is generally exported in PDF format for others to review. 

Formatted reports are displayed in the Report Editor pane. 
The Page View interface lists the page thumbnails, and the 
main interface displays the page currently selected for 
review and editing. Common tools are offered on toolbars 
located above and below the page area, respectively.
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Creating formatted reports

By default, a formatted report is created as soon as a report snapshot or a report table is 
created. Subsequent report items are automatically added sequentially on pages of the 
formatted report as they are generated. A formatted report can also be created manually at 
any time.

Objective: Create an empty formatted report manually.

Required: A PolyWorks|Inspector project.

Steps

Results

Notes

Newly created report items are added to the active formatted report, which is displayed in 
bold in the Tree View. To make any formatted report the active one, select it in the Tree View 
and choose Report > Formatted Report > Activate.

1. Choose Report > Create Formatted Report.

2. Specify report properties.

3. Click Apply and then click Close.

The formatted report object is added at the 
bottom of the Tree View as the active 
formatted report (in bold).

The formatted report is initially empty. 
Newly created report items (snapshots and 
tables) are automatically added to the 
active formatted report.
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Editing formatted reports

Objective: Edit an existing formatted report, move report items, and add text and graphics.

Required: The project contains a formatted report.

1. In the Tree View, double-click a report name to 
open the Report Editor.

2. Perform one of the following edition 
operations.
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Add a snapshot to the title page

For reports using one of the standard layouts, it is possible to quickly add a snapshot to the 
title page. The title page offers a container for snapshots.

Objective: Add a snapshot to the title page.

Required: A report using one of the standard report layouts.

Steps

1. Click Capture 3D Scene Region to launch the 
capture 3D scene region mode.

The Capture 3D Scene Region dialog box 
opens.

2. Show the objects to be captured and orient 
them in the 3D scene.

Resize the capture region if required.

The Annotation Display Options toolbar is 
displayed in the lower part of the 3D scene. 
Move, change options, or show/hide annotations 
if necessary.

3. In the Capture 3D Scene Region dialog box, it is 
possible to set the region in pixels, if required.

Set the values for the Left, Top, Width, Height 
parameters. 

4. Click Capture.
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Results

Note

Alternatively, if a snapshot is in the Report > Items branch of the Tree View, it is possible to 
drag and drop it over the snapshot container to add the snapshot to the title page.

The snapshot is automatically added to the 
title page. 
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Move or resize report items in the formatted report

Steps

Results

Notes

To crop an image, click it to select it, then choose Format > Crop Image. Drag the handles to 
crop, and then click anywhere outside the image to confirm.

Add and edit a text field in the report

Steps

1. In the Report Editor, left-click the report item to 
select it.

2. Left-click and drag the report item to move it to 
a different location.

Move the report item to another page by dragging 
it to a page thumbnail in the Page View.

3. Left-click and drag the handles of the report 
item to resize it.

The changes are applied to the report items.

1. In the Report Editor, choose Insert > Text Field > 
Fixed to add a text field.

2. Position the text field by moving the mouse to 
the intended location on the page, and left-click 
to confirm.

The text field edition mode is automatically 
activated. To access this mode after creation, 
select the text field and choose Edit > Text.
590



REPORTING MEASUREMENT RESULTS
Results

Notes

Add and edit a graphical shape in the formatted report

Steps

3.  Type to add text.

It is possible to change the format of a text field by 
clicking it and choosing Edit > Item Properties.

The text field is created and formatted in the 
report.

It is also possible to add a variable to the text 
field. Enter the text field edition mode, then 
right-click and choose Insert. Page numbers, 
dates, and properties can all be added, and 
their values update automatically

1. In the Report Editor, choose Insert > Shapes > 
[choose a shape type] to add graphical shapes.
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Results

Add a fixed image to the formatted report

Steps

Results

2. Position the shape by moving the mouse to the 
intended location on the page.

3. Left-click and drag to create the shape.

It is possible to format the created shape by 
clicking it and choosing Edit > Item Properties.

The shape is created and formatted in the formatted report.

1. In the Report Editor, add an image by choosing 
Insert > Image From File.

2. Browse to the image file.

3. Click Open.

4. Move the image to the desired location on the 
report page.

5. Resize the image, if necessary, by dragging the 
item handles.

The image is added to the report.
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Add, reorder, or remove pages from the formatted report

Steps

Results

1. In the Report Editor, add a report page by 
choosing Insert > Page.

2. Reorder pages by clicking and dragging a page 
thumbnail.

3. Delete a report page by selecting the thumbnail 
and choosing Edit > Delete.

The pages are added, reordered, or deleted from the formatted report.
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Generate a PDF file from a formatted report

Objective: Save a formatted report as a PDF file.

Required: The project contains a formatted report. 

Steps

Results

1. In the Tree View, double-click a report name to 
open the Report Editor.

2. In the Report Editor, choose File > Export 
Report > PDF.

3. Browse to the desired location.

4. Specify a name for the exported formatted 
report.

5. Click Save.

The formatted report is saved in PDF format.
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Exporting report items

Report items, such as tables and snapshots, can be exported from a formatted report. This 
can be useful when the inspection results are used to fill out an existing external template, or 
are published online or on a company network. Available export options include Excel, HTML, 
and text files.

Objective: Export report items using available formats.

Required: The project contains a formatted report with report items.

Steps

Results

The selected report items are exported to the specified file format.

Notes

To export items to the Microsoft Excel format, Microsoft Excel must be installed on the 
computer.

1. Open the formatted report that contains the 
report items to export by double-clicking it in 
the Tree View.

2. In the Report Editor, select the report items to 
export.

To select multiple report items, hold the CTRL key 
while selecting them.

3. Choose File > Export Items to export the selected 
items.

A file browser opens.

4. Specify a File name and location.

5. Select in the Save as type list, a file format.

The Options button opens a dialog box that 
offers export parameters.

6. Click Save.
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Repeating an inspection on multiple pieces

In PolyWorks|Inspector, all measurement 
object parameters and relations are 
stored in the project. The stored 
information facilitates relational, 
parametric inspection within the 
PolyWorks|Inspector project, where 
remeasuring of one object automatically 
updates any related objects. This 
functionality also allows for perfect 
repeatability when inspecting multiple 
pieces, using the inspection routine of the 
first inspected piece to inspect 
subsequent pieces. A single inspection project can contain several piece templates. Then, 
when measuring a new piece, the operator can choose the appropriate piece template based 
on the current setup, for example, according to the type of device used.

Multipiece inspection consists of four general steps:  

1. Inspect and report the first piece.

2. Create a piece template from the first piece.

3. Create a new piece from the piece template.

4. Inspect a new piece using Play Inspection. 
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All pieces are stored within a single PolyWorks|Inspector project and their results can be 
reviewed individually or summarized using Statistical Process Control (SPC) tools.

Working with multiple pieces 

Each physical version of a part is called a piece. By default, the first piece is named piece 1. 
When the inspection is completed for piece 1, a piece template can be created from this 
piece to be used for subsequent pieces. 

Operations related to multiple pieces are managed in the Multipiece Inspection toolbar.

New Piece

Opens an interface used to add a new piece to the project.

New Piece Template

Opens an interface used to create a new piece template.

Play Inspection

Plays the active measurement sequence.

Sequence Editor

Displays the Sequence Editor pane.

Object Control SPC

Opens an interface to perform statistical process analysis on object 
controls.

Surface Data SPC

Opens an interface to perform statistical process analysis on surface data 
objects.
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Creating a new piece template

Once a piece inspection is completed, it is recommended to create a piece template using the 
active piece to ensure uniformity among the new pieces.

Objective: Create a new piece template from the current piece.

Required: A piece completely inspected.

Steps

Pieces and piece templates are stored within the 
project. They are available from the piece list at the 
top of the Tree View.

Upon opening a piece, it automatically becomes 
the active piece and therefore the current piece.

Choose File > Project Properties to manage pieces 
and piece templates, and their properties.

Alternatively, use the Piece Properties button.

1. Choose Tools > Piece > Template > New.

The New Piece Template dialog box opens.

2. In the Copy from list, select (Current Piece).

If the project contains existing templates, these are 
available in the list to allow creating a new piece 
template from the selected one.

Propagation links can be established to propagate 
changes. For more information, see Propagating 
piece changes on page 605.

3. Click Create.
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Results

Inspecting a new piece using Play Inspection

The Play Inspection tool offers a guided, 
step-by-step sequence to capture 3D 
datasets of a new piece, using either point 
cloud digitizing or probing devices. 

Combining it with the Control Reviewer pane 
allows to view control results in real-time as 
the associated measurement objects are 
measured. See Reviewing measurement results 
using the Control Reviewer on page 533.

The Play Inspection tool: 

• Automatically proposes a logical order of measurement that considers device positions, 
data alignments, object Tree View sequence, and geometric constraints; 

• Triggers the right measurement method for each object;

• Manages multiple device positions.

The sequence proposed by the Play Inspection tool is called an autogenerated sequence and 
it can be customized using the Sequence Editor. For information, see Introducing the Sequence 
Editor on page 643.

Objective: Repeat an initial inspection on a new piece.

Required: A first piece completely inspected or a piece template.

Steps

The piece template is created and stored in the project. It contains all the measurements and 
inspection sequences defined for the first piece.

1. Choose Tools > Piece > New.
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The New Piece properties dialog box opens.

The piece name as well as the creation date and 
time are automatically specified.

2. Choose the Source piece used to define the 
new piece:

• Current piece: A nominal copy of the 
current piece is used to create the new piece.

• Piece template: The template is used to 
create the new piece.

By default, if a piece template is used to create the 
new piece, the new piece is linked to that piece 
template. This allows for propagating piece 
changes. For more information, see Propagating 
piece changes on page 605. 

3. If required, specify other standard information 
for the new piece.

4. Click Create.

A nominal copy of the current piece or piece 
template is created.

The measurement sequence associated to the 
current piece or to the piece template is applied 
to the new piece.

By default, Play Inspection is automatically 
launched, guiding the user through the steps 
necessary to calculate the measurement 
objects for the new piece. The inspection is 
based on the measurement sequence of the 
first inspected piece or the piece template.

When required, the measurement sequence is 
paused and a message is displayed to indicate 
that a manual action is required.

5. If required, use the Pause, Skip Current 
Operation, and Stop buttons to interrupt or 
modify the inspection process.

A message is displayed when the new piece inspection is finished.
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Results

Notes 

The new inspection is completed and the 
measurement objects of piece 2 are displayed 
in the Tree View. A measured status icon 
indicates the measured status.

The results of the inspection performed in 
piece 2 are shown in the 3D scene.

• The inspection sequence can be launched manually at any 
time by choosing Tools > Piece > Play Inspection to measure 
unmeasured objects.

 

• If a measurement object cannot be calculated, a warning 
message is displayed. The message can be used for 
troubleshooting purposes. The problematic objects are 
flagged in the Tree View with an X overlay. 
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Customizing guiding instructions

During an inspection, standard on-screen messages 
guide the operator through scanning or probing the 
piece properly. Additional guidance can also be 
provided through custom instructions or images for 
any Data objects or measurement objects.

Objective: Repeat an initial inspection on a new piece 
using custom guidance.

Required: A first piece completely inspected or a piece template.

Steps 

1. In the Tree View, select a Data object or a 
measurement object.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. In the Guiding instructions section, select 
Message and/or Image. 

For measurement objects, these parameters are 
offered only when the measurement method is 
Custom, Undefined, or Probe.

• In the Message area, enter custom 
instructions.

• Under the Image area, click the import 
button and load a drawing or image file that 
illustrates the instructions. The image is 
displayed in the viewing area.

5. Click Apply.
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Results 

Notes 

The custom message and image are displayed 
during Play Inspection.

Custom guiding instructions can also be specified for Data alignment and Data color map 
objects. These parameters are available in the property sheet of the object, respectively on the 
Data alignment and the Data color map tabs.
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Propagating piece changes 

It is possible to modify or add certain information for multiple measured pieces at once, such 
as to modify or add data alignments, measurement objects, or inspection reports. This can be 
useful, for example, to easily correct an error among many pieces that have already been 
scanned, such as changing tolerances on a geometry control, without having to make that 
change to each piece manually.

To be able to propagate changes, pieces must first be linked to a piece template. Changes can 
then be propagated through the linked piece template to the other linked pieces when 
desired. 

Changes can be propagated to previous pieces, 
subsequent pieces, or a subset of pieces if they are 
linked to a piece template. More than one template 
can also be used. An icon indicates whether the 
current piece or piece template is unlinked or linked.

Linking pieces to a piece template

Objective: Link a new piece to a piece template.

Required: A piece template has already been created.

Steps

1. Choose Tools > Piece > New to create a new 
piece.
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Results

The New Piece dialog box opens.

The piece name as well as the creation date and 
time are automatically specified.

2. Choose Piece template as the Source piece 
and select the template used to create the new 
piece. 

The Link to the piece template check box is 
selected by default and links the new piece to 
the selected piece template.

3. If required, specify other standard information 
for the new piece.

4. Click Create.

 

The piece that is created is linked to the 
specified piece template. The linked icon is 
displayed on the status bar.
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Notes 

Propagating changes to pieces

Objective: Propagate changes made to the current piece to other linked pieces to correct an 
error.

Required: Pieces are linked to the same piece template.

Steps 

Propagation links can also be established and managed after a piece or piece template has 
been created, for example to unlink pieces from a piece template. 

This can be done using several tools, including the Pieces Summary page of the Project 
Properties dialog box, shown below, which is available by choosing File > Project Properties.

Alternatively, use the Piece Properties button.

1. Open a piece.
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2. Make the desired changes. For example, change 
the tolerances on any control using the 
Geometry Controls pane.

A notification is displayed above the status bar 
when beginning to make changes that can be 
propagated.

The propagation split button on the status bar 
displays the propagation status, warning that 
the current piece now differs from its linked 
piece template.

Moving the mouse pointer over the icon displays a 
tooltip with details.

3. Click the propagation split button and choose 
Propagate to Piece Template. Changes will be 
made to each linked piece only when they are 
opened.

 

Alternatively, choosing Propagate to Piece 
Template and Linked Pieces makes the changes to 
the linked pieces immediately. Note that this is a 
long operation, depending on the amount of 
linked pieces.

The propagation operation cannot be undone.
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Results 

Notes 

The changes made to the current piece are immediately propagated to the linked piece 
template. These changes are also made to the other linked pieces when they are opened.

The propagation split button on the status bar displays the propagation status. The current 
piece now matches its linked piece template.

Moving the mouse pointer over the icon displays a tooltip with details.

• The following changes can be propagated:

• Nominal information that has been added or modified, such as information on the CAD 
model, nominal components of measurement objects, and tolerances. 

• Some changes that have an impact on a project’s measured results and the way those 
results are reported, such as modifications made to extraction parameters or objects, 
control views, or formatted reports that have been added or deleted. 

Note that if any of these changes are made, they are all propagated if the propagation 
operation is launched.

• If changes that can be propagated are made but not propagated before closing the current 
linked piece, the Piece Propagation window is displayed and offers different operations 
depending on the context.
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Guided feature probing using measurement points

In metrology, it is important to reduce the number of factors that could affect measurement 
results. For example, when performing a part inspection by probing, controlling the location 
of the points that are to be probed is sometimes desired.

This is especially useful when setting up a project for a multipiece inspection process, where 
multiple instances of a part are inspected. In order to obtain meaningful results, each 
measurement of the part must be performed in the exact same way.

When probing features, the repeatability of each measurement depends largely on the 
number and the location of the probed data points of each feature. Adding measurement 
points to features provides guidance as to where the points should be probed, instead of 
randomly probing points on the part for every new inspection.

There are three main steps when using measurement points for guidance: 

1. Features are created. 

2. The measurement method is set to Probe, the 
Guided point acquisition mode is configured, 
and measurement points are defined for each 
feature that will be probed.

3. When measuring the piece, the features are 
probed using measurement points as guidance.
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The Measurement Points pane

When using measurement points for guidance, the Measurement Points pane can be used to 
customize the measurement points used for the probing operation. To open the 
Measurement Points pane:

The Measurement Points pane is opened: columns provide information on measurement 
points, and a vertical toolbar offers operations used to create, edit, and delete measurement 
points:

The vertical toolbar offers the following buttons: 

1. In the Tree View, select the desired feature.

2. Choose Edit > Object Properties.

The property sheet is opened.

3. On the Measurement tab, make sure that:

• The measurement method is set to Probe.

• The point acquisition mode is set to Guided.

4. Under Point acquisition, press Measurement 
Points.

Define Measurement Points from Probed Data Points

Defines measurement points from previously probed data points.

Anchor Measurement Points

Launches an interactive mode that allows creating measurement points by 
anchoring them on features.

Vertical toolbarColumns
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Pick Go to Positions

Can only be used when the measurement method is set to CNC Probe (in 
other words, when automatically probing using a CNC CMM).

Launches an interactive mode that allows adding intermediate positions, 
or go to position points, between measurement points along the 
measurement path to avoid collisions with the part or its fixture.

Edit Points

Opens a dialog box used to edit the position and normal of selected 
measurement points.

Drag Points

Launches an interactive mode that allows repositioning measurement 
points by dragging them in the 3D scene.

Delete Points

Deletes selected measurement points.

Delete Points Interactively

Launches an interactive mode that allows deleting measurement points by 
clicking them in the 3D scene.
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Configuring the guided point acquisition mode

It is possible to configure whether the acquisition of a feature’s probed data points is guided 
or not. The guided point acquisition mode is used to define measurement points at the 
locations and the order in which data points should be probed.

Once the guided acquisition mode is set, parameters are made available to configure the 
acquisition.

Parametric information that defines the nominal components of features can be used to 
define the measurement points.

Objective: Configure the guided acquisition mode for features.

Required: The project contains features with at least the nominal primitives.

Steps  

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

In the Point acquisition section:

5. In the Mode list, select Guided.

6. Set the point acquisition Order.

• Select Sequential to specify that the 
measurement points will be used to guide 
point acquisition in the order of the 
measurement points list.

• Select Auto-Detect to specify that the 
measurement points will be used to guide 
point acquisition in any order.

7. Set the Guiding sphere radius.

Sets the size of the spheres used to guide the user 
to the location of the measurement points while 
probing.

8. If Limit acquisition to radius is selected, 
points can only be acquired when the probe is 
within the specified radius.
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9. Set the Measurement Points parameter. 

• Select From Nominal to use the nominal 
component of the feature to define the 
measurement points.

See the following sections for the parameters 
related to each feature type.

• Select Custom to use probed points of the 
measured component of the feature or to 
anchor measurement points directly in the 
3D scene.

Then, click Measurement Points to the right 
of the list box to open the Measurement 
Points pane to define and edit measurement 
points. See Defining measurement points from 
the nominal component on page 615.

10. In the Points not on reference surface list 
box, specify the behavior when one or more 
defined measurement points are not on a 
reference surface:

• Select Disallow to prevent the CNC probe 
mode from launching when some points are 
not on a reference surface.

To correct this situation, edit the point 
acquisition parameters or edit the 
measurement points through the Measurement 
Points pane.

• Select Skip to skip the points in error.

A minimum number of points must be probed 
to form a valid feature.

• Select Acquire to attempt to probe the 
points in error.

This may result in acquisition failure. If there is 
no reference surface at all, this behavior is 
used.

11. Click Apply.

Measurement points are added to the feature 
based on the set parameters.
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Defining measurement points from the nominal component

When defining measurement points using From Nominal, the Point acquisition section 
offers both general and feature-specific parameters that are used to configure the 
measurement points defined from the nominal component of a feature.

Setting the parameters for line features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal.

7. Set the Location, which specifies the location 
of the feature on the part:

• Click Convex Edge when the line is located 
on an edge with an angle pointing outwards.

• Click Concave Edge when the line is on an 
edge with an angle pointing inwards.

8. Enter the Number of points that are evenly 
distributed along the line.

9. Specify the Offset to plane distance between 
the feature plane and the measurement points. 
The offset direction is based on the Location.

10. Set the Measurement side:

• Click Left when the measurement points are 
located on the left side of the line and the 
material is on the right side of the line.

• Click Right when the measurement points 
are located on the right side of the line and 
the material is on the left side of the line.

11. Click Apply and close the Properties dialog box.
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Results

Setting the parameters for plane features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

Measurement points are defined using the nominal 
primitive of the selected line.

Along Boundary

This pattern is used to distribute measurement points along the external boundary of the 
plane.

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal.

7. Set the pattern to Along Boundary.

8. Specify the Number of points distributed 
along the boundary.
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Measurement points are defined using the nominal 
primitive of the selected plane.

Grid

This pattern defines uniformly-spaced measurement points by sampling a grid that covers the 
plane.

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal.

7. Set the pattern to Grid.

8. Set the Sampling step value of the grid.
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Setting the parameters for circle features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

Measurement points are defined using the 
nominal primitive of the selected plane.

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal. 
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7. Set the Location, which specifies the location 
of the feature on the part:

• Click Top when the circle is located at the top 
of the part geometry.

• Click Bottom when the circle is located at 
the bottom of the part geometry.

The in-space orientation considered for the 
circle feature comes from its nominal 
component.

8. Enter the Number of points that are evenly 
distributed along the circle.

9. Specify the Offset to plane distance between 
the plane of the circle and the measurement 
points. The offset direction is based on the 
Location.

10. Click Apply and close the Properties dialog box.

Tip

• Top location of an internal circle.

• Bottom location of an internal circle.

Measurement points are defined using the 
nominal primitive of the selected circle.
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Setting the parameters for slot features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

The icons displayed for the Location are based on the in-space orientation of the nominal 
component of the feature.

For an external circle, the Top and Bottom location 
icons are shown to the right.

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal.

7. Set the Location, which specifies the location 
of the feature on the part:

• Click Top when the slot is located at the top 
of the part geometry.

• Click Bottom when the slot is located at the 
bottom of the part geometry.

The in-space orientation considered for the slot 
feature comes from its nominal component.

8. Enter the Number of points per arc that are 
evenly distributed along each arc.

9. Specify the Offset to plane distance between 
the plane of the slot and the measurement 
points. The offset direction is based on the 
Location.

10. Click Apply and close the Properties dialog box.
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Results

Notes

Tip

• Top location of an internal slot.

• Bottom location of an internal slot.

Measurement points are defined using the 
nominal primitive of the selected slot.

The icons displayed for the Location are based on the in-space orientation of the nominal 
component of the feature.

For an external slot, the Top and Bottom location 
icons are shown to the right.
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Setting the parameters for rectangle features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal. 

7. Set the Location, which specifies the location 
of the feature on the part:

• Click Top when the rectangle is located at the 
top of the part geometry.

• Click Bottom when the rectangle is located 
at the bottom of the part geometry.

The in-space orientation considered for the 
rectangle feature comes from its nominal 
component.

8. Enter the Number of points per side that are 
evenly distributed along each side.

9. Specify the Offset to plane distance between 
the plane of the rectangle and the 
measurement points. The offset direction is 
based on the Location.

10. Click Apply and close the Properties dialog box.
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Results

Notes

Tip

• Top location of an internal rectangle.

• Bottom location of an internal rectangle.

Measurement points are defined using the 
nominal primitive of the selected rectangle.

The icons displayed for the Location are based on the in-space orientation of the nominal 
component of the feature.

For an external rectangle, the Top and Bottom 
location icons are shown to the right.
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Setting the parameters for polygon features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal.

7. Set the Location, which specifies the location 
of the feature on the part:

• Click Top when the polygon is located at the 
top of the part geometry.

• Click Bottom when the polygon is located at 
the bottom of the part geometry.

The in-space orientation considered for the 
polygon feature comes from its nominal 
component.

8. Enter the Number of points per side that are 
evenly distributed along each side.

9. Specify the Offset to plane distance between 
the plane of the polygon and the measurement 
points. The offset direction is based on the 
Location.

10. Click Apply and close the Properties dialog box.
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Results

Notes

Tip

• Top location of an internal polygon.

• Bottom location of an internal polygon.

Measurement points are defined using the 
nominal primitive of the selected polygon.

The icons displayed for the Location are based on the in-space orientation of the nominal 
component of the feature.

For an external polygon, the Top and Bottom 
location icons are shown to the right.
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Setting the parameters for ellipse features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal. 

7. Set the Location, which specifies the location 
of the feature on the part:

• Click Top when the ellipse is located at the 
top of the part geometry.

• Click Bottom when the ellipse is located at 
the bottom of the part geometry.

The in-space orientation considered for the 
ellipse feature comes from its nominal 
component.

8. Enter the Number of points that are evenly 
distributed along the ellipse.

9. Specify the Offset to plane distance between 
the plane of the ellipse and the measurement 
points. The offset direction is based on the 
Location.

10. Click Apply and close the Properties dialog box.
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Results

Notes

Tip

• Top location of an internal ellipse.

• Bottom location of an internal ellipse.

Measurement points are defined using the 
nominal primitive of the selected ellipse.

The icons displayed for the Location are based on the in-space orientation of the nominal 
component of the feature.

For an external ellipse, the Top and Bottom 
location icons are shown to the right.
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Setting the parameters for cylinder features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

Results

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal. 

7. Enter the Number of circles, which specifies 
the number of equidistant circles on which 
measurement points are defined.

8. Enter the Number of points per circle, which 
specifies the number of measurement points 
that are evenly distributed along each defined 
circle.

9. Enable the Max Depth option, if needed. It 
allows users to define the maximum distance 
of the deepest circle. The depth considers the 
axis orientation of the cylinder.

10. Click Apply and close the Properties dialog box.

Measurement points are defined using the 
nominal primitive of the selected cylinder.
628



INSPECTING MULTIPLE PIECES
Setting the parameters for cone features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

Results

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal.

7. Enter the Number of circles, which specifies 
the number of equidistant circles on which 
measurement points are defined.

8. Enter the Number of points per circle, which 
specifies the number of measurement points 
that are evenly distributed along each defined 
circle.

9. Enable the Max Depth option, if needed. It 
allows users to define the maximum distance 
of the deepest circle. The depth considers the 
axis orientation of the cone.

10. Click Apply and close the Properties dialog box.

Measurement points are defined using the 
nominal primitive of the selected cone.
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Setting the parameters for sphere features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal. 

7. Enable Point on top of the sphere, if needed. 
This creates a measurement point at the top of 
the sphere.

8. Enter the Number of circles, which specifies 
the number of equidistant circles on which 
measurement points are defined.

9. Enter the Number of points per circle, which 
specifies the number of measurement points 
that are evenly distributed along each defined 
circle.

10. For the First circle:
Set the Angle from top, at which the first circle 
is positioned. 

11. For the Last circle:
Set the Angle from top, at which the last circle 
is positioned.

12. Click Apply and close the Properties dialog box.
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Results

Notes

Measurement points are defined using the 
nominal primitive of the selected sphere.

The parameters for the sphere are illustrated below.

Point on top
First circle

Last circle

First circle angle

Last circle 
angle
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Setting the parameters for polyline features

Objective: Define measurement points from the nominal component of a feature.

Required: The project contains a feature with a nominal component.

Steps

Results

1. In the Tree View, select the feature to which 
measurement points will be added.

2. Choose Edit > Object Properties.

The Properties dialog box opens.

3. Click the Measurement tab.

4. Set the Method to Probe.

5. Set the point acquisition Mode to Guided.

6. Set the Measurement points to From 
Nominal.

7. Click Apply and close the Properties dialog box.

Measurement points are defined at each vertex of 
the nominal primitive of the selected polyline.
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Notes

Defining custom measurement points

The Measurement Points pane can be used to define, visualize, and edit measurement points 
on features. Two creation methods are offered:

• Define Measurement Points from Probed Data Points: Measurement points are 
defined automatically from probed data points.

• Anchor Measurement Points: Measurement points are anchored directly on the feature 
or on a Reference object in the 3D scene.

Measurement points are only available for features that support the Probe or the CNC Probe 
measurement method, and they are specific to each feature.

Defining measurement points from probed data points

Objective: Define measurement points from probed data points for selected features.

Required: The selected feature must have probed data points.

Steps  

Since polylines do not have surface information, 
each measurement point only contains a location 
(x, y, and z coordinates) but no orientation.

1. Open the Measurement Points pane:

• by clicking Measurement Points in the 
Properties of the feature (see Configuring 
the guided point acquisition mode on 
page 613).

• by right-clicking the feature and choosing 
Edit > Measurement Points.

2. Click Define Measurement Points from 
Probed Data Points.
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Results

Defining measurement points by anchoring

Objective: Define measurement points by anchoring points on features.

Required: The PolyWorks|Inspector project must have one or more features that support 
the Probe measurement method.

Steps

Measurement points are defined using probed data points obtained from the selected 
feature.

1. Open the Measurement Points pane:

• by clicking Measurement Points in the 
Properties of the feature (see Configuring 
the guided point acquisition mode on 
page 613)

• by right-clicking the feature and choosing 
Edit > Measurement Points

2. Click Anchor Measurement Points to launch 
an interactive anchoring mode.

3. In the 3D scene, click directly on the feature to 
create the measurement points.

The number of measurement points must be 
equal to or larger than the minimum number of 
points for that feature type.

4. Right-click to exit the anchoring mode.
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Results

Anchoring points on features that have arcs or sides
Slot, rectangle, and polygon features are probed using individual arcs or sides. To anchor 
measurement points for these features, the arc or side associated with each measurement 
point must be specified in order to provide the appropriate guidance. The Anchor 
Measurement Points dialog box is used to specify which arc or side the measurement point 
will be anchored on.

Steps

Measurement points are defined on the feature. 

1. In the Tree View, select the slot, rectangle, or 
polygon feature to which measurement points 
will be added.

2. In the Measurement Points pane, click Anchor 
Measurement Points to launch an interactive 
anchoring mode.

The Anchor Measurement Points dialog box 
opens.

3. From the Step list, select the corresponding arc 
or side for which measurement points will be 
anchored.

4. In the 3D scene, click directly on the feature or 
on the Reference object to anchor the 
measurement points at the desired locations.

The number of measurement points must be 
equal to or larger than the minimum number of 
points.
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Results

Editing and deleting measurement points

The Measurement Points pane offers various tools to edit and delete measurement points.

Editing measurement points numerically

Measurement points can be edited numerically by editing their position and normal.

Steps 

5. From the list, select the next arc or side and 
continue anchoring the points on the feature.

Repeat the procedure for the other arcs or sides.

6. Right-click to exit the anchoring mode.

Measurement points are defined on the feature for each arc or side.

1. In the Measurement Points pane, select the 
measurement point that will be edited. 

Use a multiple selection to edit more than one 
measurement point at a time.

2. Click Edit Points.
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Editing measurement points interactively

Measurement points can be edited interactively by dragging them in the 3D scene.

Steps

The Edit Points dialog box opens. 

3. Specify the Position and Normal for the 
measurement point.

The measurement point x, y, or z coordinates can 
also be edited directly in the Measurement Points 
pane. Click a coordinate to edit its value.

1. Click Drag Points to launch an interactive 
dragging mode. 

2. Reposition measurement points by dragging 
them directly in the 3D scene.

3. Right-click to exit the dragging mode.
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Editing arcs and sides of measurements points

In cases where a measurement point was anchored to the wrong side or arc, it is possible to 
correct this and change the arc or the side the measurement points belong to.

Steps

Deleting selected measurement points

Measurement points can be deleted by selecting them and launching the deletion operation. 

Steps  

Deleting measurement points interactively

Measurement points can be deleted interactively.

Steps  

1. In the Measurement Points pane, click the 
measurement point that is on the wrong 
arc or side and drag it to the correct arc or 
side.

1. In the Measurement Points pane, select the 
measurement points that will be deleted.

Use a multiple selection to delete more than one 
measurement point at a time.

2. Click Delete Points. 

1. Click Delete Points Interactively to launch an 
interactive deleting mode. 

2. Click the measurement points in the 3D scene 
to delete them.

3. Right-click to exit the mode.
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Probing features using measurement points 

Once the guided acquisition mode has been configured (Configuring the guided point 
acquisition mode on page 613) and the measurement points have been defined (Defining 
measurement points from the nominal component on page 615), via the properties of the 
feature, the probing in a guided mode can be launched.

The order in which the points are probed is controlled by the specified acquisition Order:

• Sequential: The next measurement point is the first unmeasured point in the list of 
measurement points. 

• Auto-Detect: The next measurement point is the one closest to the probing device.

The measurement point guiding spheres are highlighted in the 3D scene. The Limit 
acquisition to radius option allows restricting the point acquisition for each measurement 
point to a precise zone delimited by cylinders or by spheres (for point with no normal) 
centered at the measurement points. The next measurement point guiding sphere is always 
highlighted as follows in the 3D scene:

• If the Limit acquisition to radius option is set, it is highlighted in red if the probing 
device is out of the zone, and in green if it is in the zone. A sound also indicates if the 
probing device is within the zone or not.

• If the Limit acquisition to radius option is not set, the guiding zone of the 
measurement point closest to the probing device is highlighted in green.

Once a measurement point has been used for point acquisition, its guiding zone is no longer 
displayed in the 3D scene.

Example  

Defined measurement points on a plane feature.
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Probing a plane feature in the Sequential order. The points are probed in numerical order.

Probing a plane feature in the Auto-Detect order. The points are probed in any order.
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Using measurement points with features probed in 
multiple device positions

Sometimes, features need to be probed from multiple device positions. This can be due to the 
size of the part or the physical constraints that make it impossible to access a feature from a 
certain position.

Defining measurement points using the From Probed Data Points method will automatically 
group the measurement points, taking into consideration the device positions in which they 
were gathered.

Objective: Probe a feature from multiple device positions using measurement points as 
guidance.

Required: A PolyWorks|Inspector project that contains at least one feature with defined 
measurement points grouped in different device positions.

Steps

1. Open the project and click Play Inspection.

2.  Probe the points in the first device position.
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Results

3. Move the device.

For more information on multiple device 
positions, see Working with multiple device 
positions on page 666.

4. Continue the Play Inspection sequence.

5. Probe points in the second device position.

6. If more than two device positions are required, 
repeat steps 3 to 5 until the feature is 
completely probed.

When playing the inspection of a project that contains a feature originally created by probing, 
using multiple device positions and the From Probed Data Points method measurement 
points, PolyWorks prompts the user to probe the feature displaying only the measurement 
points that belong to the first position. Then the sequence is paused and the user is prompted 
to move the device. Once the new device position is created, the user is prompted to probe 
the feature displaying corresponding measurement points.
642



INSPECTING MULTIPLE PIECES
Introducing the Sequence Editor

The measurement objects needed for the inspection are listed in the Tree View pane. These 
objects contain all the information related to how the measurements must take place and the 
links that exist between the objects. In multipiece inspection, the Play Inspection tool plays an 
autogenerated measurement sequence, by default, that is based on the objects in the Tree 
View. It can also play a measurement sequence that has been customized through the 
Sequence Editor.

The Sequence Editor can be used to customize the autogenerated sequence or to create a 
custom sequence where steps can be added one by one. Instructions for the operator can be 
added, the order of measurements can be changed, and additional steps for measuring can 
be included. Also, by inserting macro scripts, many functionalities can be added, such as those 
related to reporting.

The Sequence Editor pane

To open the Sequence Editor pane: 

The Sequence Editor pane is displayed. It features a menu bar, a standard toolbar, and a 
sequence area.  

1. Choose Tools > Sequence Editor.

Alternatively, click the Sequence Editor button 
from the Multipiece Inspection toolbar.

Menu bar

Standard 
toolbar

Sequence 
area
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Menu bar
Provides access to all Sequence Editor functionalities.

Standard toolbar
Provides quick access to the main functionalities of the Sequence Editor.     

Create From Autogenerated Sequence / New Sequence

Split button used to create a new sequence, either from the autogenerated 
sequence or from scratch.

Insert Step

Displays the Insert toolbar (see Insert toolbar on page 645) that offers quick 
access to the steps that can be added to the sequence.

Start Recording

Starts the recording mode. 

Execute One by One From Marker

Executes the next step in the sequence based on the marker position.

Execute From Marker

Executes steps starting at the marker position.

Stop Execution

Stops the execution of the sequence.

Reset Execution Status

Removes all information concerning step execution. The marker is 
positioned at the beginning of the sequence.
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Insert toolbar
To open the Insert toolbar, click the Insert button on the Standard toolbar. It offers quick 
access to the steps that can be added to the sequence.              

Guiding Instructions

Inserts a step used to add text and/or an image that will be displayed when 
running the sequence.

Question

Inserts a question step composed of a question and an answer variable.

Conditional Statement for Selected Steps

Inserts a conditional statement based on the content of an answer 
variable. 

Comment

Inserts text to provide useful information about the sequence.

Scanning Options

Inserts a step to change the scanning profile or customize scanning 
options.

Coordinate System

Inserts a step to activate a different coordinate system in the sequence.

Alignment

Inserts a step to create or activate a data alignment.

Device Position

Inserts a step to activate a device position or to perform a move device 
operation.

Data Object

Inserts a step to acquire a Data object.
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Sequence area
This area lists all the steps that make up a sequence.      

Measurement Object

Inserts a step to measure an object.

Add Probed Data Points

Inserts a step to add probed data points to a specified object.

Macro Script

Inserts a macro script by creating a new one or by importing a copy of a 
script.

Marker

The marker sets the position from which the execution of the sequence starts or from which 
sequence steps are added with the recording mode. Also, the real-time sequence validation 
considers the steps starting at the marker position. Choose Sequence > Set Marker Position to 
set the marker position. Alternatively, the marker can be dragged to the desired position.

Marker

Step number

Execution status 
color

Icons

Edit step 
shortcut
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Step number

Incremental number for each sequence step.

Execution status color 

The execution status of steps is indicated by their 
background color.

• Light green: step has been executed.

• White: step has not been executed.

• Gray: step was interactively skipped during 
the execution of the sequence.

Icons

When creating a measurement sequence, a real-
time sequence validation is performed in the 
background. If a step may cause a problem, an 
icon is displayed to inform the user.

Warning icons are displayed to inform the 
user of a potential problem.

Error icons are displayed when there is an 
error in the step.

Information icons are displayed when a step 
is unusual or unnecessary.

Moving the mouse pointer over an icon displays a 
tooltip with the details.

The status bar at the bottom of the Sequence Editor 
pane provides a summary of the problems detected 
in the measurement sequence.
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Edit step shortcut

Opens a dialog box to define or edit a sequence 
step. The content of the dialog box depends on 
the step that is currently defined or edited.

For example, when editing guiding instructions, 
edit the step to add instructions (message and/or 
image) for the operator to illustrate how to mount 
a part into its fixture.
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Using the Sequence Editor

Creating a measurement sequence from recorded actions

A measurement sequence is an ordered list of operations, called steps, created to measure 
objects. 

From the autogenerated sequence

When the nominal inspection project is ready, it is possible to create a measurement 
sequence from the autogenerated one. 

Steps  

Results 

1. Choose Tools > Sequence Editor.

Alternatively, click the Sequence Editor button 
on the Multipiece Inspection toolbar.

2. In the Sequence Editor pane, choose Sequence 
> Create from Autogenerated Sequence.

3. Type the Name and Description of the 
sequence.

4. Click Create.

The sequence is created. It contains the 
objects from the Tree View along with 
initial conditions and device positions. 

The sequence is ready to be customized. 
See Customizing a measurement sequence 
on page 652.
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From recorded actions

Once a measurement device is properly configured and connected, it is possible to start the 
inspection of a part and create the sequence at the same time. Once recorded, subsequent 
pieces can be inspected just by playing the inspection sequence.

Steps  

1. Choose Tools > Sequence Editor.

Alternatively, click the Sequence Editor button 
on the Multipiece Inspection toolbar.

2. In the Sequence Editor pane, choose 
Sequence > New.

3. Type the Name and Description of the 
sequence.

4. Click Create.

5. Start the recording mode. Choose 
Edit > Start Recording.

The actions performed subsequently are added to 
the sequence (for example, alignments, activation 
of a coordinate system, and measurement 
operations).

To stop recording actions, choose Edit > Stop 
Recording. 
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Results 

A sequence is created. The initial condi-
tions are automatically added to the 
sequence area.
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Customizing a measurement sequence

Once the measurement sequence is created, changes can be made. For example, it is possible 
to change the order of sequence steps to optimize an inspection, add guiding messages and 
images to facilitate the inspection of the part, or include macro scripts to increase efficiency.

Modifying the order of sequence steps

Steps in the sequence can be reordered, if required.

Steps  

Results  

1. In the Sequence Editor pane, select the 
sequence steps that will be moved in the 
sequence area.

 

2. Drag the selected sequence steps to the 
desired position in the sequence.

In the Sequence Editor, the steps are displayed at 
the new position.
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Adding sequence steps

Steps can be added to the sequence. They can be broadly categorized as follows:

• General steps

• Context steps

• Measurement steps

• Macro script steps

When a step is added, a contextual dialog box is opened to specify a Tree View object or 
required information. If an object is preselected in the Tree View, then the inserted step is 
automatically set to the selected object.

Choosing steps from the Insert menu

Steps  

Notes 

1. In the Sequence Editor pane, choose Insert > 
[select which step to add].

A step is added to the sequence and a 
contextual dialog box is displayed.

 

2. Specify the required information in the 
contextual dialog box.

3. Click outside the dialog box to confirm.

• Steps added using the Insert menu can be 
used as placeholders if relevant objects have 
not yet been created in the project. A warning 
icon appears. These steps must be defined 
before executing the sequence.

 

• Moving the mouse pointer over the object 
displays a tooltip with recommended actions 
to correct the issue.

• When a step is inserted, it appears at the end 
of the sequence, except if there is a selection in 
the sequence; in this case, the step is inserted 
above the selection.
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Selecting objects in the Tree View

Steps  

Results  

Dragging objects from the Tree View

Steps  

1. In the Tree View, select the objects associated 
with the steps that will be added to the 
sequence.

 

2. In the main menu, choose Measure > Add to 
Sequence.

The steps are added to the sequence.

 

1. In the Tree View, select the objects associated 
with the steps that will be added to the 
sequence.

 

2. Drag the objects to the desired position in the 
active sequence.
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Notes

A convenient way to add steps for existing objects is to drag the objects from the Tree View.

Inserting macro script steps

Steps  

Results  

Editing sequence steps

Once added, sequence steps can be modified by accessing the step’s contextual dialog box.

Steps  

1. In the Sequence Editor pane, choose Insert > 
Macro Script. Two items are offered.

• New: The Macro Script Editor opens, 
allowing users to create a macro script.

• Import: Allows users to browse for an 
existing macro script.

 

The step is added to the sequence. The macro 
script or, when imported, a copy of the macro 
script is saved in the current piece.

 

1. In the Sequence Editor pane, select the 
sequence step that will be modified and 
choose Edit > Step.

Alternatively, click the Edit Step shortcut arrow 
that corresponds to the step that will be 
modified.

The sequence step contextual dialog box 
opens.

 

2. Set the required parameters.
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Defining conditional blocks

Depending on the inspection requirements, some measurement objects can be excluded 
from the inspection. It is possible to define these requirements, in a measurement sequence, 
as conditional statement steps. These steps allow users to construct a sequence that is 
adaptable to certain variations in an inspection, like the presence of an optional part.

Steps  

Results  

1. Choose Insert > Question.

 

2. Type in a Yes or No question.

3. From the Answer variable list, select the 
variable where the answer will be stored.

If a new variable must be created, choose 
(Create New) and type the Variable name.

4. Set the initial value of the variable using the 
Sequence validation answer list. Refer to the 
Notes section for more information.

5. Select the steps in the sequence that are 
affected by the conditional statement.

6. Choose Insert > Conditional Statement.

7. Select the variable that will be used in the 
conditional statement.

8. Set the conditional value of the variable. If the 
variable is equal to the answer provided by the 
operator, the steps that are part of the 
conditional statement are executed. 
Otherwise, they are shown in gray and will not 
be executed.

The steps are added to the sequence. 

The steps that were selected when the conditional 
statement was inserted are grouped under the 
conditional statement.
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Notes  

The Sequence validation answer allows users to validate the corresponding conditional 
statement steps for a given scenario. This value is not used when the measurement sequence 
is executed in the Sequence Editor or processed by the Play Inspection tool.
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Evaluating pieces using Statistical Process Control

Statistical Process Control (SPC) is a tool that analyzes common measurements between 
multiple pieces for repeatability. Reviewing SPC results tells the user whether a part is being 
manufactured predictably or not. 

PolyWorks|Inspector offers two SPC tools: 

Object Control SPC:
Analyzes measurement object dimensions, such as hole diameter, flatness, and length.

Surface Data SPC:
Analyzes the range of part shape using color maps.

Analyze part dimensions for repeatability using Object 
Control SPC

The Object Control SPC tool analyzes the values of any 
measurement common to multiple pieces in the inspection 
project. Results are displayed in graphic and tabular format in 
the Object Control SPC Results pane.

Objective: Display statistics of measured object values for all 
pieces.

Required: A completed inspection project containing more than one inspected piece.

Steps

1. In the Tree View of a piece, select the objects to 
consider in the SPC analysis.

2. Choose Tools > Statistical Process Control > Object 
Controls.

3. The Object Control SPC dialog box opens, with a 
list of the inspected pieces.

Pieces can be excluded from analysis by 
deselecting them in the list.

4. In the Options section, specify the Sample size.

See the following section for more information.
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Results

The value for each of the five pieces is displayed for the selected measurement object in the 
Object Control SPC Results pane.

Statistics of the piece values is shown in the object annotation.
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Sample size

A sample consists of a collection of pieces. The sample size determines how many pieces 
represent a sample and is used to calculate mean values. The default sample size is 1.

• Sample size equal to 1: I-MR charts are generated, consisting of the Individuals (I) chart 
and the Moving Range (MR) chart.

• Sample size greater than 1: Xbar-R charts are generated, consisting of the Mean (Xbar) 
chart and the Range (R) chart.

Understanding SPC results

The SPC tool offers different charts to analyze results. Depending on the sample size (1, or 
more than 1), different charts are generated.

I-MR charts 

Generated when the sample size is 1, the I-MR charts display information about the 
performance of the process. They consist of:

• Individuals (I) chart: It displays the 
measured values per piece for the 
selected control of the selected 
measurement object, and the mean of 
these values.

• Moving Range (MR) chart: For the selected 
control of the selected measurement 
object, it displays the variation from the 
previous piece, and the mean of these 
variations.
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Xbar-R charts

Trend charts 

Generated when the sample size is greater than 1, the Xbar-R charts display information 
about the behavior of the process and outcome over time. They consist of:

• Mean (Xbar) chart: It displays the average 
measured value per sample for the 
selected control of the selected 
measurement object, and the mean of 
these values.

• Range (R) chart: For the selected control 
of the selected measurement object, it 
displays the range of data in each sample, 
and the mean of these ranges.

• Trend charts display the measured value 
per piece for the selected control of the 
selected measurement object and the 
mean of these values.
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Sample statistics table

Overall statistics table

Values per piece table

The Sample statistics table displays, per piece within each sample, the measured value for the 
selected control of the selected measurement object, the mean and the range of these values, 
and their average values.

The Overall statistics table displays statistics values such as the Mean, Std Dev, Min, Max, Cp, 
Cpk, %Within Tol (percentage of pieces within tolerance), and more for the selected 
measurement object.

The Values per piece table displays the measured values per piece for the selected controls of 
the selected measurement object.
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Analyze part shape for repeatability using Surface Data 
SPC

The Surface Data SPC tool analyzes the range in shape 
of multiple pieces in the inspection project by 
comparing them to the Reference object. Various 
results can be displayed using a color map. They 
include the range of variation, mean deviation, highest 
deviating areas, and more.

Objective: Display statistical analyses of Data object shape variation for all pieces.

Required: An inspection project containing a Reference object and more than one piece.

Steps

1. Choose Tools > Statistical Process Control > 
Surface Data Objects.

The Initialize Surface Data SPC dialog box and 
the Surface Data SPC pane open.

2. In the Pieces list, select From Project.

3. In the Reference objects list, select an object.

4. Specify the Sampling step defining the density 
of deviation measurements made to the Data 
objects. 

The value should be at least as large as the point 
spacing of point cloud Data objects. 

For all Data object types, the sampling step must 
be small enough to measure meaningful details.

5. Specify the Max distance to use to measure 
the deviations of the Data objects from the 
Reference object.

6. Click Initialize.
663



INSPECTING MULTIPLE PIECES
Results

Notes

The Surface Data SPC pane opens, listing the 
pieces included in the analysis. Deselect 
pieces to be removed from the analysis.

Tools used to initialize, reset, remeasure, report, 
and change options are located on the vertical 
toolbar of the Surface Data SPC pane.

A color map in the 3D scene, generated on 
the Reference object, is shown based on the 
Color map type specified in the Surface Data 
SPC pane.

Other piece locations are available in the 
Pieces list of the Initialize Surface Data SPC 
dialog box.

When using From Data Objects, individual 
Data objects that are aligned to the 
Reference object can also be used for Surface 
Data SPC. They can be added to the Surface 
Data SPC tool, using pane buttons, and are 
immediately measured.
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Working with multiple device positions

There are many challenges to acquiring data points on large objects. Some objects are larger 
than the measurement volume of a device. Sometimes, data must be acquired on a portion of 
a part that is hidden from the measuring device. These situations demand that the device be 
moved around the part to acquire the data. In PolyWorks|Inspector, device positions address 
this specific need.

The different device positions must be aligned to each other. Two methods are detailed in this 
manual:

• Using targets

• From points obtained by probing targets

• Using a custom alignment such as the best-fit of Data to Data objects 

In the example illustrated below, a part is measured using a laser tracker in three different 
device positions.

The active device position is displayed on the status bar, in the lower right corner of the 
interface.

The Device Positions toolbar is located at the bottom of the PolyWorks|Inspector user 
interface. 

It offers the following tools:  

Define Measured Targets

Opens the Define Measured Device Position Targets dialog box from which 
to measure the targets.
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The basic acquisition workflow with multiple device 
positions using targets

For this typical workflow, the part is inspected by probing and/or scanning, and probed targets 
are used for the alignment. The targets can be defined from physical targets strategically 
placed on the part and/or around the part, or they can be features (points, circles, spheres) on 
the part. Note that a combination of physical targets and features on the part can be used.

 

Move Device

Allows the creation of a new device position.

Manage Device Positions and Targets

Opens the Device Positions and Targets pane which allows visualizing the 
different device positions and targets and editing them.

Position 1

Define measured targets
Define the accessible targets of 
position 1.

Scan the part & measure 
objects
Scan the accessible surfaces of the 
part and, if required, measure 
objects using scanned or probed 
data.

Note that the Data object needs to 
be aligned to the Reference object to 
measure certain types of objects.
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Move device
Define a new device position and 
physically move the device or the 
part.

Position 2

Define measured targets
The acquisition of targets is  
automatically launched. 

Define all the accessible targets of 
position 2. There must be a minimum 
of three common targets, with the 
previous position, for alignment. 

There can be more targets than in 
the previous position. Typically, these 
will be used with targets in future 
positions. 

Scan the part & measure 
objects
Scan the accessible surfaces of the 
part and, if required, measure 
objects using scanned or probed 
data.

Note that the Data objects need to 
be aligned to the Reference object to 
measure certain types of objects.

Move device
Define a new device position and 
physically move the device or the 
part.
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Moving the device or the part by probing targets

A robust and repeatable method for defining targets is using 
target locations. The targets can be on the part itself or placed 
around it. The probe is used to define each target every time the 
device or the part is moved, aligning the different setups 
together.

Objective: Move the device or the part and align it to previous 
data by probing device position targets.

Required: A probing device is available and ready to use. The required plug-ins are loaded.

Steps

Position n

Repeat the process
Repeat this process for as many 
positions needed to acquire the 
required data.

1. In position 1, define the targets by choosing 
Tools > Device Positions > Define Measured Device 
Position Targets.

The Define Measured Device Position Targets 
dialog box opens.

2. In the Method list, select Probe.

3. Set the Type to Point.

4. In the Submethod list, select Uncompensated.

The target will be acquired at the probe tip center.

5. Click Probe.

6. Probe all accessible stable target locations.

Three targets are a minimum to perform the 
target alignment, but more are recommended.

The targets are listed in the Device Positions and 
Targets pane.
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Results

7. Scan the accessible surfaces of the part and, if 
required, measure objects.

Note that the Data object needs to be aligned 
to the Reference object to measure certain 
types of objects.

8. Physically move the device or part, and define a 
new device position – position 2 – by choosing 
Tools > Device Positions > Move Device.

The Move Device dialog box opens.

9. In the Alignment method list, select Targets.

10. Click OK.

The Define Measured Device Position Targets 
dialog box opens.

11. Probe all accessible and stable target locations 
to align position 2.

At least three targets must be the same as in 
position 1. Although a minimum of three targets is 
required to perform the target alignment, it is 
recommended to use more targets. 

The targets can be probed in any order.

The targets are listed in the Device Positions and 
Targets pane, with alignment errors.

12. Continue scanning and probing the part in the 
new position.

• The new device position is aligned to the 
previous device position. 

New scanning and probing Data objects 
are created in the Tree View to keep the 
device positions independent of each 
other.
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Notes

All accessible targets should be measured from each device position. This ensures that plenty 
of targets are available for future device position alignments. As soon as there are three 
common targets between the device positions, the current device position is aligned. Adding 
additional common targets strengthens the alignment.

To avoid ambiguous alignment solutions, physical targets should be placed in a 
nonsymmetrical array. If necessary, target matches between device positions can be 
edited manually. The Edit Target Match tool, found on the Target alignment 
results tab of the Device Positions and Targets pane, allows defining specific target 
match pairs.

When connected to a laser tracker probing device with the capability to orient to gravity, it is 
possible to orient to gravity while creating the device position.

 

Bundle adjustment

Bundle adjustment optimizes the auto-match alignment of device positions by finding the 
most probable effective location for each target through averaging, and aligns all instances of 
the target to that location. The effective location is updated every time a new device position is 
added. This option gives best results when the entire part volume is measured such that the 
last device position is adjacent to the first device position.

Without bundle adjustment, any target measured in more than one device position is always 
aligned to the first measured instance of that target.

• The probed targets and the alignment 
accuracy are displayed in the Device 
Positions and Targets pane.
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Objective: Activate bundle adjustment for target alignment.

Required: A project with multiple device positions aligned using targets.

Steps 

Results

1. Choose Tools > Options to access the 
PolyWorks|Inspector options.

The PolyWorks|Inspector Options dialog box 
opens.

2. Open the Device Positions options page.

3. Select Bundle adjustment.

4. Click Apply.

5. Close the PolyWorks|Inspector Options dialog 
box.

The alignment is updated, and the error for all targets is recalculated based on the new 
effective target location.
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Notes

Accuracy models are used to determine the most probable location for each target. It is 
therefore important to set the proper accuracy model for each device position according to 
the device used. The default accuracy model can be set from the Device Positions page in the 
PolyWorks|Inspector options. Alternatively, a specific accuracy model can be set for each 
device position in the Device positions tab of the Device Positions and Targets pane. Two 
bundle adjustment accuracy models are available:

Uniform accuracy model 
Digitizing arms have small measurement volumes and, as such, have fairly consistent 
accuracy throughout that volume. For digitizing arms, the Uniform accuracy model is used.

Range and angle accuracy model 
Laser trackers have large measurement volumes, and the point positional certainty varies 
throughout that volume based on the distance and angle from the tracker. Therefore, for laser 
trackers, the Range and angle accuracy model is used.

Device position uncertainty

When physically predetermining a set of target locations that can be measured from several 
device positions, users can, by inadvertence or inexperience, set up their alignment targets in 
ways that systematically produce unstable alignment solutions. It is possible to detect these 
unreliable target setups by evaluating device position uncertainties. Here are some of the 
most common problematic target setups:

• The alignment targets of a device position are 
nearly collinear.
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Objective: Measure the uncertainty of a device position.

Required: A project with two or more device positions. Bundle adjustment must be enabled.

Steps

• The horizontal angular span of the alignment 
targets of a device position is small.

• The measurement device is moved along one 
direction, and a new device position is aligned 
by only using targets measured by the closest 
previous device position, producing daisy-
chained device positions.

1. Choose Tools > Device Positions > Manage 
Positions and Targets. The Device Positions 
and Targets pane opens.

2. Select the Device positions tab at the 
bottom of the pane.

3. Click Evaluate Position Uncertainty.

The Device Positions options page offers 
parameters related to uncertainty 
computation.
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Results

Notes

• When targets are added or removed, the uncertainty values are considered out-of-date 
and are removed. The uncertainty tool must be relaunched to update the uncertainty 
values.

• It is possible to modify the tolerance for the device position uncertainty on the Device 
Position page of the PolyWorks|Inspector options.

The uncertainty of the unlocked positions is calculated and shown in the Device Positions and 
Targets pane along with a pass/fail test. 
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The basic acquisition workflow with multiple device 
positions using surface information

For this workflow, the part is digitized and the scanned surfaces are used for alignment, which 
involves relying on the overlap between the objects to align. 

Position 1

Scan the part 
In position 1, scan the area of the part 
that is accessible.

Move device
Define a new device position and 
physically move the device or the part.

Position 2

Scan the part 
In position 2, scan the area of the part 
that is accessible to capture surface 
data that overlaps with previous 
scans.

Align scan with previous 
scans
Based on the surface information, use 
a Best-Fit Data to Data objects 
alignment to align the scanned data; 
overlapping data is required. 

Move device
Define a new device position and 
physically move the device or the part.
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Position n

Repeat the process
Repeat this process for as many 
positions as needed to acquire the 
required data.

Last position

Scan the part and align with 
previous scans
In the last position, scan the part 
capturing surface data that overlaps 
with previous scans. Based on the 
surface information, use a Best-Fit 
Data to Data objects alignment to align 
the scanned data where overlapping 
data is available. 

Globally optimize alignments
Use this alignment when three or 
more Data objects, from different 
device positions, were scanned and 
are closely aligned.
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Moving the device or the part using a custom alignment

When scanning a part, it is sometimes impossible to capture all of 
the surfaces without moving the scanning device, or changing the 
part position relative to the scanning device. This generates one 
surface Data object for each different setup used. If the device 
positions are not already aligned, it is possible to align these 
surface Data objects to one another. The alignment uses the areas 
that overlap with neighboring polygonal Data objects. First a pre-
alignment is done by the user by picking matching points, and 
then a best-fit alignment is performed using the surface shape in the overlying regions. 

Objective: Scan the part into different device positions.

Required: A scanning device is available and ready to use. The required plug-ins are loaded.

Steps

1. In position 1, scan the areas of the part that are 
accessible. 

Position 1 can be aligned to a Reference object.

2. Move the device or part, and define a new 
device position – position 2 – by choosing Tools > 
Device Positions > Move Device.

The Move Device dialog box opens.

3. In the Alignment method list, select Custom.

4. Click OK.

5. Continue scanning the part in the new position.
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Results

Next step

Once all the part has been digitized, align the polygonal Data objects using a Best-fit Data to 
Data objects.

New scanned Data objects are created in the 
Tree View for each device positions.
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Unifying polygonal Data objects

When data is acquired using multiple device positions, one polygonal Data object per device 
position is typically created. Before inspecting the part, it is recommended to unify the 
polygonal Data objects into only one Data object. 

Objective: Unify polygonal Data objects into one object.

Required: Polygonal Data objects acquired using different device positions that are already 
aligned to each other.

Steps

1. Select the polygonal Data objects in the Tree 
View.

2. Choose Tools > Data Objects > Create Polygonal 
Models. 

The Create Polygonal Data Objects dialog box 
opens.

3. Specify a Name.

4. In the Method list, select From Data Objects.

5. Under Source data objects, select the Data 
objects that will be unified.

When the objects are selected in the Tree View, 
their check box is automatically selected.

6. In the Meshing method list, select Quality 
Meshing.
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Results

7. Specify how the Meshing parameters are to 
be obtained (From source objects is 
recommended). If Custom is selected, the 
following parameters must be specified:

• Sampling step: Determines the average 
distance between vertices. The smaller the 
step, the finer the details are in the resulting 
polygonal Data object. It is recommended to 
use the same step as the one used when 
scanning.

• Max edge length: Sets the maximum size for 
any triangle edge. A good approximation is 
ten times the sampling step, but always keep 
it smaller than the finest details on the 
polygonal Data object. Otherwise, details will 
lose definition.

8. Click Create.

A new polygonal Data object is created and 
added to the Data branch of the Tree View. The 
source objects are moved into a group. The 
new polygonal Data object is dependent on the 
source objects it was created from. If any of the 
source objects are modified, this new Data 
object is updated.

The new polygonal Data object is displayed 
in the 3D scene.
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Introducing the Offline Simulation mode

The Offline Simulation mode allows users to perform simulated data acquisition without 
using a physical device. Simulated data is provided for all scanning and probing operations. As 
a result, an entire inspection project, including data color maps, device positions, 
measurement sequences, and formatted reports, can be prepared. Once the inspection 
project is complete, it can be used with an actual device to play the inspection, acquire the 
data, and measure the part.

Activating/deactivating the Offline Simulation mode

To create inspection projects offline using simulated data, the Offline Simulation mode must 
first be activated.

1. On the Devices toolbar, click the Activate 
Offline Simulation button.

The Simulated Data watermark is displayed at 
the bottom of the 3D scene as a reminder that 
simulated data is being used in the project.

The inspection can be performed using:

• simulated scanned data (see The workflow 
when performing an inspection using 
simulated scanned data on page 684)

• simulated probed data (see The workflow 
when performing an inspection using 
simulated probed data on page 689)

Note that the watermark is displayed as long 
as the Offline Simulation mode is activated and 
the project contains simulated data.

2. To deactivate the Offline Simulation mode, 
press the same button on the Devices toolbar, 
now named Deactivate Offline Simulation.
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The workflow when performing an inspection 
using simulated scanned data

The workflow for an inspection using a scanning device and the Offline Simulation mode is 
illustrated below:   

Create nominal project 
and share

Import
Reference object

Acquire
Data object 

Align
Data object

to Reference object

Measure
dimensions and deviations

Report
measurement results

Deactivate the Offline 
Simulation mode 

Activate the Offline 
Simulation mode 
684



USING THE OFFLINE SIMULATION MODE
Understanding the workflow  

       

 

Import Reference object
Import the nominal information of the part 
(typically a CAD model) into the inspection 
project.

Activate the Offline Simulation mode

Activate the Offline Simulation mode

Click the button on the Devices toolbar to 
activate the Offline Simulation mode.

Specify the scanning plug-in

In the scanning plug-in list, select the required 
plug-in for your scanning device.

Acquire Data object
Acquire simulated scanned data, based on the 
Reference object.

Align Data object to Reference object

Alignment

Align the Data object to the Reference object 
using a best-fit alignment.

Refine alignment

Refine the alignment of the Data object to the 
Reference object using one of the many 
alignment techniques once the required objects 
are available.
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Measure dimensions and deviations
Create the objects required to perform the 
inspection of the part. 

Set the required dimensional and GD&T 
controls, if applicable.

Measure the different objects using simulated 
scanned data.

Deactivate the Offline Simulation 
mode
Click the button on the Devices toolbar to 
deactivate the Offline Simulation mode.

Report measurement results

Report the inspection measurement results 
using:

• Control views in the Control Reviewer;

• Tables and snapshots in formatted reports.

Create nominal project and share

Save the inspection project

Create nominal project

The creation of the nominal project removes all 
measurements and saves the project under a 
new name.

The project is now ready to be used to play the 
inspection.
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Particularities when acquiring simulated scanned data

Before using a scanning device to acquire simulated scanned data, make sure that the 
following requirements have been met:

• The project contains a Reference object.

• The Offline Simulation mode is enabled.

• The scanning plug-in has been selected and the connection to the device has been 
established.

• An alignment to the Reference object has been previously simulated.

Scanning options

If required, set options for the acquisition of simulated scanned data. The goal is to have data 
dense enough so that the extraction of measurement objects is successful. Note that these 
options are not applicable when scanned data is acquired with an actual scanning device.  

1. Click the Scan button.

The plug-in dialog box opens.

For information on the parameters offered for 
scanning, see Acquiring surface and boundary 
Data objects on page 91.

2. Under Scanning options, select the 
appropriate Profile based on the size of the 
smallest details on the part.

3. If required, click Options to set the options 
specific to the device.

The Line Scan Options dialog box opens.

4. On the Offline Simulation page, set the 
required parameters.

This page contains the default parameters 
used to configure the acquired simulated 
scanned data.
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• Line-to-line distance: Controls the distance 
between consecutive scan lines.

• Point-to-point distance: Controls the 
distance between two neighboring points on 
the same scan line.

• Noise: Introduces noise into the simulated 
scanned data based on a tolerance. 

• Scan nominal primitives for measured 
primitive extraction: Additional data is 
simulated for features in the Tree View for 
which the measurement method is set to 
Extract or Undefined. This ensures that 
feature extraction is done successfully.
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The workflow when performing an inspection 
using simulated probed data

The workflow for an inspection using a probing device and the Offline Simulation mode is 
illustrated below: 

Deactivate the Offline 
Simulation mode 

Create nominal project 
and share

Report
measurement results

   Measure
dimensions and deviations

Align part
to Reference object

Import
Reference object

Activate the Offline 
Simulation mode 
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 Understanding the workflow  

Import Reference object
Import the nominal information of the part 
(CAD model) into the inspection project.

Activate the Offline Simulation mode

Activate the Offline Simulation mode

Click the button on the Devices toolbar to 
activate the Offline Simulation mode.

Specify the probing plug-in

In the probing plug-in list, select the required 
plug-in for your probing device.

Connect to the probing device

Connect to the probing device to simulate the 
connection.

Align part to Reference object

Alignment

Simulate the alignment of the part to the 
Reference object using a Surface Points 
alignment.

Refine the alignment

Refine the alignment of the part to the CAD 
model using one of the many alignment 
techniques once the required objects are 
available.
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Measure dimensions and deviations
Create the necessary objects in order to 
perform the inspection of the part. 

Set the required dimensional and GD&T 
controls, if applicable.

Then, specify the Probe method, set the related 
probing parameters, and measure the different 
objects using simulated probed data. 

Deactivate the Offline Simulation mode

Disconnect from the probing plug-in

Click the button on the Devices toolbar to 
disconnect from the probing plug-in.

Deactivate the Offline Simulation mode

Click the button on the Devices toolbar to 
deactivate the Offline Simulation mode.

Report measurement results

Report the measurement results based on the 
probed data through:

• Control views in the Control Reviewer;

• Tables and snapshots in formatted reports.

Create nominal project and share

Save the inspection project

Create nominal project

The creation of the nominal project removes all 
measurements and saves the project under a 
new name. 

The project is now ready to be used to play the 
inspection.
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Simulating multiple device positions

The Offline Simulation mode can be used to simulate probing targets in different device 
positions. Four targets are automatically generated and probed, and they are listed in the 
Device Positions and Targets pane. 

However, when measuring the actual part, any number of targets can be created for each 
device position as long as there is a minimum of three targets per position that are 
measurable in the next device position.

For more information on multiple device positions, see Working with multiple device positions 
on page 666.
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Creating a nominal project

Once the inspection project containing simulated data is completed, the simulated data must 
be removed before sharing it with operators. This can be done by creating a nominal project. 
The project can then be used to start measuring the different pieces of a part.

Objective: Create a nominal project ready for use with a measurement device.

Required: A completed inspection project made with simulated data.

Steps

Results

1. Make sure that the Offline Simulation mode is 
deactivated.

2. Choose File > Create Nominal Project.

The Create Nominal Project dialog box opens.

3. Click Create.

A browser opens. 

4. Specify a file name and location. 

5. Click Save.

The project is ready to use. All measurements 
are deleted.

6. Connect to the measurement device.

7. Choose Tools > Piece > Play Inspection.

The Play inspection is launched, guiding the 
user through the steps necessary to measure 
the measurement objects.
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APPENDIX
Automatic project update

By default, PolyWorks|Inspector projects are always automatically up to date. This means that 
measurement objects, alignments, data color maps, report items and formatted reports are 
automatically recalculated as necessary. 

The icon of the Automatic project update status, located 
at the right end section of the status bar, indicates 
whether the automatic project update is activated or not. 

If needed, the Automatic project update can be 
activated/deactivated by clicking the arrow to the 
right of the icon and selecting the Automatic project 
update command. When activated, the command is 
preceded by a check mark.

Troubleshooting the automatic project update

The update status of objects in the Tree View is 
constantly monitored by the Automatic project 
update function. In some cases, object updates 
cannot be performed, such as when the 
measurement parameters of an object do not allow 
its remeasurement or when an object is linked to an 
object that no longer exists. In these cases, a yellow 
warning triangle is superimposed on the Automatic 
project update icon on the status bar and a 
notification is shown.
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Choose Tools > Troubleshoot Project Update to display a dialog box that lists the objects in error 
and a message for each. 

 The following update status icons can be displayed on the object icon in the Tree View: 

A red x mark indicates that the object is in error. 

A yellow warning triangle indicates that the object could not be updated. 

An anchor symbol indicates that the object is nonupdatable or rendered as such. 

A clock icon indicates that the object is out-of-date. An object can have an out-of-date 
status only when the Automatic project update is deactivated. 

Moving the mouse pointer over the object 
displays a tooltip with the details.   

Operations that trigger an automatic project update

Common operations that trigger the automatic project update include:

• Modifying a Data or Reference object by replacing the object or by deleting elements.

• Changing the active alignment.

• Opening a formatted report.
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Setting and saving the user configuration

The PolyWorks Metrology Suite has a default standard configuration for the Workspace 
Manager and each module. The standard configuration holds information about window sizes 
and positions, display modes, selection modes, dialog box parameters, templates 
(annotations, controls, and tables), and various module options like units and Options panel 
settings. 

A user configuration also exists, which augments the standard configuration. As a user works 
in the software, any changes to these settings and parameters can be saved in the user 
configuration.

On the computer, the user configuration files are found in a folder 
named .innovmetric.[version].

Each user can have their own personal user 
configuration. The location of the user 
configuration directory, by default within the 
\User directory, is shown in the Workspace 
Manager Options dialog box.

Changes to the parameters and settings in the user configuration can be saved by choosing 
Tools > Save User Configuration in any module. The saved settings become the default the next 
time the module is launched. In the Workspace Manager, the current user configuration for all 
modules can be exported by choosing Tools > User Configuration > Export. Likewise, an external 
user configuration can be loaded by choosing Tools > User Configuration > Load.
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Scripted measurement methods

Scripted measurement methods can be used to measure objects in a custom way. These 
methods can be accessed through the property sheet of an object (see the note later in this 
section for the list of objects that support this method). 

They can also be managed using the Macro Scripts dialog box, which is opened when 
choosing Tools > Macro Scripts > Manage Macro Scripts.

Once the Object Measurement macro script type has been selected, the left side of the 
Macro Scripts dialog box can be used to:

• Select the macro script type.

• Displays a list of available macro scripts.

• Create, export, edit, and delete macro scripts.

• Assign the selected macro script to the selected measurement objects. 

• Flag selected macro scripts as favorites (with a star), so that they are made available in 
the list of measurement methods. 

Once a macro script has been imported into the project, the right side of the Macro Scripts 
dialog box can be used to:

• Specify or edit the name or the description of the macro script. 

• Add, edit, remove, or reorder parameters for the script. 

For more information, see the PolyWorks|Inspector Reference Guide.
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Objective: Measure an object using a scripted measurement method.

Required: The project contains objects as well as macro scripts to measure the objects.

Steps

1. Select the object in the Tree View, then choose 
Edit > Object Properties.

2. On the Measurement tab, choose a macro 
script from the Method list. The macro scripts 
available in the list are those that have been 
flagged as favorites in the Macro Scripts dialog 
box.

Clicking Manage Macro Scripts at the bottom of 
the list opens the Macro Scripts dialog box. 

Once the desired script is selected from the 
Scripts list, a list area on the Measurement tab 
displays the parameters defined for the 
selected script and allows specifying their 
values.

The Object name parameter and its default value 
are uneditable.

3. Choose the Script method and, if applicable, 
the Script submethod.

This specifies which measurement method and, 
when applicable, submethod will be used by the 
scripted operation to measure the object.

4. Specify other parameters as needed.

The parameters offered vary depending on the 
selected script method and submethod.

5. Click Apply in the property sheet of the object. 
The object is ready to be measured.
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Notes

• The following objects can be measured using a scripted measurement method:   

• Several object measurement scripts are included in PolyWorks|Inspector. 

• These scripts are listed in the object measurement script list area of the Macro Scripts 
dialog box. 

• Parameters have already been defined for these scripts. 

• Once the scripts have been imported into the project, parameter definitions can be 
edited (except for the Object name) and new parameters can be added. 

• These scripts can also be edited and modified.

• Some of the scripts offered are specifically designed to be used with certain plug-ins. 

Object Types Details

Data objects All types

Features All types, except angles, distances, patterns, and 
slabs

Cross-sections All types

Comparison points All types

Gauges All types

Custom measurements All types

Reference targets All types, except feature reference target points 
and cross-section reference target points.
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Saving a compressed copy of a project

When only one specific inspection project needs to be shared or exported, it is possible to 
create a compressed copy of this project directly from an open PolyWorks|Inspector project.

When opening this compressed file in the PolyWorks Metrology Suite, or in the free 
PolyWorks|Reviewer™, a new workspace is automatically created.

Objective: Share inspection results by saving a compressed copy of an inspection project.

Required: A completed, open inspection project.

Steps

Results

Notes

From the Workspace Manager, it is also possible to create a compressed copy of one or more 
PolyWorks|Inspector projects. Simply open the workspace, select the projects, and choose File 
> Export > Objects to Compressed Workspace.

1. To create a compressed copy of the project, 
choose File > Save Compressed Copy.

2. In the message window that is displayed, click 
OK.

The PolyWorks|Inspector project is saved and 
closed.

A file browser opens.

3. Browse for the location to save the file and click 
Save.

A copy of the project is saved to a new 
workspace that is compressed and then 
saved at the specified location as a .pwzip 
file. It can be opened with the PolyWorks 
Metrology Suite or the PolyWorks|Reviewer.
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APPENDIX
PolyWorks keyboard shortcuts

General interfaces 

Select objects mode CTRL+SHIFT+SPACEBAR

Switch to local split view 
mode

CTRL+SPACEBAR

Exit interactive modes ESC

Cancel macro script ESC

File >
Open project CTRL+O

Save project CTRL+S

Edit > 
Undo CTRL+Z

Redo CTRL+Y

Undo transformation CTRL+SHIFT+Z

Duplicate objects (E, I) CTRL+U

Ignore objects CTRL+SHIFT+E

Use objects CTRL+SHIFT+U

Delete >

Objects SHIFT+DEL

Elements DEL

Select >
Elements > Objects > 

All CTRL+A All CTRL+SHIFT+A

Invert CTRL+I Invert CTRL+SHIFT+I

None CTRL+N None CTRL+SHIFT+N

Interactively SPACEBAR
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APPENDIX
Object Display Options

Specific interfaces

IMAlign

View >
Normal View (E,I) SHIFT+F9 Hide >

Center> Objects CTRL+SHIFT+D

All Objects CTRL+C Elements CTRL+D

Objects CTRL+SHIFT+C Restore >

Standard Views > Objects CTRL+SHIFT+R

+X SHIFT+F1 Elements CTRL+R

-X SHIFT+F2 Keep>

+Y SHIFT+F3 Objects CTRL+SHIFT+K

-Y SHIFT+F4 Elements CTRL+K

+Z SHIFT+F5

-Z SHIFT+F6

Rotate 90° around 
View

SHIFT+right-
click

To display the color map CTRL+T

Static display > Dynamic display >
Flat CTRL+F Flat CTRL+SHIFT+F

Flat + Wireframe 
(E, I)

CTRL+L Flat + Wireframe 
(E,I)

CTRL+SHIFT+L

Point CTRL+P Point CTRL+SHIFT+P

Smooth CTRL+G Smooth CTRL+SHIFT+G

Wireframe CTRL+W Wireframe CTRL+SHIFT+W

Bounding box CTRL+SHIFT+B

Edit >
Lock Images CTRL+SHIFT+L

Unlock Images CTRL+SHIFT+O

Align >
Start Best-Fit alignment CTRL+F2

Stop Best-fit alignment CTRL+F3

Point Pairs CTRL+F5
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PolyWorks|Inspector    

Display menu on objects and annotations Right-click

Position annotations ALT + left-click

Select > Data Points > Measured Data Points CTRL+M

Select > Data Points > Measured Data Points 
of Local Planes

CTRL+B

Tools > Reference Objects > Correct Inverted 
CAD Surfaces

CTRL+Q
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Getting help

Users can access help resources both within the software interface and externally. Resources 
include reference guides, illustrated tips, video tutorials, and webinars.

Getting help through the software interface

Reference Guides
PDF documents located on the Help menu of the Workspace Manager and of 
each module. The reference guides define all of the functionalities of the 
PolyWorks Metrology Suite.

Question mark
Found on the title bar of displayed dialog boxes. Clicking the question mark 
icon opens the appropriate reference guide at the section documenting the 
active dialog box.

F1
Pressing F1 opens the reference guide to the section documenting the active 
dialog box. If the 3D scene has the focus during an interactive mode, pressing 
F1 opens the How To window.  

Release Notes
A PolyWorks Metrology Suite intermediate release is produced approximately 
once a month. These releases contain new tools along with bug fixes. The 
“Release Notes” document gives the details of the intermediate release and is 
available through Help > Release Notes.
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Getting help outside of the software interface

The website

The InnovMetric website (www.innovmetric.com) offers technical webinars (ABOUT US > 
Webinars page), which introduce new major functionalities and demonstrate the use and 
benefits of existing PolyWorks tools.

The PolyWorks Technical Support Zone (TSZ)

The secure Technical Support Zone offers PolyWorks users 24/7 online access to: 

Software Releases:

This is where you will find the downloadable versions of the PolyWorks Metrology Suite 
and the PolyWorks Collaborative Suite, as well as access to the Release Notes. 

Knowledge Base:

Provides articles, illustrated tips, and video tutorials to help you get the most out of 
PolyWorks, including practical tips and tricks, workflow-oriented videos to help you learn 
the basic capabilities, videos on how to solve PolyWorks training session exercises, and 
technical webinars designed to boost your PolyWorks skills. 

Support:

Get direct assistance from a PolyWorks expert by creating and submitting a Technical 
Support Zone Case where you can confidentially share files for troubleshooting purposes. 
You can also access articles related to your questions as well as your other open or closed 
cases. 

Macro Zone:

The PolyWorks Metrology Suite offers the possibility of creating macro scripts to automate 
repetitive tasks or generate a personal set of tools to save time and perform tasks in a 
predefined, controlled manner. In the Macro Zone, you will find a variety of useful macro 
scripts developed by our Technical Support team.

Forum:

A platform where you can ask questions and share ideas and comments with the 
PolyWorks user community. 

Global Search Tool:

A powerful tool that searches the entire site content to find the information you are 
looking for. 
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